WiFi issue with Atheros WiFi card in laptop...might be a kernel bug or a bug with Ubuntu's new network manager.

Bug #992519 reported by Michael Hazell on 2012-05-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

I have a Toshiba M55-S139 laptop. It has the Atheros AR5005G Wireless Network Adapter. In Ubuntu 10.04, the WiFi worked fine, with very little issues. Now in Ubuntu 12.04, the WiFi connects for about 10 seconds and then randomly disconnects. I have tried resetting the WiFi settings, and it has not helped at all.

I don't know if it has something to do with the kernel, but I need an answer to fix this problem, or I'll have to rollback to Ubuntu 10.04.

I can provide more hardware info it it is needed. My laptop has been upgraded with maxed out ram....but I believe that is irrelevant in this matter.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/992519/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → gnome-nettool (Ubuntu)

Did you upgrade or is it a clean install?

What is the output of:

sudo lshw -C network; lsb_release -a; uname -a; sudo rfkill list

Thanks

Matt Fischer (mfisch) on 2012-05-04
Changed in gnome-nettool (Ubuntu):
status: New → Incomplete
Michael Hazell (techman-) wrote :

@ActionParsnip:

Here is what I got:
michael@ubuntu:~$ sudo lshw -C network; lsb_release -a; uname -a; sudo rfkill list
  *-network:0
       description: Wireless interface
       product: AR2413/AR2414 Wireless Network Adapter [AR5005G(S) 802.11bg]
       vendor: Atheros Communications Inc.
       physical id: 2
       bus info: pci@0000:04:02.0
       logical name: wlan0
       version: 01
       serial: 00:11:f5:8d:e7:c0
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=3.2.0-23-generic-pae firmware=N/A ip=192.168.1.4 latency=168 link=yes maxlatency=28 mingnt=10 multicast=yes wireless=IEEE 802.11bg
       resources: irq:9 memory:c0200000-c020ffff
  *-network:1
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 6
       bus info: pci@0000:04:06.0
       logical name: eth0
       version: 10
       serial: 00:0f:b0:9c:a1:92
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=64 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
       resources: irq:22 ioport:a000(size=256) memory:c0210000-c02100ff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux ubuntu 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686 i686 i386 GNU/Linux
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
michael@ubuntu:~$

Matt Fischer (mfisch) wrote :

This is not a bug in gnome-nettool, gnome-nettool is a way to run tools like ping, arp, etc. It does not setup wireless networking.

affects: gnome-nettool (Ubuntu) → ubuntu
Michael Hazell (techman-) wrote :

@Matt Fischer: Then what does?

Leo (llenchikk) wrote :

I may confirm that. Acer Aspire 5110 laptop with 12.04 has this issue. Manual upgrading to 3.3 kernel fix this.

Changed in ubuntu:
status: Incomplete → Confirmed

Techman, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 992519

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions