Ubuntu

[Vostro 3450] No sound from internal speakers

Reported by Jeff Lane on 2012-04-30
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
David Henningsson
Oneiric
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
David Henningsson

Bug Description

Installed Precise on the Vostro 3450. During testing, no audio could be heard from the internal speakers. I tried multiple ways of producing sound, from the checkbox tests to using sound recorder to playing some music files. I tried selecting and re-selecting the internal audio source, adjusting volume levels, etc to no effect.

I WAS able to hear audio on headphones, so it's just the internal channel that seems affected by this.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-23-generic 3.2.0-23.36
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1559 F.... pulseaudio
 /dev/snd/pcmC0D0c: ubuntu 1559 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xe1800000 irq 51'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,102804c5,00100100 HDA:80862805,80860101,00100000'
   Controls : 24
   Simple ctrls : 11
Date: Mon Apr 30 13:27:19 2012
HibernationDevice: RESUME=UUID=ce51c56c-a353-44f2-8d6d-323bedb163a2
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Dell Inc. Dell System Vostro 3450
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 radeondrmfb
 1 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=9a44bdfd-71e1-4a63-8934-c2d5992113dd ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-23-generic N/A
 linux-backports-modules-3.2.0-23-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/12/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X24
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Emerald Lake
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrX24:bd01/12/2011:svnDellInc.:pnDellSystemVostro3450:pvr:rvnDellInc.:rnEmeraldLake:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System Vostro 3450
dmi.sys.vendor: Dell Inc.

Jeff Lane (bladernr) wrote :
tags: added: blocks-hwcert
Brad Figg (brad-figg) on 2012-04-30
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc4-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
Ara Pulido (apulido) on 2012-06-19
tags: added: regression-release
Jeff Marcom (jeffmarcom) wrote :

I've also reproduced this issue with Oneiric release.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Jeff Marcom (jeffmarcom) wrote :

Retested with upstream 3.5 and the issue is still present

Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: quantal
tags: added: oneiric
Brad Figg (brad-figg) on 2012-06-25
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Precise):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in linux (Ubuntu Oneiric):
status: New → Confirmed
Changed in linux (Ubuntu Quantal):
status: Confirmed → Triaged
Changed in linux (Ubuntu Quantal):
assignee: nobody → David Henningsson (diwic)
Anthony Wong (anthonywong) wrote :

I see that this machine was certified with 11.04, can someone with the machine test with 11.04 again to make sure this is not a hardware problem?

David Henningsson (diwic) wrote :

A quick look at the codec did not reveal any errors, so I'm also thinking it could be broken hardware on the actual machine. Setting to incomplete while waiting for response to comment #6.

Changed in linux (Ubuntu Quantal):
status: Triaged → Incomplete
Changed in linux (Ubuntu Precise):
status: Confirmed → Incomplete
Changed in linux (Ubuntu Oneiric):
status: Confirmed → Incomplete
David Henningsson (diwic) wrote :

Also, if it is still working under 11.04, could you please attach alsa-info for the functioning case (11.04 with sound coming out of speakers), and for the non-functioning case (11.10, 12.04 or 12.10 with no sound coming out of speakers)? I will compare them and look for differences. Thanks!

Jeff Marcom (jeffmarcom) wrote :

So I can't actually get natty to install on this machine at the moment. I've tried both the cd image and usb drive method and their is no display during the install process.

The 11.04 certificate private notes for this system show the following:

Tester's Notes
Speakers seem to have been broken on this config.

Changed in linux (Ubuntu Oneiric):
status: Incomplete → New
Changed in linux (Ubuntu Precise):
status: Incomplete → New
Changed in linux (Ubuntu Quantal):
status: Incomplete → New
Brad Figg (brad-figg) on 2012-09-27
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Oneiric):
status: New → Confirmed
Changed in linux (Ubuntu Precise):
status: New → Confirmed
Anthony Wong (anthonywong) wrote :

Hi Jeff,

Is there any options in BIOS that changes the video setting? This model seems to be using hybrid graphics.

David Henningsson (diwic) wrote :

Okay, so maybe hardware failure then?

Ed Mountjoy (emountjoy) wrote :

I am having the same problem with my Thinkpad X230 since updating to 12.10. Strangely, I still heard the drums through my internel speakers when lightdm loads. Sound works when using USB speakers or using headphones.

Mafoof (m3ttcew) wrote :

Can also confirm this bug with A Lenovo ThinkPad X230 & Quantal. Only headphones/external speakers work whereas it was fine in Precise.

Before upgrading to Quantal (clean install) I experimened with xubuntu-desktop and found the reverse problem with it: sound would not play through headphones - only the internal speakers.

David Henningsson (diwic) wrote :

Please don't use this bug for other hardware than Vostro 3450. It's not the same bug. Thanks!

David Henningsson (diwic) wrote :

Setting to incomplete while waiting for confirmation about whether this is hw failure or not.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu Oneiric):
status: Confirmed → Incomplete
Changed in linux (Ubuntu Precise):
status: Confirmed → Incomplete
Changed in linux (Ubuntu Quantal):
status: Confirmed → Incomplete
Jeff Marcom (jeffmarcom) wrote :

it doesn't seem that then internal speakers are working at all on this hardware.

Closing as invalid.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu Oneiric):
status: Incomplete → Invalid
Changed in linux (Ubuntu Precise):
status: Incomplete → Invalid
Changed in linux (Ubuntu Quantal):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers