Ubuntu

[Lenovo Edge Laptops] MMC/SD/SDHC Card reader not working

Reported by Jeff Lane on 2012-04-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned

Bug Description

During certification of Precise on the Edge 11, I've observed that the card reader is not registering any insert events for any card.

This worked in Natty, was broken in Oneiric up until close to final release, when it was fixed, and now appears to have broken again in Precise.

I tried MMC, SD and SDHC cards and none of them were recognized by the reader, dmesg didn't register any events, nada.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-23-generic 3.2.0-23.36
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1478 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0700000 irq 45'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:14f15066,17aa21c8,00100302 HDA:80862804,80860101,00100000'
   Controls : 14
   Simple ctrls : 6
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 86HT15WW-1.161000'
   Mixer name : 'ThinkPad EC 86HT15WW-1.161000'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sat Apr 28 20:13:36 2012
HibernationDevice: RESUME=UUID=d3f8687e-ce31-4eb4-8e39-4509b6f68351
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: LENOVO 032823U
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=eaa064cc-2c53-4e0f-93cd-51198397a19d ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-23-generic N/A
 linux-backports-modules-3.2.0-23-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/13/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 86ET16WW (1.00 )
dmi.board.name: 032823U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr86ET16WW(1.00):bd07/13/2010:svnLENOVO:pn032823U:pvrThinkPadEdge:rvnLENOVO:rn032823U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 032823U
dmi.product.version: ThinkPad Edge
dmi.sys.vendor: LENOVO

Jeff Lane (bladernr) wrote :
Brad Figg (brad-figg) on 2012-04-29
Changed in linux (Ubuntu):
status: New → Confirmed
Jeff Lane (bladernr) on 2012-04-29
summary: - [Lenovo Edge 11] MMC Card reader not working
+ [Lenovo Edge Laptops] MMC Card reader not working

Changed header appropriately. This has also been seen on a Lenovo Edge 13.

Ara Pulido (apulido) on 2012-04-30
summary: - [Lenovo Edge Laptops] MMC Card reader not working
+ [Lenovo Edge Laptops] MMC/SD/SDHC Card reader not working
tags: added: blocks-hwcert
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc4-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Ara Pulido (apulido) wrote :

Jeff (Marcom), can you test what Joseph is asking for, please?

tags: added: regression-release
Ara Pulido (apulido) wrote :

Marking as regression-release, as this wasn't happening in 11.10

Jeff Marcom (jeffmarcom) wrote :
Download full text (17.1 KiB)

Re tested with the following:

Lenovo Thinkpad Edge E320

Lenovo Thinkpad Edge E520

Lenovo Thinkpad Edge E325

Lenovo Thinkpad Edge 13

Kernels tested: 3.2.0.23, 3.2.0.24, 3.2.0.25.

Inserted and re-inserted SDHC,MMC, SD, and Micro SD cards multiple times with various kernels and did not see an issue.

I was able to mount and write to each successfully.

Udevadm output upon insertion and removal:

monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

KERNEL[102.284661] add /devices/pci0000:00/0000:00:13.2/usb2/2-2 (usb)
UDEV [102.286460] add /devices/pci0000:00/0000:00:13.2/usb2/2-2 (usb)
KERNEL[102.290295] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0 (usb)
UDEV [102.291455] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0 (usb)
KERNEL[102.302738] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6 (scsi)
KERNEL[102.302771] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/scsi_host/host6 (scsi_host)
UDEV [102.303183] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6 (scsi)
UDEV [102.304835] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/scsi_host/host6 (scsi_host)
KERNEL[103.305672] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0 (scsi)
KERNEL[103.306528] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0 (scsi)
UDEV [103.306560] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0 (scsi)
KERNEL[103.306586] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0/scsi_disk/6:0:0:0 (scsi_disk)
KERNEL[103.306609] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0/scsi_device/6:0:0:0 (scsi_device)
UDEV [103.307114] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0 (scsi)
UDEV [103.307285] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0/scsi_device/6:0:0:0 (scsi_device)
UDEV [103.307647] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0/scsi_disk/6:0:0:0 (scsi_disk)
KERNEL[103.308409] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0/scsi_generic/sg2 (scsi_generic)
UDEV [103.309780] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0/scsi_generic/sg2 (scsi_generic)
KERNEL[103.310774] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0/bsg/6:0:0:0 (bsg)
UDEV [103.312312] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0/bsg/6:0:0:0 (bsg)
KERNEL[104.584729] add /devices/virtual/bdi/8:32 (bdi)
UDEV [104.585474] add /devices/virtual/bdi/8:32 (bdi)
KERNEL[104.626192] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0/block/sdc (block)
KERNEL[104.627418] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6/target6:0:0/6:0:0:0/block/sdc/sdc1 (block)
UDEV [104.727432] add /devices/pci0000:00/0000:00:13.2/usb2/2-2/2-2:1.0/host6...

tags: removed: needs-upstream-testing staging
Jeff Marcom (jeffmarcom) on 2012-06-05
tags: added: staging
Jeff Marcom (jeffmarcom) wrote :

Having trouble reproducing this particular issue. Marking as Invalid

Changed in linux (Ubuntu Precise):
status: New → Invalid
Ara Pulido (apulido) on 2012-06-12
Changed in linux (Ubuntu):
status: Incomplete → Invalid
husfeldt (thomas-husfeldt) wrote :

I made it work on Lenovo E530, and Linux Mint 13.
You need to download and compile drivers from Realtek.
Realtek RTS5229_Linux_Driver_v1.07..

Follow the Readme,txt

>make
>sudo make install
>sudo depmod

Reboot!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers