Slow Dash animation

Bug #990002 reported by Bucic
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Dash show/hide animations are very slow. It gets worse with Dash set to open as maximized. Then it takes almost a full second to appear and slightly less to hide.The current background does not affect this behavior. It can be a solid color wallpaper or a web page. Same. I don't know whether it's relevant but the blurred image is translated ~4 mm down in relation to original image I see on my display.

Thinkpad T500
Intel 4500M HD graphics (selected as the only graphics)
Ubuntu 12.04 amd64 / Ubuntu 12.04 Beta 2 amd64 , clean

I have also noticed that the login screen works terribly laggy as well.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: hg1 1940 F.... pulseaudio
 /dev/snd/pcmC0D0p: hg1 1940 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc020000 irq 49'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa2100,00100000 HDA:14f12c06,17aa2122,00100000'
   Controls : 20
   Simple ctrls : 12
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 7VHT16WW-1.06'
   Mixer name : 'ThinkPad EC 7VHT16WW-1.06'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=31f016b8-c071-4499-8940-8205dfb79167
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: LENOVO 20823HU
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-26-generic root=UUID=3bd1069a-c263-4185-855f-3d60de752208 ro
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-26-generic N/A
 linux-backports-modules-3.2.0-26-generic N/A
 linux-firmware 1.85
StagingDrivers: mei
Tags: precise running-unity staging
Uname: Linux 3.2.0-26-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/14/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 6FET92WW (3.22 )
dmi.board.name: 20823HU
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6FET92WW(3.22):bd12/14/2011:svnLENOVO:pn20823HU:pvrThinkPadT500:rvnLENOVO:rn20823HU:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 20823HU
dmi.product.version: ThinkPad T500
dmi.sys.vendor: LENOVO

Revision history for this message
Bucic (bucic) wrote :

the required attachement

Revision history for this message
Bucic (bucic) wrote :

the required attachement

description: updated
Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 990002

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: precise
Bucic (bucic)
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Dave Vree (hdave) wrote :

I have three machines running 12.04 and Dash is extraordinarily slow on 2 of the 3. One of the slow machines is a Dell XPS mlaptop with an nVidia GeForce 7400 Go. The video card is reasonably fast when running all manner of compiz animations, but as soon as I open Dash, my machine starts grinding. It's so bad that the mouse slowly stutters across the screen when trying to click on a dash icon. Filtering items takes 1-2 seconds every click. As soon as Dash closes, everything is fast again. The other machine doing this is an Asus EEE PC-1000.

The machine of mine where Dash is super speedy and works great has a slower processor than the Dell laptop, but has Intel graphics.

Revision history for this message
Jesse Gordon (jointstereotype-yahoo) wrote :

I'm experiencing the same sluggishness / slowness with the Dash and login screen using a fresh install of Ubuntu 12.04 32-bit (Ubuntu 3.2.0-24.37-generic-pae 3.2.14) on an Asus Core i3-based laptop (2GB RAM, Intel HD Graphics). Otherwise, the system is snappy, Unity 3D is turned on, 1080p video plays fine using VLC, etc.

Like the OP stated, using a wallpaper or solid background color doesn't seem to make a difference in the Dash's performance, and I too am noticing whatever background I may have set is getting shifted downward whenever the Dash is opened.

The login screen shows similar cursor / selection lag. Once logged in, the desktop (but not the Dash) appears to perform just fine. Compositing is enabled, no delay when moving, maximizing / minimizing windows, etc.

version.log: Ubuntu 3.2.0-24.37-generic-pae 3.2.14

Revision history for this message
Jesse Gordon (jointstereotype-yahoo) wrote :

Unity Dash performance appears to be *much* improved after a round of updates this morning. At least, on my machine. :D

Revision history for this message
Bucic (bucic) wrote :

Indeed, much improved. But still crap. This is ridiculous! Whoever came up with this dynamic blur should find another profession perhaps. Or why don't he enlighten us, why would I need to see a blurred website as a background to dash filled with objects. Or a YouTube video playing there (sic!).

tags: added: needs-kernel-logs needs-upstream-testing
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Bucic, thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 990002

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Bucic (bucic) wrote : AcpiTables.txt

apport information

tags: added: apport-collected running-unity staging
description: updated
Revision history for this message
Bucic (bucic) wrote : AlsaDevices.txt

apport information

Revision history for this message
Bucic (bucic) wrote : BootDmesg.txt

apport information

Revision history for this message
Bucic (bucic) wrote : CRDA.txt

apport information

Revision history for this message
Bucic (bucic) wrote : Card0.Amixer.values.txt

apport information

Revision history for this message
Bucic (bucic) wrote : Card0.Codecs.codec.0.txt

apport information

Revision history for this message
Bucic (bucic) wrote : Card0.Codecs.codec.1.txt

apport information

Revision history for this message
Bucic (bucic) wrote : CurrentDmesg.txt

apport information

Revision history for this message
Bucic (bucic) wrote : IwConfig.txt

apport information

Revision history for this message
Bucic (bucic) wrote : Lspci.txt

apport information

Revision history for this message
Bucic (bucic) wrote : Lsusb.txt

apport information

Revision history for this message
Bucic (bucic) wrote : PciMultimedia.txt

apport information

Revision history for this message
Bucic (bucic) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Bucic (bucic) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Bucic (bucic) wrote : ProcModules.txt

apport information

Revision history for this message
Bucic (bucic) wrote : PulseList.txt

apport information

Revision history for this message
Bucic (bucic) wrote : RfKill.txt

apport information

description: updated
Revision history for this message
Bucic (bucic) wrote : AlsaDevices.txt

apport information

Revision history for this message
Bucic (bucic) wrote : BootDmesg.txt

apport information

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Bucic, thank you for performing apport-collect. Could you please confirm this issue exists with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

description: updated
tags: removed: needs-kernel-logs
Revision history for this message
Bucic (bucic) wrote :

@penalvch
Please >confirm< that you still would like me to perform the above knowing that:
1. System updates made the issue somewhat (see point 2 below) go away. Not long after I filed the bug report. The login screen seems to be working as it should completely, performance-wise.
2. I am unable to assess whether Dash on my system performs at 100% right now. It may be that just the animation settings are ridiculous (see point 4 below).
3. I use a custom Compiz (?) configuration i.e. I've changed some settings via CCSM
4. Also see this AskUbuntu question I posted: http://askubuntu.com/questions/138622/how-to-disable-all-unity-animations

Note:
I am not a 'power user'. If I get stuck with the testing I will have to ask for help here.

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Bucic, well providing the testing information is up to you.

If you find the problem mentioned in the title and Bug Description remains, please provide the minimum requirement information as mentioned in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/990002/comments/49 . If the problem is gone, could you please mark this report Status Invalid?

Thank you for your understanding.

Revision history for this message
Bucic (bucic) wrote :

I'll get it done soon but let me rephrase my concerns:
I got terrible performance of Dash and the log in screen. Within the first month after the 12.04 release some updates vastly improved the performance. The problem is >I'm not sure< whether I regained 100% performance or just e.g. 95%. Ridiculously long animation times in Unity prevent me from identifying it.

Revision history for this message
Bucic (bucic) wrote :

OK, here's my final findings:
a) (if I'm forced to answer Y/N) the bug no longer exist on my system. Fixed by updates received via Update Manager during the first month after 12.04 release
b) testing the following mainline kernels I did not notice any differences regarding Dash and login screen performance:
3.4.0-030400
Currently using the latest official: 3.2.0.26
I also tried 3.5.0-5. No >major< culprits but I can't say if it doesn't affect the bug scope, so disregard it, please.
c) I was running a custom Compiz configuration (done via CCSM) at the moment of submitting data through apport. See the attached screenshot. That said I did not alter Compiz configuration prior to receiving the fix (see point a))

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Bucic (bucic) wrote :

Problem fixed after getting official updates soon after 12.04 release.

Revision history for this message
William Ranvaud (wiranvaud) wrote :

This might be a duplicate of bug https://bugs.launchpad.net/ubuntu/+source/unity/+bug/841527 (slow dash if transparency).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers