Ubuntu

[Toshiba Satellite C660D-10P] FN-Hotkeys not working on Linux 3.2

Reported by Nicolai_J. on 2012-04-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Low
Unassigned

Bug Description

Hi,

The following FN hotkeys are not working:
Toggle touchpad on/off (FN + F9)
Toggle wlan on/off (FN + F8)

Magic SYSRQ commands (REISUB for save reboot) are not working properly (my laptop have no own SYSRQ key - it's a combination of FN + HOME).

Backlight brightness control is not working (FN + F6 / FN + F7 working correctly, but no effect on backlight brightness change).

I already tested the latest the latest upstream kernel, no change.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-24-generic 3.2.0-24.37
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC259 Analog [ALC259 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu6
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC259 Analog [ALC259 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: nk 1993 F.... pulseaudio
CRDA:
 country EC:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 20), (3, 17)
  (5250 - 5330 @ 20), (3, 23), DFS
  (5735 - 5835 @ 20), (3, 30)
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xff700000 irq 16'
   Mixer name : 'Realtek ALC259'
   Components : 'HDA:10ec0269,1179fd3d,00100100'
   Controls : 19
   Simple ctrls : 11
Date: Fri Apr 27 13:05:55 2012
HibernationDevice: RESUME=UUID=a62c2468-edad-4860-9ea0-1b1b684dff1d
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 002: ID 09da:9090 A4 Tech Co., Ltd XL-750BK Laser Mouse
MachineType: TOSHIBA Satellite C660D
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-24-generic root=UUID=030271bf-b0cf-4729-98a9-9466c10bfd14 ro nomodeset acpi_osi=Linux video=uvesafb:mode_option=1024x768-24,mtrr=3,scroll=ywrap quiet
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2012-04-26 (0 days ago)
dmi.bios.date: 04/13/2011
dmi.bios.vendor: TOSHIBA
dmi.bios.version: 1.30
dmi.board.asset.tag: NULL
dmi.board.name: PWWAE
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.00
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvr1.30:bd04/13/2011:svnTOSHIBA:pnSatelliteC660D:pvrPSC0UE-00D001GR:rvnTOSHIBA:rnPWWAE:rvr1.00:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: Satellite C660D
dmi.product.version: PSC0UE-00D001GR
dmi.sys.vendor: TOSHIBA

Nicolai_J. (fireandfuel) wrote :
Brad Figg (brad-figg) on 2012-04-27
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Nicolai_J. (fireandfuel) wrote :

brightness control problem: https://bugzilla.kernel.org/show_bug.cgi?id=43168

That's 1 upstream bug, I think in this report are 2-3 bugs.
I'm not sure in which category I should report the other FN keys problems at bugzilla.kernel.org.

I add the other bugs as soon as I know in which category they should be.

PS: That is the first time I use bugzilla.kernel.org . I hope that I was precise enough for this type of bug tracker. :)

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Nicolai_J. (fireandfuel) wrote :

After searching I think Drivers/Platform_x86 is the right place for the other fn key problem.
2nd bug report: https://bugzilla.kernel.org/show_bug.cgi?id=43175

Changed in linux:
status: Confirmed → Incomplete
Francesco Muzio (muziofg-a) wrote :

This keyboard looks like the keyboard of my Satellite A300D

Some FN-FX combination maybe works if you set the keyboard layout geniuskb19e.
Also (but probably is a issue of my model) I have booted the kernel with the parameter acpi_osi=Linux

Changed in linux:
status: Incomplete → Fix Released

Nicolai_J., if you update to the 12.04.3 hardware enablement stack, is this issue resolved?

summary: - [precise] Toshiba Satellite C660D FN-Hotkeys not working on Linux 3.2
+ [Toshiba Satellite C660D-10P] FN-Hotkeys not working on Linux 3.2
tags: added: latest-bios-1.30
Changed in linux (Ubuntu):
importance: Medium → Low
status: Triaged → Incomplete
Nicolai_J. (fireandfuel) wrote :

I don't use Ubuntu since I switched to Arch Linux in Fall 2012.
Anyway, thanks for the help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.