NetworkManager keeps reporting "Wired Network Disconnected" on Pandaboard -- smsc95xx

Bug #987511 reported by Gema Gomez on 2012-04-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Installing today's image on a Pandaboard, without a wired network, connected to the wireless and network manager got all confused and kept reporting that "Wired Network Disconnected". It thought for a while it was actually connected to a wired network.

Will attach two pictures of the problem.

Despite being connected to the wireless, the moving icon of searching for a network/connecting to it kept flipping.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: network-manager 0.9.4.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-1412.16-omap4 3.2.14
Uname: Linux 3.2.0-1412-omap4 armv7l
ApportVersion: 2.0.1-0ubuntu5
Architecture: armhf
Date: Mon Apr 23 21:09:07 2012
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IpRoute:
 default via 192.168.2.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.2.0/24 dev wlan0 proto kernel scope link src 192.168.2.236 metric 2
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
PciNetwork:

ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 MIRED aa6b81d3-5ba0-48e4-9d0a-90458961895b 802-11-wireless 1335211724 lun 23 abr 2012 21:08:44 BST yes no /org/freedesktop/NetworkManager/Settings/1
 Wired connection 1 0d3d8026-36ab-41bc-9cc5-171e2674b844 802-3-ethernet 1335184856 lun 23 abr 2012 13:40:56 BST yes no /org/freedesktop/NetworkManager/Settings/0
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 eth0 802-3-ethernet connecting (getting IP configuration) /org/freedesktop/NetworkManager/Devices/1
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.4.0 connected enabled enabled enabled enabled disabled

Gema Gomez (gema) wrote :
Gema Gomez (gema) wrote :

Adding the sample images. My wireless network is called MIRED. The wired network I don't know where it comes from, because there was no cable attached to the board

Gema Gomez (gema) wrote :

This message keeps appearing.

tags: added: iso-testing qa-manual-testing
Oliver Grawert (ogra) wrote :

if you see this issue the next time, could you also attach the dmesg output ? i belive this is not network manager but the kernel driver going mad.

Thomas Hood (jdthood) on 2012-07-04
summary: - network manager not handling properly wireless only on pandaboard
+ NetworkManager keeps reporting "Wired Network Disconnected" on
+ Pandaboard -- smsc95xx
Thomas Hood (jdthood) wrote :

NM thinks that a cable is connected to the Ethernet interface; it then does DHCPDISCOVER but gets no answer, times out, and reports "Wired Network Disconnected". Probably either the hardware or the driver is misrepresenting the carrier state.

Thomas Hood (jdthood) wrote :

Could it have something to do with the foillowing?

Apr 23 12:40:46 localhost kernel: [ 0.000000] WARNING: at /build/buildd/linux-ti-omap4-3.2.0/arch/arm/common/gic.c:611 gic_init+0xb0/0x11c()

Apr 23 12:40:46 localhost kernel: [ 0.322692] WARNING: at /build/buildd/linux-ti-omap4-3.2.0/arch/arm/mach-omap2/omap_hwmod.c:1509 _enable+0x1ec/0x220()

affects: network-manager (Ubuntu) → linux (Ubuntu)
Paolo Pisati (p-pisati) wrote :

can you try with:

https://launchpad.net/ubuntu/+archive/primary/+files/linux-image-3.2.0-1415-omap4_3.2.0-1415.20_armhf.deb

also, from a command line execute:

cat /sys/class/net/eth0/carrier

and

sudo mii-tool eth0

(install the necessary tools in not already present)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 987511

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers