Ubuntu

EXT4 filesystem errors after switching to SSD drive

Reported by Dawid Wróbel on 2012-04-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have switched to Crucial M4 SSD drive this week and as soon as I booted the copied-over system from a new disk, I began noticing EXT4 errors in dmesg. They seem pretty serious and I am being warned that "data WILL BE lost". I can't confirm any data loss yet, but maybe just because I didn't notice it.

What's more, it seems that whenever I do something disk intensive, these errors tend to show up in dmesg and at the same time some processes segfault, like google-chrome's processes (plugins, tabs) or Virtualbox. It gives a feeling that maybe they are being starved by I/O scheduler. I tried noop and deadline and it's been the same, I went back now to CFQ to see if this changes anything.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-23-generic (not installed)
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: cromo 1862 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6adc000 irq 48'
   Mixer name : 'Intel Cantiga HDMI'
   Components : 'HDA:111d76b2,10280233,00100302 HDA:80862802,80860101,00100000'
   Controls : 26
   Simple ctrls : 12
Date: Sun Apr 15 20:08:10 2012
HibernationDevice: RESUME=UUID=4da1c619-669e-4d7c-9cef-ffb960bd2aa8
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100902.1)
MachineType: Dell Inc. Latitude E6400
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=c0ac5e9b-4a61-4d91-a546-5379b9ba2edb ro ipv6.disable=1 quiet splash elevator=deadline vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-22-generic N/A
 linux-backports-modules-3.2.0-22-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: Upgraded to precise on 2012-03-07 (39 days ago)
dmi.bios.date: 02/16/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A28
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA28:bd02/16/2011:svnDellInc.:pnLatitudeE6400:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E6400
dmi.sys.vendor: Dell Inc.

Dawid Wróbel (dawidw) wrote :
Dawid Wróbel (dawidw) wrote :

Switching to CFQ didn't help, I still see same errors in dmesg:

[ 1253.737180] EXT4-fs error (device sda3): ext4_ext_search_left:1224: inode #52632: comm flush-8:0: ix (5298) != EXT_FIRST_INDEX (0) (depth 0)!
[ 1253.737188] EXT4-fs (sda3): delayed block allocation failed for inode 52632 at logical offset 5344 with max blocks 2 with error -5
[ 1253.737191] EXT4-fs (sda3): This should not happen!! Data will be lost
[ 1253.737192]
[ 1421.134271] show_signal_msg: 81 callbacks suppressed
[ 1421.134275] chrome[3343]: segfault at bbadbeef ip 00007fb2c03c3c61 sp 00007fff786944a0 error 6 in chrome[7fb2bea3a000+4094000]
[ 1421.222617] chrome[3489]: segfault at bbadbeef ip 00007fb2c03c3c61 sp 00007fff78693d40 error 6 in chrome[7fb2bea3a000+4094000]

BTW. People using other distributions seem to be suffering from same bug:
https://bbs.archlinux.org/viewtopic.php?id=138532
https://bbs.archlinux.org/viewtopic.php?id=138793

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-23.36
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc3-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Dawid Wróbel (dawidw) wrote :

After some more investigation I finally noticed that all the dmesg errors were about the same inode, so I found the files stored in it, deleted them (luckily nothing important was there) and now the errors are gone. Also, one of the files was Chrome's cache so it explains the Chrome's segfault. I am still not sure what triggered the error but I think it's likely that Virtualbox caused the damage because one of my VMs was using rawdisk vmdk (i.e. attached to a physical disk) that is somewhat experimental feature. This would also explain the Virtualbox'es segfaults.

Anyway, I am sorry for confusion but I got confused myself by the apparent coincident. This bug report can now be closed and marked as invalid.

tags: added: confirmed
Dawid Wróbel (dawidw) on 2012-04-17
Changed in linux (Ubuntu):
status: Incomplete → Invalid
tags: removed: confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers