every app becomes unresponsive when nautilus is copying files

Bug #978622 reported by Terry Jones on 2012-04-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

When copying a large amount of data from one folder to another folder on the same partition it is causing all other applications to become unresponsive, most noticably Firefox 11.0.

Amount of data be copied (79GB) at a rate of between 18-30MBps, using the simple procedure of right clicking a folder, selecting copy and pasting it into another folder.

During the copying process all other applications hang, or take a good 3-5 minutes to open up. Once open they become unresponsive - - all is rectified once the copy process is complete.

System Specs:

Core i7 950
8GB DDR3 RAM
1TB SATA2 HDD

OS Specs:

Ubuntu 12.04 beta 2 LTS x64 bit with all the latest updates as of 11/04/2012 NZT

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0-0ubuntu5
Architecture: amd64
Date: Wed Apr 11 18:28:41 2012
EcryptfsInUse: Yes
GsettingsChanges: org.gnome.nautilus.window-state geometry '1152x602+215+221'
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 LANGUAGE=en_NZ:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: Upgraded to precise on 2012-04-06 (4 days ago)
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: terry 2972 F.... pulseaudio
 /dev/snd/controlC0: terry 2972 F.... pulseaudio
 /dev/snd/controlC1: terry 2972 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfbff8000 irq 56'
   Mixer name : 'Realtek ALC889'
   Components : 'HDA:10ec0889,1458a022,00100004'
   Controls : 49
   Simple ctrls : 23
Card1.Amixer.info:
 Card hw:1 'Camera'/'Sonix Technology Co., Ltd. USB 2.0 Camera at usb-0000:00:1a.7-5, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB0c45:62e0'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 3328
   Mono: Capture 3328 [100%] [31.00dB] [on]
Card2.Amixer.info:
 Card hw:2 'NVidia'/'HDA NVidia at 0xf9ffc000 irq 17'
   Mixer name : 'Nvidia GPU 10 HDMI/DP'
   Components : 'HDA:10de0010,10de0101,00100100'
   Controls : 24
   Simple ctrls : 4
DistroRelease: Ubuntu 12.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Gigabyte Technology Co., Ltd. X58A-UD7
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_NZ:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=bbf4bb05-ce35-43b7-b8bd-d57315ff5215 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-22-generic N/A
 linux-backports-modules-3.2.0-22-generic N/A
 linux-firmware 1.78
RfKill:

SourcePackage: linux
Tags: precise precise
Uname: Linux 3.2.0-22-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-04-06 (5 days ago)
UserGroups: adm admin cdrom dialout lpadmin mythtv plugdev sambashare
dmi.bios.date: 05/16/2011
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F9a
dmi.board.name: X58A-UD7
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF9a:bd05/16/2011:svnGigabyteTechnologyCo.,Ltd.:pnX58A-UD7:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnX58A-UD7:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: X58A-UD7
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Terry Jones (terryjones1983) wrote :
Sebastien Bacher (seb128) wrote :

the issue is a kernel io handling,scheduler one

affects: nautilus (Ubuntu) → linux (Ubuntu)
Terry Jones (terryjones1983) wrote :

"the issue is a kernel io handling,scheduler one"

What does that actually mean? I have sent it through with the wrong details or is it limited to just my system?

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 978622

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Terry Jones (terryjones1983) wrote :

thanks for the update, have followed all your instructions.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-23.36
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc2-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Terry Jones (terryjones1983) wrote :

Development 3.2.0.23 tested - bug still exists
Upstream 3.4 tested - bug still exists

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream
removed: kernel-request-3.2.0-23.36 needs-upstream-testing
Brad Figg (brad-figg) wrote :

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-23.36
tags: added: bot-stop-nagging
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Invalid
tags: added: latest-bios-f7 needs-upstream-testing regression-potential
removed: kernel-request-3.2.0-23.36

Terry Jones, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please just make a comment to this.

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.