pvops NULL pointer dereference oops in latest precise kernel

Bug #974982 reported by Jan Van Winkel on 2012-04-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara
Precise
Medium
Leann Ogasawara

Bug Description

=== Precise SRU Justification ===
Latest Precise Kernel (linux-headers-3.2.0-22-generic 3.2.0-22.35) does not boot in pvops mode and this due to a kernel NULL pointer dereference oops generated in xen_irq_init.

=== Fix ===
Revert commit 73d63d03 which was included in upstream stable v3.2.14. Based on discusson upstream regarding this commit, it appears it should not have been applied to upstream stable v3.2.y:

http://<email address hidden>/msg04782.html

commit 73d63d038ee9f769f5e5b46792d227fe20e442c5
Author: Suresh Siddha <email address hidden>
Date: Mon Mar 12 11:36:33 2012 -0700

    x86/ioapic: Add register level checks to detect bogus io-apic entries

=== Testing ===
The bug reporter has tested a kernel with the above commit reverted. They confirm the machine boots properly.

=== Original Bug Description ===
Latest Precise Kernel (linux-headers-3.2.0-22-generic 3.2.0-22.35) does not boot in pvops mode and this due to a kernel NULL pointer dereference oops generated in xen_irq_init.

Following post on the kernel mailing list points to patch that introduced this issue in 3.2.14 kernels:
http://www.spinics.net/lists/kernel/msg1321449.html

To confirm if the issue is was not present in the 3.2.13 kernel I installed the main line kernel (linux-image-3.2.13-030213-generic 3.2.13-030213.201203231755) and the system booted without issue.

Jan Van Winkel (vanwinkeljan) wrote :

Steps to reproduce:
* Install fresh Precise machine
* Follow instructions on http://wiki.xen.org/wiki/XAPI_on_Ubuntu to install XCP
* Reboot machine

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 974982

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
Jan Van Winkel (vanwinkeljan) wrote :

Machine can not boot due to this issue.

Problem was introduced in 3.2.14 by commit "x86/ioapic: Add register level checks to detect bogus io-apic entries" (73d63d038ee9f769f5e5b46792d227fe20e442c5)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-22.35
Jan Van Winkel (vanwinkeljan) wrote :

Problem occurred with 3.2.0-22.35

Jan Van Winkel (vanwinkeljan) wrote :

Forgot to change status

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

I'll build a precise test kernel with that commit reverted and post a link to it shortly.

Joseph Salisbury (jsalisbury) wrote :

@Jan

I built a Precise test kernel with the following commit reverted:
73d63d038ee9f769f5e5b46792d227fe20e442c5

The test kernel can be downloaded from:
http://people.canonical.com/~jsalisbury/lp974982/

Can you test that kernel and report back if it fixes this bug?

Hrm, looks like there was some confusion and discusson upstream regarding this commit and it seems like it should not have been applied to upstream stable v3.2.y:

http://<email address hidden>/msg04782.html

Jan, if we could get feedback from the test kernel Joseph created that would be great. Thanks.

tags: added: kernel-da-key
Jan Van Winkel (vanwinkeljan) wrote :

Sorry for the delay guys, I was out for a long weekend

Just tried Joseph's kernel and the machine boots correctly

Btw thanks for the quick support

Changed in linux (Ubuntu Precise):
assignee: nobody → Leann Ogasawara (leannogasawara)
status: Confirmed → In Progress
description: updated
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-23.36

---------------
linux (3.2.0-23.36) precise-proposed; urgency=low

  [ Andy Whitcroft ]

  * tools/hv: add basic Makefile
    - LP: #977246
  * tools/hv: add basic manual pages
    - LP: #977246
  * Hyper-V KVP daemon -- add to the tools package
    - LP: #977246

  [ David Henningsson ]

  * SAUCE: (drop after 3.3) ALSA: HDA: Remove quirk for Gigabyte
    GA-H61M-S2PV
    - LP: #948360

  [ Leann Ogasawara ]

  * d-i: Add dm-mirror and dm-raid to md-modules
    - LP: #919281

  [ Tim Gardner ]

  * [Config] Fix invalid linux-headers link
    - LP: #974403
  * Remove headers asm symlink entirely
    - LP: #974403

  [ Upstream Kernel Changes ]

  * Revert "x86/ioapic: Add register level checks to detect bogus io-apic
    entries"
    - LP: #974982
  * ALSA: HDA: Realtek: Take vmaster dac from multiout dac list
    - LP: #974090
  * kexec: remove KMSG_DUMP_KEXEC
    - LP: #944772
  * kmsg_dump: don't run on non-error paths by default
    - LP: #944772
  * pstore: Introduce get_reason_str() to pstore
    - LP: #944772
 -- Leann Ogasawara <email address hidden> Tue, 10 Apr 2012 08:16:09 -0700

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers