Wireless Dropout - Tx aggregation enabled on ra (workaround: iwlwifi requires 11n_disable=1)

Bug #974838 reported by Evan Carroll on 2012-04-06
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Fedora)
Fix Released
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

After repeated messages in syslog with "Wireless Dropout - Tx aggregation enabled on ra" the wireless connection drops but nm-applet shows the connection is maintained.

[ 1993.150229] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2027.374298] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2038.349962] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2067.814290] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2165.598224] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2213.412664] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2236.470968] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 6
[ 2270.489254] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2714.040308] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2753.314277] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2788.096691] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2934.442107] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0
[ 2993.274320] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:24:a5:d7:9e:5e tid = 0

Download full text (4.4 KiB)

After a period of time, the wireless simply stops functioning... NetworkManager
thinks its still connected.. but no network traffic works.
After a period of time (if left) sometimes it reconnects at G-54Mbit speed.. vs 'N' at around 270Mbit

The following are observed in dmesg:

[ 505.669220] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 555.202192] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 588.834218] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 617.740773] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 690.116581] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 742.430541] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 788.704026] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 801.676020] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 962.686813] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1015.634260] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1099.420837] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1107.568703] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1119.465765] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1147.984058] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1213.937449] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1239.211977] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1352.128153] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1428.874172] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1467.239910] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1501.816674] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1585.802417] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1638.777505] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1669.836635] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1706.886181] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0
[ 1733.298790] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 00:04:ed:bb:c6:fd tid = 0

Kernel; Linux greenback.local 3.2.2-1.fc16.x86_64 #1 SMP Thu Jan 26 03:21:58 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Some details as to the wireless adapter;

[ 5.214347] Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[ 5.214441] iwlwifi 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 5.214496] iwlwifi 0000:03:00.0: setting latency timer to 64
[ 5.214542] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
[ 5.214544] iwlwifi 0000:03:00.0: pci_resource_base = ffffc900058a0000
[ 5.214545] iwlwifi 0000:03:00.0: HW...

Read more...

I have this problem too. I'm using Fedora 16 with all the latest updates. It seems to have stopped working properly in the last few days.
To get my connection backup I have to
systemctl restart NetworkManager.service

/var/log/messages is full of lines like
Feb 5 07:45:17 localhost kernel: [ 7143.937635] iwlwifi 0000:06:00.0: Tx aggregation enabled on ra = 00:26:5a:cc:6a:5d tid = 0

It is an incredibly annoying problem

kernel-3.2.2-1.fc16.x86_64

I think this is a duplicate of 785561

making a file
 /etc/modprobe.d/iwlwifi.conf with a single line
 like this:
options iwlwifi 11n_disable=1
is a temporary fix

this line disables 11n and leaves things in g

There is also a thread from November 2011 on the kernel mailing list so why did this end up released when it's disastrous for anyone with this wifi card ?

confirm this bug on kernel-3.2.2-1.fc16.x86_64.

yes the problem is with kernel-3.2.2-1.fc16.x86_64

An update released just then into 'updates' reports to fix this, update includes kernel-3.2.3-2.fc16.x86_64

Currently connected back at 243 Mb/s ... this bug is VERY reminiscent of something around this time last year that had the same work around 'options iwlwifi 11n_disable=1'

kernel-3.2.3-2.fc16 should address this issue.

kernel-3.2.3-2.fc16.x86_64
appears to fix the problem
thank you

Changed in linux (Ubuntu):
status: New → Confirmed
Evan Carroll (evancarroll) wrote :

I believe this is a continuation *but* not a duplicate of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/876147

I previously had the following in /etc/modprobe.d/iwlagn.conf

options iwlagn 11n_disable=1

This made everything work for my Lenovo x200s. Then I upgraded and iwlagn was renamed to iwlwifi. Iwlagn was aliased to iwlwifi.conf however the options in the modprobe.d did not carry over. I had to rename the file to iwlwifi.conf (/etc/modprobe.d/iwlwifi.conf) and then change the contents to

options iwlwifi 11n_disable=1

This stops my iw card from going 802.11n but permits me to hold a steady connection.

Evan Carroll (evancarroll) wrote :

ie., during the upgrade from 11.10 to 12.04 perhaps /etc/modprobe.d/iwlagn.conf should be renamed to /etc/modprobe.d/iwlwifi.conf with s/iwlagn/iwlwifi/g in the file. And, perhaps we should consider adding `11n_disable=1` to the file in the event no file is created: this problem is fix in kernel 3.3. We won't have to worry about it for 12.10.

summary: - Wireless Dropout - Tx aggregation enabled on ra
+ Wireless Dropout - Tx aggregation enabled on ra (workaround: iwlwifi
+ requires 11n_disable=1)
Seth Forshee (sforshee) wrote :

What kernel are you running? Actually you should just run 'apport-collect 974838' to get this and a lot of other useful information attached to this bug. But the fix referred to by the Fedora bug has been in precise for a while now.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
Paul Szabo (psz-maths) wrote :

After upgrading my home router from an old device with 802.11g(?) to
a model supporting 802.11n, I could not connect to wireless anymore,
could not even ping the router itself.

Noticing the line in /var/log/syslog and googling for
  ... iwlwifi ... Tx aggregation enabled on ra = ... tid = 0
I noticed this bug report. As suggested here, creating a file with
one line so:
  $ cat /etc/modprobe.d/iwlwifi.conf
  options iwlwifi 11n_disable=1
allowed things to work just fine.

My kernel version:
  $ uname -a
  Linux psz-laptop 3.2.0-32-generic #51-Ubuntu SMP Wed Sep 26 21:32:50 UTC 2012 i686 i686 i386 GNU/Linux

---

I tried to use "apport-collect 974838" but it told me this bug was not mine.
Instead I attach extracts from /var/log/syslog:

syslog.old-without-802.11N
  Logs with the old 802.11g(?) router

syslog-bad
  Logs with new 802.11n router, cannot connect

syslog-good
  Logs with new 802.11n router and with 11n_disable=1 workaround

---

Cheers, Paul

Paul Szabo <email address hidden> http://www.maths.usyd.edu.au/u/psz/
School of Mathematics and Statistics University of Sydney Australia

rCX (rcx) wrote :

Had the same problem and saw many "Tx aggregation enabled on ra" errors in syslog.
The suggested workaround ("options iwlwifi 11n_disable=1" in /etc/modprobe.d/iwlwifi.conf) seems to fix this.

OS: Ubuntu 12.04
Kernel: 3.2.0-60-generic
Computer: Lenovo Thinkpad Edge 14
Wireless Card: Intel Centrino Wireless-N 1000

Changed in linux (Fedora):
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.