Screen brightness and other Fn keys do not work on HP Folio 13

Bug #974568 reported by Craig Taylor on 2012-04-05
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Debian)
Fix Released
Unknown
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hardware: HP Folio 13 1000ea

Description: Ubuntu precise (development branch)
Release: 12.04

I have had a good search online about this topic and the best advice seems to be that I should raise a bug here.
There has been good discussion in the forum here:
  http://ubuntuforums.org/showthread.php?t=1913496

But ultimately the screen brightness, and wifi toggle keys do not work, or seem to register in showkey, xev etc.
The media keys register an event, but do not seem to be mapped correctly to the appropriate action.

I see the same behaviour in 11.10 also...

Regards,
CraigT

Nick Harris (nj-harris) on 2012-04-05
Changed in ubuntu:
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/974568/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Craig Taylor (h-c-o) wrote :

Assuming this is kernel relating and obeying 'bugbot'.
c

affects: ubuntu → linux (Ubuntu)
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc2-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: precise
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Craig Taylor (h-c-o) wrote :

Tested against the 3.4-rc2 release; No change.

tags: removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Nick Harris (nj-harris) wrote :

I will do that for you, i shall keep you updated with the responce.

Changed in linux (Ubuntu):
status: Triaged → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-23.36
Nick Harris (nj-harris) wrote :

Here is a link to the bug report on bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=43097

If you would like me to cc the bug to you just leave me your email address or send me an email at <email address hidden>

Nick Harris (nj-harris) wrote :

Please update the kernal like brad figg said and i will update the bug on bugzilla.
Thanks for your help to make ubuntu better.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Craig Taylor (h-c-o) wrote :

Thanks for sticking this into bugzilla, I can assure everyone monitoring this thread that I test every update and would report back should it resolve the problem.

I can confirm that the function keys for f2 (brightness down), f3 (brightness up) and f12 (toggle wifi) is not recognized by the kernel (i.e. no scancodes with /lib/udev/keymap -i input/event2, acpi_listen, xev or showkey).

Precise Pangolin@Kernel: 3.2.0-26 with HP Folio 13.

Do you need help testing with 3.3/3.4 kernels?

TomasHermosilla (thermosilla) wrote :

Confirmed in 3.5 too

no longer affects: xfce4-power-manager (Ubuntu)
Changed in linux (Debian):
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Invalid
Stefan Nagy (stefan-nagy) wrote :

This bug is about to get fixed upstream; the fix will probably be included in kernel v3.10.

Daniel van Vugt (vanvugt) wrote :
Changed in linux:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in linux:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in linux:
status: Fix Released → Confirmed
Changed in linux:
status: Confirmed → Incomplete
Changed in linux:
status: Incomplete → In Progress
Changed in linux:
status: In Progress → Fix Released
Daniel van Vugt (vanvugt) wrote :

Fix released in Ubuntu 13.10 saucy. Somewhere around kernel update 3.10.0-5 it started working.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in linux (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.