Ubuntu

[Lenovo IdeaPad U300s] 't' key sends "Hiragana-Katana"

Reported by Jonathan Lange on 2012-04-05
92
This bug affects 17 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Since booting today, my laptop's 't' key (physical) does not function correctly. Instead of sending the correct keycode, it sends "<Hiragana-Katakana>. I use a dvorak keyboard layout, so it ought to map to 'y' for me.

jpds reports that cparrino has had the same issue on nearly-identical hardware, and that the key also does not work in grub.

He also provides this work-around:

 $ xmodmap -e "keycode 101 = t"

Which only works in qwerty. Use "keycode 101 = y" for dvorak.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-22-generic 3.2.0-22.35
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jml 2013 F.... pulseaudio
Date: Thu Apr 5 18:13:59 2012
HibernationDevice: RESUME=UUID=b85b0353-c88b-4a7b-93ca-aa6190b1ff4d
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: LENOVO 1080
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=36faead1-a41c-4363-813a-2c4c56e715ef ro quiet splash vt.handoff=7
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/21/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 56CN38WW
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: U300s
dmi.board.vendor: LENOVO
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo IdeaPad U300s
dmi.modalias: dmi:bvnLENOVO:bvr56CN38WW:bd11/21/2011:svnLENOVO:pn1080:pvrLenovoIdeaPadU300s:rvnLENOVO:rnU300s:rvr1.0:cvnLENOVO:ct10:cvrLenovoIdeaPadU300s:
dmi.product.name: 1080
dmi.product.version: Lenovo IdeaPad U300s
dmi.sys.vendor: LENOVO

Jonathan Lange (jml) wrote :
Brad Figg (brad-figg) on 2012-04-05
Changed in linux (Ubuntu):
status: New → Confirmed
Jonathan Davies (jpds) on 2012-04-05
tags: added: css-sponsored-p
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a kernel version where you were not having this particular problem? This will help determine if the problem you are seeing is the result of the introduction of a regression, and when this regression was introduced.

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
Jonathan Davies (jpds) wrote :

xev output of 't' key on an affected laptop.

Jonathan Lange (jml) wrote :

I can't time it to a particular upgrade, sorry, there are so many upgrades at this point of the development cycle. If you can tell me how to figure out whether an upgrade happened based on a guess of a date, then I will do so. As it is, I first saw this issue on the day or the day before filing this bug, and I upgrade two or three times a week.

Note also that I have to run the above 'xmodmap' command again after resuming from suspend.

I used Xubuntu 12.04 Beta 1 and after an uptime of ~12 days the "Delete"-Key were suddenly mapped wrong. Instead of deleting, it triggert right-mouse-btn menus. After 19 Days of uptime the Arrow-Up-Key was suddenly mapped wrong.
I did never upgrade or install much except QtCreator and the Ogre SDK.
After 29 days of uptime i suddenly got a system freeze and hat to kill my u300s via a hardware switch. So i took the chance and did a full system upgrade via synaptics . Everything got even worse, intel driver is crashing all the time and shit, SysRq keys dont work anyway and the buttons now keep getting mapped wrong even after reboots.
I used those keycodes to fix them temporarly ( for some reason they got wrong-mapped after some time again):
xmodmap -e "keycode 96 = Delete"
xmodmap -e "keycode 75 = Up"

srsly wtf ?

* Just wanted to add that I'm using a german keyboard and german kb layout, so dont wonder about different keycodes.

Tim Peeters (tpeeters) wrote :

Yes, this sounds very weird but I have almost the same problem.

I use US keyboard layout (I bought the U300s in Malaysia), and after a few weeks suddenly my 't' key did not work anymore. Maybe it was mapped to another key also, but I did not check at the time. I thought it was a hardware problem and after taking the laptop apart and putting it back together it worked again.

And since today, my Delete key does not work anymore. I also booted windows and I had the same issue (Delete not working) there. I checked (on Ubuntu) with 'xev' and it is mapped to keycode 74, like the F8 key. I "fixed" it with
$ xmodmap -e "keycode 74 = Delete"

but now my F8 also acts as a delete key. And, of course, Delete was working before and suddenly changed its behavior, which is weird. Can it be a hardware or bios problem?

Scott Ransom (sransom) wrote :

This is interesting... a month or so ago my "t" key on my Lenovo U300S started returning the event for "F3". This happened even in the BIOS screen (i.e. it was not a Linux or Ubuntu issue) and it started happening at some random time days after rebooting/upgrading. Lenovo replaced my keyboard in the laptop and the problem has not appeared since.... So this could be a manufacturing defect with the laptops.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc2-precise/

tags: added: needs-upstream-testing

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-23.36

On my Levono U300s, the 't' key seems to have remapped to TAB. It this occurs in the BIOS as well.

Takashi Kawashima (coolshades) wrote :

I had the same issue with my U300s. When I pressed "t" key, the key was recognized as "F10". I'm using the US key mapping. It started less than a week after I received it from Lenovo.

From what I see, the cause of the symptom is not in the OS level. Like Will stated I observed the same symptom in the BIOS level.

I applied the latest BIOS update from Lenovo (ver. 56cn43ww) that was released on April 20.
http://consumersupport.lenovo.com/us/en/DriversDownloads/drivers_show_5482.html

After the BIOS was updated, the wrong key mapping was fixed. I assume Lenovo was aware of the mapping issue and included the fix in the current BIOS update.

One thing to note is that you may need to restore the factory default OS (Win7) to apply this update since no iso version is distributed by Lenovo at this moment.

Tijn Schuurmans (tijns) wrote :

In the evening of the same day that I got my U300s the 't' key started sending "Hiragana-Katana". Luckily I was able return this laptop and I got a brand new one. A week after I got that one, its "delete" key started acting up. It thinks it's "F10" now. The situation is really similar to what Alexander Hochreite (noir-baumann) and Tim Peeters (tpeeters) described.

Alexander are you sure it is sending right-mouse button? It sounds to me like it could very well be the signal for F10, since that key opens the menu in Gnome. Did you double-check it with xev?

One interesting thing I noticed is that the two laptops I owned are made on the same date. See the sticker on the bottom: Mfg Date: 11/12/24. Moreover, the first laptop has a serial number that is 2 higher than its replacement. Could it be that we simply discovered a bad batch of keyboards? Can anyone else check the manufacturing date?

Tijn Schuurmans (tijns) wrote :

I am going to try to do the same thing as Takashi Kawashima (coolshades) did. That will be a tricky thing since I've blown away the windows-partition but if I manage to do it I will post the results here.

Tim Pennucci (ttp4tx) wrote :

I got my U300s three weeks ago or so and just now my 't' key decided to map to Shift_L. I was logged in at the time, the computer was idle with its screen locked. I was aware that this problem has cropped up on other machines, so I knew where to look. I also see that the 't' key doesn't work in BIOS, and I don't know how to update the BIOS driver since I, too, have blown away Windows...

Tijn Schuurmans (tijns) wrote :

My attempts to boot up Windows to flash the BIOS completely failed. So, I sent my laptop to the Ideapad service center with a letter that contained a link to this thread and explained everything I tried to fix it.

I got a short letter back with my laptop saying that they simply flashed the BIOS for me. This seems to have solved the problem indeed; the delete key is working again. I only wish there was a way to flash a rom from the BIOS configuration settings (I heard that some Asus laptops do this) so that I would not dependent on Windows. But in the end, I am really happy with the way this problem has been resolved.

TL;DR: problem is likely a BIOS software problem. BIOS update solves it.

Tijn Schuurmans (tijns) wrote :

The soap continues, within a day my T-key started sending the signal for Hiragana-Katana. I just found out that the service center flashed an old version of the BIOS 56cn38ww, while 56cn43ww is the newest. I am really unhappy with this situation.

Conclusion: the problem is resolved by flashing the BIOS with any version. The problem occurs afaik (at least) with 56cn38ww.

It's almost like the bug reprograms the keyboard. I have a strong feeling that it is linked to switching between X and a virtual terminal (in text mode). I think the problem started when I switched from a text terminal (where I ran apt-get as super-user) to X where I was logged in in Gnome. I think somehow pressing ctrl+alt+fn+F2 (switch to text terminal 2) or ctrl+alt+fn+F7 triggered the bug to mess up the T-key. (I might have accidentally pressed shift as well, or maybe missed an alt or ctrl once, it's surprisingly hard to press the right keys+fn if one's used to doing it on muscle memory alone.) This T-key-thing happened to me twice now, and the first time I remember having the same feeling about it.

Jonathan Lange (jml) wrote :

Anyone managed to flash the BIOS without a Windows install?

Takashi Kawashima (coolshades) wrote :

Hi Tijn,

As far as my U300s is concerned, since I updated the BIOS to ver. 56cn43ww, the keyboard issue has NOT come back and seems to be resolved. If the BIOS version of your laptop is a previous version, I think it is worth trying the version I have installed.

I guess the problem for many of us is that the BIOS update requires Windows to run on the laptop. Luckly I created the restore DVDs before wiping the SSD, so I was able to reinstall Windows 7. I also used G4L to restore Linux partitions after the BIOS update was complete.

In any case, what Lenovo should have offerred is an ISO version of BIOS update utility besides the current updater which requires Windows to run. If you have an XP CD-Rom, you can install the OS to update the BIOS, but it will be a pain in the neck.

Tijn Schuurmans (tijns) wrote :

Thank you Takashi!

Last weekend I finally succeeded in installing (a borrowed version of) Windows 7 on a small partition to flash the BIOS.

To everyone struggling with the same thing: for me, the trick was to use the Windows USB Boot Tool on my old Vista laptop to create a bootable USB-stick. This is a small app MS provides to put an windows installation ISO image on a USB stick. (Who knew this existed? I didn't until the local computer shop guy told me about it last week.) When you run the Windows installer it will show an error about a missing DVD drive (well, duh.). You then have to put the USB stick in the other USB port and simply click "Install Windows" once more. This will trick the installer and it will not show the error again.

I flashed the BIOS with version 56cn43ww. Since then the T key and delete key behave as expected. I tried pressing ctrl+alt+win+shift+F2/F7 in all sorts of combinations to see if I can mess it up again... but to no avail (see my previous post). I really hope this has solved the issue. Fingers crossed.

Tijn Schuurmans (tijns) wrote :

Issue is not solved after all. My T-key is failing again.

I now know how one can reproduce it:

    While running on battery, press Fn+Alt+F2 (to enter a command in gnome-shell).

That's all it takes, and it is totally in line with what I first encountered. To make it worse, I can't repair it because WinFlash.exe won't flash my BIOS again. It refuses to flash a BIOS with the same version number.

I'm encountering this issue too. It started with the letter 't' acting as the F9 key (same keycode in xev and showkeys). Since yesterday things got worse. By now the keys t, arrow-up, delete and F5 all act as the F9 key, which renders the xmodmap solution useless (all 5 keys result in the letter t because xmodmap).

Are there any ideas to work around this?

Did anyone try a factory reset with recovery discs?

Update:
So I called Lenovo and they told me to send the laptop back. I recovered it to factory state with dvds I burned before I did a clean Kubuntu install. This morning (~5 days back on win7) I opened the lid and pushed the power button to switch the machine on. Apparently it was hibernating because after I pushed the power button again I got a menu from windows asking me if I wanted a normal resume from hibernation or a reboot. All of a sudden I noticed my arrow-up key was functioning again.... Opening Notepad and striking my affected keys (t, arrow-up, delete, F5) made me realise this issue had resolved itself, for now. I was planning on sending it back to Lenovo today but I guess I'll wait with that (what can they do if everything works normal).

I think I will stay on windows 7 for a while to see if the keys keep behaving as they should.

Cheers

Tim Peeters (tpeeters) wrote :

Tijn, you were asking for the manufacturing date. Mine is 11/12/06, not the same week but it is the same month.

I have the U300s version with an i5 CPU.

I can happily report that I haven't had the keyboard issues for a while now. I still didn't figure out why I had them before, or why I don't have problems anymore now. The only problem I have at the moment is that I don't dare to remove Windows to use the full disk for Ubuntu, because the keyboard problem may come back and then I need to do a BIOS upgrade from Windows.

Tijn Schuurmans (tijns) wrote :

Thanks Tim!

Last week my story became even more absurd. On Tuesday my U300s returned from the Lenovo service center (in NL that's Medion). This might have been its fourth or fifth trip there. They replaced the keyboard and upgraded the BIOS (which I found surprising since it already had the latest version as far as I know, but hey, it's probably just fine). Anyhow, it was a real speedy repair so I was quite happy and I finally thought these troubles were over.

On Wednesday I took this laptop on a business trip. As I was typing notes during a meeting I got the feeling that I was mistyping characters twice every now and then. Over the next two days this turned out to be a real (different) keyboard-error. The problem quickly got worse; I can now hardly type one line without having unwanted double characters or unexpected kb-cursor movements. (before you ask: the trackpad is not on while I'm typing).

So, the story continues...

Cliff Wells (cliff-develix) wrote :

Mine started doing this last night (delete key performs some other function) after resuming from suspend. I'm running their latest BIOS (checked before I installed Ubuntu) on an i7. It worked fine for two weeks prior to this.

One thing about this keyboard is that the Fn keys can be remapped from the BIOS (so you either get Fn keys by default or control keys). I tried toggling this value but it had no effect. Still, I suspect the issue may be related to this feature.

Cliff Wells (cliff-develix) wrote :

@Tim

Are you planning on returning this system for a refund? If you've sent it in that many times, you should be able to get a refund. I'm sending mine in for "repair" mostly so that I can create a record of repair attempts in order to force a refund. I'm curious if anyone else has tried to return theirs and what obstacles they had to overcome.

My impression of this system is that it's lacking in features and quality for a so-called premium laptop. We also have a Samsung Series 9 (NP900X3B) and a Dell XPS 13. Both are superior machines compared to the U300s, and they cost significantly less as well.

Tim Peeters (tpeeters) wrote :

No, I am not planning to return the system for a refund. I bought it when I was in Malaysia for two months (its a lot cheaper there, but I knew I was taking a risk with warranty), and now I am (back) in Netherlands and I doubt that I have rights to any warranty at all. I think they don't even sell this model here. Also, I never sent it in, so there's no record of repair attempts.

And for the last weeks at least it has been working without any problems. So I just hope it stays working.

Moisés Herrera (mfherreradi) wrote :

Hello everyone,

Same problem after opened a console from GUI (as tijns said in post #21) u300s i5, ubuntu 12.04 and gnome 3.4.
Enabled t key with xmodmap -e "keycode 75 = t" on a terminal.
I'm waiting for a kernel fix.

Regards,
MH

Tim Peeters (tpeeters) wrote :

Moisés, which kernel are you running? Can you post the output of 'uname -a'?

If you have the kernel that Brad Figg requested to test with or newer, the status of this bug report can be changed from Incomplete to Confirmed. I have a new kernel, but I didn't have the issue for a while now so I cannot confirm.

Thanks,
Tim.

Moisés Herrera (mfherreradi) wrote :

Hi Tim,
I'm sorry for this late response, I'm running 3.2.0-29-generic

I hope this can help.

Best regards,

MH

Moisés Herrera (mfherreradi) wrote :

Tim,

Today something weird happened, I just remember being downloading from Ubuntu Software Center, "Chromium web browser". After the installation, the "t" key was missed again, checking xev command, reports keycode 117 (same as "Next").
Now I have two "t" key on keyboard and no "Next" key.

uname -a full-line outputs
Linux MH-IdeaPad-U300s 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Best regards,
MH

Tim Peeters (tpeeters) on 2012-08-22
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Milan Slezak (miloush) wrote :

I had the same problem...

First time i solved it by flashing to last BIOS version. But the problem returned after some time so flashing is just temporary fix. Last BIOS (56CN43WW) does not fix the problem. The act of flashing probably resets something somewhere and makes it work, until UBUNTU mess it up again. How it does I dont know, just wondering how OS can break something on BIOS level...

Next time I made couple of actions and i'm not sure what exactly made my 't' work again:

- I was Enabling/Disabling Function keys in BIOS (...that can be related to some kind of keyboard remaping)
- I Used recovery button on left side when NB was switched off and than choosed "One key recovery" (and as I don't have recovery image on my disk it failed)
- I tried to load BIOS defaults
- I accidently let my NB switched on and drained battery

Personaly I think "One key recovery" or playing with "Enabling/Disabling F keys" was the trick but I cant confirm that so for sure i'm listing all actions I took. The only true is that my 't' is back without BIOS flashing.

Hope this was helpfull...

Milan Slezak (miloush) wrote :

Well, problem with 't' is back in 2 days... It has really something to do with recovering from Suspended state.

None of the procedures I mentioned in previous post worked except one !!!

I decided to remove bottom lid and disconnect the battery (Can't lose weeks waiting for warranty repair). And BINGO my 't' is back !!! (...Accidental battery drain did the job for me last time)

Here is u300s maintenance manual:
http://download.lenovo.com/consumer/mobiles_pub/ideapad_%20u300_u300s_u400_hmm_1st_edition_oct_2011.pdf

If somebody knows some less invasive way how to reset please share ;)

Thanks,

Miloush

robert.vertesi (vertesi) wrote :

I confirm that draining the battery makes this error go away. However I agree it would be better if we had some more gentle solution... This arror is really annoying and I do not understand how the op.sys. can break something on the BIOS level...

I have an u300s since a month and the keys have already got messed up twice. First it was 't' and I flushed the firmware from windows. Next time the up arrow went wild but you cannot flush again with the same version so I drained the batteries with cpuburn. I have no idea what caused the error. First i was typing in the terminal and I couldn't hit 't'. Next time I was just browsing around when I realized I could not scroll the page upwards.

robert.vertesi (vertesi) wrote :

Sorry for spamming this thread but do ALL U300s's do this with Precise?
It took less than a day and my Del key began sending
^[[19~ 27 0033 0x1b
   91 0133 0x5b
   49 0061 0x31
   57 0071 0x39
  126 0176 0x7e

I am considering sending the computer back. I really don't want to. But if the next one would do the same than it's pointless and I have to select another make or get rid of Ubuntu...

Carlos Aguilar (aguila-x-) wrote :

Hello everybody

i'm new at linux, actually im still learning some basic terminal commands and i got this problem too.. I use CentOS 6.3

So actually the only way to solve is draining the battery.. is there any other way?

tyvm

Cliff Wells (cliff-develix) wrote :

@robert.vertesi You *can* reflash using same version, you have to do it from command line and use /force option. I no longer have my U300s, so I can't give you the exact path/command to run, but I did it right before getting rid of it.

robert.vertesi (vertesi) wrote :

Carlos, do you have a dual boot machine? You can download the firmware update for windows from Lenovo's homepage. This will fix the issue at least once...

Cliff, thank you, i'll try to figure it out when it breaks next time.
I think, however, that flashing the firmware on a regular basis from op.sys. is not a guarantee for long life (of the laptop).

In case anybody was wondering, the problem also occurs on Ubuntu 12.10 Beta 1 ... so tired of this bug, keeping me from running linux ..

security vulnerability: no → yes
security vulnerability: yes → no

Anyone know how to force the BIOS update from console? I cant seem to figure it out, and more and more keys are getting remapped..

Milan Slezak (miloush) wrote :

Can somebody confirm that "Cliff Wells" trick to reflash same BIOS version using /force option works? Is there any manual for BIOS flashing util? I tried almost every combination of cmd options (/? /help .....) to get help but with no success.

Now my NB works ok (after battery disconnect) so I have no reason to try but its fine to know for future... I DONT SUSPEND and problem does not appear since that time.

Good luck!

"winflash /FORCE" allowed me to launch winflash and reflash an older BIOS.

ptoche (patrick-toche) wrote :

I have just joined the club. I've had my Lenovo U300S for nearly a year now and only yesterday, for the first time, have I experienced the bug. I have a dual-boot windows/ubuntu. The bug is definitely in the bios since it affects both os. In my case, the letter t is remapped to F9 (because I'm on dvorak, it's actually the letter y). The same remapping on windows and ubuntu.

As a workaround, I have remapped the keys. On Windows I use Sharpkeys, a simple freeware which modifies the registry. On Kubuntu, I have used $ xmodmap -e "keycode 75 = y"

The problem started after ... I flashed the bios. I flashed the bios because all of a sudden some of the function keys started to go. I couldn't access most of the function keys between F7 and F12, including the wireless switch and the brightness keys. After flashing the bios, the function keys started working again. But that's when I lost the letter t. And I seem to have lost it for good.

I had flashed with the latest bios, 56cn38ww. After detecting the problems, I downdated the bios, but that didn't help. I still have a windows partition so I flashed the bios within windows. In case you're wondering, to downdate in windows, you can execute a bat file with the following line of text:
C:\BIOS\56cn43ww\WinFlash.exe /NODATE C:\BIOS\56cn43ww\56CN43WW.ROM
where you should check that the paths are consistent with your setup.

Now for all intent and purposes my laptop is working since I have remapped the t-key and I don't care much for F9. But I don't like it no I don't Mr Lenovo!

I'm going to try to drain the battery. I'll get back to you if I learn anything interesting.

ptoche (patrick-toche) wrote :

In my previous comment I seem to have mixed up the bios references 56cn43ww and 56cn38ww, I have flashed back and forth several times between them to no avail. Does anyone know of another bios?

ptoche (patrick-toche) wrote :

Update on my previous report: Draining the battery (the old fashioned way) worked for me. All my keys came back, even the letter t.

However, within a few hours, the problem returned. And here is what I believe happens: Recall that I have a dual-boot windows-kubuntu. The problem occurred after I disabled the wireless from within windows (using the function key FN+F7 and clicking the Lenovo pop-up gui), then having disabled the wireless went into kubuntu, went back into windows and the special function keys were gone.

I recall doing something like that around the time of the first problems.

To be clear, the letter t was still there, but the function keys from F6 to F12 were gone.

The problem stumped me for a while. I reinstalled a bunch of drivers and flashed the BIOS, to no avail. I noticed that my webcam was gone too. I started suspecting a hardware problem. After all, my ssd died after only one month, so the machine is fragile. So to sum up: within a few hours of fixing the problem, I was in trouble again: no webcam, no wireless, several function keys dead.

Then I got an idea: I disabled the wireless from the BIOS (the wireless was shown as enabled, so I didn't immediately think of fiddling with that). Then I disabled the wireless, went into windows, then went out again re-enabled the wireless in the BIOS, went back in and voilà! Not only was the wireless back on but the function keys started working again.

It took me a little while to get the webcam to work because I hadn't realized that FN+F9 is an activating shortcut, but I did figure it out after a while. And suddenly everything was back to normal (except the time wasted, which is lost forever).

Unfortunately none of these actions were performed under controlled-experiment conditions.

If I have learned anything though, it's this: draining the battery may get your letter t back, disabling and re-enabling the wireless in the BIOS settings may get your function keys back, and avoiding launching Ubuntu with the wireless disabled can save you some headaches.

robert.vertesi (vertesi) wrote :

After a couple of weeks my 'del' key got screwed up again.
This is getting to be a bad joke.

I confirm that you can flash the BIOS to the same version using
C:\BIOS\56cn43ww\WinFlash.exe C:\BIOS\56cn43ww\56CN43WW.ROM /FORCE
but it makes no use.
However it does if you do it with an older version, like I did with
C:\BIOS\U300s\WinFlash.exe C:\BIOS\U300s\56CN38WW.ROM /FORCE
So I am running on the older bios now and the 'del' is fine.
Probably one can go back and force between the versions every time the kb breaks.

About the circumstances of this bug: I realized it after resuming from suspend. However it may happened earlier today since before suspend I used an external kb with which I most likely woulld not notice it even if it was there.

Tim Peeters (tpeeters) wrote :

Now my Delete key got mapped to F5 :s Not convenient at all.

I thought the problem was not occurring any more, but I realize that it always happens when I travel. It happened after I opened the laptop and it came back from standby, and my wireless network was switched off before I closed it.

I will try to see if disabling and enabling wireless in the bios helps, as ptoche suggested. I never used Windows, so that is not the problem.

Tim Peeters (tpeeters) wrote :

I cannot fix the problem by making changes in the bios and rebooting.

Tim Peeters (tpeeters) wrote :

My problem got solved by using WinFlash to upgrade my bios from 56CN38WW to 56CN43WW, for now... Let's see when it comes back.

Moisés Herrera (mfherreradi) wrote :

What happened with this tread?
Any good news?

I'm suffering from this issue months ago and there is no known fix.

Milan Slezak (miloush) wrote :

I personally always bring cross screwdriver with me and if shit happens it takes me about 2 minutes to open back lid and disconnect battery :D
Unfortunately I did not find quicker nor persistent solution yet...except not suspending / hibernating or buying new NB.

I don't expect Lenovo (or Canonical) to solve it :(

Good luck!

Moisés Herrera (mfherreradi) wrote :

No suspend/hibernate (a must in today's laptops)... ok

Anyway, this is not a trivial issue,
t missed key makes virtualized machines almost unusable, there is not an easy workaround to bring back t on a Guest machine.

It's a shame Ubuntu.

robert.vertesi (vertesi) wrote :

Yeah, the good news is that they fixed the computer after a bios upgrade failed at 99%.
I thought the machine was completely bricked, and I lacked it for 1.5 months.
Therefore
***********************************************************
I DO NOT RECOMMEND USING THE METHOD DESCRIBED IN #47
***********************************************************
Now I'm looking for an alternative to Ubuntu.
It's a pity and a shame...

ptoche (patrick-toche) wrote :

Robert, I don't know how much of this is software and how much of it is hardware (or maybe a combination of both) but consider this:

I got the U300S in approx November of 2011, by February of 2012 the hard drives had died and had to be replaced. In approx September of 2012, the t-key issue had spread to the function keys, to the touchpad and eventually no BIOS flashing or anything could help. I took the laptop in for repair in October, a couple of weeks after reporting some success on this bug discussion.

Lenovo replaced the entire keyboard and touchpad, plus said they also replaced the internal battery charger and the USB3, even though neither of these had caused me any problem. I was happy man until a few weeks ago. Then this: first, I noticed the loudspeakers weren't working, but since I don't use them I couldn't be sure how long it had been, the sound was fine with a headset, for about a week, when that also went south. Then I lost the touchpad again, for a few hours, and then the delete key is now completely gone. In the meantime the USB3 (which had been working 100% until Lenovo replaced it, reporting problems in their tests) started to work only about 50% of the time (2 insertions for 1 detection). I'm taking it to repair for the third time tomorrow.

So bottomline: there's a very serious issue inside, probably cables improperly connected and shorting and damaging the hardware. For some reason there's an interaction with Ubuntu and/or the sleep mode / battery charge. But the bottomline is: it's rotten inside. So if you have a warranty, get it all fixed by Lenovo and think twice next time you buy a new laptop.

robert.vertesi (vertesi) wrote :

Patrick, I couldn't agree more...
Ok, strictly speaking it's not an unavoidable hardware bug because Win7 works well. But...

I installed Fedora w/ Gnome3. It took me 2 days to install everything and configure the whole (dual boot) system as I like.
Than yesterday evening the "up" key broke. It sends some weird stuff and if I try to change to prev. workspace (ctl+alt+up) the X crashes. So I'd rather say it's a kernel or gnome bug.

Since mid-November the I could use the machine 3 days altogether and I have to send it back again.
I wonder if there are U300s's at all which do not break under Linux? Does it make any sense to push for a replacement? Should I try a virtual machine under Win7?
(The warranty process is quite difficult for me since the company communicates with the repair shop, I don't even speak the language here and have no idea what they do... The funny thing I chose the make because of (its former) reliability and linux-compatibility. Although I was warned I didn't listen...)

Ariel Schiera (arisolucion) wrote :

Why this bug importance is medium? it should be high because makes the ultrabook unusable, even after restart and inside BIOS. I can't find any GNU Linux distro working ok on this Lenovo Ideapad u300s. Also the model it's not on sale any more at Lenovo, so i think we bought an expensive piece of aluminium that only runs Windows and will never run Linux correctly. Next time i'll buy another brand too.

Tim Peeters (tpeeters) wrote :

I haven't had the problem since half a year, but I don't know if I was lucky or it is really solved. Still, I keep a windows partition only in for when this problem returns (the lenovo bios-flashing software does not work on linux) that I would like to get rid of when I can be sure the problem is fixed.

Tim Peeters, i can confirm you are lucky. For about a month my Lenovo Ideapad U300s worked ok with Ubuntu and Kubuntu (both 13.04). But now I'm having this issue again, now my F5 key sends F9, i discovered it when i was close to post a bug about refreshing with F5 key, but's not a refresh bug no... is this horrible U300s bug that randomly switch keyboard keys, and it only happens when running Ubuntu/Kubuntu (i've not tested another distros). Once it happens, the problem affects also Windows and the BIOS screen. The unique way to solve it is to discharge and/or remove the battery. It's really a headache, i use the ultrabook for work and now i have not a screwdriver, so i'll have to wait around 2 hours for the battery and fix the problem. I really hate this annoying bug and it's not happening on Windows 7, i mean it's not a hardware failure.

robert.vertesi (vertesi) wrote :

Ariel, I also tried Fedora and my keys got messed up, see #57.

Jonathan Lange, as per http://download.lenovo.com/express/ddfm.html an update is available for your BIOS (43). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything? If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Thank you for your understanding.

tags: added: bios-outdated-43 bot-stop-nagging
removed: kernel-request-3.2.0-23.36
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - Lenovo u300s 't' key sends "Hiragana-Katana"
+ [Lenovo IdeaPad U300s] 't' key sends "Hiragana-Katana"
Jonathan Lange (jml) wrote :

Thank you for your update Christopher.

I worked around the problem by draining the battery, as described in more than one post above. This was many months ago, and since then I've not had the problem again.

I won't be updating my BIOS any time soon.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.