No battery detected

Bug #974352 reported by Serge Hallyn
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Battery (which should be fully charged) is being shown as 0% charged, both in /proc/acpi/battery/BAT0/state and battery appindicator.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-22-generic 3.2.0-22.35
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Thu Apr 5 09:51:00 2012
HibernationDevice: RESUME=UUID=9fb60ad6-789f-4542-8831-462512f0425e
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120323)
MachineType: Sony Corporation VPCF11KFX
ProcEnviron:
 TERM=screen
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=ab404185-0c14-4e92-9f61-666764289233 ro quiet splash vt.handoff=7
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/07/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0250Y6
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0250Y6:bd12/07/2009:svnSonyCorporation:pnVPCF11KFX:pvrR5840006:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCF11KFX
dmi.product.version: R5840006
dmi.sys.vendor: Sony Corporation

Revision history for this message
Serge Hallyn (serge-hallyn) wrote :
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Did this just start happening after a recent update?

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
Revision history for this message
Serge Hallyn (serge-hallyn) wrote : Re: [Bug 974352] Re: No battery detected

Quoting Joseph Salisbury (<email address hidden>):
> Did this just start happening after a recent update?

Yeah, just this morning.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

And if you boot back into kernel 3.2.0-21, does this issue go away?

tags: added: regression-update
Changed in linux (Ubuntu):
importance: Medium → High
tags: added: kernel-key
Revision history for this message
Tim Gardner (timg-tpi) wrote :

Serge - you could also install these 2 kernels and report the results:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.13-precise
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.14-precise

The biggest differences from 3.2.0-21 to 3.2.0-22 is the rebase against v3.2.14, though there is one ACPI related patch that did not come in via stable: "ACPICA: Fix regression in FADT revision checks"

Revision history for this message
Seth Forshee (sforshee) wrote :

Nothing has changed in the ACPI battery driver since 3.1. At a glance I don't see anything that looks relevant between 3.2.13 and 3.2.14, so it will be interesting to see how the tests of old kernels comes out.

And contrary to the subject, it looks to me like the battery is in fact being detected, as dmesg shows that it's present during boot. Something just seems to be wrong about the charge state. Serge, could you also paste the full output of /proc/acpi/battery/BAT0/state?

Revision history for this message
Serge Hallyn (serge-hallyn) wrote :

Terribly sorry,

I *think* my battery is actually bad.

Marking invalid.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
tags: removed: kernel-da-key kernel-key
To post a comment you must log in.