Precise Beta 2 Live CD hangs at boot on HP Pavilion zv6000

Bug #972823 reported by iGadget on 2012-04-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

When trying to boot from a freshly burned Precise Beta 2 (x86-64) CD, the live environment fails to load on my HP Pavilion ZV6000 laptop. Instead of booting successfully as all previous Ubuntu releases do, the system freezes somewhere halfway booting from the CD.

Stuff I tried already:
- Test the CD: tests finish without any errors
- Enable all debug options (except 'Free software only') from the Live CD's boot menu F6 / Other Options:
acpi=off
noapic
nolapic
edd=on
nodmraid
nomodeset

After setting all these debug options, I do get an error message, which I can hardly believe being the cause of the crash. However, I have made a photo of the error (attached).

If there's anything else I can do, please let me know.

iGadget (igadget) wrote :
iGadget (igadget) wrote :

As proposed by astraljava on #ubuntu-testing, selected linux-firmware as the most likely candidate for the package causing this bug.

affects: ubuntu → linux-firmware (Ubuntu)
Tim Gardner (timg-tpi) wrote :

While the lack of firmware for the b43 looks suspicious, its not fatal. Try booting without "quiet splash" on the grub command line. Use F6 to expose the grub options and just backspace back past the "--". If that doesn't solve your problems, then do the same thing and add "pcie_aspm=off".

iGadget (igadget) wrote :

Tim, thanks for your response.

I tried both things you suggested, but the result is exactly the same as before.

Anything else I can try?

Tim Gardner (timg-tpi) wrote :

acpi=off ?

iGadget (igadget) wrote :

Booting with all debug options enabled (except 'Free software only'), with "quit splash" removed AND "pcie_aspm=off" added...
...results in exactly the same freeze.

I'm starting to suspect the lack of firmware for the b43... Or is there yet something else I can try?

Tim Gardner (timg-tpi) wrote :

Unplug the b43 ? Check if the BIOS allows you to disable wireless.

iGadget (igadget) wrote :

Nice one! Actually the BIOS does allow me to do this. Unfortunately, it doesn't make any difference - the adapter is still magically recognized even though it's disabled in the BIOS. And consequently, the result is exactly the same.

I'm a bit scared you're now going to ask me to strip my laptop and cut a wire somewhere ;)

How hard would it be to strip out the entire b43 driver from the ISO? Or is there some magic boot string which will prevent it to be loaded?

Tim Gardner (timg-tpi) on 2012-04-09
affects: linux-firmware (Ubuntu) → linux (Ubuntu)
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc2-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing precise

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 972823

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
status: Incomplete → New
status: New → Incomplete

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Incomplete. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

tags: added: kernel-request-3.2.0-22.35
walterav (walterav) wrote :

Can you try booting with the following kernel boot parameter:

b43.blacklist=true

If this works this might be a duplicate of bug 956677, which has been confirmed but no cause have been found yet(also see bug 945257). Don't know if the b43 kernel team package is the problem or a other related package on top of it mentioned in this thread.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers