Ubuntu

[oneiric-proposed] linux-image-3.0.0-18-generic makes apport-gtk and chromium-browser segfault on startup

Reported by Marius Gedminas on 2012-04-03
220
This bug affects 47 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Oneiric
High
Herton R. Krzesinski

Bug Description

I installed updates from oneiric-proposed today. linux-image-3.0.0-18-generic (version 3.0.0-18.31) was among those updates. After rebooting I noticed that I can no longer launch chromium-browser: it segfaults on startup. I attempted to use 'ubuntu-bug chromium-browser' and discovered that apport-gtk also segfaults pretty early on startup.

Rebooting into an older kernel (3.0.0-17 from linux-image-3.0.0-17-generic version 3.0.0-17.30) makes both segfaults go away.

I've sent an email to ubuntu-users@ containing more information, including partial gdb backtraces (with debug symbols) of both segfaults: https://lists.ubuntu.com/archives/ubuntu-users/2012-April/258939.html

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-18-generic 3.0.0-18.31
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic 3.0.22
Uname: Linux 3.0.0-17-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mg 2594 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe020000 irq 49'
   Mixer name : 'Analog Devices AD1984'
   Components : 'HDA:11d41984,17aa20bb,00100400'
   Controls : 32
   Simple ctrls : 20
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 7KHT24WW-1.08'
   Mixer name : 'ThinkPad EC 7KHT24WW-1.08'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Apr 3 23:20:58 2012
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=7d2e9839-7107-4e9d-99e1-0096aa225198
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: LENOVO 646655G
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-17-generic root=UUID=4efb22e5-85e5-4a14-9eaa-4f4435e321c3 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-17-generic N/A
 linux-backports-modules-3.0.0-17-generic N/A
 linux-firmware 1.60.1
SourcePackage: linux
UpgradeStatus: Upgraded to oneiric on 2011-10-13 (172 days ago)
dmi.bios.date: 04/08/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 7LETC7WW (2.27 )
dmi.board.name: 646655G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7LETC7WW(2.27):bd04/08/2010:svnLENOVO:pn646655G:pvrThinkPadT61:rvnLENOVO:rn646655G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 646655G
dmi.product.version: ThinkPad T61
dmi.sys.vendor: LENOVO

Marius Gedminas (mgedmin) wrote :
Brad Figg (brad-figg) on 2012-04-03
Changed in linux (Ubuntu):
status: New → Confirmed
Friðrik Dýrfjörð (dyrfjord) wrote :

I have the same problem.
Updated earlier this day, 3.0.0-18-generic.
Chromium simply segfaults, I tried installing google-chrome thinking it might just be chromium, but chrome also segfaults.

Solutions to similar problems I found do nothing for me, usually for much older versions of glibc and/or chromium.

Russell Faull (rfaull) wrote :

Similar experience after installing 3.0.0.18. Crashes also include Synaptic, Nautilus, System Setting. After reboot to 3.0.0.17 no crashes.

BTW there seems to be no change log yet for 3.0.0.18.

eiks (eike-send) wrote :

Confirmed. Same here.

Luis Henriques (henrix) wrote :

I have build a test kernel that we would like you to test if possible. The only addition commit on this test kernel is 93dc6107a76daed81c07f50215fa6ae77691634f "Don't limit non-nested epoll paths".

Could you please check if it solves the issues you're having and report back? You can get this kernel here:

http://people.canonical.com/~henrix/lp972529/

Changed in linux (Ubuntu):
importance: Undecided → High
Russell Faull (rfaull) wrote :

Bug also prevents Unity from loading reliably. Unity 2D seems to work, but not sure. Will try Luis's suggested kernel.

Friðrik Dýrfjörð (dyrfjord) wrote :

Not sure if I am doing this right, I just installed the headers and image with dpkg, but it does not work.

uname -a
Linux dimmalimm 3.0.0-18-generic #31~lp972529 SMP Tue Apr 3 16:37:26 UTC 2012 i686 i686 i386 GNU/Linux
fbd@dimmalimm:~$ chromium-browser
Segmentation fault

Please let me know what data to send you, so I can be of more help. :)

Ilya Kraynov (ilya-kraynov) wrote :

Test kernel didn't help.

tkoun (tkoun) wrote :

same here.
reverted back to 3.0.0.17

nice example of successful downgrade

PS: here is what my dmesg shows for 3 successive chromium seg faults
[45875.627522] Chrome_DBThread[12450] general protection ip:85c416 sp:b1423658 error:0
[46053.285026] Chrome_IOThread[13294] general protection ip:b5c416 sp:adfc2ec8 error:0
[47117.334594] chromium-browse[17242] general protection ip:39e740 sp:bffe6acc error:0 in libglib-2.0.so.0.3000.3[38c000+f7000]

Brad Figg (brad-figg) wrote :

Anyone experiencing this issue, please try the kernel at: http://people.canonical.com/~herton/fpu_bug/

This one works Brad Figgs, thanks you very much!

Lei Zhang (thestig-google) wrote :

From Google Chrome's perspective, we are seeing a big spike in crashes, and many of the crashes don't make much sense. It is only happening on 32-bit Ubuntu 11.10. Everyone with the crash seems to be running 3.0.0.-18.31. Both Intel and AMD CPUs are affected. Based on a random sampple, on the Intel side, I see crashes from core2s and atom CPUs.

jorge (xxopxe) wrote :

Tried the kernel posted by Brad Figg at #10, seems to solve the (incredibly abbundant) crashes.

Ilya Kraynov (ilya-kraynov) wrote :

Brads patch is working. Thanks.

gpredrag (gavrilovic) wrote :

I can also confirm problems with Unity, Chrome, Evince, Firefox, Gnome System Settings. Everything is starting to crash at random since upgrade to 3.0.18 kernel

tags: added: kernel-da-key
gpredrag (gavrilovic) wrote :

The kernel posted by Brad Figg at #10 apparently solved problems.
I can login normaly and unity starts (not one out of three times, since kernel upgrade), nothing is crashing on me . Thanks a lot!

Giulio Bonanome (gbonanome) wrote :

Also for me the kernel poste by Brad at #10 solved the problem, no more crash for chromium or firefox.

steros (steros) wrote :

Same problem, also a ThinkPad (x60s).
Random applications, Java, Firefox, Nautilus, ubuntu-bug, Chrome, crash (usually a segmentation fault). And sometimes create log messages like these:
    Apr 6 01:29:03 xamos kernel: [ 47.104308] do_general_protection: 42 callbacks suppressed
    Apr 6 01:29:03 xamos kernel: [ 47.104317] pidgin[1864] general protection ip:630a25 sp:b74a2150 error:0 in libglib-2.0.so.0.3000.0[5c4000+f7000]
    Apr 6 01:29:23 xamos kernel: [ 67.219321] Chrome_DBThread[1885] general protection ip:79cede sp:b10eaeac error:0 in libpthread-2.13.so[792000+17000]

Reverting back to kernel 3.0.0.17 helps, kernel posted in #10 helps.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Herton R. Krzesinski (herton)
orsenthil (orsenthil) wrote :

The patch provided by Brad Figg ( https://bugs.launchpad.net/ubuntu/+source/linux/+bug/972821/comments/10 ) resolves the problem. Please push this to upgrade as soon as possible. Browsers have become THE MOST used software in Operating system and unusable browser is equivalent to unusable operating system. Please push this otherwise it's giving a bad name to Ubuntu.

Christopher (soft-kristal) wrote :

I just started running 3.0.0-19 as of a few minutes ago. Mine's a Lenovo IdeaPad laptop, which seems to be among the ones most affected by -18.

There have been no hiccups as of yet, but I'll repost after having used it for an extended period.

Russell Faull (rfaull) wrote :

3.0.0.19 working for me without problems.

Christopher (soft-kristal) wrote :

A day running -19 without anything crashing. This bug is fixed.

Brad Figg (brad-figg) on 2012-04-07
tags: added: verification-needed-oneiric
Giulio Bonanome (gbonanome) wrote :

also for me a day with "3.0.0-19-generic" and no more problem on chrome nor firefox

Marius Gedminas (mgedmin) wrote :

I don't know if you need any more "me too"s, but I also see no segfaults with linux-image-3.0.0-19-generic (version 3.0.0-19.32).

Those new kernels broke my Open Sound System (OSSv4 4.2-2006) installation and VirtualBox. I had to make a chroot environment to build working modules. I'm writing those because both 3.0.0-18 and 3.0.0-19 are responsible for building bad kernel modules.

$ lsmod
Module Size Used by
oss_usb 116131 3
oss_hdaudio 148247 7
osscore 561053 4 oss_usb,oss_hdaudio
rfcomm 38408 0
bnep 17923 2
bluetooth 148869 10 rfcomm,bnep
pci_stub 12550 0
vboxpci 32018 1 [permanent]
vboxnetadp 13328 0 [permanent]
vboxnetflt 27252 0 [permanent]
vboxdrv 256347 3 vboxpci,vboxnetadp,vboxnetflt,[permanent]
...
nvidia 10941552 112 [permanent]
...

You can see that some kernel modules are builded as [permanent] which is not the way it should be (that's with oss modules copied from chroot).

I've struggled to get my sound back for two or three days and I've found solution on VirtualBox bugzilla: https://www.virtualbox.org/ticket/9891#comment:12

I've also posted it on Open Sound System forums: http://www.opensound.com/forum/viewtopic.php?f=3&t=4730

Herton R. Krzesinski (herton) wrote :

Marking this bug as verification-done-oneiric given positive testing results above.

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Launchpad Janitor (janitor) wrote :
Download full text (24.1 KiB)

This bug was fixed in the package linux - 3.0.0-19.33

---------------
linux (3.0.0-19.33) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #985736

  [ Luis Henriques ]

  * SAUCE: ite-cir: postpone ISR registration
    - LP: #984387

linux (3.0.0-19.32) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #974368

  [ Brad Figg ]

  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (no-up) Quirk for enabling backlight hotkeys on Samsung N150P
    - LP: #875893

  [ Daniel Vetter ]

  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: (no-up) Reinstate missing hunk from nx emulation
    - LP: #972821

  [ Tim Gardner ]

  * SAUCE: ubuntu drivers: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233
  * SAUCE: (no-up) remove __initdata from vesafb_fix
    - LP: #969309

  [ Upstream Kernel Changes ]

  * usermodehelper: use UMH_WAIT_PROC consistently
    - LP: #963685
  * usermodehelper: introduce umh_complete(sub_info)
    - LP: #963685
  * usermodehelper: implement UMH_KILLABLE
    - LP: #963685
  * usermodehelper: kill umh_wait, renumber UMH_* constants
    - LP: #963685
  * usermodehelper: ____call_usermodehelper() doesn't need do_exit()
    - LP: #963685
  * kmod: introduce call_modprobe() helper
    - LP: #963685
  * kmod: make __request_module() killable
    - LP: #963685
  * x86, tsc: Fix SMI induced variation in quick_pit_calibrate()
    - LP: #965586
  * ata_piix: Add Toshiba Satellite Pro A120 to the quirks list due to
    broken suspend functionality.
    - LP: #886850
  * ACPICA: Fix regression in FADT revision checks
    - LP: #883441
  * ASPM: Fix pcie devices with non-pcie children
    - LP: #961482
  * USB: option: Add MediaTek MT6276M modem&app interfaces
    - LP: #971808
  * USB: option driver: adding support for Telit CC864-SINGLE, CC864-DUAL
    and DE910-DUAL modems
    - LP: #971808
  * USB: option: make interface blacklist work again
    - LP: #971808
  * USB: option: add ZTE MF820D
    - LP: #971808
  * USB: ftdi_sio: fix problem when the manufacture is a NULL string
    - LP: #971808
  * USB: ftdi_sio: add support for BeagleBone rev A5+
    - LP: #971808
  * USB: Microchip VID mislabeled as Hornby VID in ftdi_sio.
    - LP: #971808
  * USB: ftdi_sio: new PID: Distortec JTAG-lock-pick
    - LP: #971808
  * USB: ftdi_sio: add support for FT-X series devices
    - LP: #971808
  * USB: ftdi_sio: new PID: LUMEL PD12
    - LP: #971808
  * powerpc/usb: fix bug of kernel hang when initializing usb
    - LP: #971808
  * usb: musb: Reselect index reg in interrupt context
    - LP: #971808
  * usb: gadgetfs: return number of bytes on ep0 read request
    - LP: #971808
  * USB: gadget: Make g_hid device class conform to spec.
    - LP: #971808
  * futex: Cover all PI opcodes with cmpxchg enabled check
    - LP: #971808
  * sysfs: Fix memory leak in sysfs_sd_setsecdata().
    - LP: #971808
  * tty: ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.