Internal SD card reader is not working on Dell XPS L501X

Bug #969583 reported by Callahan on 2012-03-30
82
This bug affects 16 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Inserting a sd card into the internal card reader is not recognized by the system. Same problem occurs with older ubuntu versions (driver missing?)

WORKAROUND: Put the following in rescan.c:
#include <stdio.h>
main(){
  FILE *outfile;
  outfile=fopen("/sys/bus/pci/rescan","w");
  if (outfile != NULL){
    fprintf(outfile,"1\n");
    fclose(outfile);
  }
  else printf("permission denied\n");
}

then compile with:
gcc rescan.c -o rescan
sudo cp rescan /usr/local/bin
sudo chown root /usr/local/bin/rescan
sudo chmod u+s /usr/local/bin/rescan

then in system->preferences->keyboard shortcuts, create a custom keybinding (Add). The command should point to /usr/local/bin/rescan .

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-20-generic 3.2.0-20.33
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3357 F.... pulseaudio
CasperVersion: 1.312
Date: Fri Mar 30 20:43:34 2012
GvfsMonitorLog: Monitoring events. Press Ctrl+C to quit.
HotplugNewDevices:

HotplugNewMounts:

LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
MachineType: Dell Inc. XPS L501X
ProcEnviron:
 TERM=xterm
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 nouveaufb
 1 inteldrmfb
ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
SourcePackage: linux
StagingDrivers: mei
Symptom: storage
UdisksMonitorLog: Monitoring activity from the disks daemon. Press Ctrl+C to cancel.
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/29/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 00CKNG
dmi.board.vendor: Dell Inc.
dmi.board.version: A07
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A07
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd03/29/2011:svnDellInc.:pnXPSL501X:pvrA07:rvnDellInc.:rn00CKNG:rvrA07:cvnDellInc.:ct8:cvrA07:
dmi.product.name: XPS L501X
dmi.product.version: A07
dmi.sys.vendor: Dell Inc.

Callahan (thomas-born) wrote :
affects: ubuntu → linux (Ubuntu)
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/969583

tags: added: laptop-testing
Joseph Salisbury (jsalisbury) wrote :

So this issue isn't new in precise?

Also, would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: New → Incomplete
Callahan (thomas-born) on 2012-03-31
Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Callahan (thomas-born) wrote :

upstream kernel test:

- Kernel 3.3.0-030300 will not start with this system
- Daily built 3.3.0-999 from 30 March 2012 does run with this system.

=> Internal SD card reader still not recognized / useable.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Callahan (thomas-born) on 2012-03-31
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-21.34
Callahan (thomas-born) wrote :

Upstream Kernel tests already done - see comment # 4

tags: added: bot-stop-nagging
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Callahan (thomas-born) wrote :

I have found a useful workaround in another Bug #703180

Put the following in rescan.c:

#include <stdio.h>
main(){
  FILE *outfile;
  outfile=fopen("/sys/bus/pci/rescan","w");
  if (outfile != NULL){
    fprintf(outfile,"1\n");
    fclose(outfile);
  }
  else printf("permission denied\n");
}

then compile with:
gcc rescan.c -o rescan
sudo cp rescan /usr/local/bin
sudo chown root /usr/local/bin/rescan
sudo chmod u+s /usr/local/bin/rescan

then in system->preferences->keyboard shortcuts, create a custom keybinding (Add). The command should point to /usr/local/bin/rescan, and set whatever key combination you like - I used the gears button on the top left of the keyboard, which produces 'super-L'

Callahan, thank you for reporting this and helping make Ubuntu better. If you could also please test the latest upstream kernel (3.4) available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
removed: kernel-bug-exists-upstream kernel-request-3.2.0-21.34 laptop-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: laptop-testing
Callahan (thomas-born) wrote :

Kernel upstream Test already done. See comment #4. Bug persists.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: needs-upstream-testing
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
removed: kernel-bug-exists-upstream
Callahan (thomas-born) wrote :

Christopher, sorry for not seeing you meant "3.4"

I have just done the upstream kernel test with Kernel 3.4.0-999-generic_3.4.0-999.201204030410

The SD card is still not recognized. The bug persists upstream.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: needs-upstream-testing
tags: added: kernel-bug-exists-upstream
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Callahan (thomas-born) wrote :

kernel bug opened. Bug number#43041 at bugzille.kernel.org

Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
James (jamesasgrim) wrote :

This also affects my Dell XPS L702x - I am running the latest 12.04 beta. The rescan workaround also fixes it, so I'm assuming it's the same bug just affecting a similar laptop.

James, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

It's not just a Dell, it also affects my Lenovo R61 Thinkpad. The SDcard slow doesn't even recognize a card being put into it, alone from reading a card. Worked on all previous versions for me.

Reverend_of_War, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Sparhawk (sparhawkthesecond) wrote :

It also affects me on my Dell XPS 17 L702X, running Ubuntu 12.04.
However, for me, the workaround ($ sudo echo 1 > /sys/bus/pci/rescan) results in "bash: /sys/bus/pci/rescan: Permission denied". Restarting works. Would anyone have a suggestions to rescan it otherwise? Cheers.

Sparhawk, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Sparhawk: that workaround doesn't work with sudo. "su -l" and then "echo 1 > /sys/bus/pci/rescan" works instead. It's bad form but it works.

Sparhawk (sparhawkthesecond) wrote :

I don't know the root password, so I did "sudo su -l" for the first part, but it works fine! Cheers!

summary: - Internal SD card reader is not working on Dell XPS L501x
+ Internal SD card reader is not working on Dell XPS L501X and L502X

Daniel d'Andrada, please do not toggle this bug. If you are having a problem in Ubuntu, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

summary: - Internal SD card reader is not working on Dell XPS L501X and L502X
+ Internal SD card reader is not working on Dell XPS L501X
Sparhawk (sparhawkthesecond) wrote :

New bug #995743 created and panelvch subscribed. Cheers.

summary: - Internal SD card reader is not working on Dell XPS L501X
+ 197b:2394 Internal SD card reader is not working on Dell XPS L501X
summary: - 197b:2394 Internal SD card reader is not working on Dell XPS L501X
+ 197b:2391 Internal SD card reader is not working on Dell XPS L501X

Not working either RICOH sd reader on DELL Inspiron 6400
It was working perfectly on 10.04LTS

ed_qta, please stop making comments in this report. For more on this, please see https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported . If you are having a problem in Ubuntu, please file a new report by executing the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

description: updated

Callahan, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please just make a comment to this?

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Medium → Low
status: Triaged → Incomplete
summary: - 197b:2391 Internal SD card reader is not working on Dell XPS L501X
+ Internal SD card reader is not working on Dell XPS L501X
Download full text (5.1 KiB)

Christopher,

As I have changed from Ubuntu to Manjaro I am not any longer interested in
solving this bug.

Please ask other participants to do some testing for you.

Thanks for you help up to now!

Best regards,

Thomas

2013/12/29 Christopher M. Penalver <email address hidden>

> Callahan, this bug was reported a while ago and there hasn't been any
> activity in it recently. We were wondering if this is still an issue? If
> so, could you please test for this with the latest development release
> of Ubuntu? ISO images are available from http://cdimage.ubuntu.com
> /daily-live/current/ .
>
> If it remains an issue, could you please just make a comment to this?
>
> If reproducible, could you also please test the latest upstream kernel
> available (not the daily folder) following
> https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional
> upstream developers to examine the issue. Once you've tested the upstream
> kernel, please comment on which kernel version specifically you tested. If
> this bug is fixed in the mainline kernel, please add the following tags:
> kernel-fixed-upstream
> kernel-fixed-upstream-VERSION-NUMBER
>
> where VERSION-NUMBER is the version number of the kernel you tested. For
> example:
> kernel-fixed-upstream-v3.13-rc5
>
> This can be done by clicking on the yellow circle with a black pencil icon
> next to the word Tags located at the bottom of the bug description. As
> well, please remove the tag:
> needs-upstream-testing
>
> If the mainline kernel does not fix this bug, please add the following
> tags:
> kernel-bug-exists-upstream
> kernel-bug-exists-upstream-VERSION-NUMBER
>
> As well, please remove the tag:
> needs-upstream-testing
>
> Once testing of the upstream kernel is complete, please mark this bug's
> Status as Confirmed. Please let us know your results. Thank you for your
> understanding.
>
> ** Changed in: linux (Ubuntu)
> Importance: Medium => Low
>
> ** Changed in: linux (Ubuntu)
> Status: Triaged => Incomplete
>
> ** Summary changed:
>
> - 197b:2391 Internal SD card reader is not working on Dell XPS L501X
> + Internal SD card reader is not working on Dell XPS L501X
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/969583
>
> Title:
> Internal SD card reader is not working on Dell XPS L501X
>
> Status in The Linux Kernel:
> Confirmed
> Status in “linux” package in Ubuntu:
> Incomplete
>
> Bug description:
> Inserting a sd card into the internal card reader is not recognized by
> the system. Same problem occurs with older ubuntu versions (driver
> missing?)
>
> WORKAROUND: Put the following in rescan.c:
> #include <stdio.h>
> main(){
> FILE *outfile;
> outfile=fopen("/sys/bus/pci/rescan","w");
> if (outfile != NULL){
> fprintf(outfile,"1\n");
> fclose(outfile);
> }
> else printf("permission denied\n");
> }
>
> then compile with:
> gcc rescan.c -o rescan
> sudo cp rescan /usr/local/bin
> sudo chown root /usr/local/bin/rescan
> sudo chmod u+s /usr/local/bin/rescan
>
> then in system->preferences->keyboard shortcuts, create a custom
> ...

Read more...

Callahan, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/969583/comments/27 regarding this is no longer an issue for you. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

no longer affects: linux
Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.