"Stop" hotkey pauses instead of stops Movie Player

Bug #969453 reported by Bob Merhebi on 2012-03-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

The "Stop" hotkey (keyboard) does not stop the playing track in Movie Player; instead it just pauses it.

Note: there already is a Play/Pause hotkey for pausing!

lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-20-generic 3.2.0-20.33
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Fri Mar 30 21:06:59 2012
HibernationDevice: RESUME=UUID=ca289df0-21d9-4446-88e6-7a0e7970674c
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
MachineType: Dell Inc. Studio XPS 1640
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic root=UUID=60fe93c2-69d8-4f58-b5ea-b65e06e7b3c8 ro quiet splash vt.handoff=7
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/29/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A14
dmi.board.name: 0Y536R
dmi.board.vendor: Dell Inc.
dmi.board.version: A14
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A14
dmi.modalias: dmi:bvnDellInc.:bvrA14:bd03/29/2010:svnDellInc.:pnStudioXPS1640:pvrA143:rvnDellInc.:rn0Y536R:rvrA14:cvnDellInc.:ct8:cvrA14:
dmi.product.name: Studio XPS 1640
dmi.product.version: A143
dmi.sys.vendor: Dell Inc.

Bob Merhebi (bobmerhebi) wrote :
Changed in linux (Ubuntu):
importance: Undecided → Medium
Brad Figg (brad-figg) on 2012-03-30
Changed in linux (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/969453

tags: added: laptop-testing
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Bob Merhebi (bobmerhebi) wrote :

$ ls
linux-headers-3.3.0-030300_3.3.0-030300.201203182135_all.deb
linux-headers-3.3.0-030300-generic_3.3.0-030300.201203182135_amd64.deb
linux-image-3.3.0-030300-generic_3.3.0-030300.201203182135_amd64.deb

$ sudo dpkg -i *.deb
Selecting previously unselected package linux-headers-3.3.0-030300.
(Reading database ... 128508 files and directories currently installed.)
Unpacking linux-headers-3.3.0-030300 (from linux-headers-3.3.0-030300_3.3.0-030300.201203182135_all.deb) ...
Selecting previously unselected package linux-headers-3.3.0-030300-generic.
Unpacking linux-headers-3.3.0-030300-generic (from linux-headers-3.3.0-030300-generic_3.3.0-030300.201203182135_amd64.deb) ...
Selecting previously unselected package linux-image-3.3.0-030300-generic.
Unpacking linux-image-3.3.0-030300-generic (from linux-image-3.3.0-030300-generic_3.3.0-030300.201203182135_amd64.deb) ...
Done.
Setting up linux-headers-3.3.0-030300 (3.3.0-030300.201203182135) ...
Setting up linux-headers-3.3.0-030300-generic (3.3.0-030300.201203182135) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.3.0-030300-generic /boot/vmlinuz-3.3.0-030300-generic
ERROR (dkms apport): kernel package linux-headers-3.3.0-030300-generic is not supported
Error! Bad return status for module build on kernel: 3.3.0-030300-generic (x86_64)
Consult /var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/make.log for more information.
Setting up linux-image-3.3.0-030300-generic (3.3.0-030300.201203182135) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.3.0-030300-generic /boot/vmlinuz-3.3.0-030300-generic
ERROR (dkms apport): kernel package linux-headers-3.3.0-030300-generic is not supported
Error! Bad return status for module build on kernel: 3.3.0-030300-generic (x86_64)
Consult /var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/make.log for more information.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.3.0-030300-generic /boot/vmlinuz-3.3.0-030300-generic
update-initramfs: Generating /boot/initrd.img-3.3.0-030300-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.3.0-030300-generic /boot/vmlinuz-3.3.0-030300-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.3.0-030300-generic /boot/vmlinuz-3.3.0-030300-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.3.0-030300-generic /boot/vmlinuz-3.3.0-030300-generic
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.3.0-030300-generic
Found initrd image: /boot/initrd.img-3.3.0-030300-generic
Found linux image: /boot/vmlinuz-3.2.0-20-generic
Found initrd image: /boot/initrd.img-3.2.0-20-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda2
Found Ubuntu 10.04.4 LTS (10.04) on /dev/sda7
done

$ uname -a
Linux astrobob-Studio-XPS-1640 3.3.0-030300-generic #201203182135 SMP Mon Mar 19 01:36:20 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Bug still exists!

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-21.34
Bob Merhebi (bobmerhebi) wrote :

I tried to access the previously installed mainline kernel but it doesn't load. When I select it I get the "purple" screen without the Ubutnu logo & it hangs there. I tried uninstalling & reinstalling the kernel but the same issue repeats; what should I do?

P.S.: Today the standard kernel that comes with beta 2 was upgrade to 3.2!

I guess I'll do a fresh install of beta 2!

Bob Merhebi (bobmerhebi) wrote :

"Stop" works as intendedw with "rhythmbox" but *not* with totem !!!

tags: removed: kernel-request-3.2.0-21.34
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Brad Figg (brad-figg) wrote :

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-21.34
Bob Merhebi (bobmerhebi) on 2012-04-06
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: kernel-request-3.2.0-21.34

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-22.35
Bob Merhebi (bobmerhebi) wrote :

$ uname -r
3.3.0-030300-generic

tags: added: bot-stop-nagging
removed: kernel-request-3.2.0-22.35
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Bob Merhebi, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/969453/comments/7 regarding this does in fact work. As well, Totem has pause, not stop. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
importance: Medium → Low
status: Confirmed → Invalid
To post a comment you must log in.