Regression - Boots to Offset Desktop - Intel Panther Point Chipset/Sandy Bridge Graphics

Bug #968307 reported by Carl Richell on 2012-03-29
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Andy Whitcroft

Bug Description

Occurs in 12.04. Regression - does not occur in 11.10.

See attached picture. Desktop is offset to the right a couple hundred pixels. Occurs every boot. Replicatable on two laptop models with Panther Point chipsets and Sandy Bridge GPU's.

After Suspend and Resume the desktop is in the correct position.

1) Ubuntu Precise - 12.04
2) Linux system76-pc 3.2.0-20-generic #33-Ubuntu SMP Tue Mar 27 16:42:26 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
3) Boot to normal desktop
4) Boot to offset desktop

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-20-generic 3.2.0-20.33
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: oem 1537 F.... pulseaudio
Date: Thu Mar 29 08:54:32 2012
HibernationDevice: RESUME=UUID=d15e6ea3-57e3-41d2-8c72-f0c8ba9759cb
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: CLEVO CO. W240EU/W250EUQ/W270EUQ
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic root=UUID=596df159-fc9a-41b4-8528-5dca5215dbd5 ro quiet splash vt.handoff=7
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/24/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.5
dmi.board.asset.tag: Tag 12345
dmi.board.name: W240EU/W250EUQ/W270EUQ
dmi.board.vendor: CLEVO CO.
dmi.board.version: V3.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd02/24/2012:svnCLEVOCO.:pnW240EU/W250EUQ/W270EUQ:pvrNotApplicable:rvnCLEVOCO.:rnW240EU/W250EUQ/W270EUQ:rvrV3.0:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: W240EU/W250EUQ/W270EUQ
dmi.product.version: Not Applicable
dmi.sys.vendor: CLEVO CO.

Carl Richell (carlrichell) wrote :
description: updated
Brad Figg (brad-figg) on 2012-03-29
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer
to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
v3.3 kernel[1] (Not a kernel in the daily directory). Once you've
tested the upstream kernel, please remove the 'needs-upstream-testing'
tag(Only that one tag, please leave the other tags). This can be done by
clicking on the yellow pencil icon next to the tag located at the bottom
of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following
tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag:
'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
tags: added: needs-upstream-testing
Carl Richell (carlrichell) wrote :

The issue is also present in the mainline kernel - 3.3.0-030300-generic.

tags: removed: needs-upstream-testing
tags: added: kernel-bug-exists-upstream
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Joseph Salisbury (jsalisbury) wrote :

Also, can you run one additional test, which involves disabling RC6?

To disable RC6, do the following:
Hold down Left-Shift key to enter the Grub menu on boot
Hit 'e' to edit the kernel command line
Append i915.i915_enable_rc6=0 as a kernel boot parameter
For example: linux /boot/vmlinuz-3.2.0-17-generic <...> quiet splash vt.handoff=7 i915.i915_enable_rc6=0
Press Ctrl-x to boot

It would be great if you could test this and report back if your issue is resolved with RC6 disabled.

Carl Richell (carlrichell) wrote :

I disabled RC6; however, the result was the same.

I'm not sure this problem is in the kernel. Though not strictly a resolution issue, it is a problem with screen position. Could this be an xorg bug instead?

Carl Richell (carlrichell) wrote :

I should add that the offset desktop occurs in Plymouth as well - lending to a kernel problem I believe. Also, the command prompt in VT1 is offset.

Carl Richell (carlrichell) wrote :

We found that using "nomodeset" boots the screen correctly but we're then missing 3d

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Fix Released
Andy Whitcroft (apw) wrote :

As per discussions on the kernel-team@ list we have identified the upstream commit here and applied it to precise.

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → Fix Committed
Tim Gardner (timg-tpi) wrote :

drm/i915: Sanitize BIOS debugging bits from PIPECONF

Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package linux - 3.2.0-22.35

---------------
linux (3.2.0-22.35) precise; urgency=low

  [ Andy Whitcroft ]

  * Revert "SAUCE: hotkey quirks for various Zeptro Znote and Fujitsu Amilo
    laptops"
  * SAUCE: (no-up) elide some ioctl warnings which are known benign
    - LP: #972355

  [ Brad Figg ]

  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (drop after 3.4) Quirk for enabling backlight hotkeys on Samsung
    N150P
    - LP: #875893

  [ Colin Ian King ]

  * SAUCE: PCI: Allow pcie_aspm=force to work even when FADT indicates it
    is unsupported
    - LP: #962038

  [ Daniel Vetter ]

  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939

  [ Kees Cook ]

  * SAUCE: SECCOMP: audit: always report seccomp violations
  * SAUCE: SECCOMP: adjust prctl constant

  [ Leann Ogasawara ]

  * [Config] Enable CONFIG_USBIP_CORE=m
    - LP: #900384
  * Rebase to v3.2.14
  * [Config] Updateconfigs after rebase to v3.2.14

  [ Stefan Bader ]

  * d-i: Fix module name for dm-raid45
    - LP: #969248

  [ Tim Gardner ]

  * SAUCE: remove __initdata from vesafb_fix
    - LP: #969309

  [ Upstream Kernel Changes ]

  * Revert "sched: tg->se->load should be initialised to tg->shares"
  * toshiba_acpi: make one-bit bitfields unsigned
    - LP: #810015
  * ACPI: EC: Add ec_get_handle()
    - LP: #810015
  * toshiba_acpi: Support alternate hotkey interfaces
    - LP: #810015
  * toshiba_acpi: Support additional hotkey scancodes
    - LP: #810015
  * toshiba_acpi: Refuse to load on machines with buggy INFO
    implementations
    - LP: #810015
  * ata_piix: Add Toshiba Satellite Pro A120 to the quirks list due to
    broken suspend functionality.
    - LP: #886850
  * sweep the floors and convert some .get_drvinfo routines to strlcpy
    - LP: #921793
  * be2net: init (vf)_if_handle/vf_pmac_id to handle failure scenarios
    - LP: #921793
  * be2net: stop checking the UE registers after an EEH error
    - LP: #921793
  * be2net: don't log more than one error on detecting EEH/UE errors
    - LP: #921793
  * be2net: stop issuing FW cmds if any cmd times out
    - LP: #921793
  * be2net: Fix TX queue create for Lancer
    - LP: #921793
  * be2net: add register dump feature for Lancer
    - LP: #921793
  * be2net: Add EEPROM dump feature for Lancer
    - LP: #921793
  * be2net: Fix VLAN promiscous mode for Lancer
    - LP: #921793
  * be2net: Use V1 query link status command for lancer
    - LP: #921793
  * be2net: Move to new SR-IOV implementation in Lancer
    - LP: #921793
  * be2net: Fix error recovery paths
    - LP: #921793
  * be2net: Add error handling for Lancer
    - LP: #921793
  * be2net: Use new hash key
    - LP: #921793
  * be2net: Fix non utilization of RX queues
    - LP: #921793
  * be2net: netpoll support
    - LP: #921793
  * be2net: update some counters to display via ethtool
    - LP: #921793
  * be2net: workaround to fix a bug in BE
    - LP: #921793
  * be2net: fix ethtool ringparam reporting
    - LP: #921793
  * be2net: refactor/cleanup vf configuration code
    - LP: #921793
...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.