Ubuntu

ACPI Error: Method parse/execution

Reported by Louis on 2012-03-29
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Mar 27 18:52:52 b12 kernel: [ 1.428600] ACPI Error: [\TST0] Namespace lookup failure, AE_NOT_FOUND (20110413/psargs-359)
Mar 27 18:52:52 b12 kernel: [ 1.428604] ACPI Error: Method parse/execution failed [\_SB_.SCK0.CP07._TPC] (Node ffff88042712d140), AE_NOT_FOUND (20110413/psparse-536)

I've experienced many random hangs of the system and tried to fix many things sine I installed Ubuntu on my new 12-threads, 6-cores machine...

I updated the bios
I tried different video drivers
I tried different kernels

Seems (not 100% sure) that using acpi=off solves the problem, but I end up with only 6 threads, which is not desired!

Seems that with my current kernel it doesn't freeze anymore (not 100% sure yet)...

FInally, the ACPI errors seen in my attached kern.log are alway present with all the kernels I tried!

Hopefully my info will help solve this issue.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: louis 1688 F.... pulseaudio
 /dev/snd/controlC0: louis 1688 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf4f00000 irq 83'
   Mixer name : 'Realtek ALC898'
   Components : 'HDA:10ec0899,18490898,00100003'
   Controls : 37
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xf4e40000 irq 84'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=f8b9702d-99e9-4fa9-8187-1417090148dd
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
NonfreeKernelModules: fglrx
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=9c625525-6638-4655-b599-02d243286c03 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-16.29-generic 3.0.20
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-16-generic N/A
 linux-backports-modules-3.0.0-16-generic N/A
 linux-firmware 1.60
RfKill:

StagingDrivers: mei
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-16-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 03/19/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.80
dmi.board.name: X79 Extreme4
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.80:bd03/19/2012:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnX79Extreme4:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
---
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
Tags: oneiric running-unity
Uname: Linux 3.4.0-030400rc1-generic x86_64
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: louis 1925 F.... pulseaudio
 /dev/snd/controlC0: louis 1925 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf4f00000 irq 83'
   Mixer name : 'Realtek ALC898'
   Components : 'HDA:10ec0899,18490898,00100003'
   Controls : 37
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xf4e40000 irq 84'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=f8b9702d-99e9-4fa9-8187-1417090148dd
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
NonfreeKernelModules: fglrx
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-17-generic root=UUID=9c625525-6638-4655-b599-02d243286c03 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic 3.0.22
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-17-generic N/A
 linux-backports-modules-3.0.0-17-generic N/A
 linux-firmware 1.60
RfKill:

StagingDrivers: mei
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-17-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 03/19/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.80
dmi.board.name: X79 Extreme4
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.80:bd03/19/2012:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnX79Extreme4:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/967907/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

Hello
The easiest way to try if this still a bug in the kernel is to run a live session with the latest disposable image of precise:
http://cdimage.ubuntu.com/daily-live/current/
or better again, install it and if encounter again problems try the latest upstream kernel from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ubuntu:
status: New → Incomplete

Ciao Fabio,

I did try to run a live image of the latest daily build (31-Mar-2012 08:25), like you suggested.

The hang problem happened. The computer freezes and nothing is responsive anymore, even the "REISUB" and shh don't work anymore.

With my currently installed version (the one reported in the attached files) the problem has not happened yet, and I've ran for quite some time... Just hoping that the reboot I just did will not make the problem reappear... It's hard for me to provide a better diagnostic because there are never traces after the hang (nothing relevant is seen in kern.log after reboot)

Also, on the live CD is just tried, my graphics card driver were not the same as in this currently working version, which might have something to do with the issue. I am, I think, running my graphics card with acpi and tls off, but I can't tell if this really prevents the hang because the computer also did hang using these settings before.

Thanks for your suggestions,

-Louis

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New
description: updated
summary: - acpi unbuntu 11.10
+ ACPI Error: Method parse/execution
tags: added: oneiric precise
removed: 6450 acpi asrock bot-comment extreme4 i7-3930k kernel radeon x79
tags: added: kernel-acpi kernel-bug

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 967907

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
status: Incomplete → New
status: New → Incomplete

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Incomplete. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

tags: added: kernel-request-3.2.0-21.34

apport information

tags: added: apport-collected running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Hello,

I've ran the apport command as requested. Also, I can confirm that the bug still occurs with the latest kernel version (12.04 daily build).

Note that I ran the apport command in my current kernel version, which also exhibits the bug.

Thank you!

-Louis

Another thing I noticed is that if the hang has occured very recently, it will take less time before reoccuring again... As if it was some kind of a overheat-related issue... But the sensors do not indicate high temperatures.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc1-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Joseph,

the currently installed ubuntu version on my computer is Oneiric, should I go with the v3.2-rc4-oneiric kernel?

Thanks,

Joseph Salisbury (jsalisbury) wrote :

Actually it would be good if you could test the v3.4-rc1 kernel. That will tell us if this bug is already fixed upstream:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc1-precise/

Do I need to upgrade my distribution to precise first?

Joseph Salisbury (jsalisbury) wrote :

No, you can install the latest mainline kernel on Oneiric.

Thank you Joseph for the clarification.

The ACPI error is still present in v3.4-rc1. I cannot yet tell if the hang still occurs because the hang issue is very unpredictable. I'm attaching the new kern.log and will run apport in a minute.

-Louis

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Ok, I couldn't run apport because it is an upstream kernel...

description: updated

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-22.35
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Incomplete → Triaged

Here is my upstream bug report: https://bugzilla.kernel.org/show_bug.cgi?id=43059
Thanks for your help so far, I hope this will bring a solution

Brad Figg,

it still exists in the latest development kernel, as expected. I'm running apport to update the files in 2 seconds.

Changed in linux (Ubuntu):
status: Triaged → Confirmed
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Maarten Bezemer (veger) wrote :

Thanks for taking the time to report this bug in the upstream bug tracking system this is a tremendous help. Launchpad has the ability to watch lots of upstream bug trackers and this can be done by following the procedure documented at https://wiki.ubuntu.com/Bugs/Watches. I've added the bug watch for this bug report.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Seth Forshee (sforshee) wrote :

The ACPI error messages indicate a bios problem. The _TPC methods in the SSDT refer to a number of variables named TST0, TST1, TST2, and TST3 that aren't defined in any of the ACPI tables. The ACPI errors are simply stating that these variables are referenced but not defined. We can't really do anything about the errors.

Whether or not these are related to your lockups is unclear. The missing variables are an issue that Linux can handle, so those aren't directly responsible. However, the _TPC method is associated with power state throttling, so it's plausible that the failed method execution could cause the processors to be operating at a higher power state than it ought to be and that this leads to your lock-up. There's no clear evidence that this is actually the case, however.

Seth,

thank you for taking the time to inspect my bug. Would you suggest that I file a bug report with my motherboard manufacturer (I do have the latest bios update from them).

Changed in linux:
status: Confirmed → Fix Released
Tommy_CZ (t-kijas) wrote :

Same situation in Ubuntu 12.04 64bit, when using installation USB, it installs but slowly and showing some" acpi error method parse/execution failed" problems and "ACPI Exceptions" too.
Acer 5930g...
Core2duo, NVIDIA 9600GT...

hoover (uwe-schuerkamp) wrote :

I can confirm this bug on my gaming rig where I tried to install ubuntu 12.04.1 lts (64bit) yesterday. I could work around the problem by adding

acpi=off

to the kernel boot parameters (booting from USB stick created with unetbootin).

Louis, as per http://www.asrock.com/mb/Intel/X79%20Extreme4/?cat=Download&os=BIOS an update is available for your BIOS (3.40). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Thank you for your understanding.

tags: added: bios-outdated-3.40 bot-stop-nagging
removed: kernel-request-3.2.0-21.34 kernel-request-3.2.0-22.35
Changed in linux (Ubuntu):
status: Triaged → Incomplete

Christopher,

The hangs described in this bug report have been fixed for me. It was, it seems, a RAM hardware issue which my computer store was refusing to aknowledge and blaming Linux for it.

I did however update the BIOS as you suggested, and it seems there are no more ACPI kernel errors as I only get these warnings now,

Nov 16 22:42:15 b12 kernel: [ 2.626931] ACPI Warning: 0x0000000000000530-0x000000000000053f SystemIO conflicts with Region \GPR2 1 (20121018/utaddress-251)
Nov 16 22:42:15 b12 kernel: [ 2.626937] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Nov 16 22:42:15 b12 kernel: [ 2.626939] ACPI Warning: 0x0000000000000500-0x000000000000052f SystemIO conflicts with Region \GPR2 1 (20121018/utaddress-251)
Nov 16 22:42:15 b12 kernel: [ 2.626943] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

Thanks.

Louis, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/967907/comments/66 regarding this being due to hardware failure and being addressed by a BIOS update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.