Ubuntu

X failed to start, failed to set drm interface version

Reported by AceLan Kao on 2012-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

After rebooting many times, the lightdm won't start and the log in Xorg.0.log says
[drm] failed to set drm interface version.

It's easy to recovery it by switching to console and restart the lightdm.

AceLan Kao (acelankao) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/966871/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
AceLan Kao (acelankao) wrote :

From Christopher James:
that "no screens found" thing is because lightdm starts X before the kernel module has finished initialising.

From robert_ancell:
(I just cut off the necessary quote)
<robert_ancell> nah, it needs to ask the kernel generally - and there's a signal for "card ready" that comes via udev I believe
<robert_ancell> start on ((filesystem
<robert_ancell> and runlevel [!06]
<robert_ancell> and started dbus
<robert_ancell> and (drm-device-added card0 PRIMARY_DEVICE_FOR_DISPLAY=1
<robert_ancell> or stopped udev-fallback-graphics))
<robert_ancell> or runlevel PREVLEVEL=S)
<robert_ancell> is the upstart script /etc/init/lightdm.conf
<robert_ancell> it's the drm-device-added card0 PRIMARY_DEVICE_FOR_DISPLAY=1 which is what is waited for - my guess is that driver is not doing that / doing it wrong
<robert_ancell> yes, afaik. so the short answer is "it's probably a driver issue".

AceLan Kao (acelankao) wrote :

I tried to make the drivers/gpu/drm from precise kernel as a dkms package, and installed it on oneiric, and the system still failed to boot up sometimes.

I tried to install precise kernel on oneiric system, and it passed the reboot(30 times) test.

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Oneiric Ocelot.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in ubuntu:
status: New → Fix Released
affects: ubuntu → linux (Ubuntu)
Fabio Marconi (fabiomarconi) wrote :

sorry, substitute Oneiric ocelot with Precise Pangolin
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in linux (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments