Lubuntu Install (entire disk with encryption) doesn't prompt for disk password.

Bug #966403 reported by Tom on 2012-03-27
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Workarounds for this bug:

1) When you land at the blank screen (it is waiting for your LVM encryption password) just type your password. Alternatively, hit one of the up/down arrow keys to get to the GUI and enter your password (you will need to hit backspace twice to remove the two characters that were put in by the one arrow key press)

2) Edit your /boot/grub/grub.cfg file. In the menu entry for the kernel you wish to boot, add the text "plymouth:force-drm" (without the quotes) to the end of the line that starts with "linux /boot/vmzlinux-3.2.....". If you do this workaround, you will need to re-apply this fix anytime the kernel package is updated or grub is otherwise modified as the file is completely re-written each time.

3) Use the un-modified kernel. Read: https://wiki.ubuntu.com/KernelMainlineBuilds to manually download a mainline kernel and install on your system.

---original bug follows---

When installing the lubuntu image as part of the iso testing (lubuntu/daily/20120327/precise-alternate-amd64.iso) using the alternate installer from the daily builds for March 27, 2012, I attemted to make a full-disk encrypted setup using LVM. I used the instructions from the isotesting testcase: http://testcases.qa.ubuntu.com/Install/AlternateEncryptedLvm

The install went perfectly. However, when I rebooted, the system hung on a blank screen. I left it for over half an hour, and no response. At this point, I simply typed in the password for the LVM encryption, and the system then continuted to boot normally.

After getting into the system, I tested it (everything was working fine) then rebooted. I experienced the same symptoms (just a blank screen) after each boot.

I believe that there is supposed to be a screen prompting the user for the password for the LVM encryption instead of just a blank screen.
---
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
DefaultPlymouth: /lib/plymouth/themes/lubuntu-logo/lubuntu-logo.plymouth
DistroRelease: Ubuntu 12.04
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Beta amd64 (20120328)
Package: plymouth 0.8.2-2ubuntu28
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-20-generic root=/dev/mapper/hostname-root ro quiet splash vt.handoff=7
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-20-generic root=/dev/mapper/hostname-root ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Tags: precise
TextPlymouth: /lib/plymouth/themes/lubuntu-text/lubuntu-text.plymouth
Uname: Linux 3.2.0-20-generic x86_64
UnreportableReason: This is not an official Ubuntu package. Please remove any third party package and try again.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/23/2009
dmi.bios.vendor: Intel Corp.
dmi.bios.version: RQG4110H.86A.0013.2009.1223.1136
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: DG41RQ
dmi.board.vendor: Intel Corporation
dmi.board.version: AAE54511-205
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrRQG4110H.86A.0013.2009.1223.1136:bd12/23/2009:svn:pn:pvr:rvnIntelCorporation:rnDG41RQ:rvrAAE54511-205:cvn:ct3:cvr:

Tom (teeks99) wrote :

The hardware profile I tested this with is: http://teeks99.com/keep/lab_hwprofile.html

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/966403

tags: added: iso-testing
Colin Watson (cjwatson) on 2012-03-28
affects: debian-installer (Ubuntu) → cryptsetup (Ubuntu)
Steve Langasek (vorlon) wrote :

Hi Tom,

Please run 'apport-collect 966403' from the affected system.

affects: cryptsetup (Ubuntu) → plymouth (Ubuntu)
Changed in plymouth (Ubuntu):
status: New → Incomplete
Tom (teeks99) wrote : BootDmesg.txt

apport information

tags: added: apport-collected
description: updated
Tom (teeks99) wrote : BootLog.gz

apport information

apport information

apport information

apport information

Tom (teeks99) wrote : Lspci.txt

apport information

Tom (teeks99) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

Tom (teeks99) wrote : UdevDb.txt

apport information

Tom (teeks99) wrote : UdevLog.txt

apport information

Steve Langasek (vorlon) wrote :

Thanks. Please test whether this issue is reproducible with the Ubuntu plymouth theme:

  sudo apt-get install plymouth-theme-ubuntu-logo
  sudo update-alternatives --set default.plymouth /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth

Changed in plymouth (Ubuntu):
importance: Undecided → High
Tom (teeks99) wrote :

I did the theme change, but it didn't seem to have any impact. When I shutdown, I saw the ubuntu theme (instead of lubuntu) for the shutdown screen, but when it came back up it was still the blank screen.

I was able to push the down arrow twice (as I discovered in this bug's duplicate: https://bugs.launchpad.net/bugs/966450) and get the graphical password page, but it was still in the lubuntu theme instead of ubuntu!?!

On Wed, Mar 28, 2012 at 08:48:50PM -0000, Tom wrote:
> I did the theme change, but it didn't seem to have any impact. When I
> shutdown, I saw the ubuntu theme (instead of lubuntu) for the shutdown
> screen, but when it came back up it was still the blank screen.

> I was able to push the down arrow twice (as I discovered in this bug's
> duplicate: https://bugs.launchpad.net/bugs/966450) and get the graphical
> password page, but it was still in the lubuntu theme instead of
> ubuntu!?!

Oh sorry, yes - you need to also run 'sudo update-initramfs -u' to update
the plymouth theme in the initramfs.

If you do that, do you still get the blank screen? And if you hit the arrow
twice (btw, Esc also works), do you get the Ubuntu theme?

Tom (teeks99) wrote :

Ok, after that I'm still getting the blank screen, but when I go to the graphical screen I see the ubuntu one instead of the lubuntu one as expected.

Steve Langasek (vorlon) wrote :

Thanks, that confirms that this isn't a bug with the lubuntu theme; which means it's a hardware-specific bug instead.

Can you please boot with the option 'plymouth:debug=/var/log/plymouth-debug.log' added to the kernel commandline, and attach the resulting file?

Steve Langasek (vorlon) wrote :

Sorry, that should be plymouth:debug=file:/var/log/plymouth-debug.log

Tom (teeks99) wrote :

Here you go.

Steve Langasek (vorlon) wrote :

Thanks. It looks like plymouth is doing everything right here:

[./plugin.c] create_backend:creating renderer backend for device /dev/dri/card0
[./plugin.c] load_driver:Attempting to load driver 'nouveau'
[./plugin.c] nouveau_force_drm:opening /proc/cmdline
[./plugin.c] nouveau_force_drm:reading kernel command line
[./plugin.c] nouveau_force_drm:Kernel command line is: 'BOOT_IMAGE=/vmlinuz-3.2.0-20-generic root=/dev/mapper/pc06-root ro quiet splash vt.handoff=7 plymouth:debug=file:/var/log/plymouth-debug.log'
[./plugin.c] load_driver:falling back to frame buffer for nouveau to avoid DRM hang
[ply-renderer.c] ply_renderer_open:could not open rendering device for plugin /lib/plymouth/renderers/drm.so
[./plugin.c] create_backend:creating renderer backend for device /dev/fb0
[ply-terminal.c] ply_terminal_open:trying to open terminal '/dev/tty7'

[...]

[./plugin.c] query_device:32 bpp (8, 8, 8, 0) with rowstride 5632
[./plugin.c] initialize_head:initializing 1360x768 head

[...]

Seems to be a problem with the kernel framebuffer. Reassigning to the kernel.

affects: plymouth (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) on 2012-03-29
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: kernel-da-key kernel-key
tags: added: needs-upstream-testing
removed: kernel-key
Steve Langasek (vorlon) wrote :

Tom, if you're using only a single display on this machine, you could also try to enable using the drm backend instead of the framebuffer backend by booting with 'plymouth:force-drm'.

Tom (teeks99) wrote :

Yep, that seemed to fix it. What is the next step from here?

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-21.34
Tom (teeks99) on 2012-03-31
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Tom (teeks99) wrote :

I've now updated/dist-upgraded and am running:

$ uname -r
3.2.0-21-generic

$ dpkg -s linux-image-3.2.0-21-generic
Package: linux-image-3.2.0-21-generic
Status: install ok installed
Priority: optional
Section: kernel
Installed-Size: 144981
Maintainer: Ubuntu Kernel Team <email address hidden>
Architecture: amd64
Source: linux
Version: 3.2.0-21.34

Tom (teeks99) wrote :

Do I need to manually remove the kernel-request-3.2.0-21.34 tag?

Joseph Salisbury (jsalisbury) wrote :

@Tom,

Please don't remove the kernel-request-3.2.0-21.34 tag. It will cause the bug bot to ask you to test the kernel again.

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-22.35
Tom (teeks99) wrote :

Updated, same problem.

$ uname -r
3.2.0-22-generic

$ dpkg -s linux-image-3.2.0-21-generic
Package: linux-image-3.2.0-21-generic
Status: install ok installed
Priority: optional
Section: kernel
Installed-Size: 144981
Maintainer: Ubuntu Kernel Team <email address hidden>
Architecture: amd64
Source: linux
Version: 3.2.0-21.34

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-23.36
Tom (teeks99) on 2012-04-12
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Incomplete
Tom (teeks99) wrote :

New kernel, same problem.

$ uname -r
3.2.0-23-generic
$ dpkg -s linux-image-3.2.0-23-generic
Package: linux-image-3.2.0-23-generic
Status: install ok installed
Priority: optional
Section: kernel
Installed-Size: 145113
Maintainer: Ubuntu Kernel Team <email address hidden>
Architecture: amd64
Source: linux
Version: 3.2.0-23.36

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc2-precise/

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Tom (teeks99) wrote :

Using the mainline kernel fixed the problem. I immediately saw the password screen.

$ uname -r
3.4.0-030400rc3-generic
$ uname -a
Linux pc06 3.4.0-030400rc3-generic #201204152235 SMP Mon Apr 16 02:36:13 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
$ dpkg -s linux-image-3.4.0-030400rc3-generic
Package: linux-image-3.4.0-030400rc3-generic
Status: install ok installed
Priority: optional
Section: kernel
Installed-Size: 150716
Maintainer: Ubuntu Kernel Team <email address hidden>
Architecture: amd64
Source: linux
Version: 3.4.0-030400rc3.201204152235

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-fixed-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Tom (teeks99) on 2012-04-18
description: updated
Tom (teeks99) wrote :

I just tried this on lubuntu-alternate-12.10-amd64 and still had the same issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers