USB3.0 Ports Not Working

Bug #966248 reported by Solomon Otoo on 2012-03-27
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Bryan Wu

Bug Description

The computer has 4 usb ports. 3 of them are usb3 and one is a usb/esata. The three usb3.0 ports used to work in 11.10. Now only the usb/esata port works properly.

When I plug in flash drive into one of the usb3.0 ports, nothing happens. Same thing occurs with an external hard drive. My phone is able to charge through the usb3.0 ports so they are at least getting power.

Please let me know what other information you need.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-20-generic 3.2.0-20.32
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Tue Mar 27 08:51:44 2012
HibernationDevice: RESUME=UUID=e80e96e7-91b9-472d-adfb-ee412443bff5
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: Dell Inc. Vostro 3555
 PATH=(custom, user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic root=UUID=4e37d663-7cc1-4bdb-9246-20f135cb4013 ro quiet splash vt.handoff=7
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install) 10/24/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.vendor: Dell Inc.
dmi.board.version: A04
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd10/24/2011:svnDellInc.:pnVostro3555:pvrNotSpecified:rvnDellInc.:rn:rvrA04:cvnDellInc.:ct8:cvrNotSpecified: Vostro 3555
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.

3.2.0-25.40 3.2.18
3.2.0-24.38hyperv1 3.2.16
3.2.0-24.39 3.2.16
3.2.0-24.38 3.2.16
3.2.0-24.37 3.2.14
P 3.2.0-23.36 3.2.14
P 3.2.0-22.35 3.2.14
3.2.0-21.34 3.2.13
3.2.0-20.33 3.2.12
P 3.2.0-20.32 3.2.12
3.2.0-19.31 3.2.12
3.2.0-19.30 3.2.11
3.2.0-18.29 3.2.9
3.2.0-18.28 3.2.9
3.2.0-17.27 3.2.6
3.2.0-17.26 3.2.6
3.2.0-16.25 3.2.6
3.2.0-15.24 3.2.5
3.2.0-14.23 3.2.3
3.2.0-13.22 3.2.2
3.2.0-12.21 3.2.2
3.2.0-12.20 3.2.2
3.2.0-11.19 3.2.1
3.2.0-10.18 3.2.1
3.2.0-10.17 3.2.1
3.2.0-9.16 3.2.1
3.2.0-8.15 3.2.0
P 3.2.0-8.14 3.2.0

Solomon Otoo (suprman2020) wrote :
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.


Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: regression-update
tags: added: needs-upstream-testing
removed: regression-update
Changed in linux (Ubuntu):
status: New → Incomplete
Solomon Otoo (suprman2020) wrote :

Thanks for the help. All the usb ports are working using the mainline kernel. Is there anything else I need to do?

tags: removed: needs-upstream-testing
tags: added: kernel-fixed-upstream
J B (scottie) wrote :

on a vostro 3550 with single usb3 port, after plugging in portable usb3 drive it IS recognized. right after loading a CD into drive, usb3 portable drive is no longer detected by ubuntu. like it was disconnected.

this can be one more thing that you could test with the newer kernel, Solomon, to see if the port cuts out unexpectedly.

does not happen in msWin.
have not tried the upstream kernel yet.
current updates on the 12.04 beta.

J B (scottie) wrote :

the CD mentioned above was loaded in the separate onboard drive bay

Solomon Otoo (suprman2020) wrote :

I'm not sure if my testing will help you because we have two completely different chipsets. However I have noticed that after the computer goes to sleep for a while, the usb3.0 ports stop working when the computer resumes. I also noticed that my wireless mouse (Logitech Performance MX) does not work in the usb3.0 ports even though the receiver is detected (using lsusb).

J B, I don't have any media on me right now so I will test later today and get back to you.

Bryan Wu (cooloney) on 2012-06-05
Changed in linux (Ubuntu):
assignee: nobody → Bryan Wu (cooloney)
Bryan Wu (cooloney) wrote :


Could you please update to latest 12.04 LTS Ubuntu release? and try again. Our latest kernel should be "3.2.0-25-generic #40-Ubuntu".


Dimitri John Ledkov (xnox) wrote :

This affects my laptop as well, when I plug in my external quad HDD docking station into USB3.0 port nothing happens, when I plug into USB 2.0 all my 4 external drives appear. I am running quantal:

$ dpkg-query -W linux-image-3.4.0-3-generic
linux-image-3.4.0-3-generic 3.4.0-3.8
$ uname -a
Linux gauja 3.4.0-3-generic #8-Ubuntu SMP Sat May 26 01:46:46 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Let me know if you need any other information.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Solomon Otoo (suprman2020) wrote :

Bryan, I don't see the latest kernel in my updates. I tried last night and again this morning. Is there a way to manually install it?

tags: added: performing-bisect
description: updated
description: updated
Dimitri John Ledkov (xnox) wrote :

It takes significant amount of time for 3.0usb device to come up. (very unscientific).

description: updated
Dimitri John Ledkov (xnox) wrote :

It takes 47s to discover my USB3.0 hdd attached usb drives. Bisect inconclusive.

description: updated
Dimitri John Ledkov (xnox) wrote :

Solomon Otoo, how long have you waited for the drive to appear? Can you please wait for like 120 seconds, and see if the drive appears then?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Pink Ink (pink-ink) wrote :

There is a very similar bug here:
"xhci_hcd: Timeout while waiting for a slot - Issue with USB3 hard disk on 11.04 x86_64"
(can I link these bugs together somehow?)

On 19/06/12 23:38, Pink Ink wrote:
> There is a very similar bug here:
> "xhci_hcd: Timeout while waiting for a slot - Issue with USB3 hard disk on 11.04 x86_64"
> (can I link these bugs together somehow?)

adding relationships between bugs is a feature that is being worked on
(e.g. blocks, follow, related, etc)

So apart from this comment, no not really.


Xt8088 (2mzungu) wrote :

I'm noticing that on my Dell Vostro 3550, the USB3 ports don't seem to work well.

For instance my wireless mouse has a couple of feet of range instead of the 15 feet it gets on the same computer plugged into the USB2 port. Likewise my USB modem will not be recognized on the USB3 ports. The modem worked under 11.04 and 11.10 although the mouse issue was the same.

Any ideas?

tags: removed: performing-bisect
Pink Ink (pink-ink) wrote :

My external harddisk is still not recognised at the USB3.0 port, but works fine at the USB2.0 port.
(please see my post #9 at Question 175839,

There are some similar/related bugs which have the stati "open", "incomplete" and "confirmed".
Maybe having only one Bug for the common problem "USB3.0 Ports Not Working because of Timeout while waiting for a slot" would be an idea.
The other bugs could then be marked as duplicates.

Question #175839: Ubuntu 11.04 not recognizing usb 3.0 device
Bug #775543: 1033:0194 xhci_hcd: Timeout while waiting for a slot - Issue with USB3 hard disk on 11.04 x86_64
Bug #843764: Oneiric current, USB 3 capable External Box with a 3.5 sata disk inside doesn't work when attached to USB 3 port, works perfect on USB 2 port. AsRock 880GMH/USB3 motherboard
Bug #966248: USB3.0 Ports Not Working

To post a comment you must log in.