Ubuntu

Precise Beta 1 Desktop Alternate CD does not enable Wireless on HP 8440p

Reported by Louis Bouchard on 2012-03-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara
Precise
Medium
Leann Ogasawara

Bug Description

When trying to install 12.04 Precise on an HP 8440p with the Desktop alternate CD in order to install with full LVM encryption, the kernel does not enable the Wifi NIC, hence installation is impossible.

When using the standard desktop image (using Ubiquity), the Wireless NIC is seen correctly. Here are output of lsmod and lspci -nnk when booted using the standard desktop :

lsmod
=====

Module Size Used by
dm_crypt 23125 0
lp 17799 0
snd_hda_codec_hdmi 32474 4
pata_pcmcia 17074 1
tpm_infineon 17536 0
snd_hda_codec_idt 70795 1
joydev 17693 0
arc4 12529 2
snd_hda_intel 33773 5
snd_hda_codec 127669 3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
hp_accel 25976 0
snd_hwdep 13668 1 snd_hda_codec
snd_seq_midi 13324 0
tpm_tis 18804 0
iwlwifi 328352 0
ppdev 17113 0
lis3lv02d 19876 1 hp_accel
parport_pc 32866 1
parport 46562 3 lp,ppdev,parport_pc
snd_rawmidi 30748 1 snd_seq_midi
mac80211 506816 1 iwlwifi
input_polldev 13896 1 lis3lv02d
snd_pcm 97188 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
pcmcia 49310 1 pata_pcmcia
snd_seq_midi_event 14899 1 snd_seq_midi
snd_seq 61896 2 snd_seq_midi,snd_seq_midi_event
cfg80211 205544 2 iwlwifi,mac80211
snd_timer 29990 2 snd_pcm,snd_seq
snd_seq_device 14540 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 78855 20 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_rawmidi,snd_pcm,snd_seq,snd_timer,snd_seq_device
uvcvideo 72627 0
psmouse 87603 0
videodev 98259 1 uvcvideo
bnep 18281 2
v4l2_compat_ioctl32 17128 1 videodev
soundcore 15091 1 snd
yenta_socket 28084 0
serio_raw 13211 0
snd_page_alloc 18529 2 snd_hda_intel,snd_pcm
rfcomm 47604 0
pcmcia_rsrc 18430 1 yenta_socket
pcmcia_core 22614 3 pcmcia,yenta_socket,pcmcia_rsrc
mei 41616 0
intel_ips 18089 0
bluetooth 180104 10 bnep,rfcomm
hp_wmi 18092 0
mac_hid 13253 0
sparse_keymap 13890 1 hp_wmi
dm_multipath 23230 0
squashfs 36799 1
overlayfs 28305 1
nls_iso8859_1 12713 1
nls_cp437 16991 1
vfat 17585 1
fat 61512 1 vfat
ext2 73795 1
dm_raid45 78155 0
xor 12894 1 dm_raid45
dm_mirror 22203 0
dm_region_hash 20918 1 dm_mirror
dm_log 18564 3 dm_raid45,dm_mirror,dm_region_hash
btrfs 652957 0
zlib_deflate 27139 1 btrfs
libcrc32c 12644 1 btrfs
nouveau 774586 2
firewire_ohci 41000 0
firewire_core 63558 1 firewire_ohci
ttm 76949 1 nouveau
sdhci_pci 18826 0
crc_itu_t 12707 1 firewire_core
sdhci 33205 1 sdhci_pci
drm_kms_helper 42489 1 nouveau
drm 241834 4 nouveau,ttm,drm_kms_helper
i2c_algo_bit 13423 1 nouveau
mxm_wmi 12979 1 nouveau
wmi 19256 2 hp_wmi,mxm_wmi
video 19411 1 nouveau
e1000e 156693 0
usb_storage 49199 1

lspci -nnk
========
00:00.0 Host bridge [0600]: Intel Corporation Core Processor DRAM Controller [8086:0044] (rev 02)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
00:01.0 PCI bridge [0604]: Intel Corporation Core Processor PCI Express x16 Root Port [8086:0045] (rev 02)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:16.0 Communication controller [0780]: Intel Corporation 5 Series/3400 Series Chipset HECI Controller [8086:3b64] (rev 06)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: mei
        Kernel modules: mei
00:16.3 Serial controller [0700]: Intel Corporation 5 Series/3400 Series Chipset KT Controller [8086:3b67] (rev 06)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: serial
00:19.0 Ethernet controller [0200]: Intel Corporation 82577LM Gigabit Network Connection [8086:10ea] (rev 05)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: e1000e
        Kernel modules: e1000e
00:1a.0 USB controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b3c] (rev 05)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: ehci_hcd
00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 05)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd-hda-intel
00:1c.0 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 [8086:3b42] (rev 05)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:1c.1 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 [8086:3b44] (rev 05)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:1c.3 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 [8086:3b48] (rev 05)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:1d.0 USB controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b34] (rev 05)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev a5)
00:1f.0 ISA bridge [0601]: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller [8086:3b07] (rev 05)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel modules: iTCO_wdt
00:1f.2 SATA controller [0106]: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller [8086:3b2f] (rev 05)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: ahci
00:1f.6 Signal processing controller [1180]: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem [8086:3b32] (rev 05)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: intel ips
        Kernel modules: intel_ips
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [NVS 3100M] [10de:0a6c] (rev a2)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: nouveau
        Kernel modules: nouveau, nvidiafb
01:00.1 Audio device [0403]: NVIDIA Corporation High Definition Audio Controller [10de:0be3] (rev a1)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: snd_hda_intel
44:00.0 Network controller [0280]: Intel Corporation Centrino Ultimate-N 6300 [8086:4238] (rev 35)
        Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN [8086:1111]
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi
45:06.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 06)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: firewire_ohci
        Kernel modules: firewire-ohci
45:06.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 25)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: sdhci-pci
        Kernel modules: sdhci-pci
45:06.2 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev bb)
        Subsystem: Hewlett-Packard Company Device [103c:172b]
        Kernel driver in use: yenta_cardbus
        Kernel modules: yenta_socket
ff:00.0 Host bridge [0600]: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers [8086:2c62] (rev 02)
        Subsystem: Intel Corporation Device [8086:8086]
ff:00.1 Host bridge [0600]: Intel Corporation Core Processor QuickPath Architecture System Address Decoder [8086:2d01] (rev 02)
        Subsystem: Intel Corporation Device [8086:8086]
ff:02.0 Host bridge [0600]: Intel Corporation Core Processor QPI Link 0 [8086:2d10] (rev 02)
        Subsystem: Intel Corporation Device [8086:8086]
ff:02.1 Host bridge [0600]: Intel Corporation Core Processor QPI Physical 0 [8086:2d11] (rev 02)
        Subsystem: Intel Corporation Device [8086:8086]
ff:02.2 Host bridge [0600]: Intel Corporation Core Processor Reserved [8086:2d12] (rev 02)
        Subsystem: Intel Corporation Device [8086:8086]
ff:02.3 Host bridge [0600]: Intel Corporation Core Processor Reserved [8086:2d13] (rev 02)
        Subsystem: Intel Corporation Device [8086:8086]

When booted with the Alternate CD, the lsmod is the following :

lsmod
=====

Module Size Used by
e1000e 156693 0
parport_pc 32866 0
parport 46562 1 parport_pc
nls_iso8859_1 12713 1
nls_cp437 16991 1
vfat 17585 1
fat 61512 1 vfat
isofs 40257 0
pata_pcmcia 17074 1
vesafb 13809 2
pcmcia 49310 1 pata_pcmcia
yenta_socket 28084 0
pcmcia_rsrc 18430 1 yenta_socket
pcmcia_core 22614 3 pcmcia,yenta_socket,pcmcia_rsrc
firewire_ohci 41000 0
firewire_core 63558 1 firewire_ohci
crc_itu_t 12707 1 firewire_core
usbhid 47199 0
hid 99559 1 usbhid
usb_storage 49199 1

11.10 Uses the iwlagn module for this nic :

44:00.0 Network controller [0280]: Intel Corporation Centrino Ultimate-N 6300 [8086:4238] (rev 35)
        Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN [8086:1111]
        Kernel driver in use: iwlagn
        Kernel modules: iwlagn

It seems to have been renamed and/or replaced with iwlwifi on 12.04 but this module doesn't seem to be present on the Alt CD.

description: updated

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 965116

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
Louis Bouchard (louis-bouchard) wrote :

Cannot run apport-collect since cannot install O/S

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-20.32
tags: added: bot-stop-nagging
removed: kernel-request-3.2.0-20.32
Louis Bouchard (louis-bouchard) wrote :

Since the the kernel is coming from the alternate CD iso image, I think that the "bot-stop-nagging" is making sense here.

For information, I have preformed an installation without network, which completed correctly and after reboot, the Wireless adapter was being recognized and was working properly (aside from some LED blinking issues).

It appears that the .iso built does not contain the appropriate drivers for that type of NIC

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Precise):
assignee: nobody → Leann Ogasawara (leannogasawara)
milestone: none → ubuntu-12.04
status: Confirmed → In Progress
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: rls-p-tracking
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package linux - 3.2.0-21.34

---------------
linux (3.2.0-21.34) precise; urgency=low

  [ AceLan Kao ]

  * SAUCE: (drop after 3.4) asus-wmi: add scalar board brightness adj.
    support
    - LP: #961879
  * SAUCE: (drop after 3.4) asus-wmi: store backlight power status for AIO
    machine
    - LP: #961880

  [ Andy Whitcroft ]

  * [Config]: enable CONFIG_DRM_LOAD_EDID_FIRMWARE

  [ John Johansen ]

  * SAUCE: AppArmor: Add the ability to mediate mount
  * SAUCE: AppArmor: Add profile introspection file to interface
  * SAUCE: AppArmor: basic networking rules
  * SAUCE: Update aufs for build failure caused by apparmor backport
  * SAUCE: AppArmor: Fix change_onexec when called from a confined task
    - LP: #963756

  [ Leann Ogasawara ]

  * Revert "SAUCE: (drop after 3.3) platform/x86: Add driver for Apple gmux
    device"
  * Rebase to v3.2.13
  * d-i: Fix iwl3945 driver name typo in nic-modules
  * d-i: Add missing iwl* drivers to nic-modules
    - LP: #965116
  * d-i: Remove obsolete bcm43xx* drivers from nic-modules
  * d-i: Add brcm*mac drivers to nic-modules

  [ Seth Forshee ]

  * SAUCE: (drop after 3.3) apple_bl: Add register/unregister functions
  * SAUCE: (drop after 3.3) platform/x86: Add driver for Apple gmux device

  [ Tim Gardner ]

  * Add isci to debian scsi-modules udeb
    - LP: #963306
  * SAUCE: fsam7400: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233

  [ Upstream Kernel Changes ]

  * Bluetooth: Adding USB device 13d3:3375 as an Atheros AR3012.
    - LP: #916319
  * x86: Report cpb and eff_freq_ro flags correctly
    - LP: #960461
  * x86/amd: Add missing feature flag for fam15h models 10h-1fh processors
    - LP: #960461
  * KVM: Move cpuid code to new file
    - LP: #960466
  * KVM: expose latest Intel cpu new features (BMI1/BMI2/FMA/AVX2) to guest
    - LP: #960466
  * apparmor: add missing rcu_dereference()
  * apparmor: fix module parameter handling
  * btrfs, nfs, apparmor: don't pull mnt_namespace.h for no reason...
  * switch security_path_chmod() to umode_t
  * switch securityfs_create_file() to umode_t
  * switch ->path_mkdir() to umode_t
  * switch ->path_mknod() to umode_t
  * capabilities: remove the task from capable LSM hook entirely
  * switch security_path_chmod() to struct path *
  * AppArmor: refactor securityfs to use structures
  * AppArmor: add initial "features" directory to securityfs
  * AppArmor: add "file" details to securityfs
  * AppArmor: export known rlimit names/value mappings in securityfs
  * AppArmor: Add mising end of structure test to caps unpacking
  * AppArmor: Fix dropping of allowed operations that are force audited
  * AppArmor: Fix underflow in xindex calculation
  * AppArmor: fix mapping of META_READ to audit and quiet flags
  * AppArmor: Fix the error case for chroot relative path name lookup
  * AppArmor: Fix error returned when a path lookup is disconnected
  * AppArmor: Fix oops in policy unpack auditing
  * AppArmor: Add const qualifiers to generated string tables
  * AppArmor: Retrieve the dentry_path for error reporting when path lookup
    fails
...

Read more...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Louis Bouchard (louis-bouchard) wrote :

@leann

 I have just tested yesterday's build of the alternate CD and it is now able to see the Wireless, prompt for the ESSID & establish connection.

Thanks for fixing this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers