hub_port_status failed error (-110)

Bug #962113 reported by dino99 on 2012-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Expired
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Precise i386 logged as gnome-classic

Having some troubles with boot/reboot process, i've removed "quiet splash" from boot line to get the verbose mode.
When i shutdown the system, i get the error above : latest 2 lines before it completly shutdown. After googling about this message, it seems related to usb devices plugged ; on this system they are two : a HP 4585 printer (power down) and a ps2 keyboard with usb adaptor.

I cant see other warning/error while shuting down that system. But the bad effects are:
- reboot never works
- 1st cold boot ends with a kernel panic and the keyboard is lost
- 2nd cold try to boot also fail: often dont get a post, or if i can get the boot line then it seems receiving a stop order
- 3rd cold boot succeed

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-20-generic-pae 3.2.0-20.32
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: oem 2798 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfebfc000 irq 48'
   Mixer name : 'Realtek ALC882'
   Components : 'HDA:10ec0882,1043e601,00100101'
   Controls : 44
   Simple ctrls : 25
CurrentDmesg:
 [ 42.661466] vboxdrv: fAsync=0 offMin=0x253 offMax=0x1549
 [ 42.661526] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
 [ 42.661528] vboxdrv: Successfully loaded version 4.1.10 (interface 0x00190000).
 [ 42.893302] vboxpci: IOMMU not found (not registered)
 [ 43.909453] Netfilter messages via NETLINK v0.30.
Date: Thu Mar 22 12:54:23 2012
HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
IwConfig:
 lo no wireless extensions.

 eth1 no wireless extensions.

 eth0 no wireless extensions.
MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic-pae root=UUID=9e61e83e-bca9-43cf-aa90-5a68892213fa ro quiet splash vt.handoff=7 crashkernel=384M-2G:64M,2G-:128M intel_idle.max_cstate=0
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-20-generic-pae N/A
 linux-backports-modules-3.2.0-20-generic-pae N/A
 linux-firmware 1.72
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
WpaSupplicantLog:

dmi.bios.date: 10/22/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3001
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5W DH Deluxe
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3001:bd10/22/2009:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5W DH Deluxe
dmi.product.version: System Version
dmi.sys.vendor: ASUSTEK COMPUTER INC

dino99 (9d9) wrote :
dino99 (9d9) wrote :

note that this trouble is not very new, it exist since we use the kernel 3 series

Brad Figg (brad-figg) on 2012-03-22
Changed in linux (Ubuntu):
status: New → Confirmed
dino99 (9d9) on 2012-03-22
tags: added: bot-stop-nagging
Joseph Salisbury (jsalisbury) wrote :

Can you post a screen shot of the panic?

Also, would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
dino99 (9d9) wrote :

hi Joseph,

the kernel panic is always with a black screen, so should i post it ?
As Precise will not have the 3.3 kernel serie, then this issue has to be fixed with the LTS kernel. As said this issue is not new and all around the net.

Changed in linux (Ubuntu):
status: Incomplete → New
Joseph Salisbury (jsalisbury) wrote :

We ask to test the 3.3 kernel to see if it is fixed upstream. If it is fixed, we can cherry pick the fix into precise, or many times the fix will make it into Precise through the stable updates upstream.

Brad Figg (brad-figg) on 2012-03-22
Changed in linux (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

Kernel upstream tested:
- still get the first cold boot failling
- with the nvidia 295.33 + xorg 1.12 + kernel 3.3 and the latest Precise updates, now i dont get the verbose mode: the screen is fully black, so i cant say if the kernel upstream have solved that bug error or not.

 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/962964

tags: removed: needs-upstream-testing
dino99 (9d9) wrote :

Ok got the verbose mode again on shutting down the system, and see again this error ( 2 last lines ) with the upstream kernel; so its still an issue. Tagged as such.

tags: added: kernel-bug-exists-upstream
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
dino99 (9d9) wrote :

The last time i made a shutdown i was able to see an additional comment after this error reported above:

hub_port_status failed error (-110)
acpi_power_off called

wonder if that acpi call is made too late or not.

Maarten Bezemer (veger) wrote :

Thanks for taking the time to report this bug in the upstream bug tracking system this is a tremendous help. Launchpad has the ability to watch lots of upstream bug trackers and this can be done by following the procedure documented at https://wiki.ubuntu.com/Bugs/Watches. I've added the bug watch for this bug report.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
dino99 (9d9) wrote :

More comments:

i'm seeing previously (2 lines prior "hub_port_status failed error (-110)" error) :

a line saying something like : root / is busy

dino99 (9d9) wrote :

Giving the real message done into #13 above :

mount / is busy

dino99 (9d9) wrote :

About comment #14 above:

i've found this report : https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/963106
and it seems related to the problem reported here : https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/963106/comments/6

Changed in linux:
status: Confirmed → Incomplete
dino99 (9d9) wrote :

This error is gone with kernel 3.4.01 generic-pae

dino99 (9d9) on 2012-08-30
Changed in linux (Ubuntu):
status: Triaged → Fix Released
dino99 (9d9) on 2012-08-30
affects: linux → ubuntu
Changed in ubuntu:
status: Incomplete → Invalid
Changed in ubuntu:
status: Invalid → Incomplete
Changed in ubuntu:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.