[ET2012I+ATI] Brightness control doesn't work.

Bug #961879 reported by AceLan Kao on 2012-03-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
AceLan Kao
Nominated for Oneiric by AceLan Kao
Precise
Undecided
AceLan Kao

Bug Description

In ET2012I+ATI device, the brightness cannot be adjust when press Fn+F5 & Fn+F6.

Expect Result:
When press press Fn+F5 & Fn+F6, the screen brightness will be increase or decrease.

Actual Result:
When press press Fn+F5 & Fn+F6, the screen brightness has no effect.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 961879

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
AceLan Kao (acelankao) on 2012-03-22
Changed in linux (Ubuntu):
assignee: nobody → AceLan Kao (acelankao)
Tim Gardner (timg-tpi) wrote :

UBUNTU: SAUCE: (drop after 3.4) asus-wmi: add scalar board brightness adj. support

Changed in linux (Ubuntu Precise):
status: Incomplete → Fix Committed
AceLan Kao (acelankao) on 2012-03-23
tags: added: blocks-hwcert-enablement
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package linux - 3.2.0-21.34

---------------
linux (3.2.0-21.34) precise; urgency=low

  [ AceLan Kao ]

  * SAUCE: (drop after 3.4) asus-wmi: add scalar board brightness adj.
    support
    - LP: #961879
  * SAUCE: (drop after 3.4) asus-wmi: store backlight power status for AIO
    machine
    - LP: #961880

  [ Andy Whitcroft ]

  * [Config]: enable CONFIG_DRM_LOAD_EDID_FIRMWARE

  [ John Johansen ]

  * SAUCE: AppArmor: Add the ability to mediate mount
  * SAUCE: AppArmor: Add profile introspection file to interface
  * SAUCE: AppArmor: basic networking rules
  * SAUCE: Update aufs for build failure caused by apparmor backport
  * SAUCE: AppArmor: Fix change_onexec when called from a confined task
    - LP: #963756

  [ Leann Ogasawara ]

  * Revert "SAUCE: (drop after 3.3) platform/x86: Add driver for Apple gmux
    device"
  * Rebase to v3.2.13
  * d-i: Fix iwl3945 driver name typo in nic-modules
  * d-i: Add missing iwl* drivers to nic-modules
    - LP: #965116
  * d-i: Remove obsolete bcm43xx* drivers from nic-modules
  * d-i: Add brcm*mac drivers to nic-modules

  [ Seth Forshee ]

  * SAUCE: (drop after 3.3) apple_bl: Add register/unregister functions
  * SAUCE: (drop after 3.3) platform/x86: Add driver for Apple gmux device

  [ Tim Gardner ]

  * Add isci to debian scsi-modules udeb
    - LP: #963306
  * SAUCE: fsam7400: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233

  [ Upstream Kernel Changes ]

  * Bluetooth: Adding USB device 13d3:3375 as an Atheros AR3012.
    - LP: #916319
  * x86: Report cpb and eff_freq_ro flags correctly
    - LP: #960461
  * x86/amd: Add missing feature flag for fam15h models 10h-1fh processors
    - LP: #960461
  * KVM: Move cpuid code to new file
    - LP: #960466
  * KVM: expose latest Intel cpu new features (BMI1/BMI2/FMA/AVX2) to guest
    - LP: #960466
  * apparmor: add missing rcu_dereference()
  * apparmor: fix module parameter handling
  * btrfs, nfs, apparmor: don't pull mnt_namespace.h for no reason...
  * switch security_path_chmod() to umode_t
  * switch securityfs_create_file() to umode_t
  * switch ->path_mkdir() to umode_t
  * switch ->path_mknod() to umode_t
  * capabilities: remove the task from capable LSM hook entirely
  * switch security_path_chmod() to struct path *
  * AppArmor: refactor securityfs to use structures
  * AppArmor: add initial "features" directory to securityfs
  * AppArmor: add "file" details to securityfs
  * AppArmor: export known rlimit names/value mappings in securityfs
  * AppArmor: Add mising end of structure test to caps unpacking
  * AppArmor: Fix dropping of allowed operations that are force audited
  * AppArmor: Fix underflow in xindex calculation
  * AppArmor: fix mapping of META_READ to audit and quiet flags
  * AppArmor: Fix the error case for chroot relative path name lookup
  * AppArmor: Fix error returned when a path lookup is disconnected
  * AppArmor: Fix oops in policy unpack auditing
  * AppArmor: Add const qualifiers to generated string tables
  * AppArmor: Retrieve the dentry_path for error reporting when path lookup
    fails
...

Read more...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Sylvester (sylvestersoprano) wrote :

I just lost 48 TB of data with this patch..

But hey ! i can dim now !

AceLan Kao (acelankao) wrote :

So sorry about this,
I'll add comments in bug 969576

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers