Ubuntu

HDMI audio device detected by the system but not listed in Sound Settings

Reported by Leuke on 2012-03-21
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
David Henningsson

Bug Description

It is certainly just a graphical matter because using hardinfo, running pacmd or trying to switch to HDMI in XBMC works, it's just not listed in System Settings -> Sound.
From the screenshot you can easily verify there is no HDMI output listed.
This is a regression from Oneiric, which correctly shows all the available hardware outputs on the same computer.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.3.92-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic-pae 3.2.11
Uname: Linux 3.2.0-19-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
Date: Wed Mar 21 15:59:43 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120318)
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu1
 deja-dup 21.90-0ubuntu1
 gnome-bluetooth 3.2.2-0ubuntu3
 indicator-datetime 0.3.91-0ubuntu1

Leuke (leuke) wrote :
Leuke (leuke) wrote :

This is the same window on the same computer using Oneiric, it's very easy to switch to Digital Stereo (HDMI) Output.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Conor Curran (cjcurran) wrote :

I can see the same thing here.
No HDMI device can be found in the output devices list,

My trace from the control center shows that the HDMI ports are unavailable, this would be why ...

>>>>>>>>>>>>>>>>>>
 SET PROFILES HDMI / DisplayPort 3
 create_ui_device_from_port, direction 1
 description HDMI / DisplayPort 3
 origin Built-in Audio
 port available 0

 SET PROFILES HDMI / DisplayPort 2
 create_ui_device_from_port, direction 1
 description HDMI / DisplayPort 2
 origin Built-in Audio
 port available 0

 SET PROFILES HDMI / DisplayPort
 create_ui_device_from_port, direction 1
 description HDMI / DisplayPort
 origin Built-in Audio
 port available 0

 SET PROFILES Microphone
 create_ui_device_from_port, direction 0
 description Microphone
 origin Built-in Audio
 port available 0

tags: added: soundnua
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Conor Curran (cjcurran)
assignee: Conor Curran (cjcurran) → David Henningsson (diwic)
status: Confirmed → Triaged
Conor Curran (cjcurran) wrote :

A restart fixed it ?

David Henningsson (diwic) wrote :

Hi,

An improvement from Oneiric is that the HDMI output should not be listed if HDMI audio output does not currently work, so it is only a regression if HDMI audio output in fact works, but it is not listed.

Could you verify that you have activated your secondary monitor and that HDMI audio works, and then submit the output of "pacmd ls" and an alsa-info according to https://wiki.ubuntu.com/Audio/AlsaInfo ?

Thanks!

Leuke (leuke) wrote :

I understand the intentions, but I'm fairly sure that is not my case because I tried HDMI output using XBMC's own sound manager and it worked perfectly.
As requested this is the output of "pacmd ls".

Leuke (leuke) wrote :

And this is the alsa-info file.
Hope they help!

David Henningsson (diwic) wrote :

Yes, they are helpful. It seems you have HDMI profiles but not ports, because your driver does not create any jacks.

Could you try to edit this file:

/usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-0.conf

and change this line

required-any = any

to

required-any = ignore

Restart pulseaudio (e g "pulseaudio -k", or restart your computer) for the changes to take effect.

Please report back if this resolved your problem. Thanks!

Leuke (leuke) wrote :

I modified that line and then tried both restarting pulseaudio and the entire system, but that didn't resolve.
I noticed that there are several hdmi-output-x.conf files, so then I tried to modify all of them (from 0 to 3) as you suggested and restarted the computer again.
Nevertheless I can't yet see HDMI output in Sound Settings, that menu hasn't changed at all.

Maybe not relevant but in addition to XBMC also vlc is able to correctly detect HDMI.

David Henningsson (diwic) wrote :

Ok, strange. Could you provide a pulseaudio verbose log according to https://wiki.ubuntu.com/PulseAudio/Log ?

This should be with the required-any set to ignore.

Thanks!

Leuke (leuke) wrote :

Here it is. This is the output file with "required-any = ignore" in "hdmi-output-0.conf".

David Henningsson (diwic) wrote :

Aha. I think it should be

required = ignore

instead of

required-any = ignore

I should probably fix PulseAudio to make "required-any = ignore" work as well here.

Leuke (leuke) wrote :

Now it works, thank you!
Just a consideration: "required = ignore" completely fixes the problem for this system (it's a Nvidia ION netbook).

On the contrary, on another computer ( AMD graphics desktop, open source drivers) this is the situation:
    - default : hdmi not detected and not working.
    - required = ignore : hdmi not detected and not working
    - required-any = ignore : hdmi detected but not working

So, ignoring the fact HDMI audio isn't working while it should (this is not strictly related to this bug), the first and the second behaviors are what we would expect, while the third shows an option detected but not effectively available.
This is the reason of the change from oneiric to precise, right?

David Henningsson (diwic) wrote :

I will fix this shortly, but we can't upload a new version until the beta2 freeze is over. Thanks for the cooperation!

affects: gnome-control-center (Ubuntu) → pulseaudio (Ubuntu)
Changed in pulseaudio (Ubuntu):
status: Triaged → In Progress
jamey0824 (jamesforyst) wrote :

I have the same problem on my 4 amd/ati card multiseat setup. But I get one card listed, I tried all combo's of this and none work.

gavin (gavinewin) wrote :

Not sure if I have the right topic here, but it sounds similar. I have a Acer I7 Nvidia Optimus notebook. When I plug in a HDMI monitor, I can go to sound settings and select HDMI output which deselects built in audio. Everyting works fine. However, when I take the notebook out (not plugged into the second monitor) and even after a full restart, I have no sounds, I have to go back into sound settings and select built in audio, even though it is the only sound option available. Shouldn't this be selected automatically on a reboot if it is the only sound output available?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:1.1-0ubuntu14

---------------
pulseaudio (1:1.1-0ubuntu14) precise; urgency=low

  * 012*.patch: Cherry-pick bugfix patches from upstream git
  * 0620-alsa-mixer-Show-HDMI-ports-for-older-Nvidia-cards.patch (LP: #961286)
 -- David Henningsson <email address hidden> Fri, 30 Mar 2012 09:47:17 +0200

Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Released
Andrei Gherzan (andrei-7i) wrote :

I have the same issue with:
[General]
description = HDMI / DisplayPort
priority = 59

[Jack HDMI/DP,pcm=3]
required = ignore

in /usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-0.conf

Any help?

Conor Curran (cjcurran) wrote :

Could you provide a verbose pulseaudio log (see comment 11 above).

Andrei Gherzan (andrei-7i) wrote :

Oh. I'm taking about a NVS4200M

Andrei Gherzan (andrei-7i) wrote :

Here is the needed log.

David Henningsson (diwic) wrote :

@Andrei:

( 0.523| 0.000) I: [pulseaudio] alsa-util.c: Successfully attached to mixer 'hw:1'
( 0.523| 0.000) D: [pulseaudio] module-alsa-card.c: Jack 'HDMI/DP,pcm=3 Jack' is now unplugged
( 0.523| 0.000) D: [pulseaudio] device-port.c: Setting port hdmi-output-0 to status no

This indicates that you don't have your HDMI cable plugged in. Or possibly, that there is a problem with your video drivers detecting that you have actually plugged it in.
That's why it doesn't show up. Are you sure it works? If it does not work, the sound settings is doing the correct thing by hiding stuff that doesn't work anyway.

Andrei Gherzan (andrei-7i) wrote :

After digging a little:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice

So i have 3 hdmi devices. (btw cable was plugged in). The only one which works is:
 aplay -D plughw:1,8 ~/Downloads/White_Noise.wav

Any ideas?

David Henningsson (diwic) wrote :

@Andrei, ok, then that's the first I've heard of with working audio but broken jack detection.

> Any ideas?

Most likely the problem is on the video driver side. Are you using proprietary NVidia drivers or Nouveau drivers?

Andrei Gherzan (andrei-7i) wrote :

proprietary NVidia . But these are the same used in 11.10. And there the bug is not replicated.

Andrei

Gibb (capt-gibb) wrote :

I have the same problem but have no Nvidia (Samsung 90X3A, Sandy Bridge Intel HD 3000). No HDMI sound and no option to select it in the settings.

aplay -l gives:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

ozite (mlufaso) wrote :

I think I may have a similar problem, but the information in the previous comments didn't help. My AlsaInfo is at http://www.alsa-project.org/db/?f=6a2f2ceebd41031845175e0fe59b5d8f2477a510

I also put some screenshots and more information in a thread at http://ubuntuforums.org/showthread.php?t=2013831.

Since the issues appeared to be similar, I added the information here first. Let me know if I should create a different bug report.

Aaron Gerber (agerber85) wrote :

Same here. HDMI video output becomes available automatically when hooked up, but HDMI sound output does not. (It is not listed in Sound Settings dialog.)

My machine has not proprietary drivers installed, so that can't be the source of the problem.

If I restart pulseaudio while HDMI is hooked up, the HDMI sound output becomes available. Essentially, the list of available outputs is not being refreshed automatically.

My pulseaudio is version 1:1.1-0ubuntu15.

Leuke (leuke) wrote :

This bug was fixed in Precise and in Quantal, but it is back in Raring more or less as it was before: hdmi detected but not listed.

Changed in pulseaudio (Ubuntu):
status: Fix Released → New
Leuke (leuke) wrote :
Leuke (leuke) wrote :
David Henningsson (diwic) wrote :

Hi Leuke, do you know when it showed up in Raring again, if it was related to any specific version of Linux kernel or possibly version of nvidia binary drivers?

Leuke (leuke) wrote :

Not exactly, but I just downloaded some packages from kernel.ubuntu.com/~kernel-ppa/mainline/ and I found out that this behavior started with linux 3.6.0.
When I downgrade to linux 3.5.7 I can choose HDMI without problems.

Raymond (superquad-vortex2) wrote :

ftp://download.nvidia.com/XFree86/gpu-hdmi-audio-document/gpu-hdmi-audio.html

6.1.2. Chipset with 8-channel support, single stream

ELD and PD information is not available on these chipsets.

In these chipsets, the multiple 2-channel converters are aggregated by the ALSA driver and exposed as a single 8-channel device. Some chipsets support 2, or 8 channels (MCP77). Other chipsets support 2, 6, or 8 channels (MCP79).

Raymond (superquad-vortex2) wrote :

is there any reason to create "HDMI/DP,pcm=3 Jack" when PD is not supported (
Misc = NO_PRESENCE) ?

Codec: Nvidia MCP79/7A HDMI
Address: 3
AFG Function Id: 0x1 (unsol 0)
Vendor Id: 0x10de0007
Subsystem Id: 0x10de0101
Revision Id: 0x100100
No Modem Function Group found
Default PCM:
    rates [0x0]:
    bits [0x0]:
    formats [0x0]:
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
GPIO: io=0, o=0, i=0, unsolicited=0, wake=0
Node 0x04 [Audio Output] wcaps 0x211: Stereo Digital
  Control: name="IEC958 Playback Con Mask", index=0, device=0
  Control: name="IEC958 Playback Pro Mask", index=0, device=0
  Control: name="IEC958 Playback Default", index=0, device=0
  Control: name="IEC958 Playback Switch", index=0, device=0
  Device: name="HDMI 0", type="HDMI", device=3
  Converter: stream=0, channel=0
  Digital:
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0xc0]: 48000 88200
    bits [0xf]: 8 16 20 24
    formats [0x1]: PCM
Node 0x05 [Pin Complex] wcaps 0x400381: Stereo Digital
  Control: name="HDMI/DP,pcm=3 Jack", index=0, device=0
  Pincap 0x00000014: OUT Detect
  Pin Default 0x18560110: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x04

Raymond (superquad-vortex2) wrote :

this control always return false when PD is not supported

control.26 {
  iface CARD
  name 'HDMI/DP,pcm=3 Jack'
  value false
  comment {
   access read
   type BOOLEAN
   count 1
  }
 }

David Henningsson (diwic) wrote :
Changed in pulseaudio (Ubuntu):
status: New → Fix Released
affects: pulseaudio (Ubuntu) → linux (Ubuntu)
kylea (kylea) wrote :

I have 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Description: Ubuntu 13.04
Release: 13.04

With an Intel card - HDA Intel PCH
Chip Intel PantherPoint HDMI

I cannot see the HDMI option

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.