VirtualBox virtual e1000 hangs intermittently

Bug #960554 reported by David Lawson on 2012-03-20
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

I've seen similar network hangs several times now, I'll try to verify that they're the same basic cause and see if I can figure out what's provoking them.

Mar 20 15:14:53 ubox kernel: [ 9632.136482] e1000 0000:00:03.0: eth0: Detected Tx Unit Hang
Mar 20 15:14:53 ubox kernel: [ 9632.136483] Tx Queue <0>
Mar 20 15:14:53 ubox kernel: [ 9632.136484] TDH <79>
Mar 20 15:14:53 ubox kernel: [ 9632.136485] TDT <7b>
Mar 20 15:14:53 ubox kernel: [ 9632.136485] next_to_use <7b>
Mar 20 15:14:53 ubox kernel: [ 9632.136486] next_to_clean <79>
Mar 20 15:14:53 ubox kernel: [ 9632.136487] buffer_info[next_to_clean]
Mar 20 15:14:53 ubox kernel: [ 9632.136487] time_stamp <1002396f9>
Mar 20 15:14:53 ubox kernel: [ 9632.136488] next_to_watch <7a>
Mar 20 15:14:53 ubox kernel: [ 9632.136488] jiffies <10023996a>
Mar 20 15:14:53 ubox kernel: [ 9632.136489] next_to_watch.status <0>
Mar 20 15:14:55 ubox kernel: [ 9634.140485] e1000 0000:00:03.0: eth0: Detected Tx Unit Hang
Mar 20 15:14:55 ubox kernel: [ 9634.140487] Tx Queue <0>
Mar 20 15:14:55 ubox kernel: [ 9634.140487] TDH <79>
Mar 20 15:14:55 ubox kernel: [ 9634.140488] TDT <7b>
Mar 20 15:14:55 ubox kernel: [ 9634.140489] next_to_use <7b>
Mar 20 15:14:55 ubox kernel: [ 9634.140489] next_to_clean <79>
Mar 20 15:14:55 ubox kernel: [ 9634.140490] buffer_info[next_to_clean]
Mar 20 15:14:55 ubox kernel: [ 9634.140490] time_stamp <1002396f9>
Mar 20 15:14:55 ubox kernel: [ 9634.140491] next_to_watch <7a>
Mar 20 15:14:55 ubox kernel: [ 9634.140492] jiffies <100239b5f>
Mar 20 15:14:55 ubox kernel: [ 9634.140492] next_to_watch.status <0>
Mar 20 15:14:56 ubox kernel: [ 9634.832830] ------------[ cut here ]------------
Mar 20 15:14:56 ubox kernel: [ 9634.832839] WARNING: at /build/buildd/linux-3.2.0/net/sched/sch_generic.c:255 dev_watchdog+0x25a/0x270()
Mar 20 15:14:56 ubox kernel: [ 9634.832841] Hardware name: VirtualBox
Mar 20 15:14:56 ubox kernel: [ 9634.832842] NETDEV WATCHDOG: eth0 (e1000): transmit queue 0 timed out
Mar 20 15:14:56 ubox kernel: [ 9634.832844] Modules linked in: isofs vboxvideo(O) drm vesafb vboxsf(O) ppdev snd_intel8x0 snd_ac97_codec ac97_bus snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event rfcomm joydev psmouse serio_raw snd_seq snd_timer snd_seq_device bnep parport_pc bluetooth snd mac_hid vboxguest(O) binfmt_misc soundcore snd_page_alloc i2c_piix4 lp parport usbhid hid e1000
Mar 20 15:14:56 ubox kernel: [ 9634.832867] Pid: 0, comm: swapper/0 Tainted: G O 3.2.0-19-generic #30-Ubuntu
Mar 20 15:14:56 ubox kernel: [ 9634.832869] Call Trace:
Mar 20 15:14:56 ubox kernel: [ 9634.832870] <IRQ> [<ffffffff8106724f>] warn_slowpath_common+0x7f/0xc0
Mar 20 15:14:56 ubox kernel: [ 9634.832877] [<ffffffff81067346>] warn_slowpath_fmt+0x46/0x50
Mar 20 15:14:56 ubox kernel: [ 9634.832881] [<ffffffff8155ceda>] dev_watchdog+0x25a/0x270
Mar 20 15:14:56 ubox kernel: [ 9634.832884] [<ffffffff81082f90>] ? __queue_work+0x320/0x320
Mar 20 15:14:56 ubox kernel: [ 9634.832886] [<ffffffff8155cc80>] ? qdisc_reset+0x50/0x50
Mar 20 15:14:56 ubox kernel: [ 9634.832889] [<ffffffff8155cc80>] ? qdisc_reset+0x50/0x50
Mar 20 15:14:56 ubox kernel: [ 9634.832892] [<ffffffff81076186>] call_timer_fn+0x46/0x160
Mar 20 15:14:56 ubox kernel: [ 9634.832894] [<ffffffff8155cc80>] ? qdisc_reset+0x50/0x50
Mar 20 15:14:56 ubox kernel: [ 9634.832896] [<ffffffff81077ad2>] run_timer_softirq+0x132/0x2a0
Mar 20 15:14:56 ubox kernel: [ 9634.832899] [<ffffffff81095025>] ? ktime_get+0x65/0xe0
Mar 20 15:14:56 ubox kernel: [ 9634.832902] [<ffffffff8106ea38>] __do_softirq+0xa8/0x210
Mar 20 15:14:56 ubox kernel: [ 9634.832904] [<ffffffff8109bfb4>] ? tick_program_event+0x24/0x30
Mar 20 15:14:56 ubox kernel: [ 9634.832908] [<ffffffff81665aec>] call_softirq+0x1c/0x30
Mar 20 15:14:56 ubox kernel: [ 9634.832910] [<ffffffff81015305>] do_softirq+0x65/0xa0
Mar 20 15:14:56 ubox kernel: [ 9634.832913] [<ffffffff8106ee1e>] irq_exit+0x8e/0xb0
Mar 20 15:14:56 ubox kernel: [ 9634.832915] [<ffffffff8166648e>] smp_apic_timer_interrupt+0x6e/0x99
Mar 20 15:14:56 ubox kernel: [ 9634.832918] [<ffffffff8166435e>] apic_timer_interrupt+0x6e/0x80
Mar 20 15:14:56 ubox kernel: [ 9634.832919] <EOI> [<ffffffff8105611d>] ? set_next_entity+0xad/0xd0
Mar 20 15:14:56 ubox kernel: [ 9634.832924] [<ffffffff8103ce4b>] ? native_safe_halt+0xb/0x10
Mar 20 15:14:56 ubox kernel: [ 9634.832930] [<ffffffff8101b993>] default_idle+0x53/0x1d0
Mar 20 15:14:56 ubox kernel: [ 9634.832932] [<ffffffff8101bb6d>] amd_e400_idle+0x5d/0x120
Mar 20 15:14:56 ubox kernel: [ 9634.832934] [<ffffffff81012236>] cpu_idle+0xd6/0x120
Mar 20 15:14:56 ubox kernel: [ 9634.832937] [<ffffffff816221ee>] rest_init+0x72/0x74
Mar 20 15:14:56 ubox kernel: [ 9634.832940] [<ffffffff81cfcc0d>] start_kernel+0x3ba/0x3c7
Mar 20 15:14:56 ubox kernel: [ 9634.832943] [<ffffffff81cfc388>] x86_64_start_reservations+0x132/0x136
Mar 20 15:14:56 ubox kernel: [ 9634.832946] [<ffffffff81cfc140>] ? early_idt_handlers+0x140/0x140
Mar 20 15:14:56 ubox kernel: [ 9634.832948] [<ffffffff81cfc459>] x86_64_start_kernel+0xcd/0xdc
Mar 20 15:14:56 ubox kernel: [ 9634.832950] ---[ end trace 661833ed21a3f32e ]---

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-19-generic 3.2.0-19.30
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: I82801AAICH [Intel 82801AA-ICH], device 0: Intel ICH [Intel 82801AA-ICH]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dlawson 1713 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'I82801AAICH'/'Intel 82801AA-ICH with STAC9700,83,84 at irq 21'
   Mixer name : 'SigmaTel STAC9700,83,84'
   Components : 'AC97a:83847600'
   Controls : 34
   Simple ctrls : 24
CurrentDmesg:

Date: Tue Mar 20 15:38:46 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb:
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
MachineType: innotek GmbH VirtualBox
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-19-generic root=UUID=e9fc079d-1344-41af-9e74-b855a61d3def ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-19-generic N/A
 linux-backports-modules-3.2.0-19-generic N/A
 linux-firmware 1.71
RfKill:

SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2012-03-12 (8 days ago)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

David Lawson (deej) wrote :
Brad Figg (brad-figg) on 2012-03-20
Changed in linux (Ubuntu):
status: New → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-19.31
Changed in linux (Ubuntu):
importance: Undecided → Medium
David Lawson (deej) wrote :

I've convirmed this is still occurring in 3.2.20-20.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-20.32
David Lawson (deej) on 2012-03-23
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
David Lawson (deej) wrote :
Download full text (9.9 KiB)

I've replicated this on the mainline kernel, though the stack trace is slightly different. I imagine that's to be expected.

Apr 9 11:13:20 ubox kernel: [39032.376474] e1000 0000:00:03.0: eth0: Detected Tx Unit Hang
Apr 9 11:13:20 ubox kernel: [39032.376475] Tx Queue <0>
Apr 9 11:13:20 ubox kernel: [39032.376476] TDH <b6>
Apr 9 11:13:20 ubox kernel: [39032.376476] TDT <b8>
Apr 9 11:13:20 ubox kernel: [39032.376477] next_to_use <b8>
Apr 9 11:13:20 ubox kernel: [39032.376477] next_to_clean <b6>
Apr 9 11:13:20 ubox kernel: [39032.376478] buffer_info[next_to_clean]
Apr 9 11:13:20 ubox kernel: [39032.376478] time_stamp <10093bd46>
Apr 9 11:13:20 ubox kernel: [39032.376479] next_to_watch <b7>
Apr 9 11:13:20 ubox kernel: [39032.376479] jiffies <10093c096>
Apr 9 11:13:20 ubox kernel: [39032.376480] next_to_watch.status <0>
Apr 9 11:13:22 ubox kernel: [39034.380430] e1000 0000:00:03.0: eth0: Detected Tx Unit Hang
Apr 9 11:13:22 ubox kernel: [39034.380431] Tx Queue <0>
Apr 9 11:13:22 ubox kernel: [39034.380432] TDH <b6>
Apr 9 11:13:22 ubox kernel: [39034.380433] TDT <b8>
Apr 9 11:13:22 ubox kernel: [39034.380433] next_to_use <b8>
Apr 9 11:13:22 ubox kernel: [39034.380434] next_to_clean <b6>
Apr 9 11:13:22 ubox kernel: [39034.380434] buffer_info[next_to_clean]
Apr 9 11:13:22 ubox kernel: [39034.380435] time_stamp <10093bd46>
Apr 9 11:13:22 ubox kernel: [39034.380435] next_to_watch <b7>
Apr 9 11:13:22 ubox kernel: [39034.380436] jiffies <10093c28b>
Apr 9 11:13:22 ubox kernel: [39034.380437] next_to_watch.status <0>
Apr 9 11:13:24 ubox kernel: [39036.384806] e1000 0000:00:03.0: eth0: Detected Tx Unit Hang
Apr 9 11:13:24 ubox kernel: [39036.384808] Tx Queue <0>
Apr 9 11:13:24 ubox kernel: [39036.384808] TDH <b6>
Apr 9 11:13:24 ubox kernel: [39036.384809] TDT <b8>
Apr 9 11:13:24 ubox kernel: [39036.384810] next_to_use <b8>
Apr 9 11:13:24 ubox kernel: [39036.384810] next_to_clean <b6>
Apr 9 11:13:24 ubox kernel: [39036.384811] buffer_info[next_to_clean]
Apr 9 11:13:24 ubox kernel: [39036.384811] time_stamp <10093bd46>
Apr 9 11:13:24 ubox kernel: [39036.384812] next_to_watch <b7>
Apr 9 11:13:24 ubox kernel: [39036.384813] jiffies <10093c480>
Apr 9 11:13:24 ubox kernel: [39036.384813] next_to_watch.status <0>
Apr 9 11:13:25 ubox kernel: [39037.318026] e1000 0000:00:03.0: eth0: Detected Tx Unit Hang
Apr 9 11:13:25 ubox kernel: [39037.318027] Tx Queue <0>
Apr 9 11:13:25 ubox kernel: [39037.318028] TDH <b6>
Apr 9 11:13:25 ubox kernel: [39037.318029] TDT <b8>
Apr 9 11:13:25 ubox kernel: [39037.318029] next_to_use <b8>
Apr 9 11:13:25 ubox kernel: [39037.318030] next_to_clean <b6>
Apr 9 11:13:25 ubox kernel: [39037.318031] buffer_info[next_to_clean]
Apr 9 11:13:25 ubox kernel: [39037.318031] time_stamp <10093bd46>
Apr ...

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: kernel-request-3.2.0-19.31 kernel-request-3.2.0-20.32 needs-upstream-testing

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-22.35
David Lawson (deej) on 2012-04-09
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: bot-stop-nagging
removed: kernel-request-3.2.0-22.35
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
David Lawson (deej) wrote :

It looks like there are already several variations on this bug filed with upstream, though its surprising that it's present both in the 2.6 and 3.2/3.3 series.

Vincent Gerris (vgerris) wrote :

I can confirm this on 12.04 x86. when machines with an intel 1000 vm net card are started, the machine totally hangs hard.
When changed to aMD vm net cards, no problem.

Nasty bug! Hope it will be fixed soon, seems like a regression bug. No issues on 3.00.17 kernel

Changed in linux (Ubuntu):
importance: Medium → High
Vincent Gerris (vgerris) wrote :

It does not seem to affect only the e1000 driver in virtual box.
I changed the network drivers to AMD III and the VM booted, but now it crashes in those too.
Unsure if that is because of the latest kernel update.
I changed them to e1000 desktop now and it seems to work.

Very annoying bug, hope it will be fixed soon.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers