disk-detect/multipath/enable=true fails at loading dm-multipath module

Bug #959749 reported by Peter Petrakis on 2012-03-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Stefan Bader
multipath-tools (Ubuntu)
Medium
Colin Watson

Bug Description

This appears to be a regression from Lucid. Attached is a screenshot of the fault, and a preseed to reproduce the
issue. The most relevant parts of the preseed are:

disk-detect disk-detect/multipath/enable boolean true
d-i partman-auto/disk string /dev/mapper/mpath0
...
d-i pkgsel/include string byobu vim openssh-server multipath-tools multipath-tools-boot

Which works well with Lucid. However, when I test the precise installer, I get a message
saying dm-multipath.ko couldn't be loaded and it might be a parameter problem. This
module doesn't take any parameters. After hitting continue life goes on until I get
to the partman section which bails because there's no mpath0.

I tested without setting auto/disk just to see and noted it was only presenting sd devices, it doesn't
look like multipath was ever loaded.

I wonder if the requisite modules are even on the installer anymore? The install
is being performed over PXE.

Peter Petrakis (peter-petrakis) wrote :

Preseed file to aid reproduction

Stefan Bader (smb) wrote :

The dm-multipath was built-in in Lucid and became a module at some point. This needs to be added to the d-i section for the kernel build to make it available for the installer.
The device handlers never seem to have been built-in or contained in any d-i file. On the other hand it should not hurt to have them packaged as well (except space considerations on the media, but all four take about 100KB for amd64). And it is likely a bit late to experiment now.

So proposing to add dm-multipath to the md-modules udeb and the device handlers to the scsi-modules udeb.

Changed in linux (Ubuntu):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Undecided → Medium
status: New → In Progress
tags: added: patch
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2012-03-20
no longer affects: debian-installer (Ubuntu)
Stefan Bader (smb) wrote :

Leann added a second change to make modules go into multipath-modules udeb (this looks like fixing bug 598251)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-19.31

---------------
linux (3.2.0-19.31) precise; urgency=low

  [ Stefan Bader ]

  * d-i: Add dm-multipath and scsi device handlers
    - LP: #959749
  * d-i: Move multipath modules into their own udeb
    - LP: #598251, #959749

  [ Tim Gardner ]

  * [Config] Auto-detect do_tools setting
  * [Config] correctly specify CROSS_COMPILE for tools build
  * [Config] CONFIG_DRM_PSB_CDV=n
  * Rebase to v3.2.12

  [ Upstream Kernel Changes ]

  * powerpc/pmac: Fix SMP kernels on pre-core99 UP machines
    - LP: #959959
  * rebase to v3.2.12
 -- Leann Ogasawara <email address hidden> Tue, 20 Mar 2012 09:11:26 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) on 2012-03-21
Changed in multipath-tools (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multipath-tools - 0.4.9-3ubuntu4

---------------
multipath-tools (0.4.9-3ubuntu4) precise; urgency=low

  * Restore multipath-udeb dependency on multipath-modules (LP: #959749).
 -- Colin Watson <email address hidden> Wed, 21 Mar 2012 14:34:01 +0000

Changed in multipath-tools (Ubuntu):
status: New → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers