Ubuntu

BUG: soft lockup - CPU#0 stuck for 22s! [Xorg:1199]

Reported by Lars Noodén on 2012-03-18
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Collected automatically at startup

ProblemType: KernelOops
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-19-powerpc-smp
Uname: Linux 3.2.0-19-powerpc-smp ppc
Annotation: Your system might become unstable now and might need to be restarted.
Architecture: powerpc
Date: Sun Mar 18 21:32:05 2012
Failure: oops
SourcePackage: linux
---
AcpiTables:

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Snapper [PowerMac Snapper], device 0: PMac Snapper [PowerMac Snapper]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.94.1-0ubuntu2
Architecture: powerpc
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Snapper [PowerMac Snapper], device 0: PMac Snapper [PowerMac Snapper]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lars 1672 f.... lxpanel
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Snapper'/'PowerMac Snapper (Dev 31) Sub-frame 0'
   Mixer name : 'PowerMac Snapper'
   Components : ''
   Controls : 15
   Simple ctrls : 14
CurrentDmesg: [ 605.601386] ondemand governor failed, too long transition latency of HW, fallback to performance governor
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=ef89a4a8-d96c-4a02-83cb-80c9314a0e4e
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha powerpc (20120318)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb:
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 046d:c019 Logitech, Inc. Optical Tilt Wheel Mouse
 Bus 001 Device 003: ID 05ac:8203 Apple, Inc. Bluetooth HCI
Package: linux (not installed)
PciMultimedia:

ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 nouveaufb
ProcKernelCmdLine: root=/dev/mapper/hostname-root ro quiet splash
ProcVersionSignature: Ubuntu 3.2.0-19.30-powerpc-smp 3.2.11
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-19-powerpc-smp N/A
 linux-backports-modules-3.2.0-19-powerpc-smp N/A
 linux-firmware 1.71
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: precise
Uname: Linux 3.2.0-19-powerpc-smp ppc
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Lars Noodén (larsnooden) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/958749

tags: added: iso-testing

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 958749

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Lars Noodén (larsnooden) wrote :

Can this be bad hardware?

Joseph Salisbury (jsalisbury) wrote :
Download full text (4.8 KiB)

It could be related to nouveau:

[ 368.033311] BUG: soft lockup - CPU#0 stuck for 23s! [Xorg:1013]
[ 368.033324] Modules linked in: parport_pc ppdev lp parport rtc_generic btusb bnep mac_hid rfcomm bluetooth ext2 snd_powermac snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device snd soundcore snd_page_alloc apm_emu apm_emulation dm_crypt nouveau firewire_ohci sungem firewire_core crc_itu_t sungem_phy ttm drm_kms_helper usbhid hid drm uninorth_agp
[ 368.033442] NIP: c0021bf4 LR: e9613330 CTR: c0021bcc
[ 368.033453] REGS: e6d7f990 TRAP: 0901 Not tainted (3.2.0-19-powerpc-smp)
[ 368.033461] MSR: 00009032 <EE,ME,IR,DR> CR: 28004442 XER: 20000000
[ 368.033485] TASK = e71a0720[1013] 'Xorg' THREAD: e6d7e000 CPU: 0
[ 368.033494] GPR00: e9613330 e6d7fa40 e71a0720 0500202c 907a7d00 00000000 26be3680 006013da
[ 368.033518] GPR08: 00000008 c2400000 00000000 c0021bcc 28004448
[ 368.033550] NIP [c0021bf4] ioread32be+0x28/0x48
[ 368.033657] LR [e9613330] nouveau_wait_eq+0x80/0xc4 [nouveau]
[ 368.033664] Call Trace:
[ 368.033677] [e6d7fa40] [c2400000] 0xc2400000 (unreliable)
[ 368.033710] [e6d7fa50] [e9613330] nouveau_wait_eq+0x80/0xc4 [nouveau]
[ 368.033747] [e6d7fa80] [e9620ab4] nv_load_state_ext+0x8e4/0xf04 [nouveau]
[ 368.033782] [e6d7fad0] [e962657c] nouveau_hw_load_state+0xb8/0x14c [nouveau]
[ 368.033851] [e6d7faf0] [e96847f0] nv_crtc_commit+0x44/0x1a8 [nouveau]
[ 368.033879] [e6d7fb20] [e9222400] drm_crtc_helper_set_mode+0x238/0x38c [drm_kms_helper]
[ 368.033896] [e6d7fd10] [e9222dac] drm_crtc_helper_set_config+0x6dc/0x974 [drm_kms_helper]
[ 368.033982] [e6d7fd90] [e91c4408] drm_mode_setcrtc+0x2f0/0x38c [drm]
[ 368.034010] [e6d7fe10] [e91b3488] drm_ioctl+0x1d4/0x44c [drm]
[ 368.034026] [e6d7fee0] [c017dcf0] do_vfs_ioctl+0xac/0x2f4
[ 368.034037] [e6d7ff10] [c017dfc4] sys_ioctl+0x8c/0xac
[ 368.034052] [e6d7ff40] [c001974c] ret_from_syscall+0x0/0x38
[ 368.034066] --- Exception: c01 at 0x20285688
[ 368.034070] LR = 0x202855f0
[ 368.034076] Instruction dump:
[ 368.034084] 7d615b78 4e800020 7c0802a6 90010004 60000000 9421fff0 7c0802a6 90010014
[ 368.034107] 93e1000c 7c3f0b78 7c0004ac 80630000 <0c030000> 4c00012c 397f0010 800b0004
[ 403.041308] INFO: rcu_sched detected stall on CPU 0 (t=15000 jiffies)
[ 403.041320] Call Trace:
[ 403.041334] [e6d7f760] [c000c16c] show_stack+0x110/0x1c8 (unreliable)
[ 403.041356] [e6d7f7b0] [c063d158] dump_stack+0x2c/0x44
[ 403.041376] [e6d7f7c0] [c00d3f00] print_cpu_stall+0x50/0xb4
[ 403.041389] [e6d7f7e0] [c00d4cdc] __rcu_pending+0x104/0x240
[ 403.041402] [e6d7f800] [c00d60dc] rcu_check_callbacks+0x1f4/0x254
[ 403.041420] [e6d7f830] [c006cc70] update_process_times+0x4c/0x84
[ 403.041442] [e6d7f850] [c00995c4] tick_sched_timer+0x94/0x118
[ 403.041462] [e6d7f880] [c0087788] __run_hrtimer+0x84/0x220
[ 403.041475] [e6d7f8b0] [c0088d6c] hrtimer_interrupt+0x194/0x438
[ 403.041490] [e6d7f950] [c000f2e8] timer_interrupt+0x1e4/0x2f0
[ 403.041504] [e6d7f980] [c0019dfc] ret_from_except+0x0/0x14
[ 403.041572] --- Exception: 901 at ioread32be+0x28/0x48
[ 403.041577] LR = nouveau_wait_eq+0x80/0xc4 [nouveau]
[ 403.041590] [e6d7fa40] [c2400000] 0xc2...

Read more...

Changed in linux (Ubuntu):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the Oneiric kernel, to see if the issue exists there as well:

https://launchpad.net/~canonical-kernel-team/+archive/ppa/+build/3211482

Lars Noodén (larsnooden) wrote :

Does testing the Oneiric kernel involve just pulling in the kernel package and installing it? Or must I install Oneric first?

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-19.31
Lars Noodén (larsnooden) wrote :

This lockup hasn't happened now for a while, so it seems to have been fixed.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Javi Ena (javi-f) wrote :
Download full text (7.9 KiB)

I've been experiencing crashes like this the whole day ....:

Jun 20 17:46:27 sheeeit kernel: [ 7503.419644] BUG: soft lockup - CPU#2 stuck for 23s! [Xorg:1740]
Jun 20 17:46:27 sheeeit kernel: [ 7503.419655] Modules linked in: pci_stub vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) snd_hda_codec_hdmi snd_hda_codec_realtek joydev bnep parport_pc rfcomm ppdev btusb bluetooth usbhid hid snd_hda_in
tel snd_hda_codec snd_hwdep uvcvideo videodev snd_pcm v4l2_compat_ioctl32 binfmt_misc snd_seq_midi arc4 snd_rawmidi dm9601 usbnet ipt_MASQUERADE snd_seq_midi_event iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack snd_seq nf_defrag_ipv4 ip
_tables dell_laptop x_tables dell_wmi sparse_keymap snd_timer snd_seq_device xfs dcdbas snd iwlwifi psmouse i915 serio_raw mac80211 drm_kms_helper drm soundcore snd_page_alloc mei(C) cfg80211 i2c_algo_bit wmi video bridge stp dummy lp mac_
hid parport
Jun 20 17:46:27 sheeeit kernel: [ 7503.419771] CPU 2
Jun 20 17:46:27 sheeeit kernel: [ 7503.419773] Modules linked in: pci_stub vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) snd_hda_codec_hdmi snd_hda_codec_realtek joydev bnep parport_pc rfcomm ppdev btusb bluetooth usbhid hid snd_hda_in
tel snd_hda_codec snd_hwdep uvcvideo videodev snd_pcm v4l2_compat_ioctl32 binfmt_misc snd_seq_midi arc4 snd_rawmidi dm9601 usbnet ipt_MASQUERADE snd_seq_midi_event iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack snd_seq nf_defrag_ipv4 ip
_tables dell_laptop x_tables dell_wmi sparse_keymap snd_timer snd_seq_device xfs dcdbas snd iwlwifi psmouse i915 serio_raw mac80211 drm_kms_helper drm soundcore snd_page_alloc mei(C) cfg80211 i2c_algo_bit wmi video bridge stp dummy lp mac_
hid parport
Jun 20 17:46:27 sheeeit kernel: [ 7503.419862]
Jun 20 17:46:27 sheeeit kernel: [ 7503.419868] Pid: 1740, comm: Xorg Tainted: G C O 3.2.0-24-generic #39-Ubuntu Dell Inc. Dell System XPS L321X/0Y4RM9
Jun 20 17:46:27 sheeeit kernel: [ 7503.419879] RIP: 0010:[<ffffffff8101b310>] [<ffffffff8101b310>] rtc_cmos_write+0x10/0x10
Jun 20 17:46:27 sheeeit kernel: [ 7503.419895] RSP: 0018:ffff8800ced99bd0 EFLAGS: 00000246
Jun 20 17:46:27 sheeeit kernel: [ 7503.419900] RAX: 00000b9c67049997 RBX: 0000000000000000 RCX: 0000000067049997
Jun 20 17:46:27 sheeeit kernel: [ 7503.419904] RDX: 00000000000026ea RSI: 00000000000e4210 RDI: 0000000000029143
Jun 20 17:46:27 sheeeit kernel: [ 7503.419909] RBP: ffff8800ced99bf8 R08: ffff8800ced99c90 R09: 0000000000000001
Jun 20 17:46:27 sheeeit kernel: [ 7503.419914] R10: 0000000000000000 R11: 0000000000000000 R12: ffffffff8103dcf9
Jun 20 17:46:27 sheeeit kernel: [ 7503.419918] R13: ffff8800ced99c08 R14: ffffffff81077dda R15: ffff8800ced99b48
Jun 20 17:46:27 sheeeit kernel: [ 7503.419924] FS: 00007f89aed85880(0000) GS:ffff88011fa80000(0000) knlGS:0000000000000000
Jun 20 17:46:27 sheeeit kernel: [ 7503.419930] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Jun 20 17:46:27 sheeeit kernel: [ 7503.419934] CR2: 00002bba32f0b030 CR3: 00000000cee47000 CR4: 00000000000406e0
Jun 20 17:46:27 sheeeit kernel: [ 7503.419939] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Jun 20 17:46:27 sheeeit kernel: [ 7503.419944] DR3: 0000000000000000 DR6: 0...

Read more...

Javi Ena (javi-f) wrote :

I forgot to say, it's happened using:

linux-image-3.2.0-24-generic
and
linux-image-3.2.0-25-generic

either within xen or without (booting directly the kernel)

this still hapenes with 3.2.0-39-generic.

Mikko Rantalainen (mira) wrote :
Download full text (12.5 KiB)

I've hit this multiple times during last week. The cause for me might be either graphics adapter driver (i915) or VirtualBox kernel driver (vbox*). Here's a portion of /var/log/kern.log (hostname replaced with "localhost"):

Jun 18 08:35:12 localhost kernel: [ 1697.352128] BUG: soft lockup - CPU#3 stuck for 22s! [Xorg:1317]
Jun 18 08:35:12 localhost kernel: [ 1697.352130] Modules linked in: pci_stub vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) bnep rfcomm bluetooth parport_pc ppdev snd_hda_codec_hdmi snd_hda_codec_realtek usbhid hid uvcvideo videodev snd_usb_audio v4l2_compat_ioctl32 snd_usbmidi_lib eeepc_wmi snd_hda_intel snd_hda_codec snd_hwdep asus_wmi snd_pcm sparse_keymap i915 snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq drm_kms_helper snd_timer drm snd_seq_device psmouse snd serio_raw soundcore snd_page_alloc i2c_algo_bit mei(C) video mac_hid wmi lp parport usb_storage r8169
Jun 18 08:35:12 localhost kernel: [ 1697.352157] CPU 3
Jun 18 08:35:12 localhost kernel: [ 1697.352158] Modules linked in: pci_stub vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) bnep rfcomm bluetooth parport_pc ppdev snd_hda_codec_hdmi snd_hda_codec_realtek usbhid hid uvcvideo videodev snd_usb_audio v4l2_compat_ioctl32 snd_usbmidi_lib eeepc_wmi snd_hda_intel snd_hda_codec snd_hwdep asus_wmi snd_pcm sparse_keymap i915 snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq drm_kms_helper snd_timer drm snd_seq_device psmouse snd serio_raw soundcore snd_page_alloc i2c_algo_bit mei(C) video mac_hid wmi lp parport usb_storage r8169
Jun 18 08:35:12 localhost kernel: [ 1697.352179]
Jun 18 08:35:12 localhost kernel: [ 1697.352180] Pid: 1317, comm: Xorg Tainted: G C O 3.2.0-48-generic #74-Ubuntu System manufacturer System Product Name/P8H77-M PRO
Jun 18 08:35:12 localhost kernel: [ 1697.352183] RIP: 0010:[<ffffffff810a35a2>] [<ffffffff810a35a2>] smp_call_function_many+0x212/0x280
Jun 18 08:35:12 localhost kernel: [ 1697.352189] RSP: 0000:ffff880401b1db68 EFLAGS: 00003202
Jun 18 08:35:12 localhost kernel: [ 1697.352190] RAX: 00000000000008fc RBX: ffffffff81312710 RCX: 0000000000000008
Jun 18 08:35:12 localhost kernel: [ 1697.352191] RDX: 00000000f7000000 RSI: ffffffff81806c60 RDI: 0000000000003293
Jun 18 08:35:12 localhost kernel: [ 1697.352193] RBP: ffff880401b1dbb8 R08: 0000000000000000 R09: 0000000000000004
Jun 18 08:35:12 localhost kernel: [ 1697.352194] R10: 0000000000000004 R11: 0000000000000000 R12: 0000000000003293
Jun 18 08:35:12 localhost kernel: [ 1697.352196] R13: ffff880401b1db18 R14: 0000000800000000 R15: 0000000000000000
Jun 18 08:35:12 localhost kernel: [ 1697.352197] FS: 00007f9489d1f880(0000) GS:ffff88041fac0000(0000) knlGS:0000000000000000
Jun 18 08:35:12 localhost kernel: [ 1697.352199] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Jun 18 08:35:12 localhost kernel: [ 1697.352200] CR2: 00007f947e59f240 CR3: 00000004014f5000 CR4: 00000000001426e0
Jun 18 08:35:12 localhost kernel: [ 1697.352202] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Jun 18 08:35:12 localhost kernel: [ 1697.352203] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Jun 18 08:35:12 localhost kernel: [ 1697.352205] Process X...

Mikko Rantalainen (mira) wrote :

$ uname -a
Linux localhost 3.2.0-48-generic #74-Ubuntu SMP Thu Jun 6 19:43:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

I guess this bug should be re-opened...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers