Ubuntu

Single IP unreachable after suspend

Reported by didi_X8 on 2012-03-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
didi_X8

Bug Description

The following issue occured several times over the last month with Ubuntu 11.10 x86_64, kernel 3.0.0-16-generic.
It happened from the beginning (3.0.0-15). I didn't have this Computer before, so I don't know if the issue is specific to this Ubuntu / kernel version.

Sometimes, after waking up from suspend, single remote hosts are not reachable. It may be the first host the system tries to connect to (or may be the last one connected to before susped), but I'm not sure about that.
"not reachable" means there's no route. It's not a DNS issue because trying to ping the IP itself also fails. Example ping output:

$ ping 80.237.133.28
PING 80.237.133.28 (80.237.133.28) 56(84) bytes of data.
From 78.104.151.116 icmp_seq=1 Destination Host Unreachable
...

at the same time:
$ ping google.com
PING google.com (209.85.148.139) 56(84) bytes of data.
64 bytes from fra07s07-in-f139.1e100.net (209.85.148.139): icmp_req=1 ttl=57 time=15.3 ms
...

here, 78.104.151.116 is my own IP in this network.
The destination IP is definitely reachable, I can reach it at the same moment on a different machine in the same network. Or from my own machine if I first ssh to another machine and connect from there.

The issue is hardly a network interface driver issue, because this already happened with both WiFi and Ethernet connection.

It looks like the issue doesn't happen in all networks. In my home network it didn't happen yet, but already in two other networks. I don't know what makes the difference.

As I said, the issue is isolated to single destination hosts. At the same time, the connection works normally for all other destinations.
I could solve this only by reboot up to now. Things I tried:
- restart networking
- suspend / wakeup again
- disconnect / reconnect network interface
- switch network interface (WiFi / Ethernet)
- ip route flush cache
- ip neigh flush all

I am no networking expert, but a sysadmin of the university network took a look at my Computer when the issue appeared. He couldn't find out the reason, but suspected it to be a kernel issue.

I think the posting at http://askubuntu.com/questions/100717/some-ips-unreachable-after-resume-from-suspend describes the same issue, but I didn't get any further feedback there.

For any further advice on how I could gather more useful information / try to fix it I would be very helpful.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: didi 6739 F.... pulseaudio
 /dev/snd/pcmC0D0p: didi 6739 F...m pulseaudio
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf2520000 irq 43'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:14f15069,17aa21a4,00100302 HDA:80862804,17aa21b5,00100000'
   Controls : 12
   Simple ctrls : 6
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6UHT32WW-1.13'
   Mixer name : 'ThinkPad EC 6UHT32WW-1.13'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 11.10
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: LENOVO 29124NG
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=de_AT:de
 PATH=(custom, user)
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=e56748e9-2b6d-4d64-81e2-cd1f2a6ab6d6 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-16.29-generic 3.0.20
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-16-generic N/A
 linux-backports-modules-3.0.0-16-generic N/A
 linux-firmware 1.60
StagingDrivers: mei
Tags: oneiric staging
Uname: Linux 3.0.0-16-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom davfs2 dialout lpadmin plugdev sambashare
dmi.bios.date: 05/10/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 6UET64WW (1.44 )
dmi.board.name: 29124NG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6UET64WW(1.44):bd05/10/2011:svnLENOVO:pn29124NG:pvrThinkPadT410s:rvnLENOVO:rn29124NG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 29124NG
dmi.product.version: ThinkPad T410s
dmi.sys.vendor: LENOVO

didi_X8 (didi156-gmail) on 2012-03-16
description: updated
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc7-precise/

affects: linux-meta (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing oneiric

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 956918

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
didi_X8 (didi156-gmail) wrote :

As requested, I'm now running 3.3.0-030300rc7-generic and waiting if it happens again...

didi_X8 (didi156-gmail) wrote :

I couldn't reproduce it anymore with kernel 3.3.0.
Now I upgraded to Ubuntu 12.04 and switched back to the default kernel, also no problems yet. Seems to be solved.

didi_X8 (didi156-gmail) wrote :

fixed in 12.04

Changed in linux (Ubuntu):
assignee: nobody → didi_X8 (didi156-gmail)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers