mceusb: add Formosa device ID 0xe042

Bug #954772 reported by _nico on 2012-03-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu-Version: 12.04 till 10.10
Kernel-Version: 3.2.0.12.12 till 3.0.0.0

Hello, this is my first Kernel-Bug-Report, i hope everything will be all right.

Please add the following lines in mceusb.c ...

/* Formosa21 / eHome Infrared Receiver */
{ USB_DEVICE(VENDOR_FORMOSA, 0xe042) },

... for IR-Receiver:

lsusb
Bus 003 Device 003: ID 147a:e042 Formosa Industrial Computing, Inc.

exactly like here:
http://www.spinics.net/lists/linux-media/msg45332.html
http://patchwork.linuxtv.org/patch/10311/

!!!! EDIT/UPDATE: for Ubuntu 10.04 LTS and lower please patch lirc-module "mceusb.c" !!!!

Thanks, Nico

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-generic 3.2.0.12.12
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64

_nico (nicohartung1) on 2012-03-14
description: updated
description: updated

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 954772

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
_nico (nicohartung1) wrote :

Hi, it's a virtualbox vm - the ir-receiver is not connected. I used this vm only for reporting this bug on launchpad!

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.29
_nico (nicohartung1) on 2012-03-14
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: bot-stop-nagging
Joseph Salisbury (jsalisbury) wrote :

We generally ask bug reporters to first request that the driver be added to the upstream kernel. This can be done by mailing the Linux Kernel Mailing List or opening a bug at bugzilla.kernel.org.

People affected by this bug are probably wondering why the kernel team doesn't just add the patch and fix it. The reason is that the kernel team is reluctant (not opposed) to apply any patch/driver to a kernel that is not from upstream. Applying patches and adding drivers that don't come from upstream add greatly to the support of the kernel as other upstream patches/drivers may touch the same area as the non-upstream patch and may prevent them from applying cleanly.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
_nico (nicohartung1) wrote :

I thought you could fix it for the new Ubuntu 12.04 LTS.

Bugreport Kernel.org:
https://bugzilla.kernel.org/show_bug.cgi?id=42926

Maarten Bezemer (veger) wrote :

Thanks for taking the time to report this bug in the upstream bug tracking system this is a tremendous help. Launchpad has the ability to watch lots of upstream bug trackers and this can be done by following the procedure documented at https://wiki.ubuntu.com/Bugs/Watches. I've added the bug watch for this bug report.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
_nico (nicohartung1) wrote :

Workaround for Kernel 3.x:

echo 147a e042 > /sys/bus/usb/drivers/mceusb/new_id

Thanks to foosel - http://bit.ly/IVqWe1

Changed in linux:
status: Confirmed → Fix Released

_nico, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.