Oneiric update to 3.0.24 stable release

Bug #954576 reported by Tim Gardner on 2012-03-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Tim Gardner

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.0.24 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the 3.0.24 stable release:

ASoC: wm8962: Fix sidetone enumeration texts
NOMMU: Lock i_mmap_mutex for access to the VMA prio list
hwmon: (max6639) Fix FAN_FROM_REG calculation
hwmon: (max6639) Fix PPR register initialization to set both channels
hwmon: (ads1015) Fix file leak in probe function
powerpc/perf: power_pmu_start restores incorrect values, breaking frequency events
drm/radeon/kms: fix MSI re-arm on rv370+
PCI: workaround hard-wired bus number V2
mac80211: Fix a rwlock bad magic bug
ipheth: Add iPhone 4S
ALSA: hda - Fix redundant jack creations for cx5051
mmc: core: check for zero length ioctl data
NFSv4: Ensure we throw out bad delegation stateids on NFS4ERR_BAD_STATEID
ARM: 7321/1: cache-v7: Disable preemption when reading CCSIDR
ARM: 7325/1: fix v7 boot with lockdep enabled
net: Make qdisc_skb_cb upper size bound explicit.
IPoIB: Stop lying about hard_header_len and use skb->cb to stash LL addresses
gro: more generic L2 header check
veth: Enforce minimum size of VETH_INFO_PEER
3c59x: shorten timer period for slave devices
ipv6-multicast: Fix memory leak in input path.
ipv6-multicast: Fix memory leak in IPv6 multicast.
ipv4: fix for ip_options_rcv_srr() daddr update.
ipv4: Save nexthop address of LSRR/SSRR option to IPCB.
ipv4: Fix wrong order of ip_rt_get_source() and update iph->daddr.
ipv4: reset flowi parameters on route connect
net: Don't proxy arp respond if iif == rt->dst.dev if private VLAN is disabled
netpoll: netpoll_poll_dev() should access dev->flags
net_sched: Bug in netem reordering
via-velocity: S3 resume fix.
tcp_v4_send_reset: binding oif to iif in no sock case
tcp: allow tcp_sacktag_one() to tag ranges not aligned with skbs
tcp: fix range tcp_shifted_skb() passes to tcp_sacktag_one()
tcp: fix tcp_shifted_skb() adjustment of lost_cnt_hint for FACK
route: fix ICMP redirect validation
ipv4: fix redirect handling
USB: Added Kamstrup VID/PIDs to cp210x serial driver.
USB: option: cleanup zte 3g-dongle's pid in option.c
USB: Serial: ti_usb_3410_5052: Add Abbot Diabetes Care cable id
USB: Remove duplicate USB 3.0 hub feature #defines.
USB: Fix handoff when BIOS disables host PCI device.
xhci: Fix oops caused by more USB2 ports than USB3 ports.
xhci: Fix encoding for HS bulk/control NAK rate.
USB: Set hub depth after USB3 hub reset
i387: math_state_restore() isn't called from asm
i387: make irq_fpu_usable() tests more robust
i387: fix sense of sanity check
i387: fix x86-64 preemption-unsafe user stack save/restore
i387: move TS_USEDFPU clearing out of __save_init_fpu and into callers
i387: don't ever touch TS_USEDFPU directly, use helper functions
i387: do not preload FPU state at task switch time
i387: move AMD K7/K8 fpu fxsave/fxrstor workaround from save to restore
i387: move TS_USEDFPU flag from thread_info to task_struct
i387: re-introduce FPU state preloading at context switch time
usb-storage: fix freezing of the scanning thread
USB: Don't fail USB3 probe on missing legacy PCI IRQ.
x86/amd: Fix L1i and L2 cache sharing information for AMD family 15h processors
ath9k: stop on rates with idx -1 in ath9k rate control's .tx_status
genirq: Unmask oneshot irqs when thread was not woken
genirq: Handle pending irqs in irq_startup()
scsi_scan: Fix 'Poison overwritten' warning caused by using freed 'shost'
scsi_pm: Fix bug in the SCSI power management handler
ipvs: fix matching of fwmark templates during scheduling
jme: Fix FIFO flush issue
davinci_emac: Do not free all rx dma descriptors during init
builddeb: Don't create files in /tmp with predictable names
hdpvr: fix race conditon during start of streaming
hwmon: (f75375s) Fix register write order when setting fans to full speed
epoll: introduce POLLFREE to flush ->signalfd_wqh before kfree()
epoll: ep_unregister_pollwait() can use the freed pwq->whead
epoll: limit paths
cdrom: use copy_to_user() without the underscores
Linux 3.0.23
autofs: work around unhappy compat problem on x86-64
Fix autofs compile without CONFIG_COMPAT
compat: fix compile breakage on s390
drm/i915: Prevent a machine hang by checking crtc->active before loading lut
ARM: LPC32xx: serial.c: HW bug workaround
ARM: LPC32xx: serial.c: Fixed loop limit
ARM: LPC32xx: irq.c: Clear latched event
ARM: LPC32xx: Fix interrupt controller init
ARM: LPC32xx: Fix irq on GPI_28
watchdog: hpwdt: clean up set_memory_x call for 32 bit
i2c: mxs: only flag completion when queue is completely done
regulator: fix the ldo configure according to 88pm860x spec
S390: KEYS: Enable the compat keyctl wrapper on s390x
ALSA: hda - Add a fake mute feature
ALSA: hda - Always set HP pin in unsol handler for STAC/IDT codecs
mfd: Fix ACPI conflict check
genirq: Clear action->thread_mask if IRQ_ONESHOT is not set
ARM: S3C24XX: DMA resume regression fix
Move Logitech Harmony 900 from cdc_ether to zaurus
alpha: fix 32/64-bit bug in futex support
mmc: sdhci-esdhc-imx: fix for mmc cards on i.MX5
NOMMU: Don't need to clear vm_mm when deleting a VMA
cifs: fix dentry refcount leak when opening a FIFO on lookup
mac80211: zero initialize count field in ieee80211_tx_rate
ath9k_hw: prevent writes to const data on AR9160
mm: thp: fix BUG on mm->nr_ptes
HID: usbhid: Add NOGET quirk for the AIREN Slim+ keyboard
crypto: mv_cesa - fix final callback not ignoring input data
osd_uld: Bump MAX_OSD_DEVICES from 64 to 1,048,576
ASoC: dapm: Check for bias level when powering down
ASoC: i.MX SSI: Fix DSP_A format.
avr32: select generic atomic64_t support
kprobes: adjust "fix a memory leak in function pre_handler_kretprobe()"
drm/i915: gen7: implement rczunit workaround
drm/i915: gen7: Implement an L3 caching workaround.
drm/i915: gen7: work around a system hang on IVB
drm/i915: gen7: Disable the RHWO optimization as it can cause GPU hangs.
ARM: orion: Fix USB phy for orion5x.
ARM: orion: Fix Orion5x GPIO regression from MPP cleanup
OMAP: DSS2: HDMI: use default dividers
OMAP: 4430SDP/Panda: use gpio_free_array to free HDMI gpios
OMAP: 4430SDP/Panda: rename HPD GPIO to CT_CP_HPD
OMAPDSS: remove wrong HDMI HPD muxing
OMAP: 4430SDP/Panda: setup HDMI GPIO muxes
OMAP: 4430SDP/Panda: add HDMI HPD gpio
OMAPDSS: HDMI: PHY burnout fix
ARM: 7345/1: errata: update workaround for A9 erratum #743622
media: staging: lirc_serial: Fix init/exit order
media: staging: lirc_serial: Free resources on failure paths of lirc_serial_probe()
media: staging: lirc_serial: Fix deadlock on resume failure
media: staging: lirc_serial: Do not assume error codes returned by request_irq()
Input: ALPS - fix touchpad detection when buttons are pressed
hwmon: (pmbus_core) Fix maximum number of POUT alarm attributeshwmon: (jc42) Add support for ST Microelectronics STTS2002 and STTS3000
hwmon: (jc42) Add support for AT30TS00, TS3000GB2, TSE2002GB2, and MCP9804
carl9170: Fix memory accounting when sta is in power-save mode.
drm/radeon/kms: set SX_MISC in the r6xx blit code (v2)
net/usbnet: avoid recursive locking in usbnet_stop()
dm io: fix discard support
dm raid: fix flush support
cs5535-mfgpt: don't call __init function from __devinit
mfd: Fix cs5535 section mismatch
Linux 3.0.24

Tim Gardner (timg-tpi) on 2012-03-13
tags: added: kernel-stable-tracking-bug
Tim Gardner (timg-tpi) on 2012-03-13
description: updated
Changed in linux (Ubuntu Oneiric):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (24.1 KiB)

This bug was fixed in the package linux - 3.0.0-19.33

---------------
linux (3.0.0-19.33) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #985736

  [ Luis Henriques ]

  * SAUCE: ite-cir: postpone ISR registration
    - LP: #984387

linux (3.0.0-19.32) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #974368

  [ Brad Figg ]

  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (no-up) Quirk for enabling backlight hotkeys on Samsung N150P
    - LP: #875893

  [ Daniel Vetter ]

  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: (no-up) Reinstate missing hunk from nx emulation
    - LP: #972821

  [ Tim Gardner ]

  * SAUCE: ubuntu drivers: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233
  * SAUCE: (no-up) remove __initdata from vesafb_fix
    - LP: #969309

  [ Upstream Kernel Changes ]

  * usermodehelper: use UMH_WAIT_PROC consistently
    - LP: #963685
  * usermodehelper: introduce umh_complete(sub_info)
    - LP: #963685
  * usermodehelper: implement UMH_KILLABLE
    - LP: #963685
  * usermodehelper: kill umh_wait, renumber UMH_* constants
    - LP: #963685
  * usermodehelper: ____call_usermodehelper() doesn't need do_exit()
    - LP: #963685
  * kmod: introduce call_modprobe() helper
    - LP: #963685
  * kmod: make __request_module() killable
    - LP: #963685
  * x86, tsc: Fix SMI induced variation in quick_pit_calibrate()
    - LP: #965586
  * ata_piix: Add Toshiba Satellite Pro A120 to the quirks list due to
    broken suspend functionality.
    - LP: #886850
  * ACPICA: Fix regression in FADT revision checks
    - LP: #883441
  * ASPM: Fix pcie devices with non-pcie children
    - LP: #961482
  * USB: option: Add MediaTek MT6276M modem&app interfaces
    - LP: #971808
  * USB: option driver: adding support for Telit CC864-SINGLE, CC864-DUAL
    and DE910-DUAL modems
    - LP: #971808
  * USB: option: make interface blacklist work again
    - LP: #971808
  * USB: option: add ZTE MF820D
    - LP: #971808
  * USB: ftdi_sio: fix problem when the manufacture is a NULL string
    - LP: #971808
  * USB: ftdi_sio: add support for BeagleBone rev A5+
    - LP: #971808
  * USB: Microchip VID mislabeled as Hornby VID in ftdi_sio.
    - LP: #971808
  * USB: ftdi_sio: new PID: Distortec JTAG-lock-pick
    - LP: #971808
  * USB: ftdi_sio: add support for FT-X series devices
    - LP: #971808
  * USB: ftdi_sio: new PID: LUMEL PD12
    - LP: #971808
  * powerpc/usb: fix bug of kernel hang when initializing usb
    - LP: #971808
  * usb: musb: Reselect index reg in interrupt context
    - LP: #971808
  * usb: gadgetfs: return number of bytes on ep0 read request
    - LP: #971808
  * USB: gadget: Make g_hid device class conform to spec.
    - LP: #971808
  * futex: Cover all PI opcodes with cmpxchg enabled check
    - LP: #971808
  * sysfs: Fix memory leak in sysfs_sd_setsecdata().
    - LP: #971808
  * tty: ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers