Ubuntu

No Screen Backlight Control; Notebooks (Vaio, Macbook, HP/Compaq, Samsung, Zepto et al.) with Nvidia Geforce8/Geforce9/Quadro series graphics

Reported by getaceres on 2007-03-24
186
This bug affects 22 people
Affects Status Importance Assigned to Milestone
HAL
Invalid
Undecided
Unassigned
acpi-support (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by Iain Lane
Nominated for Precise by TJ
Nominated for Quantal by TJ
hal (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by Iain Lane
Nominated for Precise by TJ
Nominated for Quantal by TJ
hotkey-setup (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by Iain Lane
Nominated for Precise by TJ
Nominated for Quantal by TJ
linux (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by Iain Lane
Nominated for Precise by TJ
Nominated for Quantal by TJ
nvclock (Ubuntu)
Undecided
andy langer
Declined for Jaunty by Iain Lane
Nominated for Precise by TJ
Nominated for Quantal by TJ
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by Iain Lane
Nominated for Precise by TJ
Nominated for Quantal by TJ

Bug Description

Using Ubuntu on laptops with Nvidia Geforce8/Geforce9/Quadro vga card:

On various laptops from Sony, HP, Samsung and others there is no way to control backlight brightness. In case of Sony e.g. on Vaios with 8-series adapters, e.g.
nVidia Corporation GeForce 8400M GS
nVidia Corporation GeForce 8600M GT (rev a1)

The registers have been found (kudos to mikes!) and incorporated into
nvclock, which you can check out by anonymous cvs and install:

]$ sudo apt-get install cvs
]$ cvs -d:pserver:<email address hidden>:/cvsroot/nvclock login
]$ cvs -z3 -d:pserver:<email address hidden>:/cvsroot/nvclock co -P nvclock
]$ cd nvclock
]$ ./autogen.sh
]$ ./configure
]$ make
]$ sudo make install

To test, make sure you are using nVidia's proprietary driver, then:
]$ sudo nvclock -S 100
]$ sudo nvclock -S 15
]$ sudo nvclock -S +10

So far mikes' registers have been found to work on:

Apple laptops
{
Macbook 5,1 Aluminum 13.3" (Geforce 9400M)
}

HP/Compaq laptops
{
8510W (Quadro FX 570M, MXM)
8710P (Quadro NVS 320M, MXM)
}

Samsung laptops:
{
Q210 (Geforce 9200M)
Q310 (Geforce 9200M)
R510 (Geforce 9200M)
}

Sony laptops:
{
8400M GS:
VGN SZ650N, SZ61MN/B, SZ730E, SZ750N, SZ71MN/B, SZ71E SZ95S, SZ6RMN

8400M GT:
VGN FZ38M, FZ31M, FZ11Z, NR31, AR41E, FZ11S, FZ290, FZ250AE, FZ21E, FZ21M, FZ21S, FZ470E, FZ340E, FZ190N, FZ18M, FZ31E, FZ18E, FZ260E NR21Z, NR38S, NR21S,FZ280E

8600M GS:
VGN FZ31Z, FZ21Z, FZ31S

8600M GT:
VGN AR51SU, AR71S
}

Zepto laptops
{
Geforce 9600GT based laptops using MXM cards
}

Add your model to the list by clicking on the "Update description / tags" link, NOT by asking in a bug comment for someone else to do it.

To get hotkeys to work, follow the instructions in this comment:
https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/95444/comments/75
or install the package at :
https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/95444/comments/111

Dual-adapter models (SZ6 among others) can get backlight control with the Intel adapter using xbacklight, and can get hotkey functionality as per bug #173652.

Related branches

unggnu (unggnu) wrote :

If it still doesn't work try sudo modprobe sony-acpi . Sometimes the module isn't loaded. Maybe this is your problem.

getaceres (getaceres) wrote :

It's loaded and still Fn doesn't work and brightness is only adjustable through smartdimmer.

jose@ubuntu-vaio:~$ lsmod | grep sony
sonypi 23196 0
sony_acpi 6284 0
jose@ubuntu-vaio:~$

unggnu (unggnu) wrote :

Could you please recheck it with latest Ubuntu Gutsy Gibbon 7.10 or the Live CD? I guess the problem was the change from sony-acpi to sony-laptop.

This bug report is being closed because we received no response to the last inquiry for information. Please reopen it if this is still an issue in the current Ubuntu release. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Please don't hesitate to submit bug reports in the future, we really appreciate it. Thanks again!

Changed in linux-source-2.6.22:
status: Incomplete → Won't Fix
getaceres (getaceres) wrote :

Sorry for the delay. I've tried with both, the Live CD and my up to date Gutsy installation and they don't work (Fn is not responding and brightness cannot be changed in the gnome power manager preferences).

Changed in linux-source-2.6.22:
status: Won't Fix → New
getaceres (getaceres) wrote :

Tried with Hardy Alpha 6 Live CD and still brightness and FN keys don't work.

Hi getaceres,

On the latest Hardy Alpha release, please provide the information outlined here: https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch . Thanks.

Changed in linux:
status: New → Incomplete
getaceres (getaceres) wrote :

Volume keys work, but not the two laptop hotkey shortcuts:

By Method 3: For every key press I get two numbers, everyone with a received and completed message.

Shortcut S1:
[Mon Mar 17 21:44:00 2008] received event "sony/hotkey SNC 00000001 00000090"
[Mon Mar 17 21:44:00 2008] received event "sony/hotkey SNC 00000001 00000010"

Shorcut S2:
[Mon Mar 17 21:45:14 2008] received event "sony/hotkey SNC 00000001 00000091"
[Mon Mar 17 21:45:14 2008] received event "sony/hotkey SNC 00000001 00000011"

Brightness Down (Fn+F5):
[Mon Mar 17 21:46:58 2008] received event "sony/hotkey SNC 00000001 00000010"
[Mon Mar 17 21:46:58 2008] received event "sony/hotkey SNC 00000001 0000003b"

Brightness Up (Fn+F6):
[Mon Mar 17 21:47:59 2008] received event "sony/hotkey SNC 00000001 00000011"
[Mon Mar 17 21:47:59 2008] received event "sony/hotkey SNC 00000001 0000003b"

Display change between LCD/External/Both (Fn+F7):
[Mon Mar 17 21:49:55 2008] received event "sony/hotkey SNC 00000001 00000012"
[Mon Mar 17 21:49:55 2008] received event "sony/hotkey SNC 00000001 0000003b"

Suspend (Fn+F12):
[Mon Mar 17 21:51:11 2008] received event "sony/hotkey SNC 00000001 00000017"
[Mon Mar 17 21:51:11 2008] received event "sony/hotkey SNC 00000001 0000003b"

These are the main Fn functions although there are more like the numeric keypad and block despl.

The model:

sudo dmidecode -s system-manufacturer
Sony Corporation

sudo dmidecode -s system-product-name
VGN-FE31Z

sudo dmidecode -s system-version
C3LN0NJF

Also, brightness don't work even changing the slider in the gnome power management screen and only works using the smartdimmer command.

Changed in linux:
status: Incomplete → New
for1dev (afor1ner) wrote :

I'm having the same problem with my Vaio FZ280E. Too bad it didn't ship with a pair of sunglasses.

Been watching this thread very closely:
http://www.nvnews.net/vbulletin/showthread.php?t=100494&page=4

yaayyy open source on proprietary hardware :)

Bram (brvdpu) wrote :

I think my hotkey doesn't word because i use the nvidia drivers (v 173.14.12), which take care of the brightness too. Any idea how to set my system up to still be able to use the hotkeys?

getaceres (getaceres) wrote :

Tried with 2.6.27 kernel but still not working. Not only the brightness keys (which may be due to nvida) but I can't get to work any of the fn+<something> keys.

I'm experiencing the same problems on FZ21E and Intrepid A6
Changing the brightness from the nvidia driver panel is working well, but it doesn't work from the keys, so I wonder if it is realy a nvidia driver issue ??

description: updated
Schmirrwurst (schmirrwurst) wrote :

I'm currently using the 177 driver
ii nvidia-177-kernel-source 177.76-0ubuntu1 NVIDIA binary kernel module source
ii nvidia-177-modaliases 177.76-0ubuntu1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-glx-177 177.76-0ubuntu1 NVIDIA binary Xorg driver

kernel : 2.6.27-3-generic #1 SMP Wed Sep 10 16:18:52 UTC 2008 x86_64 GNU/Linux

$ modinfo sony_laptop
filename: /lib/modules/2.6.27-3-generic/kernel/drivers/misc/sony-laptop.ko
version: 0.6
license: GPL
description: Sony laptop extras driver (SPIC and SNC ACPI device)
author: Stelian Pop, Mattia Dongili
srcversion: E48E3D714530434ADDC399C
alias: acpi*:SNY6001:*
alias: acpi*:SNY5001:*
depends:
vermagic: 2.6.27-3-generic SMP mod_unload modversions
parm: debug:set this to 1 (and RTFM) if you want to help the development of this driver (int)
parm: no_spic:set this if you don't want to enable the SPIC device (int)
parm: compat:set this if you want to enable backward compatibility mode (int)
parm: mask:set this to the mask of event you want to enable (see doc) (ulong)
parm: camera:set this to 1 to enable Motion Eye camera controls (only use it if you have a C1VE or C1VN model) (int)
parm: minor:minor number of the misc device for the SPIC compatibility code, default is -1 (automatic) (int)

Schmirrwurst (schmirrwurst) wrote :

following bug is already about this subject, but as it is treating to problems at a time (two different cards) I believe it is better to hold them seperate.
https://bugs.launchpad.net/ubuntu/+source/xbacklight/+bug/173652, there for it is not a duplicate..

Michael Doube (michael-doube) wrote :

I agree - I've sent nVidia problems from bug #173652 to this bug. As I understand it, sony-laptop generates ACPI events for the key-presses but the script that it calls doesn't do anything to affect backlight brightness. I'm not sure who's responsible for setting LED backlight: sony-laptop or nvidia driver? Possibly the backlight is an SNC method http://tjworld.net/snc/ or a CMOS register http://tjworld.net/wiki/Sony/Vaio/FE41Z/HackingBiosNvram (please note, I am clueless here...)

And for those who set their 'brightness' with the nVidia tool, you are only changing LCD values, not LED values, i.e. you are changing the colours of the screen not the intensity of the backlight so there is no power saving (only eye saving!).

benste (benste) wrote :

Hy,
I'm not shure why I've been subscribed to this thread by __
but, in my opinion it's not resbonsibilty of nvidia, because brightness should not only work with the GLX driver also with the standard nv one.
I tried my things today on interpid again with the following result:
ACPI Events are recocnized - but nothing happens BUT from time to time NVclock seems to cause a "report this bug message". The keys on a european FE31m are like folowed:
benste@vaiofe31m:~$ acpi_listen
S1
sony/hotkey SNC 00000001 00000090
sony/hotkey SNC 00000001 00000010
s2
sony/hotkey SNC 00000001 00000091
sony/hotkey SNC 00000001 00000011
FN+ F5 (brightn down)
sony/hotkey SNC 00000001 00000010
sony/hotkey SNC 00000001 0000003b
FN + F6 (up)
sony/hotkey SNC 00000001 00000011
sony/hotkey SNC 00000001 0000003b
FN + F7 (external display change)
sony/hotkey SNC 00000001 00000012
sony/hotkey SNC 00000001 0000003b
FN + F10 (zoom display)
sony/hotkey SNC 00000001 00000015
sony/hotkey SNC 00000001 0000003b
FN + F12 (suspend to disk)
sony/hotkey SNC 00000001 00000017
sony/hotkey SNC 00000001 0000003b

And that's it,
I'm not shure what is going on in the last time, but it would be easier for me if I would know who does what since at minimum one year it seems for me that no one does anything but all are just reporting the same bug.

PS: if Nvidia should develop a brightness support via Nvclock, what a bout those who aren't using the proprate driver?

Changed in hotkey-setup:
status: New → Confirmed
status: Confirmed → In Progress
Changed in nvidia-graphics-drivers-177:
status: New → In Progress
Changed in linux:
status: New → In Progress
Alberto Milone (albertomilone) wrote :

Can you post the output of this command?
smartdimmer -g

mdoube@doris:~$ smartdimmer -g
init_nvclock() failed!

Alberto Milone wrote:
> Can you post the output of this command?
> smartdimmer -g
>
>

three times:

benste@vaiofe31m:~$ smartdimmer -g
SmartDimmer level: 21
benste@vaiofe31m:~$ smartdimmer -g
SmartDimmer level: 21
benste@vaiofe31m:~$ smartdimmer -g
SmartDimmer level: 21
seems to work or?

even -m and -i for dimming works including the wanted effect but Fn woun't work :-)

@ Michael:
you've got a 8 or 7 series?? did you install restricted driver?

I'm in the same case as Michael. I use a Vaio VGN-AR41E with a GeForce
8400M and its restricted driver.

Brightness is really a problem. It works by changing the value in the
nvidia-settings panel, but it doesn't look like it's *screen*
brightness (and still burn my eyes !).
--
Warren Seine

We may seperate this bug for 7- series and 8+ series or?

because in 7 and lower series nvclock works and in 8+ not

Benste:

nVidia 8400M GS, restricted driver.

Yes, I think we should make it clear that smartdimmer supports the 7
series but not the 8 series at this point.

Brightness keys doesn't work on Sony Vaio AR71S either.

nVidia Corporation GeForce 8600M GT (rev a1)

uses the sony-laptop module.

Have to use nvidia-settings, but it's really crappy way of doing it.

description: updated

Should I open a new one for 7series '?
I'm just a user so I wouldn't be able to find solutions :-)

Michael Doube (michael-doube) wrote :

Benste

Please do. There must be some problem in sonybright.sh if your backlight adjustment is not working from hotkeys, either it not being called, or its actions aren't being interpreted or the script itself is just wrong. Have you tried running

]~$ sudo /etc/init.d/acpid restart

After logging in to Ubuntu, then trying hotkeys again? This is necessary to make the script work as per bug #173652

benste (benste) wrote :

yes it probably muste be ther :-)

benste@vaiofe31m:/etc/acpi/events$ sh sony-brightness-down
sony-brightness-down: 3: Syntax error: "(" unexpected

benste (benste) wrote :

Michael, would you be so pleasant to post my z series bug problem ?
I'm not able to create - and link it to all the related branches.

thx.

You may better write a summary than me :-)

asino89 (asino89) wrote :

I'm writing from a live session (so whitout nvidia rstricted drivers) of ubuntu intrepid ibex beta version (downloaded yesterday)...
No way of changing the brightness of my sony vaio vgn-nr31S...

I report some of the trials i did:

ubuntu@ubuntu:/etc/acpi/events$ sh sony-brightness-down
sony-brightness-down: 3: SPIC: not found
sony-brightness-down: 4: down: not found

xbacklight -set 50
No outputs have backlight property

 /etc/acpi/sonybright.sh down
cat: /sys/class/backlight/sony/brightness: No such file or directory
/etc/acpi/sonybright.sh: line 8: [: : integer expression expected
/etc/acpi/sonybright.sh: line 15: /sys/class/backlight/sony/brightness: No such file or directory

Hope this will help somebody to fix this bug...

Same keys for my vgn-fz21E

On Wednesday 24 September 2008 18:30:56 benste wrote:
> Hy,
> I'm not shure why I've been subscribed to this thread by __
> but, in my opinion it's not resbonsibilty of nvidia, because brightness
> should not only work with the GLX driver also with the standard nv one. I
> tried my things today on interpid again with the following result: ACPI
> Events are recocnized - but nothing happens BUT from time to time NVclock
> seems to cause a "report this bug message". The keys on a european FE31m
> are like folowed: benste@vaiofe31m:~$ acpi_listen
> S1
> sony/hotkey SNC 00000001 00000090
> sony/hotkey SNC 00000001 00000010
> s2
> sony/hotkey SNC 00000001 00000091
> sony/hotkey SNC 00000001 00000011
> FN+ F5 (brightn down)
> sony/hotkey SNC 00000001 00000010
> sony/hotkey SNC 00000001 0000003b
> FN + F6 (up)
> sony/hotkey SNC 00000001 00000011
> sony/hotkey SNC 00000001 0000003b
> FN + F7 (external display change)
> sony/hotkey SNC 00000001 00000012
> sony/hotkey SNC 00000001 0000003b
> FN + F10 (zoom display)
> sony/hotkey SNC 00000001 00000015
> sony/hotkey SNC 00000001 0000003b
> FN + F12 (suspend to disk)
> sony/hotkey SNC 00000001 00000017
> sony/hotkey SNC 00000001 0000003b
>
> And that's it,
> I'm not shure what is going on in the last time, but it would be easier for
> me if I would know who does what since at minimum one year it seems for me
> that no one does anything but all are just reporting the same bug.
>
> PS: if Nvidia should develop a brightness support via Nvclock, what a
> bout those who aren't using the proprate driver?
>
>
> ** Changed in: hotkey-setup (Ubuntu)
> Status: New => Confirmed
>
> ** Changed in: hotkey-setup (Ubuntu)
> Status: Confirmed => In Progress
>
> ** Changed in: nvidia-graphics-drivers-177 (Ubuntu)
> Status: New => In Progress
>
> ** Changed in: linux (Ubuntu)
> Status: New => In Progress

Any news? I managed to fix the sony_laptop module to work with the Vaio VGN-NR31 and register the Fn keypresses as ACPI events. If anyone wants the fixed module please contact me.

But the serious problem is the lack of knowledge about the nvidia 8 series smartdimmer internals. Any luck with this? Can I help with anything? I got a 8400M GT (G86)

mikes (mikevas) wrote :

Could we please at least raise the "importance" of this task? It is really critical since a) laptop is unusable when on batery, and b) picture is too bright and washed out when on full brightness. I understand that it has to do with nvidia and/or sony, but this does not make it any less important.

Thanks

I just want to add that nothing works until I do 'xrandr --output LVDS --set BACKLIGHT_CONTROL native'. After that, xbacklight and function keys work to set screen brightness.

I also get this:
michael@panther:~$ smartdimmer -g
init_nvclock() failed!

As far as this error goes...
michael@panther:~$ /etc/acpi/sonybright.sh down
cat: /sys/class/backlight/sony/brightness: No such file or directory
/etc/acpi/sonybright.sh: line 8: [: : integer expression expected
/etc/acpi/sonybright.sh: line 15: /sys/class/backlight/sony/brightness: No such file or directory

The reason is because the file has moved to /sys/class/backlight/acpi_videoX/brightness where X is either 0 or 1. However, changing this value doesn't seem to make a difference in the screen brightness.

I don't know if any of this was useful to anybody else, but I hope so.

Hans (hans-eichbaum) wrote :

I have a Vaio VGN-SZ71MN/B. This Vaio has 2 graphic cards, controlable with a switch that says stamina / speed.
When I select 'stamina' the Intel G965 is used and I have nicely brightness control with xbacklight after using the xrandr trick. When I select 'speed' the Nvidia Geforce 8 card is used and I have no brightness control.

I have read lots about the Nvidia brightness control problems with Vaio's and wondering now the following. If the brightness control is just controllable via a register, why is it any different for the Nvidia? Or in other words, is it really just a register?
Like others I have observed occasionally flickering when using the Nvidia card, might this be related to the brightness control? has it been deliberately disabled due to this flickering problem (it might be worse when controlling the brightness leds)??

mikes (mikevas) wrote :

Any progress/ideas on this?

kiloxxx (kiloxxx) wrote :

Only a little progress with hotkeys, not with backlight.

I have a VGN-FZ11Z, after the last kernel upgrade (2.6.24-21-generic i686) it finally recognizes the brightness keys correctly. Not only acpi_listen gives responses when the key are pressed, but also kde open a little pop-up referring to the increase and the decrease of brightness.
Unfortunately the actual brightness is still fixed to 100%.

benste (benste) wrote :

fyi,
yohan Lee-tin-yien developed a .deb file exaktly for this situation (keypresses are converted into actions but nothing happens.)
BUT it woun't work until you've got a working smartdimmer which is maybe a bit triggy or not possible yet with 8 or 9 series.
The debb file will be uploaded asap.

mikes (mikevas) wrote :

I had some progress here. I attached Vista to WinDbg and traced inside the kernel and drivers. I found what it does to change the backlight, but I need some more work in order to port this to Linux. The actual change happens with a call to WRITE_REGISTER_ULONG in a kernel virtual address (9XXXXXXX) with values from 800000f0 (low) to 80000401(full). It seems prety straighforward. There is no port IO as in the pommed driver, and I dont know how this address (9XXXXXXX) is translated to nvidia register addresses and/or physical bus addresses. There are calls to HalTranslateBusAddress and mmMapIoSpace at the initialization of the driver, I'll have to trace those and see where they map the used address spaces. I will work some more on it and post the results.

If anyone is experienced with memory mapped I/O stuff in both Win and Linux, please help!

mikes (mikevas) wrote :

BINGO! As I am writing to you, my LCD brightness is set to a comfortable low level and my battery time is 2+ hours! The physical address for the register is 0xCE61C084 for the 8400M, if it means anything to you. I did a quick and dirty hack on nvclock to set the register and it worked. Possible values are from 0x0 to 0x401. To set the brightness you have to bitwise-OR the value with 0x80000000. The max value for my panel is 0x401. This means that you have to write 0x80000401 to 0xCE61C084 in order to set the brightness to full. 0x80000100 is ok for something relatively low. All values in-between are working. Implementing the nice backlight fade-in and fade-out effect from Vista should be easily doable.

Have in mind that when you are reading the value of the register the leading 8 does not appear. It is needed when you set the brightness though. The register eats it and is left with the least significant part which is the real value (i.e. 0x00000401).

For those that are going to incorporate this to smartdimmer and/or nvclock, have in mind that this physical address is outside of the ranges that are mmap-ped in the backend code, so you possibly need to add a new pointer member in the NVCard struct.

description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
seek (seek-matrixcode) on 2008-10-21
description: updated
description: updated
kikvors (kikvors) on 2008-10-24
description: updated
description: updated
description: updated
description: updated
description: updated
kyklos (rosario-vecchio) on 2008-10-25
description: updated
description: updated
Hans (hans-eichbaum) on 2008-10-25
description: updated
puse (danielpusemuckel) on 2008-10-25
description: updated
description: updated
description: updated
description: updated
description: updated
seek (seek-matrixcode) on 2008-10-26
description: updated
description: updated
ToTo (mrtoto) on 2008-11-07
description: updated
ToTo (mrtoto) on 2008-11-07
description: updated
description: updated
acid-r4in (rpeternella) on 2008-11-14
description: updated
description: updated
seek (seek-matrixcode) on 2008-11-14
description: updated
description: updated
description: updated
blks303 (blks303) on 2008-11-16
description: updated
axx (axx) on 2008-11-18
description: updated
JGJones (jgjones) on 2008-11-19
description: updated
description: updated
description: updated
yleetiny (yleetiny) on 2008-11-21
description: updated
description: updated
Neehilo (neehilo) on 2008-12-05
description: updated
Changed in hal:
status: New → Invalid
BoZ (ba-serge) on 2008-12-25
description: updated
Chris (kurisu-rs) on 2008-12-28
description: updated
description: updated
description: updated
vernonrj (vernonrjones) on 2009-01-19
description: updated
description: updated
Jordi2019 (jordi2019) on 2009-01-23
description: updated
Steve Langasek (vorlon) on 2009-02-08
Changed in hotkey-setup:
status: In Progress → Invalid
Changed in hal:
status: New → Invalid
Changed in nvidia-graphics-drivers-177:
status: In Progress → New
Steve Langasek (vorlon) on 2009-02-08
Changed in linux:
status: In Progress → New
description: updated
description: updated
187 comments hidden view all 267 comments
Shawe Ewahs (shawe-ewahs) wrote :

Icapa, if works manually, works with this scripts adding your model in the file that I say you. Not work perfectly, but works.

Download full text (3.2 KiB)

I'm sure your script is good, nvclock works perfectly but my Fn5 and Fn6
couldn't be detected, is there any test reading directly from keyboard
driver to see if keys are detected?

2009/2/15 Shawe Ewahs <email address hidden>

> Icapa, if works manually, works with this scripts adding your model in
> the file that I say you. Not work perfectly, but works.
>
> --
> No Screen Backlight Control; Notebooks (Vaio, Macbook, HP/Compaq, Samsung,
> Zepto et al.) with Nvidia Geforce8/Geforce9/Quadro series graphics
> https://bugs.launchpad.net/bugs/95444
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Hardware Abstraction Layer (HAL): Invalid
> Status in "hal" source package in Ubuntu: Invalid
> Status in "hotkey-setup" source package in Ubuntu: Invalid
> Status in "linux" source package in Ubuntu: New
> Status in "nvclock" source package in Ubuntu: New
> Status in "nvidia-graphics-drivers-180" source package in Ubuntu: New
>
> Bug description:
> Using Ubuntu on laptops with Nvidia Geforce8/Geforce9/Quadro vga card:
>
> On various laptops from Sony, HP, Samsung and others there is no way to
> control backlight brightness. In case of Sony e.g. on Vaios with 8-series
> adapters, e.g.
> nVidia Corporation GeForce 8400M GS
> nVidia Corporation GeForce 8600M GT (rev a1)
>
> The registers have been found (kudos to mikes!) and incorporated into
> nvclock, which you can check out by anonymous cvs and install:
>
> ]$ sudo apt-get install cvs
> ]$ cvs -d:pserver:<email address hidden>:/cvsroot/nvclock
> login
> ]$ cvs -z3 -d:pserver:<email address hidden>:/cvsroot/nvclock
> co -P nvclock
> ]$ cd nvclock
> ]$ ./autogen.sh
> ]$ ./configure
> ]$ make
> ]$ sudo make install
>
> To test, make sure you are using nVidia's proprietary driver, then:
> ]$ sudo nvclock -S 100
> ]$ sudo nvclock -S 15
> ]$ sudo nvclock -S +10
>
> So far mikes' registers have been found to work on:
>
> Apple laptops
> {
> Macbook 5,1 Aluminum 13.3" (Geforce 9400M)
> }
>
> HP/Compaq laptops
> {
> 8510W (Quadro FX 570M, MXM)
> 8710P (Quadro NVS 320M, MXM)
> }
>
> Samsung laptops:
> {
> Q210 (Geforce 9200M)
> Q310 (Geforce 9200M)
> R510 (Geforce 9200M)
> }
>
> Sony laptops:
> {
> 8400M GS:
> VGN SZ650N, SZ61MN/B, SZ730E, SZ750N, SZ71MN/B, SZ71E SZ95S
>
> 8400M GT:
> VGN FZ38M, FZ31M, FZ11Z, NR31, AR41E, FZ11S, FZ290, FZ250AE, FZ21E, FZ21M,
> FZ21S, FZ470E, FZ340E, FZ190N, FZ18M, FZ31E, FZ18E, FZ260E NR21Z, NR38S,
> NR21S,FZ280E
>
> 8600M GS:
> VGN FZ31Z, FZ21Z, FZ31S
>
> 8600M GT:
> VGN AR51SU, AR71S
> }
>
> Zepto laptops
> {
> Geforce 9600GT based laptops using MXM cards
> }
>
> Add your model to the list by clicking on the "Update description / tags"
> link, NOT by asking in a bug comment for someone else to do it.
>
> To get hotkeys to work, follow the instructions in this comment:
>
> https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/95444/comments/75
> or install the package at :
>
> https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/95444/comments/111
>
> Dual-adapter models (SZ6 among others) can get backlight control with the
> Intel adapter using xbacklight, and can get hotkey funct...

Read more...

Shawe Ewahs (shawe-ewahs) wrote :
Download full text (3.8 KiB)

Read all comments on this pages, people say thinks that you can try for try
to solve.

By §h@wæ
http://www.islatux.es

2009/2/15 Icapa <email address hidden>

> I'm sure your script is good, nvclock works perfectly but my Fn5 and Fn6
> couldn't be detected, is there any test reading directly from keyboard
> driver to see if keys are detected?
>
>
> 2009/2/15 Shawe Ewahs <email address hidden>
>
> > Icapa, if works manually, works with this scripts adding your model in
> > the file that I say you. Not work perfectly, but works.
> >
> > --
> > No Screen Backlight Control; Notebooks (Vaio, Macbook, HP/Compaq,
> Samsung,
> > Zepto et al.) with Nvidia Geforce8/Geforce9/Quadro series graphics
> > https://bugs.launchpad.net/bugs/95444
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in Hardware Abstraction Layer (HAL): Invalid
> > Status in "hal" source package in Ubuntu: Invalid
> > Status in "hotkey-setup" source package in Ubuntu: Invalid
> > Status in "linux" source package in Ubuntu: New
> > Status in "nvclock" source package in Ubuntu: New
> > Status in "nvidia-graphics-drivers-180" source package in Ubuntu: New
> >
> > Bug description:
> > Using Ubuntu on laptops with Nvidia Geforce8/Geforce9/Quadro vga card:
> >
> > On various laptops from Sony, HP, Samsung and others there is no way to
> > control backlight brightness. In case of Sony e.g. on Vaios with 8-series
> > adapters, e.g.
> > nVidia Corporation GeForce 8400M GS
> > nVidia Corporation GeForce 8600M GT (rev a1)
> >
> > The registers have been found (kudos to mikes!) and incorporated into
> > nvclock, which you can check out by anonymous cvs and install:
> >
> > ]$ sudo apt-get install cvs
> > ]$ cvs -d:pserver:<email address hidden>:/cvsroot/nvclock
> > login
> > ]$ cvs -z3 -d:pserver:<email address hidden>:
> /cvsroot/nvclock
> > co -P nvclock
> > ]$ cd nvclock
> > ]$ ./autogen.sh
> > ]$ ./configure
> > ]$ make
> > ]$ sudo make install
> >
> > To test, make sure you are using nVidia's proprietary driver, then:
> > ]$ sudo nvclock -S 100
> > ]$ sudo nvclock -S 15
> > ]$ sudo nvclock -S +10
> >
> > So far mikes' registers have been found to work on:
> >
> > Apple laptops
> > {
> > Macbook 5,1 Aluminum 13.3" (Geforce 9400M)
> > }
> >
> > HP/Compaq laptops
> > {
> > 8510W (Quadro FX 570M, MXM)
> > 8710P (Quadro NVS 320M, MXM)
> > }
> >
> > Samsung laptops:
> > {
> > Q210 (Geforce 9200M)
> > Q310 (Geforce 9200M)
> > R510 (Geforce 9200M)
> > }
> >
> > Sony laptops:
> > {
> > 8400M GS:
> > VGN SZ650N, SZ61MN/B, SZ730E, SZ750N, SZ71MN/B, SZ71E SZ95S
> >
> > 8400M GT:
> > VGN FZ38M, FZ31M, FZ11Z, NR31, AR41E, FZ11S, FZ290, FZ250AE, FZ21E,
> FZ21M,
> > FZ21S, FZ470E, FZ340E, FZ190N, FZ18M, FZ31E, FZ18E, FZ260E NR21Z, NR38S,
> > NR21S,FZ280E
> >
> > 8600M GS:
> > VGN FZ31Z, FZ21Z, FZ31S
> >
> > 8600M GT:
> > VGN AR51SU, AR71S
> > }
> >
> > Zepto laptops
> > {
> > Geforce 9600GT based laptops using MXM cards
> > }
> >
> > Add your model to the list by clicking on the "Update description / tags"
> > link, NOT by asking in a bug comment for someone else to do it.
> >
> > To get hotkeys to work, follow the in...

Read more...

Could some people try the latest nvclock cvs? Some time ago I added
proper smartdimmer detection but I still don't know if it works for
everyone.

Thanks,
Roderick

Schmirrwurst (schmirrwurst) wrote :

Hi thunderbird,

If I've the previous cvs version installed, could you describe the steps to properly uninstall and install, and what to test ? There so many posts now, that it's pretty confusing...
Can I test it also under jaunty ? So far as I know, the sonybright.sh ... and other scripts aren't yet available ?

Download full text (3.6 KiB)

Hi,

The steps are the same as before, so:

]$ sudo apt-get install cvs
]$ cvs -d:pserver:<email address hidden>:/cvsroot/nvclock login
]$ cvs -z3
-d:pserver:<email address hidden>:/cvsroot/nvclock co
-P nvclock
]$ cd nvclock
]$ ./autogen.sh
]$ ./configure
]$ make
]$ sudo make install

Thanks,
Roderick

Quoting Schmirrwurst <email address hidden>:

> Hi thunderbird,
>
> If I've the previous cvs version installed, could you describe the
> steps to properly uninstall and install, and what to test ? There so
> many posts now, that it's pretty confusing...
> Can I test it also under jaunty ? So far as I know, the
> sonybright.sh ... and other scripts aren't yet available ?
>
> --
> No Screen Backlight Control; Notebooks (Vaio, Macbook, HP/Compaq,
> Samsung, Zepto et al.) with Nvidia Geforce8/Geforce9/Quadro series
> graphics
> https://bugs.launchpad.net/bugs/95444
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Hardware Abstraction Layer (HAL): Invalid
> Status in “hal” source package in Ubuntu: Invalid
> Status in “hotkey-setup” source package in Ubuntu: Invalid
> Status in “linux” source package in Ubuntu: New
> Status in “nvclock” source package in Ubuntu: New
> Status in “nvidia-graphics-drivers-180” source package in Ubuntu: New
>
> Bug description:
> Using Ubuntu on laptops with Nvidia Geforce8/Geforce9/Quadro vga card:
>
> On various laptops from Sony, HP, Samsung and others there is no way
> to control backlight brightness. In case of Sony e.g. on Vaios with
> 8-series adapters, e.g.
> nVidia Corporation GeForce 8400M GS
> nVidia Corporation GeForce 8600M GT (rev a1)
>
> The registers have been found (kudos to mikes!) and incorporated into
> nvclock, which you can check out by anonymous cvs and install:
>
> ]$ sudo apt-get install cvs
> ]$ cvs
> -d:pserver:<email address hidden>:/cvsroot/nvclock
> login
> ]$ cvs -z3
> -d:pserver:<email address hidden>:/cvsroot/nvclock co
> -P nvclock
> ]$ cd nvclock
> ]$ ./autogen.sh
> ]$ ./configure
> ]$ make
> ]$ sudo make install
>
> To test, make sure you are using nVidia's proprietary driver, then:
> ]$ sudo nvclock -S 100
> ]$ sudo nvclock -S 15
> ]$ sudo nvclock -S +10
>
> So far mikes' registers have been found to work on:
>
> Apple laptops
> {
> Macbook 5,1 Aluminum 13.3" (Geforce 9400M)
> }
>
> HP/Compaq laptops
> {
> 8510W (Quadro FX 570M, MXM)
> 8710P (Quadro NVS 320M, MXM)
> }
>
> Samsung laptops:
> {
> Q210 (Geforce 9200M)
> Q310 (Geforce 9200M)
> R510 (Geforce 9200M)
> }
>
> Sony laptops:
> {
> 8400M GS:
> VGN SZ650N, SZ61MN/B, SZ730E, SZ750N, SZ71MN/B, SZ71E SZ95S
>
> 8400M GT:
> VGN FZ38M, FZ31M, FZ11Z, NR31, AR41E, FZ11S, FZ290, FZ250AE, FZ21E,
> FZ21M, FZ21S, FZ470E, FZ340E, FZ190N, FZ18M, FZ31E, FZ18E, FZ260E
> NR21Z, NR38S, NR21S,FZ280E
>
> 8600M GS:
> VGN FZ31Z, FZ21Z, FZ31S
>
> 8600M GT:
> VGN AR51SU, AR71S
> }
>
> Zepto laptops
> {
> Geforce 9600GT based laptops using MXM cards
> }
>
> Add your model to the list by clicking on the "Update description /
> tags" link, NOT by asking in a bug comment for someone else to do it.
...

Read more...

On 02/18/2009 10:38 AM, Thunderbird wrote:
> Could some people try the latest nvclock cvs? Some time ago I added
> proper smartdimmer detection but I still don't know if it works for
> everyone.

Sorry it took me so long, I've been rather busy lately. I did get to
compile the latest CVS, and while it works fine if I run it as myself
from the commandline, hald fails to run it (for my brightness keys) with
the following error:

[28671]: 14:45:47.158 [D] addon-acpi.c:195: event is 'video C160
00000086 00000000
'
14:45:47.159 [I] hald_dbus.c:5127: OK for method 'GetBrightness' with
signature '' on interface 'org.freedesktop.Hal.Device.LaptopPanel' for
UDI '/org/freedesktop/Hal/devices/computer_backlight' and execpath
'hal-system-lcd-get-brightness'
14:45:47.159 [I] hald_dbus.c:4018: no need to enqueue
14:45:47.550 [I] hald_dbus.c:4042: No more methods in queue
14:45:47.550 [I] hald_dbus.c:4105: failed with 'Error!' 'Smartdimmer is
only supported on certain (HP/SamsungSony/Zepto) laptops using a Geforce
6200/7x00Go/8x00Go. If you want support on your laptop contact the author.'
14:45:47.551 [I] hald_dbus.c:5127: OK for method 'SetBrightness' with
signature 'i' on interface 'org.freedesktop.Hal.Device.LaptopPanel' for
UDI '/org/freedesktop/Hal/devices/computer_backlight' and execpath
'hal-system-lcd-set-brightness'
14:45:47.551 [I] hald_dbus.c:4018: no need to enqueue
14:45:47.916 [I] hald_dbus.c:4042: No more methods in queue
14:45:47.917 [I] hald_dbus.c:4105: failed with 'Error!' 'Smartdimmer is
only supported on certain (HP/SamsungSony/Zepto) laptops using a Geforce
6200/7x00Go/8x00Go. If you want support on your laptop contact the author.'

While hald does claim to be running as root, I don't know what
privileges it runs the scripts with.

If I put the old smartdimmer 0.8b4 (without the detection logic), my
brightness keys work fine.

--
Bem Jones-Bey (<email address hidden>)

Download full text (5.2 KiB)

What is different when you run it as a user and at startup? In both
cases the nvidia drivers aren't loaded yet? You are certain that you
use the same binary in both cases?

Perhaps it failed to report bios info when running from a startup
script. Could you check if the output of 'nvclock -i' shows bios info
in both situations?

Thanks,
Roderick

Quoting Bem Jones-Bey <email address hidden>:

> On 02/18/2009 10:38 AM, Thunderbird wrote:
>> Could some people try the latest nvclock cvs? Some time ago I added
>> proper smartdimmer detection but I still don't know if it works for
>> everyone.
>
> Sorry it took me so long, I've been rather busy lately. I did get to
> compile the latest CVS, and while it works fine if I run it as myself
> from the commandline, hald fails to run it (for my brightness keys) with
> the following error:
>
> [28671]: 14:45:47.158 [D] addon-acpi.c:195: event is 'video C160
> 00000086 00000000
> '
> 14:45:47.159 [I] hald_dbus.c:5127: OK for method 'GetBrightness' with
> signature '' on interface 'org.freedesktop.Hal.Device.LaptopPanel' for
> UDI '/org/freedesktop/Hal/devices/computer_backlight' and execpath
> 'hal-system-lcd-get-brightness'
> 14:45:47.159 [I] hald_dbus.c:4018: no need to enqueue
> 14:45:47.550 [I] hald_dbus.c:4042: No more methods in queue
> 14:45:47.550 [I] hald_dbus.c:4105: failed with 'Error!' 'Smartdimmer is
> only supported on certain (HP/SamsungSony/Zepto) laptops using a Geforce
> 6200/7x00Go/8x00Go. If you want support on your laptop contact the author.'
> 14:45:47.551 [I] hald_dbus.c:5127: OK for method 'SetBrightness' with
> signature 'i' on interface 'org.freedesktop.Hal.Device.LaptopPanel' for
> UDI '/org/freedesktop/Hal/devices/computer_backlight' and execpath
> 'hal-system-lcd-set-brightness'
> 14:45:47.551 [I] hald_dbus.c:4018: no need to enqueue
> 14:45:47.916 [I] hald_dbus.c:4042: No more methods in queue
> 14:45:47.917 [I] hald_dbus.c:4105: failed with 'Error!' 'Smartdimmer is
> only supported on certain (HP/SamsungSony/Zepto) laptops using a Geforce
> 6200/7x00Go/8x00Go. If you want support on your laptop contact the author.'
>
> While hald does claim to be running as root, I don't know what
> privileges it runs the scripts with.
>
> If I put the old smartdimmer 0.8b4 (without the detection logic), my
> brightness keys work fine.
>
> --
> Bem Jones-Bey (<email address hidden>)
>
> --
> No Screen Backlight Control; Notebooks (Vaio, Macbook, HP/Compaq,
> Samsung, Zepto et al.) with Nvidia Geforce8/Geforce9/Quadro series
> graphics
> https://bugs.launchpad.net/bugs/95444
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Hardware Abstraction Layer (HAL): Invalid
> Status in “hal” source package in Ubuntu: Invalid
> Status in “hotkey-setup” source package in Ubuntu: Invalid
> Status in “linux” source package in Ubuntu: New
> Status in “nvclock” source package in Ubuntu: New
> Status in “nvidia-graphics-drivers-180” source package in Ubuntu: New
>
> Bug description:
> Using Ubuntu on laptops with Nvidia Geforce8/Geforce9/Quadro vga card:
>
> On various laptops from Sony, HP, Samsung and others there is no way
> to control backlight b...

Read more...

On 02/22/2009 01:53 AM, Thunderbird wrote:
> What is different when you run it as a user and at startup? In both
> cases the nvidia drivers aren't loaded yet? You are certain that you
> use the same binary in both cases?

I think you misunderstand: smartdimmer gives me that error every time
hald tries to run it. hald runs it in response to me pressing the
brightness up and down keys.

It runs the following to set the brightness: ($value is passed into the
script)

if [ "$HAL_PROP_LAPTOP_PANEL_ACCESS_METHOD" = "nvidia8" ]; then
     smartdimmer -s $((($value +1)*5))
     exit 0
fi

And it runs the following to get the brightness:

if [ "$HAL_PROP_LAPTOP_PANEL_ACCESS_METHOD" = "nvidia8" ]; then
     value=$((`smartdimmer -g | awk '{print $3;}'`))
     value=$((($value /5)-1))
     exit ${value}
fi

I am sure that it is running the same binary there that I am running by
hand, as the only smartdimmer on my system is /usr/bin/smartdimmer, and
it reliably stops working when I copy in the new binary, and works again
when I copy in the old one. Both binaries work fine from the command
line. I just checked, and hald seems to be running the script as root
(according to 'id' and 'whoami'), so I'm completely not sure why I'm
seeing different behavior.

In all these cases, X is up and running with the nvidia drivers.

>
> Perhaps it failed to report bios info when running from a startup
> script. Could you check if the output of 'nvclock -i' shows bios info
> in both situations?

Here's nvclock -i run from a gnome-terminal, as my normal user:
-- General info --
Card: nVidia QuadroFX 570M
Architecture: G84 A2
PCI id: 0x40c
GPU clock: 182.248 MHz
Bustype: PCI-Express

-- Shader info --
Clock: 594.000 MHz
Stream units: 32 (11b)
ROP units: 8 (11b)
-- Memory info --
Amount: 256 MB
Type: 128 bit DDR3
Clock: 601.712 MHz

-- PCI-Express info --
Current Rate: 16X
Maximum rate: 16X

-- Smartdimmer info --
Backlight level: 85%

-- Sensor info --
Sensor: GPU Internal Sensor
GPU temperature: 68C

-- VideoBios information --
Version: 60.84.56.01.02
Signon message: HP VB10 Mobile NB8P-GLM VGA BIOS
Performance level 0: gpu 275MHz/shader 550MHz/memory 301MHz/1.15V/100%
Performance level 1: gpu 475MHz/shader 950MHz/memory 702MHz/1.20V/100%
VID mask: 3
Voltage level 0: 1.15V, VID: 3
Voltage level 1: 1.20V, VID: 3

And here's what it looks like when HAL runs it:

-- General info --
Card: nVidia QuadroFX 570M
Architecture: G84 A2
PCI id: 0x40c
GPU clock: 182.248 MHz
Bustype: PCI-Express

-- Shader info --
Clock: 594.000 MHz
Stream units: 32 (11b)
ROP units: 8 (11b)
-- Memory info --
Amount: 256 MB
Type: 128 bit DDR3
Clock: 601.712 MHz

-- PCI-Express info --
Current Rate: 16X
Maximum rate: 16X

-- Sensor info --
Sensor: GPU Internal Sensor
GPU temperature: 71C

It does indeed look like it's missing BIOS info. Interestingly enough, I
get the same behavior if I use the 0.8b4 version of nvclock, but its
smartdimmer works from hald because it ignores the fact that it can't
look it up.

--
Bem Jones-Bey (<email address hidden>)

Download full text (6.3 KiB)

There must be a bug somewhere in my bios dumping code. I'll take a
look at it. Note smartdimmer and nvclock are internally the same. Only
from the outside smartdimmer looks different.

Roderick

Quoting Bem Jones-Bey <email address hidden>:

> On 02/22/2009 01:53 AM, Thunderbird wrote:
>> What is different when you run it as a user and at startup? In both
>> cases the nvidia drivers aren't loaded yet? You are certain that you
>> use the same binary in both cases?
>
> I think you misunderstand: smartdimmer gives me that error every time
> hald tries to run it. hald runs it in response to me pressing the
> brightness up and down keys.
>
> It runs the following to set the brightness: ($value is passed into the
> script)
>
> if [ "$HAL_PROP_LAPTOP_PANEL_ACCESS_METHOD" = "nvidia8" ]; then
> smartdimmer -s $((($value +1)*5))
> exit 0
> fi
>
> And it runs the following to get the brightness:
>
> if [ "$HAL_PROP_LAPTOP_PANEL_ACCESS_METHOD" = "nvidia8" ]; then
> value=$((`smartdimmer -g | awk '{print $3;}'`))
> value=$((($value /5)-1))
> exit ${value}
> fi
>
> I am sure that it is running the same binary there that I am running by
> hand, as the only smartdimmer on my system is /usr/bin/smartdimmer, and
> it reliably stops working when I copy in the new binary, and works again
> when I copy in the old one. Both binaries work fine from the command
> line. I just checked, and hald seems to be running the script as root
> (according to 'id' and 'whoami'), so I'm completely not sure why I'm
> seeing different behavior.
>
> In all these cases, X is up and running with the nvidia drivers.
>
>>
>> Perhaps it failed to report bios info when running from a startup
>> script. Could you check if the output of 'nvclock -i' shows bios info
>> in both situations?
>
> Here's nvclock -i run from a gnome-terminal, as my normal user:
> -- General info --
> Card: nVidia QuadroFX 570M
> Architecture: G84 A2
> PCI id: 0x40c
> GPU clock: 182.248 MHz
> Bustype: PCI-Express
>
> -- Shader info --
> Clock: 594.000 MHz
> Stream units: 32 (11b)
> ROP units: 8 (11b)
> -- Memory info --
> Amount: 256 MB
> Type: 128 bit DDR3
> Clock: 601.712 MHz
>
> -- PCI-Express info --
> Current Rate: 16X
> Maximum rate: 16X
>
> -- Smartdimmer info --
> Backlight level: 85%
>
> -- Sensor info --
> Sensor: GPU Internal Sensor
> GPU temperature: 68C
>
> -- VideoBios information --
> Version: 60.84.56.01.02
> Signon message: HP VB10 Mobile NB8P-GLM VGA BIOS
> Performance level 0: gpu 275MHz/shader 550MHz/memory 301MHz/1.15V/100%
> Performance level 1: gpu 475MHz/shader 950MHz/memory 702MHz/1.20V/100%
> VID mask: 3
> Voltage level 0: 1.15V, VID: 3
> Voltage level 1: 1.20V, VID: 3
>
> And here's what it looks like when HAL runs it:
>
> -- General info --
> Card: nVidia QuadroFX 570M
> Architecture: G84 A2
> PCI id: 0x40c
> GPU clock: 182.248 MHz
> Bustype: PCI-Express
>
> -- Shader info --
> Clock: 594.000 MHz
> Stream units: 32 (11b)
> ROP units: 8 (11b)
> -- Memory info --
> Amount: 256 MB
> Type: 128 bit DDR3
> Clock: 601.712 MHz
>
> -- PCI-Express info --
> Current Rate: 16X
> Maximum rate: 16X
>
> -- Sensor info --
> Sensor: GPU Internal Sensor...

Read more...

Schmirrwurst (schmirrwurst) wrote :

For me on FZ21E, nvclock command line seems to work, see log file...

Schmirrwurst (schmirrwurst) wrote :

FN keys are still working only after /etc/acpid restart, I don't know why, and could not find any infos in the logs...
Do the changes in the latest nvclock cvs are supposed to solve fnkeys pb ?

Changed in linux:
status: New → Confirmed
Changed in nvclock:
status: New → Confirmed
Changed in nvidia-graphics-drivers-180:
status: New → Confirmed
Bryce Harrington (bryce) wrote :

This seems to be an nvclock issue rather than -nvidia. Even if it was an -nvidia issue, it is not likely anything could be done about it since it's a proprietary binary driver. Dropping task.

Changed in nvidia-graphics-drivers-180:
status: Confirmed → Invalid
Schmirrwurst (schmirrwurst) wrote :

I think if we need nvclock to manage brightness to work with nvidia cards, then nvclock should be at least added to depedency from nvidia-driver, so that the average user, have it work directly... ?

Schmirrwurst, if in Ubuntu scripts add support for this laptops yes, is
possible add the actually partial solution for the next release? I know that
isn't the best way to do it, but is better than nothing in this moment.

My scripts added in comments works, only need add support for all laptops
listed on this thread, maybe can need add a new model of laptop that isn't
when I do the script.
My script only copy a modifieds fdi file for add support for laptops
affecteds withs this problem.

By §h@wæ
http://www.islatux.es

2009/3/13 Schmirrwurst <email address hidden>

> I think if we need nvclock to manage brightness to work with nvidia
> cards, then nvclock should be at least added to depedency from nvidia-
> driver, so that the average user, have it work directly... ?
>
> --
> No Screen Backlight Control; Notebooks (Vaio, Macbook, HP/Compaq, Samsung,
> Zepto et al.) with Nvidia Geforce8/Geforce9/Quadro series graphics
> https://bugs.launchpad.net/bugs/95444
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Schmirrwurst (schmirrwurst) wrote :

shawe, are your changed on fdi related with acpi ?

Do you know why there no more sony scripts on jaunty for now ?

Is someone able here to release the b4 version from nvclock, I'm afraid that jaunty will come out with the b3 version which is not working with gforce 8/9 card...that would make more complicated for normal user to use a workaround...
I've already proposed a nvclock package, and I've now find out, nvclock b4 has already been released for debian sid :
http://packages.debian.org/fr/sid/nvclock, how can we do to have it also for jaunty ?

Shawe Ewahs (shawe-ewahs) wrote :

Schmirrwurst why no more sony scripts on jaunty? It's the way that partial
works in this moment without big problems.
nvclock b4 works well without this scripts? I can't tested in this moment, I
haven't got my laptop.

By §h@wæ
http://www.islatux.es

2009/3/14 Schmirrwurst <email address hidden>

> shawe, are your changed on fdi related with acpi ?
>
> Do you know why there no more sony scripts on jaunty for now ?
>
> Is someone able here to release the b4 version from nvclock, I'm afraid
> that jaunty will come out with the b3 version which is not working with
> gforce 8/9 card...that would make more complicated for normal user to use a
> workaround...
> I've already proposed a nvclock package, and I've now find out, nvclock b4
> has already been released for debian sid :
> http://packages.debian.org/fr/sid/nvclock, how can we do to have it also
> for jaunty ?
>
> --
> No Screen Backlight Control; Notebooks (Vaio, Macbook, HP/Compaq, Samsung,
> Zepto et al.) with Nvidia Geforce8/Geforce9/Quadro series graphics
> https://bugs.launchpad.net/bugs/95444
> You received this bug notification because you are a direct subscriber
> of the bug.
>

for the moment there are no more "sonybright.sh" and other file related to sony/nvidia in the acpi folder, they have been removed on jaunty, and I'm wondering that one month for release, there is still nothing in vue ! So I asked you if you know if something is in progress... It would be very bad, if jaunty comes out without any acpi support for gforce users !

Schmirrwurst I only know that appears on this thread, some users send his
graphic card info for try to found a common value for recognize it, but it
hasn't any result for the moment.

By §h@wæ
http://www.islatux.es

2009/3/14 Schmirrwurst <email address hidden>

> for the moment there are no more "sonybright.sh" and other file related
> to sony/nvidia in the acpi folder, they have been removed on jaunty, and
> I'm wondering that one month for release, there is still nothing in vue
> ! So I asked you if you know if something is in progress... It would be
> very bad, if jaunty comes out without any acpi support for gforce users
> !
>
> --
> No Screen Backlight Control; Notebooks (Vaio, Macbook, HP/Compaq, Samsung,
> Zepto et al.) with Nvidia Geforce8/Geforce9/Quadro series graphics
> https://bugs.launchpad.net/bugs/95444
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Steve Langasek (vorlon) wrote :

The sony scripts were dropped from acpi-support because based on testing, these events were believed to now be handled in the kernel input layer. If your brightness hotkeys on sony work when you downgrade to the intrepid version of acpi-support, but stop working when upgrading to the jaunty version, then please open a new bug report against acpi-support with information about your model and include the output of both 'showkeys' and 'acpi_listen' when pressing these keys.

If it's a bug, it's an entirely separate bug from the one this bug report is about, so closing the acpi-support task.

Changed in acpi-support:
status: New → Invalid
Schmirrwurst (schmirrwurst) wrote :

as suggested from steve, I've opened a new but concerning acpi-support :
https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/345531

Maybe you can confirm that bug, so that acpi-support team can work on it as quick as possible...

Steve Langasek (vorlon) wrote :

Nominally, this bug can be fixed with a trivial merge of nvclock 0.8b4 from Debian. I've attached the (filtered for autogenerated content) debdiff for this relative to the version currently in jaunty.

There are some practical issues with doing this merge right now, though:
- The reason the new version of nvclock fixes this bug is specifically because it begins to ship smartdimmer, which was previously in a separate package; I understand that the nvclock smartdimmer fixes the issue for GeForce8/9, but I don't know what the risk of regression is for other hardware supported by the previous package, which we will now be Conflicting/Replacing/Providing.
- I have no hardware on which I can test this package.
- We have to replace the current 'smartdimmer' package in main with the new one from nvclock, which requires a review by the ubuntu-mir team. Initial response from the ubuntu-mir team is that they would like to see the Debian merge done first, and only afterwards evaluate it for inclusion in main.

I'm subscribing motu-release for a second opinion on whether this is ok to upload for jaunty. It would be nice to close out this long-standing bug, I just don't know that the risk of regression is appropriate at this point in the release cycle.

Schmirrwurst (schmirrwurst) wrote :

Steve you said "Initial response from the ubuntu-mir team is that they would like to see the Debian merge done first, and only afterwards evaluate it for inclusion in main", I don't know if i've understand this, but I found out Debian has already packaged nvclock b4 for sid : http://packages.debian.org/fr/sid/x11/nvclock

StefanPotyra (sistpoty) wrote :

Steve, I think if you intent to include it into main, I guess ubuntu-release should handle this instead of motu-release.

Personally, I'd be in favor for better hardware support.

The diff doesn't look too big, but it sadly also doesn't give me any info about possible regressions (dealing with hardware without docs is a little bit opaque). *shrug*

description: updated

On Sun, Mar 22, 2009 at 11:29:34PM -0000, StefanPotyra wrote:
> Steve, I think if you intent to include it into main, I guess ubuntu-
> release should handle this instead of motu-release.

Well, that can be done of course, but since the first step is to get a
universe-only update in, I figured I would ask motu-release. :)

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Martin Pitt (pitti) wrote :

I reviewed the merge. While you are at cleaning up the package anyway, you should also drop the Encoding= line from the .desktop file (these are obsolete).

Otherwise the merge looks alright to me.

description: updated
Steve Langasek (vorlon) wrote :

punted on the Encoding= issue because the .desktop file isn't shipped in the package.

Changed in nvclock:
assignee: nobody → vorlon

It is fixed yer for Ubuntu Jaunty:

https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/277589/comments/38

By §h@wæ
http://www.islatux.es

2009/3/23 Steve Langasek <email address hidden>

> punted on the Encoding= issue because the .desktop file isn't shipped in
> the package.
>
> ** Changed in: nvclock (Ubuntu)
> Assignee: (unassigned) => Steve Langasek (vorlon)
>
> --
> No Screen Backlight Control; Notebooks (Vaio, Macbook, HP/Compaq, Samsung,
> Zepto et al.) with Nvidia Geforce8/Geforce9/Quadro series graphics
> https://bugs.launchpad.net/bugs/95444
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Steve Langasek (vorlon) on 2009-03-26
Changed in nvclock:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvclock - 0.8b4-1ubuntu2

---------------
nvclock (0.8b4-1ubuntu2) jaunty; urgency=low

  * Take over the smartdimmer binary package, shipping only the
    smartdimmer tool. LP: #347813, #95444.

 -- Steve Langasek <email address hidden> Thu, 26 Mar 2009 00:01:09 +0000

Changed in nvclock:
status: In Progress → Fix Released
Thomas Lété (bistory) wrote :

This bug isn't fixed for me, hal recommends smartdimmer (>= 0.8b4) but it's wrong...
It must recommend nvclock (>= 0.8b4) instead of smartdimmer. I think it's a mistake :)
But nvclock from ubuntu isn't provided with the smartdimmer command... nvclock should superseed smartdimmer (which is now legacy).

Thomas Lété (bistory) wrote :

Just ignore my message, the smartdimmer utility has been updated recently, my apologises
My hotkeys aren't recognized by gnome...

Invalidating against package "linux" because this has been fixed in package "nvclock".

Changed in linux (Ubuntu):
status: Confirmed → Invalid
sijk (simo-kivimaki-fi) wrote :

I updated nVidia proprietary driver to version 185.18.36 and now backlight brightness control works. I suppose that the new driver listens backlight ACPI events properly.

Setup:
Ubuntu Jaunty
HP 8530w
nVidia Quadro FX 770M

Schmirrwurst (schmirrwurst) wrote :

Could you post the output from :
ls /sys/class/backlight/
and
ls /proc/acpi/video/
?

sijk (simo-kivimaki-fi) wrote :

$ ls /sys/class/backlight/
acpi_video0

$ ls /proc/acpi/video/
DGFX

Not working with sony vaio VPCZ1, with an nvidia GT 330M graphics card

~/local/nvclock$ sudo /usr/local/bin/nvclock -f -S 15
Unable to shadow the video bios
Error!
Smartdimmer is only supported on certain (HP/Samsung/Sony/Zepto) laptops using a Geforce 6200/7x00Go/8x00Go. If you want support on your laptop contact the author.

ibo (ibrahimkarahan) wrote :

Please see http://www.nvnews.net/vbulletin/showthread.php?t=143025 for a working driver on some laptops.

andy langer (lian240409) on 2012-04-08
Changed in nvclock (Ubuntu):
assignee: Steve Langasek (vorlon) → andy langer (lian240409)
asino89 (asino89) wrote :

After latest updates to nvidia driver, the backlight control isn't working.
I was using the modified nvclock (procedure suggested for this bug).
Does anyone have the same troubles?

asino89 (asino89) wrote :

I'll better explain my troubles.

When I try to use nvclock (eg I launch "sudo nvclock -S 50") i get a "Segmentation fault".
I'm sure this problem came out after the updates to my nvidia graphic card drivers, that I did (through update manager) on 2012-04-12.

I've tried even drivers #173, but it isn't working all the same.

I've tried to reinstall nvclock (even on a brand new installation of ubuntu), but when I launch "make" i get an error like this: "undefined reference to `XextFindDisplay'".

I have no ideas of why this is happening!
Any help will be appreciated!

TJ (tj) wrote :

The SIGSEGV is being tracked in bug #1039916 "Nvidia driver causing SIGSEGV in nvclock and smartdimmer".

That bug affects the "Fix released" status of this bug since this work-around no longer functions. I've nominated this bug for Precise and Quantal, but any fix of the SIGSEGV issue will be done in bug #1039916.

Displaying first 40 and last 40 comments. View all 267 comments or add a comment.