Ubuntu

[Asus eeepc 1225B] Suspend and hibernate not working

Reported by xapantu on 2012-03-09
124
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Medium
AceLan Kao

Bug Description

Steps to reproduce:
- try to enter suspend/hibernate mode

Expected result:
- The system enters sleep mode and upon pressing the power switch, resumes successfully

Actual result:
- The system fails to enter sleep mode: the power button stays blue (it should alternate off/blue)
- I can't re-launch the computer, I have to force the computer to shutdown (by pressing the power button a few seconds) and reboot.

I don't know if I can provide more useful logs, if yes, just tell me and I will post them.

It happens in oneiric, and precise with the last updates.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-18-generic 3.2.0-18.28
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94-0ubuntu2
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: xapantu 1657 F.... pulseaudio
 /dev/snd/controlC0: xapantu 1657 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0xfeb44000 irq 45'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'SB'/'HDA ATI SB at 0xfeb40000 irq 16'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,1043103b,00100100'
   Controls : 16
   Simple ctrls : 9
Date: Fri Mar 9 22:01:19 2012
HibernationDevice: RESUME=UUID=4e170104-16c5-4039-b668-29b18de63bc1
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: ASUSTeK Computer Inc. 1225B
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=f133f01b-5d96-47fc-8a26-137ae06fb235 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-18-generic N/A
 linux-backports-modules-3.2.0-18-generic N/A
 linux-firmware 1.71
SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2012-02-18 (20 days ago)
dmi.bios.date: 12/14/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 204
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: 1225B
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 204
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr204:bd12/14/2011:svnASUSTeKComputerInc.:pn1225B:pvr1.0:rvnASUSTeKComputerInc.:rn1225B:rvr204:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: 1225B
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

xapantu (xapantu) wrote :
Brad Figg (brad-figg) on 2012-03-09
Changed in linux (Ubuntu):
status: New → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.29
xapantu (xapantu) on 2012-03-10
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc7-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
bmjbmj (bmjbmj) wrote :

I have the same problem in 11.10. Kernel 3.0.0-16. The screen blanks to black, fan continues to spin and HD is active minutes (and hours) after the lid is closed. The screen remains black when the lid is reopened and the only possible way to recover is a hard shutdown.

WR// B Mathias Johansson

xapantu (xapantu) on 2012-03-14
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

i have ubuntu 12.04 and suspend and hibernate not work on my eeepc 1225b.
not good!

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-19.30
xapantu (xapantu) on 2012-03-18
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Triaged
b3nn0 (agib) wrote :

For the record:
I've submitted this bug upstream with another eee pc (r252b) which is also affected, but seems to be equal to your 1225B (same Mainboard).

https://bugzilla.kernel.org/show_bug.cgi?id=43129

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Inakrin (inakrin) wrote :

Lubuntu 12.04-beta2 affected also :(

Tomofumi (tomofumi) wrote :

I have this problem since day 1 i get this laptop...I've tried 11.10, 11.04 & 12.04 alpha/beta but all failed.
And the official release version of 12.04 LTS still failed. Using acpi_osi=Linux during boot does not help.

But after I updated the BIOS from 0204 to 0205, I don't need to remove the battery after I try to suspend the machine. That's a bit of improvement ;-)

b3nn0 (agib) wrote :

I was now able to solve the problem with a script I found on askubuntu and the kernel bugzilla. So at least the r252b can be made working completely.

In order to fix the suspend problem:
do the steps described here: http://askubuntu.com/questions/53372/suspend-hibernate-doesnt-work-on-an-asus-laptop

If you also have the problem that the computer doesn't shut down, but always reboots if you hit the shutdown button, but this command in your /etc/rc.local (the r252b has this. not sure about the 1225B although they are almost equal):
echo "LID" > /proc/acpi/wakeup
right before the "exit 0".

Pat Gauthier (patlgauthier) wrote :

I can confirm that the solution suggested by b3nn0 worked on my 1225B. Thanks for the help.

gaelfx (gaelfx) wrote :

I've had this problem ever since I installed 12.04, and I've tried b3nn0's solution, but to no avail. Both suspend and hibernate are not working and shutting down the machine always restarts it. Please help!

gaelfx (gaelfx) wrote :

Addendum: As it turns out, it seems that Fn+F1 does not work for suspending the computer, it only seems to lock it, however, leaving the computer on until the system suspends does work after b3nn0's instructions, except that the screen is completely blank when the computer resumes from suspend, so I still consider it not working. Also, the option for Hibernate is greyed out (unselectable) in system power settings.

files32 (24dima) wrote :

I confirm. On Ubuntu 12.04 does not work this script.

The script from b3nn0 works for me on an Asus 1225B with Ubuntu 12.04.

For the people who are having problems: suspend is probably working for you, but the laptop wakes up immediately after going to sleep.

I had the same problem, but found a fix:
1. Enable "wake up on lid" in BIOS
2. Disable "wake up on lid" in /proc/acpi/wakeup (I used acpitool)

Using the script and these settings, suspend works perfectly. Hibernate seems to be unavailable, but I only use suspend because it's faster.

enrico (eliboni) wrote :

b3nn0 script + sami-kankaristo suggestion to disable wake up on lid (/proc/acpi/wakeup) fixed everithing for me. For the latted I addedd in /etc/rc.local:
sudo acpitool -W 16

Shutdown, Restart, Suspend, Hibernate works perfectly both when plugged in or running on battery.

If the hibernate option is disabled/not available for you is likley because of xubuntu policies (i.e. not relatred to 1225B), check here to re-enable: https://help.ubuntu.com/12.04/ubuntu-help/power-hibernate.html

Cheers

enrico (eliboni) wrote :

An update: when awaking from hibernate, just once every 5-6 times, the keyboard/touchpad are not working. However the OS is running fine (I can login remotely via SSH). As reported above, this very same behaviour is happening as well in a normal boot/reboot.
I filed a separate bug for this one:
https://bugs.launchpad.net/ubuntu/+bug/1014240

Cheers

Mateus Araújo (iris-n) wrote :

gaelfx,

I believe I had the same problem as you, the computer resumed from suspend but did not turn on the screen. I found out the culprit was fgrlx. Disabling it and using the radeon driver instead made suspend work for me.

enrico,

Your instruction confused me a little. Adding "acpitool -W 16" into /etc/rc.local has the exact same effect as adding "echo "LID" > /proc/acpi/wakeup". Adding them both makes them cancel eachother. So I would just stick with b3nn0's suggestions, that do the trick for me.

Best,

Mateus

gaelfx (gaelfx) wrote :

Mateus,

You are correct, it is fglrx that is causing that problem. After I uninstalled fglrx, the computer could suspend/resume without a problem. Perhaps we need to inform the Catalyst people of this issue?

Mateus Araújo (iris-n) wrote :

gaelfx,

Yes, in an ideal world, we should. But somehow I doubt they'll care/do something about it.

But if you feel like it, please go ahead =)

AceLan Kao (acelankao) wrote :

xapantu,

Could you help me to verify if this kernel[1] do anything helpful to this isse?
I hard-coded the PCI id in the kernel, so it only works on your machine.
Thank you.

If anyone here would like to give it a try, please attach the result of the command "lspci -vvnn"
Thanks.

1. http://people.canonical.com/~acelan/bugs/lp951143/

AceLan Kao (acelankao) on 2012-07-03
Changed in linux (Ubuntu):
status: Triaged → Incomplete
xapantu (xapantu) wrote :

I have just tried the kernel on a live usb (I didn't have the good ubuntu version installed). It starts to suspend, but after one second or so, it wakes up. Then, / is read-only (?).

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
AceLan Kao (acelankao) wrote :

Thanks for the report.
I didn't test it on a live usb, I'll try to verify it on my machine.
Thanks.

Changed in linux (Ubuntu):
assignee: nobody → AceLan Kao (acelankao)
Alexander Fougner (fougner) wrote :

For me, this problem is solved in 3.2.0-25-generic, thanks to the EHCI Usb controller fix.

Can anyone with the suspend problem confirm if this bug is solved when running kernel 3.2.0-25-generic or later?

Zarrsh (shawncgarrett) wrote :

Its finally fixed for me, I just closed my lid and it worked! After 7 months of owning my Asus N55s its like a new laptop now. Being able to go to sleep is a game changer for me, thank you.

cat /proc/version
Linux version 3.2.0-26-generic (buildd@batsu) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012

Alexander Fougner (fougner) wrote :

I'm setting this to "fix released" because it seems to have been fixed in the new 3.2.0-25 kernel.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
tyler (utyler) wrote :

Suspend is still not working properly on this Asus 1225b with 3.2.0-26.

cat /proc/version
Linux version 3.2.0-26-generic-pae (buildd@lamiak) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #41-Ubuntu SMP Thu Jun 14 16:45:14 UTC 2012

Artuditu (artu-di-tu) wrote :

Hi, I have the same issue on my Eee PC . My proc/version result is as below 3.2.0-12 #41 Ubuntu. Do you know some work around for this problem?

Artuditu (artu-di-tu) wrote :

tyler, tnx for help.
I've found extension for Gnome3 "Alternative Status Menu " with hibernate mode and it is something like workaround. So, this suspend mode it isn't a problem for me anymore.

AceLan Kao (acelankao) wrote :

Hi all,

I just update the kernel in my directory and it should work for all machines.
http://people.canonical.com/~acelan/bugs/lp951143/

It might be the final solution for this issue discussed with upstream pci maintainer recently.
The current solution for this issue in the kernel now is not good enough and doesn't apply to all the ASUS machines.
Please give it a try and respond your result here, thanks.

Hi, I've opened bug #987056 on 2012-04-23 and was recently invited to discuss it here.
Exact hardware : Asus N55SF-S1437V.
I just tested with kernel 3.2.0-26-generic and the workaround is no longer needed, suspend just works.
Marked that bug as "fix released" and no longer affecting me.
Regards.

Tomofumi (tomofumi) wrote :

Hi all,

Just tried Acelan's kernel in my 1225B (latest BIOS 0207) without any fix or scripts in /etc/pm, here is the test results:

- first boot and login to desktop, then issue suspend (by Fn-1 Key, or Suspend at top menu), the laptop will try to suspend but wake up immediately, I can see the LCD backlight turn off and on quickly. Fortunately the system does not hang, and i can login back to the desktop from locked screen.

- then I try to issue suspend again after the 1st try, it works successfully. Further tries include Fn-1 Key, Suspend at top menu, and "sudo pm-suspend" works perfectly and resume as expected.

- then I try to close the lid, the display backlight has been turn off, but the system does not go to sleep. When i open the lid again, i can see a black screen with backlight on, click any key will show the desktop again. Try to mess with BIOS's LID settings or acpitool -W 16 still not work.

overall, this is the best experience with this eeepc laptop so far although it is still not perfect yet, thanks for this fixed kernel and looking for further updates. :)

AceLan Kao (acelankao) wrote :

Tomofumi, great!
Thanks for the testing and report.
Actually, this patch is already going into kernel 3.5-rc5 and will be in ubuntu precise kernel soon.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.