Ubuntu

External microphone does not work on Zenbook UX31

Reported by Marcus Sundman on 2012-03-09
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
David Henningsson
Precise
Medium
Unassigned

Bug Description

There is no way to switch to the external mic on an Asus Zenbook UX31, at least not with alsamixer.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94.1-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marcus 3096 F.... pulseaudio
 /dev/snd/pcmC0D0c: marcus 3096 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xdfe00000 irq 53'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,10431427,00100100 HDA:80862805,80860101,00100000'
   Controls : 19
   Simple ctrls : 9
Date: Fri Mar 9 03:49:47 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120118)
PackageArchitecture: all
PulseSinks: Error: command ['pacmd', 'list-sinks'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
PulseSources: Error: command ['pacmd', 'list-sources'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
SourcePackage: alsa-driver
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/26/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX31E.210
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX31E
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX31E.210:bd12/26/2011:svnASUSTeKComputerInc.:pnUX31E:pvr1.0:rvnASUSTeKComputerInc.:rnUX31E:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: UX31E
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Marcus Sundman (sundman) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
SorryGoFish (geoff-oxholm) wrote :

Adding `options snd-hda-intel model=laptop-dmic` to `/etc/modprobe.d/alsa-base.conf` seems to have resolved this issue for me.

David Henningsson (diwic) wrote :

Hi!

According to your BIOS, you don't have an external mic. Just to verify: This is a 4-pin headset jack, right? I e, you can use both the headphone and the mic simultaneously?

You can try enabling your external mic using the hda-jack-retask program. Install the hda-jack-retask package from https://launchpad.net/~diwic/+archive/hda and start it using the "hda-jack-retask" terminal command. Click the "show unconnected pins".

If SorryGoFish's comment is correct, the mic should be at pin 0x18. Try setting that pin to "Microphone", then apply using either method. If that pin does not work, try other unconnected pins as well.

Please report back if this resolved your problem or not. Thanks!

Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete
Marcus Sundman (sundman) wrote :

Yes, it is a 4-pin headset jack. I can use both the headphone and the mic simultaneously.

Adding the line
options snd-hda-intel model=laptop-dmic
to /etc/modprobe.d/alsa-base.conf solved the issue for me, at least partly. I now only have 1 microphone, but it auto-switches between the external one and the internal one depending on whether I have an external mic plugged in or not.

It would be nice to be able to use the internal mic sometimes even when the external one is connected, but it's also quite acceptable to have it this way.

So, do you still need me to try the hda-jack-retask thingy?

According to the reporter, external mic starts to work if the
laptop-dmic model is used. According to BIOS pin config, all
pins are consistent with the alc269vb_laptop_dmic fixup, except
for the external mic, which is not present.

Cc: <email address hidden>
BugLink: https://bugs.launchpad.net/bugs/950490
Signed-off-by: David Henningsson <email address hidden>
---
 sound/pci/hda/patch_realtek.c | 1 +
 1 file changed, 1 insertion(+)

diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index e65e354..818f90b 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -6109,6 +6109,7 @@ static const struct alc_fixup alc269_fixups[] = {

 static const struct snd_pci_quirk alc269_fixup_tbl[] = {
  SND_PCI_QUIRK(0x103c, 0x1586, "HP", ALC269_FIXUP_MIC2_MUTE_LED),
+ SND_PCI_QUIRK(0x1043, 0x1427, "Asus Zenbook UX31E", ALC269VB_FIXUP_DMIC),
  SND_PCI_QUIRK(0x1043, 0x1a13, "Asus G73Jw", ALC269_FIXUP_ASUS_G73JW),
  SND_PCI_QUIRK(0x1043, 0x16e3, "ASUS UX50", ALC269_FIXUP_STEREO_DMIC),
  SND_PCI_QUIRK(0x1043, 0x831a, "ASUS P901", ALC269_FIXUP_STEREO_DMIC),
--
1.7.9.5

Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Incomplete → In Progress
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
David Henningsson (diwic) wrote :

As for the autoswitch between mic inputs, that seems to be what most people expect to happen. I've sent a patch upstream now, if it is committed you can try it out in a day or two using the https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS procedure - it essentially does the same thing as setting the model to laptop-dmic.

Changed in linux (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.4.0-1.1

---------------
linux (3.4.0-1.1) quantal; urgency=low

  [ Andy Whitcroft ]

  * ubuntu: overlayfs -- overlayfs: apply device cgroup and security
    permissions to overlay files
    - LP: #915941, #918212
    - CVE-2012-0055

  [ Leann Ogasawara ]

  * Open Q
  * Rebase to v3.4-rc5
  * [Config] Temporarily disable CONFIG_TOUCHSCREEN_EETI on arm
  * [Config] Temporarily disable CONFIG_TOUCHSCREEN_EGALAX on arm
  * [Config] Temporarily disable CONFIG_EZX_PCAP on arm
  * [Config] Temporarily disable CONFIG_MFD_OMAP_USB_HOST on arm
  * [Config] Temporarily disable CONFIG_LIS3L02DQ on arm
  * [Config] Temporarily disable CONFIG_USB_EHCI_HCD_PLATFORM on arm
  * [Config] Temporarily disable CONFIG_TI_CPSW on arm
  * [Config] Temporarily disable CONFIG_AX88796 on arm

  [ Upstream Kernel Changes ]

  * vfs: pass struct path to __dentry_open()
  * vfs: add i_op->open()
  * vfs: export do_splice_direct() to modules
  * vfs: introduce clone_private_mount()
  * overlay filesystem
  * overlayfs: add statfs support
  * overlayfs: implement show_options
  * overlay: overlay filesystem documentation
  * fs: limit filesystem stacking depth
  * overlayfs: follow header cleanup
  * overlayfs: switch from d_alloc_root() to d_make_root()
  * overlayfs: update touch_atime() usage
  * rebase to v3.4-rc5
    - LP: #950490
  * rebase to v3.4-rc4
  * rebase to v3.4-rc3
  * rebase to v3.4-rc2
  * rebase to v3.4-rc1
  * rebase to v3.3
  * rebase to v3.3-rc7
  * rebase to v3.3-rc6
  * rebase to v3.3-rc5
  * rebase to v3.3-rc4
    - LP: #900802
    - LP: #930842
  * rebase to v3.3-rc3
    - LP: #924320
    - LP: #923316
    - LP: #923409
    - LP: #918254
  * rebase to v3.3-rc2
  * rebase to v3.3-rc1
    - LP: #795823
    - LP: #909419
    - LP: #910792
    - LP: #878701
    - LP: #724831
 -- Leann Ogasawara <email address hidden> Wed, 25 Jan 2012 06:50:04 -0800

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Colin Watson (cjwatson) on 2012-05-25
Changed in linux (Ubuntu Precise):
status: New → In Progress
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for precise in -proposed solves the problem (3.2.0-25.40). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Luis Henriques (henrix) wrote :

Tagging as verified as the patch is already on stable.

tags: added: verification-done-precise
removed: verification-needed-precise
Launchpad Janitor (janitor) wrote :
Download full text (21.0 KiB)

This bug was fixed in the package linux - 3.2.0-25.40

---------------
linux (3.2.0-25.40) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1003534

  [ Andy Whitcroft ]

  * [Config] control.stub is an intermediate product not a dependancy
    - LP: #992414
  * [Config] include include/generated/compile.h
    - LP: #942569

  [ Dave Martin ]

  * SAUCE: rtc: pl031: Enable module alias autogeneration for AMBA drivers
    - LP: #1000831

  [ Herton Ronaldo Krzesinski ]

  * Revert "SAUCE: ite-cir: postpone ISR registration"
    - LP: #1002484
  * SAUCE: async_populate_rootfs: fix build warnings
    - LP: #1003417

  [ Ike Panhc ]

  * [Config] add highbank flavour
    - LP: #1000831

  [ John Johansen ]

  * SAUCE: apparmor: fix long path failure due to disconnected path
    - LP: #955892
  * SAUCE: apparmor: fix profile lookup for unconfined
    - LP: #978038, #987371

  [ Mark Langsdorf ]

  * SAUCE: arm highbank: add support for pl320-ipc driver
    - LP: #1000831

  [ Rob Herring ]

  * SAUCE: input: add a key driver for highbank
    - LP: #1000831
  * SAUCE: ARM: highbank: Add smc calls to enable/disable the L2
    - LP: #1000831
  * SAUCE: force DMA buffers to non-bufferable on highbank
    - LP: #1000831
  * SAUCE: net: calxedaxgmac: fix net timeout recovery
    - LP: #1000831

  [ Tim Gardner ]

  * [Config] perarch and indep tools builds need separate build directories
  * [Config] CONFIG_XEN_ACPI_PROCESSOR=y
    - LP: #898112

  [ Upstream Kernel Changes ]

  * Revert "autofs: work around unhappy compat problem on x86-64"
    - LP: #1002482
  * Input: wacom - cleanup feature report for bamboos
    - LP: #568064
  * Input: wacom - remove unused bamboo HID parsing
    - LP: #568064
  * Input: wacom - add some comments to wacom_parse_hid
    - LP: #568064
  * Input: wacom - relax Bamboo stylus ID check
    - LP: #568064
  * Input: wacom - read 3rd gen Bamboo Touch HID data
    - LP: #568064
  * Input: wacom - 3rd gen Bamboo P&Touch packet support
    - LP: #568064
  * Input: wacom - ignore unwanted bamboo packets
    - LP: #568064
  * HID: wacom: Move parsing to a separate function
    - LP: #568064
  * HID: wacom: Initial driver for Wacom Intuos4 Wireless (Bluetooth)
    - LP: #568064
  * Input: wacom - add support for Cintiq 24HD
    - LP: #568064
  * Input: wacom - add LED support for Cintiq 24HD
    - LP: #568064
  * Input: wacom - add missing LEDS_CLASS to Kconfig
    - LP: #568064
  * Input: wacom - fix 3rd-gen Bamboo MT when 4+ fingers are in use
    - LP: #568064
  * power_supply: allow a power supply to explicitly point to powered
    device
    - LP: #568064
  * power_supply: add "powers" links to self-powered HID devices
    - LP: #568064
  * HID: wiimote: fix invalid power_supply_powers call
    - LP: #568064
  * HID: wacom: Fix invalid power_supply_powers calls
    - LP: #568064
  * ARM: 7178/1: fault.c: Port OOM changes into do_page_fault
    - LP: #951043
  * ARM: 7368/1: fault.c: correct how the tsk->[maj|min]_flt gets
    incremented
    - LP: #951043
  * hugepages: fix use after free bug in "quota" handling
    - LP: #990368
    - CVE-2012-2133
  * provide disable_cpufreq() functio...

Changed in linux (Ubuntu Precise):
status: In Progress → Fix Released
Marco Ribaric (blueicecream88) wrote :

Hello. So i bought a Asus UX31E and discovered the external microphone bug pretty fast.

I Googled and i found this page.

I am searching and searching but can not find this location on my computer. I am running Windows.
Those guys in comment 3 & 5 says that this will hep my problem.

/etc/modprobe.d/alsa-base.conf

Could you guys please somehow point me the right way?
I registered just so i could contact you :)

Thank you

Marcus Sundman (sundman) wrote :

This is Ubuntu Linux. It has nothing to do with Windows. In Windows there are completely different drivers than in Linux.

If you use windows you have to download the newest drivers from Asus' support website.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Xavier (fxb9500) wrote :

On 12.10 with up-to-date (as of 3/03/13) packages, my external microphone still does not work on the UX31E. The internal microphone is disabled when I plug in my headset, but I get no from the mic.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers