3.2.0-18-generic: Broadcom BCM4306 Wireless (rev 03) [14e4:4320]: Network links are *never* ready

Bug #947751 reported by Stenten on 2012-03-06
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
High
Unassigned

Bug Description

I just upgraded to 3.2.0-18-generic and now both wired and wireless networks are down. Network Manager just says Wired and Wireless are both "disconnected". Choosing the 3.2.0-17-generic kernel in GRUB fixes the problem.

I have the same problem in Arch Linux on this computer, and I've narrowed it down to the 3.2.9 kernel, since Arch's 3.2.8 kernel still works.

The Arch bug report can be found at:
bugs.archlinux.org/task/28784

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-18-generic 3.2.0-18.28
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94-0ubuntu1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: steven 1475 F.... lxpanel
Card0.Amixer.info:
 Card hw:0 'I82801DBICH4'/'Intel 82801DB-ICH4 with STAC9750,51 at irq 5'
   Mixer name : 'SigmaTel STAC9750,51'
   Components : 'AC97a:83847650'
   Controls : 36
   Simple ctrls : 23
CurrentDmesg:

Date: Tue Mar 6 00:30:34 2012
HibernationDevice: RESUME=UUID=201bb5f2-1371-4eea-88bd-6204b063567d
InstallationMedia: Lubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Dell Inc. Latitude D505
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 TERM=xterm
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=8529318e-641a-4f61-9a41-53271f813278 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-18-generic N/A
 linux-backports-modules-3.2.0-18-generic N/A
 linux-firmware 1.71
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2012-03-03 (2 days ago)
dmi.bios.date: 11/03/2006
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0H2049
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd11/03/2006:svnDellInc.:pnLatitudeD505:pvr:rvnDellInc.:rn0H2049:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D505
dmi.sys.vendor: Dell Inc.

Stenten (stenten) wrote :
Stenten (stenten) wrote :

/var/log/kern.log.

Most recent is the broken -18 kernel, second most recent is -17, third -18 again.

Stenten (stenten) wrote :

/var/log/syslog.

Most recent is broken -18 kernel, second most recent is -17, third most recent is broken -18.

Brad Figg (brad-figg) on 2012-03-06
Changed in linux (Ubuntu):
status: New → Confirmed
Stenten (stenten) on 2012-03-06
description: updated
Joseph Salisbury (jsalisbury) wrote :

I'd like to perform a kernel bisect to narrow down the issue. Would you be able to try some test kernels?

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: regression-update
tags: added: kernel-da-key
Changed in linux (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Confirmed
Stenten (stenten) wrote :

That would be wonderful, Joseph. I was about to ask the kernel team for some help bisecting it, but it looks like you're one step ahead :)

I just tested the Ubuntu mainline 3.2.8 [1] and 3.2.9 [2] kernels to double check, and the bug is still present (3.2.8 works, 3.2.9 does not).

And a note before you compile anything: my processor does not support PAE.

[1]: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.8-precise/
[2]: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.9-precise/

Joseph Salisbury (jsalisbury) wrote :

I have a test kernel building now. It is a bisect between 3.2.8 and 3.2.9. The commit halfway between these version is:
4cc383ba35be70d24fb7d43dd67f15f6ec3c7ebc

Joseph Salisbury (jsalisbury) wrote :

I created a set of test kernels, which are available at:
http://people.canonical.com/~jsalisbury/lp947751/

This test kernel is built up to commit 4cc383ba35be70d24fb7d43dd67f15f6ec3c7ebc

Can you test this kernel and report back if it exhibits the bug or not?

Stenten (stenten) wrote :

This kernel is good (I have networking with it).

Joseph Salisbury (jsalisbury) wrote :

Thanks. I'll mark that commit as good and kick off the next kernel build.

Joseph Salisbury (jsalisbury) wrote :

I created another set of test kernels, which are available at:
http://people.canonical.com/~jsalisbury/lp947751/

This test kernel is built up to commit 758e4d3da5bc2a30a7618cb8f1710e096dac0e53

Can you test this kernel and report back if it exhibits the bug or not?

Stenten (stenten) wrote :

Latest kernel is still good (the bug is not present).

digger (digger90) wrote :

Hey, i have a big problem with 3.2.0-18 kernel - kernel panic. Could you please give me some advice how to properly make a bug report with all necessary information about this problem? Now i'm back at -17.

Thanks

Joseph Salisbury (jsalisbury) wrote :

@digger

To open a new kernel bug, please run the command:
ubuntu-bug linux

This is a wiki with additional information at:
https://help.ubuntu.com/community/ReportingBugs

Joseph Salisbury (jsalisbury) wrote :

@Stenten

Thanks for testing. I'll update the bisect and build a new test kernel.

Joseph Salisbury (jsalisbury) wrote :

I created another set of test kernels, which are available at:
http://people.canonical.com/~jsalisbury/lp947751/

This test kernel is built up to commit df9a5f8f94f3276aaa8c960a46f6838f7fdab974

Can you test this kernel and report back if it exhibits the bug or not?

Stenten (stenten) wrote :

Latest kernel is bad (no networking).

Joseph Salisbury (jsalisbury) wrote :

I created another set of test kernels, which are available at:
http://people.canonical.com/~jsalisbury/lp947751/

This test kernel is built up to commit 37ef0e621b065f2d9e1c37ff42a37d6bd74bf039

Can you test this kernel and report back if it exhibits the bug or not?

Stenten (stenten) wrote :

Latest kernel is bad (no networking).

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.29
Stenten (stenten) on 2012-03-10
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: bot-stop-nagging
removed: kernel-request-3.2.0-18.29
Joseph Salisbury (jsalisbury) wrote :

Thanks Stenten,

I have another test kernel building. It is up to commit: 72633f08ad74b93530b8e038041c450492a00ed5

This should be one of the last test kernels until we know the bad commit.

Phillip Wood (phillip-wood) wrote :

Joseph, I'm another arch linux user suffering from this bug, I just found this report on google, it's great that you're working on it. For future reference this bug is reported upstream at https://bugzilla.kernel.org/show_bug.cgi?id=42896

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Hi Stenten,

I was wondering if you were able to test the latest test kernel?

Joseph Salisbury (jsalisbury) wrote :

Thanks for the information, Phillip.

Stenten (stenten) wrote :

Joseph,

You haven't uploaded the new kernel yet; it's still the old one from March 9th :)

Joseph Salisbury (jsalisbury) wrote :

Stenten,

Sorry about that. The latest test kernel is now uploaded to:
http://people.canonical.com/~jsalisbury/lp947751/

Stenten (stenten) wrote :

Latest kernel is good (I have networking).

Joseph Salisbury (jsalisbury) wrote :

I created another set of test kernels, which are available at:
http://people.canonical.com/~jsalisbury/lp947751/

This test kernel is built up to commit: aa0eb3474beae8f6d9dcc2311dc02bea50cfd7b7

Can you test this kernel and report back if it exhibits the bug or not? This should be the last test kernel. Based on your results, the bisect should report the bad commit.

Stenten (stenten) wrote :

Latest kernel is bad (no networking).

Joseph Salisbury (jsalisbury) wrote :

So bisect reports this is the offending commit:

aa0eb3474beae8f6d9dcc2311dc02bea50cfd7b7 is the first bad commit
commit aa0eb3474beae8f6d9dcc2311dc02bea50cfd7b7
Author: Thomas Gleixner <email address hidden>
Date: Tue Feb 7 17:58:03 2012 +0100

    genirq: Unmask oneshot irqs when thread was not woken

    commit ac5637611150281f398bb7a47e3fcb69a09e7803 upstream.

    When the primary handler of an interrupt which is marked IRQ_ONESHOT
    returns IRQ_HANDLED or IRQ_NONE, then the interrupt thread is not
    woken and the unmask logic of the interrupt line is never
    invoked. This keeps the interrupt masked forever.

    This was not noticed as most IRQ_ONESHOT users wake the thread
    unconditionally (usually because they cannot access the underlying
    device from hard interrupt context). Though this behaviour was nowhere
    documented and not necessarily intentional. Some drivers can avoid the
    thread wakeup in certain cases and run into the situation where the
    interrupt line s kept masked.

    Handle it gracefully.

    Reported-and-tested-by: Lothar Wassmann <email address hidden>
    Signed-off-by: Thomas Gleixner <email address hidden>
    Signed-off-by: Greg Kroah-Hartman <email address hidden>

:040000 040000 ab75402953eedef69bc60cade7653379c2f09c69 d5d5088d30573fff66356a2a87e6caafe625ae75 M kernel

I'll build a test kernel with this commit reverted and post it shortly.

Joseph Salisbury (jsalisbury) wrote :

The latest test kernel is built. I reverted the commit mentioned in comment #29: aa0eb3474beae8f6d9dcc2311dc02bea50cfd7b7

Can you test and report if this test kernel fixes the issue. If it does, then we know this commit is the cause of the bug.

Stenten (stenten) wrote :

Yep, that's the one! This latest kernel is good; it has networking.

Joseph, thank you for all your help, I appreciate your time. I've updated the upstream report to include the bad commit.

Joseph Salisbury (jsalisbury) wrote :

Thanks for all your help testing, Stenten.

Phillip Wood (phillip-wood) wrote :

Thanks for all the effort bisecting the problem. Upstream have suggested a patch to try which is included in 3.2.10. I haven't tried the patch on it's own but the 3.2.10 kernel solves the problem for me.

Changed in linux:
status: Confirmed → Incomplete
Joseph Salisbury (jsalisbury) wrote :

@Stenten,

Can you test the 3.2.11 kernel, which should include this patch:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.11-precise/

Changed in linux:
status: Incomplete → Fix Released
Stenten (stenten) wrote :

Aye, the bug is fixed in the 3.2.11 mainline kernel.

Joseph Salisbury (jsalisbury) wrote :

@Stenten,

The fix should be in the latest Precise kernel. Can you apply the latest updates, and confirm the bug is fixed?

Stenten (stenten) wrote :

Joseph,

i just upgraded maybe an hour ago, and the new -19 kernel is working beautifully.

Joseph Salisbury (jsalisbury) wrote :

Stenten,

That it great news. Thanks so much for your help with the bug. I'll mark it as Fix Released.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.