Precise kernel post-install fails in grub configuration in EC2

Bug #945424 reported by Bryan Donlan on 2012-03-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Doing a release-upgrade from oneiric on EC2 (ubuntu cloud official images), with an aufs overlay. EC2 instance is a t1.micro.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-17-virtual 3.2.0-17.27
ProcVersionSignature: Ubuntu 3.0.0-16.28-virtual 3.0.17
Uname: Linux 3.0.0-16-virtual i686
AlsaDevices:
 total 0
 crw-rw---T 1 root audio 116, 1 Mar 2 07:53 seq
 crw-rw---T 1 root audio 116, 33 Mar 2 07:53 timer
AplayDevices: Error: [Errno 2] No such file or directory
ApportVersion: 1.93-0ubuntu2
Architecture: i386
ArecordDevices: Error: [Errno 2] No such file or directory
Date: Fri Mar 2 08:02:29 2012
Ec2AMI: ami-08fd4c09
Ec2AMIManifest: (unknown)
Ec2AvailabilityZone: ap-northeast-1b
Ec2InstanceType: t1.micro
Ec2Kernel: aki-ec5df7ed
Ec2Ramdisk: unavailable
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 2
Lspci:

Lsusb: Error: command ['lsusb'] failed with exit code 1: unable to initialize libusb: -99
ProcKernelCmdLine: root=LABEL=cloudimg-rootfs ro console=hvc0
ProcModules:
 acpiphp 23408 0 - Live 0xe772a000
 aufs 159860 345 - Live 0xe7795000
 iptable_filter 12706 0 - Live 0xe7724000
 ip_tables 18106 1 iptable_filter, Live 0xe7731000
 x_tables 21975 2 iptable_filter,ip_tables, Live 0xe773a000
SourcePackage: linux
Title: package linux-image-3.2.0-17-virtual 3.2.0-17.27 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 2
UpgradeStatus: Upgraded to precise on 2012-03-02 (1 days ago)

Bryan Donlan (bdonlan) wrote :
Brad Figg (brad-figg) on 2012-03-03
Changed in linux (Ubuntu):
status: New → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.28

Despite what the bot says, apt-get upgrade does not automatically install kernel 3.2.0-18.28. One must manually install linux-image-3.2.0-18-virtual. The do-release-upgrade therefore still tries to install 3.2.0-17 and fails.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Bryan Donlan (bdonlan) wrote :

Additionally post-install configuration for linux-image-3.2.0-18-virtual still fails:

ubuntu@ip-10-150-85-237:~$ sudo dpkg --configure linux-image-3.2.0-18-virtual
Setting up linux-image-3.2.0-18-virtual (3.2.0-18.28) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-18-virtual /boot/vmlinuz-3.2.0-18-virtual
update-initramfs: Generating /boot/initrd.img-3.2.0-18-virtual
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.2.0-18-virtual /boot/vmlinuz-3.2.0-18-virtual
run-parts: executing /etc/kernel/postinst.d/x-grub-legacy-ec2 3.2.0-18-virtual /boot/vmlinuz-3.2.0-18-virtual
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-3.2.0-18-virtual
Found kernel: /boot/vmlinuz-3.0.0-16-virtual
Found kernel: /boot/vmlinuz-3.0.0-15-virtual
Found kernel: /boot/vmlinuz-3.0.0-14-virtual
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.0-18-virtual /boot/vmlinuz-3.2.0-18-virtual
/usr/sbin/grub-probe: error: cannot find a device for /boot (is /dev mounted?).
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-18-virtual.postinst line 1010.
dpkg: error processing linux-image-3.2.0-18-virtual (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 linux-image-3.2.0-18-virtual

It looks like the bug might be in grub-pc, so adding that to the bug now.

summary: - package linux-image-3.2.0-17-virtual 3.2.0-17.27 failed to
- install/upgrade: ErrorMessage: subprocess installed post-installation
- script returned error exit status 2
+ Precise kernel post-install fails in grub configuration in EC2
Bryan Donlan (bdonlan) wrote :

Please note also that I am unable to search for duplicates; launchpad times out every time I try a search. Please mark this as a duplicate if a duplicate exists.

Changed in linux (Ubuntu):
importance: Undecided → Medium

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.29
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers