shutdown does not work

Bug #944772 reported by Malte Pannemann on 2012-03-02
134
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
High
Joseph Salisbury
Precise
High
Joseph Salisbury

Bug Description

== Precise SRU Justification ==

This bug prevents desktops and servers from shutting down properly. This bug affects many different systems and a number of users. This bug is a high priory for servers, since physical access would be needed to shut the server down.

== Fix ==

Commit a3dd3323058d281abd584b15ad4c5b65064d7a61
Author: WANG Cong <email address hidden>
Date: Thu Jan 12 17:20:11 2012 -0800

    kexec: remove KMSG_DUMP_KEXEC

commit c22ab332902333f83766017478c1ef6607ace681
Author: Matthew Garrett <email address hidden>
Date: Mon Mar 5 14:59:10 2012 -0800

    kmsg_dump: don't run on non-error paths by default

comit a3dd3323 allows us to cleanly cherry-pick the actual fix, commit
c22ab332.

== Impact ==

A high number of desktop and server systems are affected as well as many users.

== Test Case ==

A test kernel was built with these two patches and tested by original bug reporter as well as other bug commenter's, which were also affected by this bug. These patches now allow the system to shutdown properly.

== Original Bug Description ==

I'am testing 12.04 (3.2.0-17-generic) and shutdown does not work. If i tray to shutdown or restart ther is the logo with the wording and the whites and the Orange points but it freezes. If it is frozen ctrl+alt+del show no effect. The hard drive turns off but the CPU and the display will continue. I have tried the following terminal commands, but the result is always the same.

sudo shutdown -h now
sudo shutdown -P now
sudo halt
sudo poweroff
sudo reboot

The problem occurs on a Acer TravelMate 8473T
Sorry that I can give no further information. This system forgets that there was a problem, because the hard drive turns off. This problem does not occur under 11.10
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: malte 3324 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf1800000 irq 53'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506c,1025057a,00100000 HDA:80862805,80860101,00100000'
   Controls : 24
   Simple ctrls : 11
CurrentDmesg: [ 75.369473] type=1400 audit(1330960723.802:30): apparmor="DENIED" operation="open" parent=1 profile="/usr/lib/telepathy/mission-control-5" name="/usr/share/gvfs/remote-volume-monitors/" pid=3945 comm="mission-control" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=fa9e2cdf-6dc3-45ce-8f28-2xxxxxxx510
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: Acer TM8473T
NonfreeKernelModules: wl
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=33d080ff-b0ba-4752-8bb7-fxxxxxxx792 ro quiet splash acpi_osi=Linux vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-18-generic N/A
 linux-backports-modules-3.2.0-18-generic N/A
 linux-firmware 1.71
StagingDrivers: rts_pstor mei
Tags: precise staging
Uname: Linux 3.2.0-18-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 05/26/2011
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: V1.09
dmi.board.asset.tag: No Asset Tag
dmi.board.name: TM8473T
dmi.board.vendor: Acer
dmi.board.version: V1.09
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.09
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvrV1.09:bd05/26/2011:svnAcer:pnTM8473T:pvrV1.09:rvnAcer:rnTM8473T:rvrV1.09:cvnAcer:ct9:cvrV1.09:
dmi.product.name: TM8473T
dmi.product.version: V1.09
dmi.sys.vendor: Acer

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/944772/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
volRot (info-rothert) wrote :

This error also occurs to me with HP NX9420 Laptop

description: updated
affects: ubuntu → linux-meta (Ubuntu)
Changed in linux-meta (Ubuntu):
assignee: nobody → Malte Pannemann (malte-pannemann)
assignee: Malte Pannemann (malte-pannemann) → nobody
Brad Figg (brad-figg) on 2012-03-05
affects: linux-meta (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 944772

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise

still happens at 3.2.0-18-generic

apport information

tags: added: apport-collected staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
description: updated
Joseph Salisbury (jsalisbury) wrote :

There is a newer version of the kernel than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not. You can upgrade just your kernel by running the following in a terminal:

sudo apt-get update
sudo apt-get install linux

If the bug still exists in the latest kernel, please change the status back to "Confirmed". If the bug is fixed, please change the status to "Fix Released".

Thanks in advance

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Download full text (10.8 KiB)

Update the Kernel but Bug still happen

malte@malte-TM8473T:~$ sudo apt-get update
OK http://packages.medibuntu.org lucid InRelease
Ign http://ppa.launchpad.net precise InRelease
Ign http://extras.ubuntu.com precise InRelease
Ign http://security.ubuntu.com precise-security InRelease
OK http://ppa.launchpad.net precise Release.gpg
OK http://extras.ubuntu.com precise Release.gpg
OK http://security.ubuntu.com precise-security Release.gpg
OK http://ppa.launchpad.net precise Release
OK http://extras.ubuntu.com precise Release
OK http://security.ubuntu.com precise-security Release
OK http://packages.medibuntu.org lucid/free amd64 Packages
OK http://extras.ubuntu.com precise/main Sources
OK http://ppa.launchpad.net precise/main Sources
Ign http://de.archive.ubuntu.com precise InRelease
OK http://extras.ubuntu.com precise/main amd64 Packages
OK http://extras.ubuntu.com precise/main i386 Packages
OK http://security.ubuntu.com precise-security/main Sources
OK http://ppa.launchpad.net precise/main amd64 Packages
OK http://ppa.launchpad.net precise/main i386 Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
OK http://packages.medibuntu.org lucid/non-free amd64 Packages
Ign http://extras.ubuntu.com precise/main TranslationIndex
OK http://security.ubuntu.com precise-security/restricted Sources
OK http://security.ubuntu.com precise-security/universe Sources
OK http://security.ubuntu.com precise-security/multiverse Sources
OK http://security.ubuntu.com precise-security/main amd64 Packages
OK http://security.ubuntu.com precise-security/restricted amd64 Packages
OK http://security.ubuntu.com precise-security/universe amd64 Packages
OK http://security.ubuntu.com precise-security/multiverse amd64 Packages
OK http://security.ubuntu.com precise-security/main i386 Packages
OK http://security.ubuntu.com precise-security/restricted i386 Packages
OK http://security.ubuntu.com precise-security/universe i386 Packages
OK http://security.ubuntu.com precise-security/multiverse i386 Packages
OK http://security.ubuntu.com precise-security/main TranslationIndex
OK http://security.ubuntu.com precise-security/multiverse TranslationIndex
OK http://security.ubuntu.com precise-security/restricted TranslationIndex
OK http://security.ubuntu.com precise-security/universe TranslationIndex
Ign http://de.archive.ubuntu.com precise-updates InRelease
OK http://packages.medibuntu.org lucid/free i386 Packages
OK http://security.ubuntu...

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.3-rc6 fixed the issue, the tag would be: 'kernel-fixed-upstream-v3.3-rc6'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc6-precise/

tags: added: needs-upstream-testing
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged

I signed up and created a report. maybe it helps. https://bugzilla.kernel.org/show_bug.cgi?id=42879

the computer will not start since the update the EFI boot loader today. https://bugs.launchpad.net/ubuntu/+source/efibootmgr/+bug/948568

Vincenzo Di Somma (vds) wrote :

Same issue on a DELL Latitude 6230.

A question to volRot (info-rothert) and Vincenzo Di Somma (vds): Does youre Notebooks use the BIOS follower UEFI too?

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Vadim Marchenko (polosaty) wrote :

Same issue on Dell Vostro 1400

Ruokoton (uborealis) wrote :

3.2.0-20-generic-pae

IBM Thinkpad X41 - also not shutting down. Suspend works ok.

Emmanuel Sunyer (esunyer) wrote :

Same issue on Dell Latitude D830.

Linux Anduin 3.2.0-20-generic #33-Ubuntu SMP Tue Mar 27 16:45:08 UTC 2012 i686 i686 i386 GNU/Linux

Rikard Lindström (ornotermes) wrote :

I too had this problem (Intel S1200BTS mainboard with EFI), i tried updating to Linux 3.3.0 mainline and it seems to work fine.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for others affected by this bug to test the latest mainline kernel listed in comment #35?

Shutdown does work with Mainlinekernel 3.3.0 on my Acer TravelMate 8473T with an UEFI Mainboard.

The kernel freeze is in a week. Will Linux 3.3.0 still be included in Ubuntu 12.04? I ask because my proprietary driver for Broadcom wlan does not work with this Mainlinekernel. Or may be backported bugfix in linux 3.2.0-20?

From /var/log/jockey.log

2012-03-30 09:18:27,191 WARNING: modinfo for module wl failed: ERROR: modinfo: could not find module wl

2012-03-30 09:18:27,192 WARNING: /sys/module/wl/drivers does not exist, cannot rebind wl driver
2012-03-30 09:18:27,274 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted

Same thing happens on a DELL Optiplex 760 with the 3.2.x Kernel series.

Joseph Salisbury (jsalisbury) wrote :

Can I request one additional test. It would be good to know if the fix in upstream v3.3 made it into upstream stable v3.2. Can folks affected by this bug test the latest v3.2 stable kernel, which is available at:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.13-precise/

tags: added: kernel-fixed-upstream
removed: kernel-bug-exists-upstream
Rikard Lindström (ornotermes) wrote :

3.2.13 does not work. I tried both restart and poweroff.

tags: added: kernel-da-key
Changed in linux (Ubuntu):
importance: Medium → High
28 comments hidden view all 108 comments
Rikard Lindström (ornotermes) wrote :

3.3.0-030300rc6-generic #201204041553 reboot and power off fine.

Joseph Salisbury (jsalisbury) wrote :

I posted the next test kernel. This kernel is a bisect up to commit:
9354f1b8e6c55c335d1c4fb10d0ae7a041935240

The test kernel is located at:
http://people.canonical.com/~jsalisbury/lp944772/

Can folks affected by this bug test this kernel and report back if the bug exists or not. I can continue the bisect once I get some feedback.

Thanks in advance.

Rikard Lindström (ornotermes) wrote :

3.3.0-030300rc6-generic #201204041731 reboot and power off fine.

Any idea of how many bisects might be left?

Joseph Salisbury (jsalisbury) wrote :

Thanks for testing, Rikard. I have the next kernel building now. There could be up to three more until we identify the bad commit.

Joseph Salisbury (jsalisbury) wrote :

I posted the next test kernel. This kernel is a bisect up to commit:
57b59c4a1400fa6c34764eab2e35a8762dc05a09

The test kernel is located at:
http://people.canonical.com/~jsalisbury/lp944772/

Can folks affected by this bug test this kernel and report back if the bug exists or not. I can continue the bisect once I get some feedback.

Thanks in advance.

Rikard Lindström (ornotermes) wrote :

3.3.0-030300rc6-generic #201204050110 reboot and power off fine.

Joseph Salisbury (jsalisbury) wrote :

I posted the next test kernel. This kernel is a bisect up to commit:
880641bb9da2473e9ecf6c708d993b29928c1b3c

The test kernel is located at:
http://people.canonical.com/~jsalisbury/lp944772/

Can folks affected by this bug test this kernel and report back if the bug exists or not. I can continue the bisect once I get some feedback.

Thanks in advance.

linux-image-3.3.0-030300rc6-generic_3.3.0-030300rc6.201204051311_amd64.deb reboot and power off fine.

Today's kernel freez. So ubuntu will released with this error?

Rikard Lindström (ornotermes) wrote :

3.3.0-030300rc6-generic #201204051311 reboot and poweroff fine for me too.

Joseph Salisbury (jsalisbury) wrote :

I posted the next test kernel. This kernel is a bisect up to commit:
f986a499ef6f317d906e6f6f281be966e1237a10

The test kernel is located at:
http://people.canonical.com/~jsalisbury/lp944772/

There should only be one additional test kernel after this.

@Malte, we may or may not be able to cherry pick the commit from upstream that fixes this bug. It will have to be proposed to the Ubuntu kernel team, once we identify the commit.

Rikard Lindström (ornotermes) wrote :

3.3.0-030300rc6-generic #201204051522 reboot and power off fine.

Joseph Salisbury (jsalisbury) wrote :

I posted the next test kernel. This kernel is a bisect up to commit:
c22ab332902333f83766017478c1ef6607ace681

The test kernel is located at:
http://people.canonical.com/~jsalisbury/lp944772/

This should be the last test kernel needed to identify the commit that fixed the bug.

Rikard Lindström (ornotermes) wrote :

3.3.0-030300rc6-generic #201204052025 reboot and power off fine.

Now that there should be a singe suspect commit left, is it time to add just that commit to 3.3-rc6 (and maybe a 3.2) to double check?

Joseph Salisbury (jsalisbury) wrote :

This was a revers bisect, so it identified the following commit as fixing the bug in v3.3-rc7:

[c22ab332902333f83766017478c1ef6607ace681] kmsg_dump: don't run on non-error paths by default

I will build a precise test kernel, with this commit applied and post it shortly.

Joseph Salisbury (jsalisbury) wrote :

The c22ab332902333f83766017478c1ef6607ace681 is not applying cleanly to precise. So I'd first like to confirm that commit in fact is the fix for this bug. To do that, I'll build a v3.3 kernel without that commit, so it will be built up to commit:
550cf00dbc8ee402bef71628cb71246493dd4500

I'll post the test kernel shortly.

Joseph Salisbury (jsalisbury) wrote :

I posted the next test kernel. This kernel is a bisect up to commit:
550cf00dbc8ee402bef71628cb71246493dd4500

I expect this test kernel to exhibit this bug. If it does, I'll investigate further on getting commit c22ab332902333f83766017478c1ef6607ace68 to apply to the precise kernel.

linux-image-3.3.0-030300rc6-generic_3.3.0-030300rc6.201204061432_amd64 does not power off and reboot

Joseph Salisbury (jsalisbury) wrote :

Thanks for testing, Malte. That confirms that the following commit is the fix for this bug:
[c22ab332902333f83766017478c1ef6607ace681] kmsg_dump: don't run on non-error paths by default

I'll work on building a Precise test kernel with this commit.

Joseph Salisbury (jsalisbury) wrote :

I built a precise test kernel with that patch applied(commit c22ab332902333f83766017478c1ef6607ace681). That commit also required a previous patch(commit a3dd3323058d281abd584b15ad4c5b65064d7a61).

The test kernel is located at:
http://people.canonical.com/~jsalisbury/lp944772/

Can you test the precise kernel and report back if it resolves this bug?

Rikard Lindström (ornotermes) wrote :

3.2.0-22-generic #35~lp944772 reboot and power off fine.

Great work Joseph!

Joseph Salisbury (jsalisbury) wrote :

Thanks for helping with the bisect and testing, Rikard and Malte!

I will work on a SRU request for Precise(Since we are past kernel freeze) and update the bug shortly.

Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
status: Triaged → In Progress
PaterSigmund (b-schwilling) wrote :

linux-image-3.2.0-22-generic_3.2.0-22.35~lp944772 works great. Thanks a lot!

As I experienced the same issue (hangs on reboot, while shutdown is fine) with the latest official kernel, I just tested this patched kernel. Now uname -a reports:
Linux ubuntu-Latitude-E5520 3.2.0-22-generic #35~lp944772 SMP Fri Apr 6 16:15:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Unfortunately this patch did not fix my SandyBridge Dell Latitude E5520 behaviour: shutdown is still fine, reboot hangs exactly the same way as before.

As I still have all beta 1 and 2 kernels installed, I can re-test some previous versions if it makes sense, as I'm pretty sure there was at least one working fine.

Regards

Alexander Hall (compuguy1088) wrote :

The patched kernel, linux-image-3.2.0-22-generic_3.2.0-22.35~lp944772, solved the issues with freezing from resume from suspend!

I confirm what Alexander experienced: with linux-image-3.2.0-22-generic_3.2.0-22.35~lp944772 even my system does not freeze anymore when resuming from suspend.

But I'm not lucky as Rikard, as I have a freeze during shutdown, if I choose for a system reboot.

Alexander Hall (compuguy1088) wrote :

After further testing, this seems to not fix my issues with resume from standby...

Rikard Lindström (ornotermes) wrote :

You who still have problems, have you tried any of the later kernels like 3.3.1 to see if the problem is solved upstream?

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3.1-precise/

Alexander Hall (compuguy1088) wrote :

Tried both mainline 3.3.1 and 3.4.0 RC2, both kernels panic. Relevant lines from 3.4.0RC2:

[ 24.635905] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 295.33 Sat Mar 17 14:55:45 PDT 2012
[ 24.635977] BUG: unable to handle kernel paging request at ffff8800e0601364
[ 24.635988] IP: [<ffffffff810b42a8>] module_put+0x28/0x90
[ 24.635998] PGD 1c0c063 PUD 0
[ 24.636003] Oops: 0002 [#1] SMP
[ 24.636008] CPU 0
[ 24.636010] Modules linked in: nvidia(PO) snd_seq_midi snd_rawmidi uvcvideo snd_seq_midi_event videobuf2_cor
e videodev snd_seq snd_timer videobuf2_vmalloc ath3k(+) snd_seq_device videobuf2_memops arc4 bluetooth hp_wmi s
nd iwl4965 r852 iwlegacy sm_common sparse_keymap nand nand_ids mtd nand_bch psmouse serio_raw mac80211 mac_hid
r592 memstick soundcore snd_page_alloc cfg80211 bch nand_ecc video coretemp wmi microcode lp parport firewire_o
hci sdhci_pci sdhci firewire_core crc_itu_t r8169

Alexander Hall (compuguy1088) wrote :

Forgot to mention that in recovery mode (for both mainline 3.3.1 and 3.4.0RC2) that it crashed/panicked as well spilling out this on the screen at the root prompt:

udev : timeout: killing '/sbin/modprobe -bv (usb or pci):

Attached is a photo showing the steady stream of these.

Alexander Hall (compuguy1088) wrote :

I hate to add another comment, but the issues I mentioned in #97 and #96. The kernel panic/oops is related to the NVIDIA proprietary drivers (I did install x-edgers ppa, that did not help), not the kernel (both 3.3.1 and 3.4.0 RC2 boot without the drivers).

Tim Gardner (timg-tpi) on 2012-04-09
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Joseph Salisbury (jsalisbury) wrote :

@Alexander and @Massimiliano

I would suggest opening new bugs for your issues, so we can address them separately.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-23.36

---------------
linux (3.2.0-23.36) precise-proposed; urgency=low

  [ Andy Whitcroft ]

  * tools/hv: add basic Makefile
    - LP: #977246
  * tools/hv: add basic manual pages
    - LP: #977246
  * Hyper-V KVP daemon -- add to the tools package
    - LP: #977246

  [ David Henningsson ]

  * SAUCE: (drop after 3.3) ALSA: HDA: Remove quirk for Gigabyte
    GA-H61M-S2PV
    - LP: #948360

  [ Leann Ogasawara ]

  * d-i: Add dm-mirror and dm-raid to md-modules
    - LP: #919281

  [ Tim Gardner ]

  * [Config] Fix invalid linux-headers link
    - LP: #974403
  * Remove headers asm symlink entirely
    - LP: #974403

  [ Upstream Kernel Changes ]

  * Revert "x86/ioapic: Add register level checks to detect bogus io-apic
    entries"
    - LP: #974982
  * ALSA: HDA: Realtek: Take vmaster dac from multiout dac list
    - LP: #974090
  * kexec: remove KMSG_DUMP_KEXEC
    - LP: #944772
  * kmsg_dump: don't run on non-error paths by default
    - LP: #944772
  * pstore: Introduce get_reason_str() to pstore
    - LP: #944772
 -- Leann Ogasawara <email address hidden> Tue, 10 Apr 2012 08:16:09 -0700

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

Hi, in the mean time I performed a full reinstallation, and eventually I just got the latest updates, including the following:
Linux Max-Latitude-E5520 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Sadly, even kernel 3.2.0-23.36 didn't fix my issue: shutdown is fine, rebooting hangs on shutting down process.

I think I should open a new bug now, as suggested by Joseph.

Just the update to Linux 3.2.0-23-generic was recorded. Power off and reboot fine!

I thank you all for everything! 12.04 will be a great release.

Rudolfs Caune (djbacons) wrote :

I have all updates till 2012.Apr.12 (including), but i still cant shut down (and restart) my laptop normally. It always hangs.
I tried Ctrl+Alt+T and sometimes it shows last entry something like "deconfiguring network interfaces ....OK"
once i got another line something like "detaching swap", but cursor was blinking in place where OK should have been. I waited few minutes but nothing.

Joseph Salisbury (jsalisbury) wrote :

@DjBacon,

Can you open a new bug for your issue? That way we can gather specific details on your hardware.

For those who are having reboot hangs like me, I opened a new bug and also posted a workaround there.
Please check if this workaround works for you as well, to identify if it's the same issue.
Note that on my machine only 64bit version hangs on reboot, precise 32bit works fine.

see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/985471

gio10 (giovanni-martinelli10) wrote :

Same problem with 3.2.0-24-generic-pae (Lenovo T61).
Shut down does not completly power off the pc, it just turns off the monitor.
Suspend works fine.

Solved on my system with the following workaround. Run:
sudo xdiagnose
and disable VESA framebuffer driver and disable PAT memory.

Shutdown does not work for me on 32bit 'precise'.

For me issue was resolved via switching from proprietary nvidia drivers ver.295.40 to nouveau driver.

When using nvidia drivers shutdown issue occured when I run some video in VLC. I was unable to switch to tty1 (just blank screen) -- in this case system hang at shutdown. If I was still able to go to tty1 then pc shuts down perfectly (for example immediately after logging in).

I tried to switch to older nvidia drivers like 275.x: seems to work but I decided to reinstall ubuntu from scratch. Now shutdown works for me ok.

HW: Dell Vostro 1500, core 2 duo, 3Gb ram, ssd ocz agility 2, nvidia geforce GS 8400M.

Changed in linux:
status: Confirmed → Fix Released
Simon Wenner (nowic) on 2012-07-01
security vulnerability: no → yes
visibility: public → private
Simon Wenner (nowic) on 2012-07-01
security vulnerability: yes → no
visibility: private → public
Dieter Maurer (d.maurer) wrote :

Poweroff still does not work for me with "3.2.0-26-generic-pae #41-Ubuntu SMP Thu Jun 14 16:45:14 UTC 2012 i686 athlon i386 GNU/Linux" on an ASRock N68-GS3 UCC mainboard. The system shuts down, reports "system halted" but power is not switched off.

Displaying first 40 and last 40 comments. View all 108 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.