xen-kbdfront module should be provided by linux-image-virtual or linux-virtual

Bug #944582 reported by Alex Bradley
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Oneiric
Undecided
Tim Gardner
Precise
Medium
Unassigned
linux-meta (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

I am working on setting up Edubuntu 11.10 as a paravirtualized Xen guest. I installed linux-image-3.0.0-16-virtual on the guest VM, but found that the xen-kbdfront module was missing. According to the provided kernel configs, the Xen PV keyboard frontend is compiled as a module in both linux-image-3.0.0-12-generic and linux-image-3.0.0-16-virtual:

root@ltsp2:/# grep CONFIG_INPUT_XEN_KBDDEV_FRONTEND /boot/config-3.0.0-1*
/boot/config-3.0.0-12-generic:CONFIG_INPUT_XEN_KBDDEV_FRONTEND=m
/boot/config-3.0.0-16-virtual:CONFIG_INPUT_XEN_KBDDEV_FRONTEND=m

The xen-kbdfront module is provided with linux-image-3.0.0-12-generic but missing in linux-image-3.0.0-16-virtual:

root@ltsp2:/# locate xen-kbd
/lib/modules/3.0.0-12-generic/kernel/drivers/input/misc/xen-kbdfront.ko
root@ltsp2:/# ls /lib/modules/3.0.0-16-virtual/kernel/drivers/input/
evbug.ko gameport joydev.ko mouse serio touchscreen

This means that if I boot the VM using the "virtual" image and try to access the VM's console through VNC, the keyboard and mouse don't work. With the "generic" image, I can load the xen-kbdfront module and the keyboard and mouse work fine.

Other information:
root@ltsp2:~# cat /proc/version_signature
Ubuntu 3.0.0-16.28-virtual 3.0.17
root@ltsp2:~# lspci -vnvn # no output
root@ltsp2:~# lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10
root@ltsp2:~# apt-cache policy linux-image-3.0.0-16-virtual
linux-image-3.0.0-16-virtual:
  Installed: 3.0.0-16.28
  Candidate: 3.0.0-16.28
  Version table:
 *** 3.0.0-16.28 0
        500 http://ca.archive.ubuntu.com/ubuntu/ oneiric-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ oneiric-security/main amd64 Packages
        100 /var/lib/dpkg/status
---
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 2012-03-02 00:35 seq
 crw-rw---- 1 root audio 116, 33 2012-03-02 00:35 timer
AplayDevices: aplay: device_list:240: no soundcards found...
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices: arecord: device_list:240: no soundcards found...
CurrentDmesg:
 [ 12.177342] init: plymouth-stop pre-start process (1299) terminated with status 1
 [ 13.007807] ppdev: user-space parallel port driver
 [ 20.928065] eth0: no IPv6 routers present
DistroRelease: Ubuntu 11.10
InstallationMedia: Edubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
Lspci:

Lsusb: Error: command ['lsusb'] failed with exit code 1: unable to initialize libusb: -99
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: root=/dev/xvda1 ro console=hvc0 root=/dev/xvda1 ro ip=:127.0.255.255::::eth0:dhcp
ProcVersionSignature: Ubuntu 3.0.0-16.28-virtual 3.0.17
Tags: oneiric
Uname: Linux 3.0.0-16-virtual x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 944582

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: oneiric
Revision history for this message
Alex Bradley (a-bradley) wrote : BootDmesg.txt

apport information

tags: added: apport-collected
description: updated
Revision history for this message
Alex Bradley (a-bradley) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Alex Bradley (a-bradley) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Alex Bradley (a-bradley) wrote : ProcModules.txt

apport information

Revision history for this message
Alex Bradley (a-bradley) wrote : UdevDb.txt

apport information

Revision history for this message
Alex Bradley (a-bradley) wrote : UdevLog.txt

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Tim Gardner (timg-tpi) wrote : Re: xen-kbdfront module missing in linux-image-3.0.0-16-virtual

Alex - have you installed linux-image-extra-virtual ? Any modules that are _not_ included in linux-image-virtual are automatically included in linux-image-extra-virtual. Precise is similarly constructed.

Changed in linux (Ubuntu Oneiric):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Invalid
Changed in linux (Ubuntu Precise):
status: Confirmed → Invalid
Revision history for this message
Alex Bradley (a-bradley) wrote :

I have now installed linux-image-extra-virtual and I confirm that xen-kbdfront is present and working. Thanks for the clarification.

I think that it's a bad packaging choice to have xen-kbdfront relegated to an "extra" package for a kernel that's supposed to be specifically tailored for use on virtual hosts. It has the strange consequence that the "generic" kernel works out of the box (i.e., without searching for extra packages) for a Xen VM with VNC console and the "virtual" kernel doesn't.

The package description of linux-image-3.0.0-16-virtual states:

"You likely do not want to install this package directly. Instead, install the linux-virtual meta-package, which will ensure that upgrades work correctly, and that supporting packages are also installed."

So I did begin by installing the linux-virtual package, for which the description claims:

"This package will always depend on the latest complete Linux kernel available for virtual machines."

I don't think a VM-oriented kernel metapackage should be described as providing a "complete" kernel and as ensuring that "supporting packages are also installed" if it leaves the Xen PV keyboard/mouse driver uninstalled. Neither linux-virtual nor linux-image-virtual has a "Depends" or "Suggests" relationship to linux-image-extra-virtual, and their descriptions don't mention it at all.

In short, I would suggest that either (1) xen-kbdfront should move into linux-image-virtual or (2) linux-virtual should depend on linux-image-extra-virtual.

Alex Bradley (a-bradley)
summary: - xen-kbdfront module missing in linux-image-3.0.0-16-virtual
+ xen-kbdfront module should be provided by linux-image-virtual or linux-
+ virtual
Revision history for this message
Tim Gardner (timg-tpi) wrote :

Alex - the whole point of the virtual image is to have a small minimal kernel, so having linux-virtual depend on the extras package doesn't make sense to me. I have updated the linux-virtual package description so that it at least mentions the extras package.

Revision history for this message
Stefan Bader (smb) wrote :

It makes sense to have that module in the main virtual package. I'll do a patch and will submit it to our list.

Revision history for this message
Tim Gardner (timg-tpi) wrote :

Actually, xen-kbdfront is already in the virtual inclusion list, but its wrong on Oneiric (correct for Precise)

Changed in linux (Ubuntu Oneiric):
status: Invalid → In Progress
Changed in linux (Ubuntu Precise):
status: Invalid → Fix Released
Revision history for this message
Stefan Bader (smb) wrote :

This actually was a packaging bug. It is included in Precise, but the path for it was wrong in Oneiric resulting in dropping it into the extras package.

Revision history for this message
Tim Gardner (timg-tpi) wrote :

UBUNTU: (config) Fix virtual flavour inclusion of xen-kbdfront

Changed in linux (Ubuntu Oneiric):
status: In Progress → Fix Committed
Revision history for this message
Tim Gardner (timg-tpi) wrote :
Changed in linux-meta (Ubuntu Oneiric):
status: New → Invalid
Changed in linux-meta (Ubuntu Precise):
status: New → Invalid
Revision history for this message
Tim Gardner (timg-tpi) wrote :

SRU Justification:

Impact: xen-kbdfront is not included in the linux-image-virtual package.

Patch: Use correct path to the kernel module.

Revision history for this message
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem ( 3.0.0-17.30). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Revision history for this message
Alex Bradley (a-bradley) wrote :

I have installed linux-image-3.0.0-17-virtual 3.0.0-17.30 on my ltsp2 VM. The xen-kbdfront module is present and I didn't have to install a corresponding version of linux-image-extra-virtual. The kernel boots successfully, the module loads, and VNC keyboard input works. Looks good to me.

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (6.6 KiB)

This bug was fixed in the package linux - 3.0.0-17.30

---------------
linux (3.0.0-17.30) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #949882

  [ Andy Whitcroft ]

  * [Config] restore build-% shortcut

  [ Stefan Bader ]

  * (config) Fix virtual flavour inclusion of xen-kbdfront
    - LP: #944582

  [ Upstream Kernel Changes ]

  * readahead: fix pipeline break caused by block plug
    - LP: #931719
  * ALSA: HDA: Fix duplicated output to more than one codec
    - LP: #924320, #931719
  * ASoC: wm_hubs: Enable line out VMID buffer for single ended line
    outputs
    - LP: #931719
  * ASoC: wm_hubs: fix wrong bits for LINEOUT2 N/P mixer
    - LP: #931719
  * ARM: 7306/1: vfp: flush thread hwstate before restoring context from
    sigframe
    - LP: #931719
  * ARM: 7307/1: vfp: fix ptrace regset modification race
    - LP: #931719
  * ARM: 7308/1: vfp: flush thread hwstate before copying ptrace registers
    - LP: #931719
  * ARM: OMAP2+: GPMC: fix device size setup
    - LP: #931719
  * drivers/tty/vt/vt_ioctl.c: fix KDFONTOP 32bit compatibility layer
    - LP: #931719
  * proc: mem_release() should check mm != NULL
    - LP: #931719
  * proc: unify mem_read() and mem_write()
    - LP: #931719
  * proc: make sure mem_open() doesn't pin the target's memory
    - LP: #931719
  * firewire: ohci: add reset packet quirk for SB Audigy
    - LP: #931719
  * firewire: ohci: disable MSI on Ricoh controllers
    - LP: #931719
  * IB/mlx4: pass SMP vendor-specific attribute MADs to firmware
    - LP: #931719
  * kprobes: fix a memory leak in function pre_handler_kretprobe()
    - LP: #931719
  * at_hdmac: bugfix for enabling channel irq
    - LP: #931719
  * mm/filemap_xip.c: fix race condition in xip_file_fault()
    - LP: #931719
  * mm: compaction: check pfn_valid when entering a new MAX_ORDER_NR_PAGES
    block during isolation for migration
    - LP: #931719
  * drm/radeon: Set DESKTOP_HEIGHT register to the framebuffer (not mode)
    height.
    - LP: #931719
  * drm/nouveau/gem: fix fence_sync race / oops
    - LP: #931719
  * drm/radeon/kms: disable output polling when suspended
    - LP: #931719
  * sched/rt: Fix task stack corruption under
    __ARCH_WANT_INTERRUPTS_ON_CTXSW
    - LP: #931719
  * ASoC: Ensure we generate a driver name
    - LP: #931719
  * udf: Mark LVID buffer as uptodate before marking it dirty
    - LP: #931719
  * drm/i915: HDMI hot remove notification to audio driver
    - LP: #931719
  * drm/i915: DisplayPort hot remove notification to audio driver
    - LP: #931719
  * drm/i915: check ACTHD of all rings
    - LP: #931719
  * drm/i915: Fix TV Out refresh rate.
    - LP: #931719
  * drm/i915: handle 3rd pipe
    - LP: #931719
  * eCryptfs: Infinite loop due to overflow in ecryptfs_write()
    - LP: #931719
  * cifs: Fix oops in session setup code for null user mounts
    - LP: #931719
  * atmel_lcdfb: fix usage of CONTRAST_CTR in suspend/resume
    - LP: #931719
  * lockdep, bug: Exclude TAINT_FIRMWARE_WORKAROUND from disabling lockdep
    - LP: #931719
  * hwmon: (w83627ehf) Fix number of fans for NCT6776F
    - LP: #931719
  * ASoC: wm_hubs: Fix routing of input PGAs to li...

Read more...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers