iwlwifi: Microcode SW error detected. Restarting 0x2000000

Bug #944271 reported by Munzir Taha (منذر طه) on 2012-03-01
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Fix Released
linux (Ubuntu)

Bug Description

My Intel Centrino Wireless-N 130 wifi disconnects frequently and can't even connect sometimes.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-17-generic 3.2.0-17.27
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 /dev/snd/controlC1: munzir 2153 F.... pulseaudio
 /dev/snd/controlC0: munzir 2153 F.... pulseaudio
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf6300000 irq 54'
   Mixer name : 'Realtek ALC892'
   Components : 'HDA:10ec0892,1462106f,00100302'
   Controls : 34
   Simple ctrls : 17
 Card hw:1 'NVidia'/'HDA NVidia at 0xf6080000 irq 17'
   Mixer name : 'Nvidia GPU 15 HDMI/DP'
   Components : 'HDA:10de0015,10de0101,00100100'
   Controls : 24
   Simple ctrls : 4
Date: Thu Mar 1 22:33:24 2012
HibernationDevice: RESUME=UUID=0432dc88-0889-43b3-86ab-cc09034bdcac
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120225)
MachineType: Micro-Star International Co., Ltd. GT680R/GX680R/GT683R/GT683DXR/GX660DXR
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic root=UUID=98c64fb8-4f56-4f8b-a19a-f4c917c1548a ro quiet splash vt.handoff=7
 linux-restricted-modules-3.2.0-17-generic N/A
 linux-backports-modules-3.2.0-17-generic N/A
 linux-firmware 1.71
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: rts5139 mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/01/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: E16F2IMS V3.0U
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: MS-16F2
dmi.board.vendor: Micro-Star International Co., Ltd.
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: Micro-Star International
dmi.chassis.version: To be filled by O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrE16F2IMSV3.0U:bd09/01/2011:svnMicro-StarInternationalCo.,Ltd.:pnGT680R/GX680R/GT683R/GT683DXR/GX660DXR:pvrTobefilledbyO.E.M.:rvnMicro-StarInternationalCo.,Ltd.:rnMS-16F2:rvrTobefilledbyO.E.M.:cvnMicro-StarInternational:ct10:cvrTobefilledbyO.E.M.:
dmi.product.name: GT680R/GX680R/GT683R/GT683DXR/GX660DXR
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Micro-Star International Co., Ltd.

Brad Figg (brad-figg) on 2012-03-01
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This may be a duplicate of bug 911059

Can you test the kernel listed in comment #51 of that bug?

If that kernel fixes your issue, please mark this bug as a duplicate of bug 911059

Changed in linux (Ubuntu):
importance: Undecided → Medium

I tested the new kernel and rebooted but still getting the same error. Attached is my dmesg output after a reboot. Also, I couldn't install the nvidia binary driver with the new kernel.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.3-rc5 fixed the issue, the tag would be: 'kernel-fixed-upstream-v3.3-rc5'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc5-precise/

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

$ uname -a
Linux GT683R 3.3.0-030300rc5-generic #201202251535 SMP Sat Feb 25 20:36:29 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
and still
Mar 2 05:56:40 GT683R kernel: [ 429.873614] iwlwifi 0000:03:00.0: Microcode SW error detected. Restarting 0x82000000.

However, the workaround 11n_disable=1 would hide the problem.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

Do you know if this issue happened with previous version of Ubuntu, such as 11.10, 11.04, etc?

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.28
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Joseph Salisbury (jsalisbury) wrote :

Thaks, Munzir

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed

Any update?

Avi Schwartz (le-avion) wrote :

I am running into the same issue with the latest 12.04 kernel.

Uname -a: Linux lionfish 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

So far I ran into this only when using rsync. The wifi connection freezes completely.

I am now using quantal with
$ uname -a
Linux GT683R 3.5.0-15-generic #22-Ubuntu SMP Wed Sep 19 20:01:43 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
and the bug is gone.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in linux:
status: Confirmed → Fix Released
Dima Ryazanov (dima-gmail) wrote :

I just ran into this while running Quantal:
Linux dima-xps 3.5.0-17-generic #28+kamal11~DellXPS-Ubuntu SMP Wed Oct 10 20:53:20 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Frank Harper (frank-harper) wrote :

My system is running 12.04, and has this bug.

$ uname -a
Linux frank-K95VM 3.2.0-34-generic #53-Ubuntu SMP Thu Nov 15 10:48:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

After disabling wireless N networking I now have a solid connection.

$ cat /etc/modprobe.d/iwlagn.conf
options iwlagn 11n_disable=1

Thanks to Munzir for reporting this bug, and thanks to Ubuntu for a great system. I hope to see the fix land in 12.04 soon.

Guy Thouret (guy-thouret) wrote :

System running 12.10 also experiencing the microcode error, resulting in drop outs, high packet loss and routing issues.

$ lspci -v
04:00.0 Network controller: Intel Corporation WiFi Link 5100
 Subsystem: Intel Corporation WiFi Link 5100 AGN
 Flags: bus master, fast devsel, latency 0, IRQ 44
 Memory at d0400000 (64-bit, non-prefetchable) [size=8K]
 Capabilities: <access denied>
 Kernel driver in use: iwlwifi
 Kernel modules: iwlwifi

$uname -a
Linux guy-ThinkPad-X100e 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I can confirm disabling 11n option gives me a rock solid connection:
$ sudo su
$ echo 'options iwlwifi 11n_disable=1' >> /etc/modprobe.d/iwlwifi.conf
$ rmmod iwlwifi
$ modprobe iwlwifi

Simon Strandman (nejsimon) wrote :

This bug is not fixed in precise so please re-open it!

Michael Steger (m-steger) wrote :

iwlwifi 0000:03:00.0: Microcode SW error detected. Restarting 0x2000000.

Linux 3.8.0-19-generic

Distributor ID: Ubuntu
Description: Ubuntu 13.04
Release: 13.04
Codename: raring

Guilhem (logik-free) wrote :

The bug is still present in my brand new laptop :
iwlwifi 0000:02:00.0: Microcode SW error detected. Restarting 0x2000000.
3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:13:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
with a
Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
 Subsystem: Intel Corporation Centrino Wireless-N 2230 BGN
 Flags: bus master, fast devsel, latency 0, IRQ 45
 Memory at f7d00000 (64-bit, non-prefetchable) [size=8K]
 Capabilities: <access denied>
 Kernel driver in use: iwlwifi
 Kernel modules: iwlwifi

Seems that either
options iwlwifi swcrypto=1
options iwlwifi 11n_disable=1

does the trick

DamirSharipov (dammer) wrote :

System Information
 Manufacturer: ASUSTeK COMPUTER INC.
 Product Name: UX32VD
 Version: 1.0

cat /etc/lsb-release

uname -a
Linux damir-laptop 3.8.0-27-generic #40-Ubuntu SMP Tue Jul 9 00:19:35 UTC 2013 i686 i686 i686 GNU/Linux

dmesg | grep iwl
[ 5.120579] iwlwifi 0000:03:00.0: irq 45 for MSI/MSI-X
[ 5.130198] iwlwifi 0000:03:00.0: loaded firmware version
[ 5.169897] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[ 5.169901] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[ 5.169903] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[ 5.169906] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
[ 5.169908] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_P2P disabled
[ 5.169911] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6235 AGN, REV=0xB0
[ 5.169978] iwlwifi 0000:03:00.0: L1 Disabled; Enabling L0S
[ 5.204953] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[ 12.426173] iwlwifi 0000:03:00.0: RF_KILL bit toggled to disable radio.
[ 102.739246] iwlwifi 0000:03:00.0: RF_KILL bit toggled to enable radio.
[ 102.739703] iwlwifi 0000:03:00.0: L1 Disabled; Enabling L0S
[ 102.746385] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[ 103.143936] iwlwifi 0000:03:00.0: L1 Disabled; Enabling L0S
[ 103.150668] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0

options iwlwifi 11n_disable=1 fix work for me

Alexander Adam (7ql6) wrote :

I have the same problem on the ASUS UX31A (problem is known).
Disabling n-Standard is not really a solution but a very dirty workaround.

This error happens more often if I use Skype.

Eric Munson (emunson) wrote :

This bug is present in upstream (3.13 as of rc7) so I don't think it can be marked fixed.

$ uname -a
Linux lappy-486 3.13.0-rc7 #3 SMP Fri Jan 10 21:08:47 EST 2014 x86_64 x86_64 x86_64 GNU/Linux

[28625.731410] iwlwifi 0000:02:00.0: Microcode SW error detected. Restarting 0x2000000.
[28625.731414] iwlwifi 0000:02:00.0: CSR values:
[28625.731417] iwlwifi 0000:02:00.0: (2nd byte of CSR_INT_COALESCING is CSR_INT_PERIODIC_REG)
[28625.731433] iwlwifi 0000:02:00.0: CSR_HW_IF_CONFIG_REG: 0X00489204
[28625.731446] iwlwifi 0000:02:00.0: CSR_INT_COALESCING: 0X8000ff40
[28625.731460] iwlwifi 0000:02:00.0: CSR_INT: 0X00000000
[28625.731474] iwlwifi 0000:02:00.0: CSR_INT_MASK: 0X00000000
[28625.731485] iwlwifi 0000:02:00.0: CSR_FH_INT_STATUS: 0X00000000
[28625.731496] iwlwifi 0000:02:00.0: CSR_GPIO_IN: 0X00000000
[28625.731509] iwlwifi 0000:02:00.0: CSR_RESET: 0X00000000
[28625.731520] iwlwifi 0000:02:00.0: CSR_GP_CNTRL: 0X080403c5
[28625.731534] iwlwifi 0000:02:00.0: CSR_HW_REV: 0X00000144
[28625.731545] iwlwifi 0000:02:00.0: CSR_EEPROM_REG: 0X00000000
[28625.731559] iwlwifi 0000:02:00.0: CSR_EEPROM_GP: 0X80000000
[28625.731570] iwlwifi 0000:02:00.0: CSR_OTP_GP_REG: 0X803a0000
[28625.731580] iwlwifi 0000:02:00.0: CSR_GIO_REG: 0X00080042
[28625.731594] iwlwifi 0000:02:00.0: CSR_GP_UCODE_REG: 0X00000000
[28625.731605] iwlwifi 0000:02:00.0: CSR_GP_DRIVER_REG: 0X00000000
[28625.731619] iwlwifi 0000:02:00.0: CSR_UCODE_DRV_GP1: 0X00000000
[28625.731629] iwlwifi 0000:02:00.0: CSR_UCODE_DRV_GP2: 0X00000000
[28625.731640] iwlwifi 0000:02:00.0: CSR_LED_REG: 0X00000060
[28625.731654] iwlwifi 0000:02:00.0: CSR_DRAM_INT_TBL_REG: 0X88212462
[28625.731665] iwlwifi 0000:02:00.0: CSR_GIO_CHICKEN_BITS: 0X27800200
[28625.731676] iwlwifi 0000:02:00.0: CSR_ANA_PLL_CFG: 0Xd55555d5
[28625.731687] iwlwifi 0000:02:00.0: CSR_HW_REV_WA_REG: 0X0001001a
[28625.731698] iwlwifi 0000:02:00.0: CSR_DBG_HPET_MEM_REG: 0Xffff0010
[28625.731700] iwlwifi 0000:02:00.0: FH register values:
[28625.731720] iwlwifi 0000:02:00.0: FH_RSCSR_CHNL0_STTS_WPTR_REG: 0X21276a00
[28625.731732] iwlwifi 0000:02:00.0: FH_RSCSR_CHNL0_RBDCB_BASE_REG: 0X02127690
[28625.731745] iwlwifi 0000:02:00.0: FH_RSCSR_CHNL0_WPTR: 0X000000d0
[28625.731757] iwlwifi 0000:02:00.0: FH_MEM_RCSR_CHNL0_CONFIG_REG: 0X80801114
[28625.731769] iwlwifi 0000:02:00.0: FH_MEM_RSSR_SHARED_CTRL_REG: 0X000000fc
[28625.731781] iwlwifi 0000:02:00.0: FH_MEM_RSSR_RX_STATUS_REG: 0X07030000
[28625.731793] iwlwifi 0000:02:00.0: FH_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000
[28625.731805] iwlwifi 0000:02:00.0: FH_TSSR_TX_STATUS_REG: 0X07ff0001
[28625.731817] iwlwifi 0000:02:00.0: FH_TSSR_TX_ERROR_REG: 0X00000000

Daniel Ovalle (daniel-ovalle) wrote :

I noticed recently this happens ONLY when I start using a bluetooth device.
My system:
09:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 [Rainbow Peak] (rev 34)
HP-ENVY-15-Notebook-PC 3.13.0-17-generic #37-Ubuntu SMP Mon Mar 10 21:44:01 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Mike Purvis (mikepurvis) wrote :

I'm seeing this crash on 14.04, running 3.13.0-23-generic. Hardware is Centrino Advanced-N 6235.

Log here: https://gist.github.com/f6ce150f833b2cef3f21

Benziane Chakib (spykspygel) wrote :

I am seeing the same crash in 14.10, kernel 3.13.0-24-generic

Log + Hardware : https://gist.github.com/sp4ke/5f3ee40a028880da12e9

Richard Davis (crashvb) wrote :

I am also seeing this with 3.13.0-24-generic.

Mikhail (mikhail.kalkov) wrote :

I am running Ubuntu 14.04.1 LTS and experiencing this issue (broken wifi until reconnection, "Microcode SW error detected. Restarting 0x20000000" in dmesg) on Lenovo G550 which has Intel WiMAX/WiFi Link 5150 with the following configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-45-generic firmware= ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11abg).

After adding "options iwlwifi 11n_disable=1" to /etc/modprobe.d/iwlwifi.conf and testing for half an hour, the original issue seems to be gone, although according to dmesg, a "microcode sw error" is still detected but this time with a different restarting number: "iwlwifi 0000:04:00.0: Microcode SW error detected. Restarting 0x82000000." Either way, wifi seems to work better with this workaround.

Mikhail (mikhail.kalkov) wrote :

I was too fast to post previous message after some 10 minutes of testing. However a recent driver upgrade from 3.13.0-45-generic to 3.13.0-46-generic (with the same firmware) has apparently solved this issue for me. At least, dmesg does not contain such errors after an hour of heavy network usage and the network seems to be stable. The version numbers above are the ones reported by lshw for my wifi card.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.