Ubuntu

encrypted install fails to boot as long as vt.handoff=7 is used

Reported by Philip Muškovac on 2012-02-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
grub-gfxpayload-lists (Ubuntu)
Medium
Chris Halse Rogers
Precise
Medium
Chris Halse Rogers
linux (Ubuntu)
High
Tim Gardner
Precise
High
Tim Gardner
plymouth (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

After installing the system from the alternate cd with full disk encryption, the system refuses to boot unless you edit the grub parameters and remove vt.handoff=7 from the kernel command line.

Occasionally this error is displayed:
error: no video mode activated.

but usually all you have is a blinking cursor. Switching to a tty and then back to tty7 will get you the pylmouth password prompt so you can input the password and continue to boot.

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-17-generic 3.2.0-17.27
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
ArecordDevices:
 Home directory /home/yofel not ours.
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: yofel 2056 F.... pulseaudio
 /dev/snd/controlC0: yofel 2056 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf2420000 irq 45'
   Mixer name : 'Conexant CX20585'
   Components : 'HDA:14f15069,17aa218b,00100302'
   Controls : 8
   Simple ctrls : 5
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xcdefc000 irq 16'
   Mixer name : 'Nvidia GPU 0b HDMI/DP'
   Components : 'HDA:10de000b,10de0101,00100100'
   Controls : 24
   Simple ctrls : 4
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6MHT43WW-1.18'
   Mixer name : 'ThinkPad EC 6MHT43WW-1.18'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Feb 28 20:36:39 2012
HibernationDevice: RESUME=UUID=1d5383ad-2871-4201-8c48-a7ac0ba2b8ad
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120228)
MachineType: LENOVO 4349W1R
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 LANGUAGE=
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-17-generic root=/dev/mapper/hostname-root ro quiet splash
PulseSinks:
 Error: command ['pacmd', 'list-sinks'] failed with exit code 1: Home directory /home/yofel not ours.
 No PulseAudio daemon running, or not running as session daemon.
PulseSources:
 Error: command ['pacmd', 'list-sources'] failed with exit code 1: Home directory /home/yofel not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-17-generic N/A
 linux-backports-modules-3.2.0-17-generic N/A
 linux-firmware 1.71SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/26/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6MET81WW (1.41 )
dmi.board.name: 4349W1R
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6MET81WW(1.41):bd10/26/2010:svnLENOVO:pn4349W1R:pvrThinkPadT510:rvnLENOVO:rn4349W1R:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4349W1R
dmi.product.version: ThinkPad T510
dmi.sys.vendor: LENOVO

Philip Muškovac (yofel) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/942846

tags: added: iso-testing
Philip Muškovac (yofel) on 2012-02-28
description: updated
Brad Figg (brad-figg) on 2012-02-28
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-key
Joseph Salisbury (jsalisbury) wrote :

@Philip

Are you able to boot if you use previous kernel versions? Is this a regressions with 3.2.0-17?

Would it be possible for you to also see if the latest mainline kernel with boot when using vt.handoff=7 ?

The latest mainline kernel is available at:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc5-precise/

Changed in linux (Ubuntu):
importance: Medium → High
Philip Muškovac (yofel) wrote :

I don't know if it's a regression as I believe I've never tried an encrypted setup on this hardware so far, and as this is a fresh install I don't have any older kernels around.

with v3.3-rc5 there's progress though. I still occasionally get
error: no video mode activated.
but after a few seconds pylmouth shows up and you can continue the boot procedure fine. That's not the case with 3.2.0-17

Andy Whitcroft (apw) wrote :

@Jo -- vt.handoff is an ubuntu specific feature which will be ignored on a mainline kernel. As you can just switch VTs to find the prompt I suspect this is not a kernel issue; also handoff in general seems to be working on a normal setup. Adding a cryptsetup task as that package supplies the initramfs bits.

Steve Langasek (vorlon) wrote :

The only thing about cryptsetup that's relevant is that it causes plymouth to be included in the initramfs where it wouldn't otherwise be. So reassigning to plymouth.

Philip, can you please run 'apport-collect -p plymouth 942846', to get information about your system that's relevant for diagnosing plymouth?

affects: cryptsetup (Ubuntu) → plymouth (Ubuntu)
Changed in plymouth (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) wrote :

I see as well from the attached kernel information that you're using the nouveau driver, and that when booted *without* vt.handoff, the nouveau driver has initialized without problems. Could you reboot with vt.handoff=7, cycle VTs as needed to get to the decryption prompt, boot and attach to the bug report the dmesg output from such a boot? Would like to compare the two.

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.28
Andy Whitcroft (apw) on 2012-03-05
tags: added: bot-quit-bugging
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: bot-stop-nagging
removed: bot-quit-bugging
RedSingularity (redsingularity) wrote :

I can confirm this problem as well on a fresh install using the latest Beta image.

Alternate install CD used
12.04
x86_64
Kernel 3.2.0-20-generic
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Tim Gardner (timg-tpi) on 2012-03-27
Changed in linux (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Tim Gardner (timg-tpi) wrote :

I was able to reproduce basically the same symptoms, but the workaround is slightly different. I've an amd64 with NVIDIA Corporation G92 [GeForce 9800 GX2] (rev a2). The _only_ way that this system will display the encryption password prompt is if you boot without "splash" in the kernel command line. I can alter which VT the password prompts appear in by changing the vt.handoff number from 7 to 1.

If splash is enabled then vt 1 comes up completely blank. Switching to vt 2 etc produces a single unblinking cursor.

Steve Langasek (vorlon) wrote :

Philip, do you by chance have GRUB_GFXPAYLOAD_LINUX=text set in your /etc/default/grub? Could you attach your /boot/grub/grub.cfg to this bug report?

Colin Watson (cjwatson) wrote :

grub2 (1.99-21ubuntu2) precise; urgency=low

  [ Andy Whitcroft ]
  * Only supply vt.handoff=7 when we are using gfxpayload=keep. Do this
    even when the command line is modified before execution. (LP: #942846)

  [ Colin Watson ]
  * Don't crash on inaccessible loop device backing paths (LP: #938724).

 -- Colin Watson <email address hidden> Thu, 05 Apr 2012 13:36:57 +0100

Changed in grub2 (Ubuntu Precise):
status: New → Fix Released
tags: removed: kernel-key
Tim Gardner (timg-tpi) wrote :

The remaining issue that I've encountered (blank screen) can be worked around by pressing <ESC> which toggles VTs. As such, I'm marking this as won't fix.

Changed in linux (Ubuntu Precise):
status: In Progress → Won't Fix
Changed in linux (Ubuntu):
status: In Progress → Won't Fix
Tim Gardner (timg-tpi) wrote :
Steve Langasek (vorlon) wrote :

Tim's PCI ID is 10de:0604. We may want this added to the gfx handoff blacklist.

Changed in grub-gfxpayload-lists (Ubuntu Precise):
importance: Undecided → Medium
status: New → Triaged
Changed in plymouth (Ubuntu Precise):
status: Incomplete → Invalid
Changed in grub-gfxpayload-lists (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
tags: added: rls-p-tracking
Changed in grub-gfxpayload-lists (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in grub-gfxpayload-lists (Ubuntu Precise):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in grub-gfxpayload-lists (Ubuntu):
milestone: ubuntu-12.04.1 → none
Changed in grub-gfxpayload-lists (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Canonical Desktop Team (canonical-desktop-team)
Changed in grub-gfxpayload-lists (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Canonical Desktop Team (canonical-desktop-team)
Sebastien Bacher (seb128) wrote :

Hey Chris, could you have a look to this bug, the LTS .1 freeze is at the end of the month and the issue has been milestoned for it. If you think you will not have time for that could you update the bug with a status update so we can try to figure out what to do?

you have also another grub-gfxpayload-lists bug assigned to your for the LTS .1, could you review it as well when you have some time?

Changed in grub-gfxpayload-lists (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Chris Halse Rogers (raof)
Changed in grub-gfxpayload-lists (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Chris Halse Rogers (raof)
Changed in grub-gfxpayload-lists (Ubuntu Precise):
milestone: ubuntu-12.04.1 → ubuntu-12.04.2
Colin Watson (cjwatson) on 2013-02-13
Changed in grub-gfxpayload-lists (Ubuntu Precise):
milestone: ubuntu-12.04.2 → ubuntu-12.04.3
To post a comment you must log in.