IPv6 DNS search list (DNSSL) isn't passed to userspace by the kernel

Bug #936714 reported by Stéphane Graber
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I recently discovered thanks to my broken DHCPv4 server that Network Manager seems to ignore the DNSSL field in the router advertissements.

One would expect NM to merge the IPv4 and IPv6 information in dual-stack environment and use the IPv6 data in IPv6 only environments.

From previous tests, I believe DHCPv6 DNS works properly and this bug is limited to DNSSL in SLAAC.

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Stéphane,

Could you please report this bug upstream to the NetworkManager developers on the GNOME bug tracker? Sound like this issue is one that should be taken care of upstream.

To help with debugging, it would also be useful if you could attach full debug logs from NetworkManager after reproducing the issue, you can do this easily by starting NetworkManager with --log-level=debug.

Changed in network-manager (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Revision history for this message
Stéphane Graber (stgraber) wrote :

Not NM's fault, the code actually looks good, it's the kernel's fault for not supporting it yet.
http://patchwork.ozlabs.org/patch/75243/

affects: network-manager (Ubuntu) → linux (Ubuntu)
affects: linux (Ubuntu) → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
status: Incomplete → Invalid
summary: - NetworkManager ignores DNSSL in RAs causing missing DNS search path on
- IPv6 networks
+ IPv6 DNS search list (DNSSL) isn't passed to userspace by the kernel
Revision history for this message
Stéphane Graber (stgraber) wrote :

Marking the NM task as Invalid and opening one against the kernel.

The patch on patchwork has been around for a while and Network Manager and possibly more tools actually support the option.
RADVD also supports the option and has it documented.

Would be great if someone from the kernel team could review the patch and try to push it further so we can have fully working stateless IPv6 in Ubuntu.

Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 936714

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Stéphane Graber (stgraber) wrote :

Disabling the bot and marking as confirmed.

There isn't any logfile to attach as the bug is a missing feature and is pretty straightforward :)

tags: added: bot-stop-nagging
Changed in linux (Ubuntu):
status: Incomplete → Triaged
status: Triaged → Confirmed
no longer affects: network-manager (Ubuntu)
Revision history for this message
Will (ivebeenlinuxed) wrote :

How is this going? Is there any movement in getting the patch added to the kernel?

Revision history for this message
Stéphane Graber (stgraber) wrote :

commit e35f30c131a562bafd069820a6983fd4023e606e
Author: Alexey I. Froloff <email address hidden>
Date: Fri Apr 6 05:50:58 2012 +0000

    Treat ND option 31 as userland (DNSSL support)

    As specified in RFC6106, DNSSL option contains one or more domain names
    of DNS suffixes. 8-bit identifier of the DNSSL option type as assigned
    by the IANA is 31. This option should also be treated as userland.

    Signed-off-by: Alexey I. Froloff <email address hidden>
    Signed-off-by: David S. Miller <email address hidden>

The option is now in quantal's kernel and should be working as expected.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Stéphane Graber (stgraber) wrote :

When running Network Manager in debug mode, we can clearly see the dnssl now making it to userspace:
Sep 18 11:23:42 castiana NetworkManager[16910]: <debug> [1347981822.603959] [nm-ip6-manager.c:1184] process_nduseropt_dnssl(): (wlan0): found RA-provided domain lan.sherb.stgraber.net (expires in 7200 seconds)
Sep 18 11:23:42 castiana NetworkManager[16910]: <debug> [1347981822.604169] [nm-ip6-manager.c:1184] process_nduseropt_dnssl(): (wlan0): found RA-provided domain sherb.stgraber.net (expires in 7200 seconds)
Sep 18 11:23:42 castiana NetworkManager[16910]: <debug> [1347981822.604193] [nm-ip6-manager.c:1184] process_nduseropt_dnssl(): (wlan0): found RA-provided domain stgraber.net (expires in 7200 seconds)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers