Ubuntu

Backlight control does not work correctly on Toshiba Satellite L750-17P.

Reported by Pikachux on 2012-02-17
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Fn+f6 & fn+f7 doesn't let me decrease/increase the backlight/brightness, only after putting the laptop to sleep and waking it up again does the backlight bar actually appear when I hit fn+f6 but it still doesn't decrease the backlight. The symptoms appear to be exactly the same as this other slightly older toshiba model posted here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/850065

UPDATE: Heres a way to turn down the backlight https://bugs.launchpad.net/ubuntu/+source/linux/+bug/934095/comments/34

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: i386
ArecordDevices: **** List of CAPTURE Hardware Devices **** card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog] Subdevices: 1/1 Subdevice #0: subdevice #0
AudioDevicesInUse: USER PID ACCESS COMMAND /dev/snd/controlC1: odin 1587 F.... pulseaudio /dev/snd/controlC0: odin 1587 F.... pulseaudio CRDA: Error: [Errno 2] Filen eller katalogen finns inte
Card0.Amixer.info: Card hw:0 'PCH'/'HDA Intel PCH at 0xc3400000 irq 50' Mixer name : 'Conexant CX20585' Components : 'HDA:14f15069,1179fc50,00100302' Controls : 13 Simple ctrls : 8
Card1.Amixer.info: Card hw:1 'NVidia'/'HDA NVidia at 0xc3000000 irq 17' Mixer name : 'Nvidia GPU 14 HDMI/DP' Components : 'HDA:10de0014,10de0101,00100100' Controls : 16 Simple ctrls : 4
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=2a275915-f56c-4620-a9fa-18c4d293dc71
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: TOSHIBA SATELLITE L750
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcEnviron: PATH=(custom, no user) LANG=sv_SE.UTF-8 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic-pae root=UUID=ca8610c9-3d1e-47af-bb6c-f72f5bee6316 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic-pae 3.0.17
RelatedPackageVersions: linux-restricted-modules-3.0.0-16-generic-pae N/A linux-backports-modules-3.0.0-16-generic-pae N/A linux-firmware 1.60
StagingDrivers: mei
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-16-generic-pae i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 10/14/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: 2.70
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: Intel Corp.
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr2.70:bd10/14/2011:svnTOSHIBA:pnSATELLITEL750:pvrPSK2YE-0FR01CN5:rvnIntelCorp.:rnBaseBoardProductName:rvrBaseBoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: SATELLITE L750
dmi.product.version: PSK2YE-0FR01CN5
dmi.sys.vendor: TOSHIBA

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 934095

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: oneiric

apport information

tags: added: apport-collected running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.3-rc2 fixed the issue, the tag would be: 'kernel-fixed-upstream-v3.3-rc2'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc3-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
Pikachux (ko-shinto) wrote :

Installed http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc3-precise/linux-image-3.3.0-030300rc3-generic-pae_3.3.0-030300rc3.201202082335_i386.deb and rebooted, now the resolution is stuck at 1024x728 without any option to go to the original max resolution of 1366x728 and nvidias proprietary driver no longer works, if i try to reinstall the nvidia driver I get a error that tells me to look inside jockey.log.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Pikachux (ko-shinto) wrote :

I have now discovered that If you put the laptop to sleep and wake it up again the fn+f6 combination will work to actually make the backlight bar appear but it has no actual effect and does not lower or increase the backlight. So the issue appears not to be the key functions in itself but the backlight does simply not get the signal that it's being lowered or increased.

Pikachux (ko-shinto) on 2012-02-19
summary: - Hotkeys/Fn key do not work on Toshiba Satellite L750-17P laptop
+ Backlight does not work on Toshiba Satellite L750-17P laptop
summary: - Backlight does not work on Toshiba Satellite L750-17P laptop
+ Backlight control does not work on Toshiba Satellite L750-17P laptop
Pikachux (ko-shinto) on 2012-02-19
description: updated
description: updated
Pikachux (ko-shinto) wrote :

Also tried the latest version from https://launchpad.net/~sforshee/+archive/toshiba-acpi-dkms/ but it didn't change anything, still the same.

Same problem with my laptop Toshiba L745-s4210 no way to make work the Fn+F6, Fn+F7.

Olivero (cholivero) wrote :

Same problem with my Toshiba C660 (reported here : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/939569).

Pikachux (ko-shinto) wrote :

Finally solved the backlight issue by installing the latest release of https://github.com/guillaumezin/nvidiabl/downloads - nvidiabl-dkms_0.73_all.deb

after intsalling it write in the terminal: sudo echo "nvidiabl" | sudo tee -a /etc/modules
so that it automatically starts on bootup.

and then you use this command to toggle the backlight in the terminal: echo 1 | sudo tee -a /sys/class/backlight/nvidia_backlight/brightness

Important to note is that if you touch the settings in "Nvidia X Server Settings" it will cause Nvidia-bl to stop functioning.

description: updated
Pikachux (ko-shinto) on 2012-02-29
description: updated
description: updated
description: updated
Pikachux (ko-shinto) on 2012-02-29
description: updated
Pikachux (ko-shinto) on 2012-03-02
summary: - Backlight control does not work on Toshiba Satellite L750-17P laptop
+ Backlight control & Thermal Sensing does not work correctly on Toshiba
+ Satellite L750-17P.
Pikachux (ko-shinto) on 2012-03-02
description: updated
Pikachux (ko-shinto) on 2012-03-26
summary: - Backlight control & Thermal Sensing does not work correctly on Toshiba
- Satellite L750-17P.
+ Backlight control does not work correctly on Toshiba Satellite L750-17P.
description: updated
tom (tumplis) on 2012-03-26
Changed in linux (Ubuntu):
assignee: nobody → tom (tumplis)
Pikachux (ko-shinto) on 2012-03-27
description: updated

Pikachux, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-kernel-logs
tags: removed: needs-kernel-logs
description: updated
tags: added: needs-full-computer-model
Changed in linux (Ubuntu):
assignee: tom (tumplis) → nobody
status: Confirmed → Incomplete
Victoid (djvictoid) wrote :

Hello all,

After going a bit grey, I found that /sys/class/backlight/toshiba breaks after suspend, but /sys/class/backlight/intel_backlight continues to function ('echo $number > backlight' after resume from suspend). Some great folks over at Arch have figured this one out. I have a Toshiba Portege R705, and this does the trick:

Source: https://wiki.archlinux.org/index.php/Intel_Graphics#Backlight_not_fully_adjusting.2C_or_adjusting_at_all_after_resume.

Adapting this for Ubuntu 13.04:

1) sudo vi /etc/default/grub

2) change the line GRUB_CMDLINE_LINUX_DEFAULT as follows:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

3) sudo update-grub

4) Configure X11 to use the intel_backlight. Create a file called 20-intel.conf here:

sudo vi /usr/share/X11/xorg.conf.d/20-intel.conf

5) Paste in the following:

Section "Device"
        Identifier "card0"
        Driver "intel"
        Option "Backlight" "intel_backlight"
        BusID "PCI:0:2:0"

EndSection

6) Reboot and bask in glorious brightness control. Suspend/resume and it continues to function normally from the Fn-F6/F7 keys.

Victoid (djvictoid) wrote :

Just to add, I noticed above that the original bug refers to nvidia rather than intel graphics, and the fix I listed is particularly appropriate only for Portege laptops with Intel graphics. The symptoms for intel graphics seems to be identical to that listed in the original bug report.

Victoid, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documention in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.