Oneiric update to 3.0.21 stable release

Bug #931719 reported by Tim Gardner on 2012-02-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.0.21 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the 3.0.21 stable release:

readahead: fix pipeline break caused by block plug
ALSA: HDA: Fix duplicated output to more than one codec
ASoC: wm_hubs: Enable line out VMID buffer for single ended line outputs
ASoC: wm_hubs: fix wrong bits for LINEOUT2 N/P mixer
ARM: 7306/1: vfp: flush thread hwstate before restoring context from sigframe
ARM: 7307/1: vfp: fix ptrace regset modification race
ARM: 7308/1: vfp: flush thread hwstate before copying ptrace registers
ARM: OMAP2+: GPMC: fix device size setup
drivers/tty/vt/vt_ioctl.c: fix KDFONTOP 32bit compatibility layer
proc: mem_release() should check mm != NULL
proc: unify mem_read() and mem_write()
proc: make sure mem_open() doesn't pin the target's memory
firewire: ohci: add reset packet quirk for SB Audigy
firewire: ohci: disable MSI on Ricoh controllers
IB/mlx4: pass SMP vendor-specific attribute MADs to firmware
kprobes: fix a memory leak in function pre_handler_kretprobe()
at_hdmac: bugfix for enabling channel irq
mm/filemap_xip.c: fix race condition in xip_file_fault()
mm: compaction: check pfn_valid when entering a new MAX_ORDER_NR_PAGES block during isolation for migration
drm/radeon: Set DESKTOP_HEIGHT register to the framebuffer (not mode) height.
drm/nouveau/gem: fix fence_sync race / oops
drm/radeon/kms: disable output polling when suspended
sched/rt: Fix task stack corruption under __ARCH_WANT_INTERRUPTS_ON_CTXSW
ASoC: Ensure we generate a driver name
udf: Mark LVID buffer as uptodate before marking it dirty
drm/i915: HDMI hot remove notification to audio driver
drm/i915: DisplayPort hot remove notification to audio driver
drm/i915: check ACTHD of all rings
drm/i915: Fix TV Out refresh rate.
drm/i915: handle 3rd pipe
eCryptfs: Infinite loop due to overflow in ecryptfs_write()
cifs: Fix oops in session setup code for null user mounts
atmel_lcdfb: fix usage of CONTRAST_CTR in suspend/resume
lockdep, bug: Exclude TAINT_FIRMWARE_WORKAROUND from disabling lockdep
hwmon: (w83627ehf) Fix number of fans for NCT6776F
ASoC: wm_hubs: Fix routing of input PGAs to line output mixer
ASoC: wm_hubs: Correct line input to line output 2 paths
ASoC: wm8962: Fix word length configuration
pcmcia: fix socket refcount decrementing on each resume
mm: compaction: check for overlapping nodes during isolation for migration
mm: fix UP THP spin_is_locked BUGs
target: Use correct preempted registration sense code
target: Allow PERSISTENT RESERVE IN for non-reservation holder
target: Correct sense key for INVALID FIELD IN {PARAMETER LIST,CDB}
Staging: asus_oled: fix image processing
Staging: asus_oled: fix NULL-ptr crash on unloading
staging: r8712u: Add new Sitecom UsB ID
usb: gadget: zero: fix bug in loopback autoresume handling
usb: Skip PCI USB quirk handling for Netlogic XLP
USB: usbserial: add new PID number (0xa951) to the ftdi driver
USB: add new zte 3g-dongle's pid to option.c
mmc: cb710 core: Add missing spin_lock_init for irq_lock of struct cb710_chip
powernow-k8: Avoid Pstate MSR accesses on systems supporting CPB
powernow-k8: Fix indexing issue
net: fix NULL dereferences in check_peer_redir()
Linux 3.0.21

Tim Gardner (timg-tpi) on 2012-02-13
tags: added: kernel-stable-tracking-bug
description: updated
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (6.6 KiB)

This bug was fixed in the package linux - 3.0.0-17.30

---------------
linux (3.0.0-17.30) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #949882

  [ Andy Whitcroft ]

  * [Config] restore build-% shortcut

  [ Stefan Bader ]

  * (config) Fix virtual flavour inclusion of xen-kbdfront
    - LP: #944582

  [ Upstream Kernel Changes ]

  * readahead: fix pipeline break caused by block plug
    - LP: #931719
  * ALSA: HDA: Fix duplicated output to more than one codec
    - LP: #924320, #931719
  * ASoC: wm_hubs: Enable line out VMID buffer for single ended line
    outputs
    - LP: #931719
  * ASoC: wm_hubs: fix wrong bits for LINEOUT2 N/P mixer
    - LP: #931719
  * ARM: 7306/1: vfp: flush thread hwstate before restoring context from
    sigframe
    - LP: #931719
  * ARM: 7307/1: vfp: fix ptrace regset modification race
    - LP: #931719
  * ARM: 7308/1: vfp: flush thread hwstate before copying ptrace registers
    - LP: #931719
  * ARM: OMAP2+: GPMC: fix device size setup
    - LP: #931719
  * drivers/tty/vt/vt_ioctl.c: fix KDFONTOP 32bit compatibility layer
    - LP: #931719
  * proc: mem_release() should check mm != NULL
    - LP: #931719
  * proc: unify mem_read() and mem_write()
    - LP: #931719
  * proc: make sure mem_open() doesn't pin the target's memory
    - LP: #931719
  * firewire: ohci: add reset packet quirk for SB Audigy
    - LP: #931719
  * firewire: ohci: disable MSI on Ricoh controllers
    - LP: #931719
  * IB/mlx4: pass SMP vendor-specific attribute MADs to firmware
    - LP: #931719
  * kprobes: fix a memory leak in function pre_handler_kretprobe()
    - LP: #931719
  * at_hdmac: bugfix for enabling channel irq
    - LP: #931719
  * mm/filemap_xip.c: fix race condition in xip_file_fault()
    - LP: #931719
  * mm: compaction: check pfn_valid when entering a new MAX_ORDER_NR_PAGES
    block during isolation for migration
    - LP: #931719
  * drm/radeon: Set DESKTOP_HEIGHT register to the framebuffer (not mode)
    height.
    - LP: #931719
  * drm/nouveau/gem: fix fence_sync race / oops
    - LP: #931719
  * drm/radeon/kms: disable output polling when suspended
    - LP: #931719
  * sched/rt: Fix task stack corruption under
    __ARCH_WANT_INTERRUPTS_ON_CTXSW
    - LP: #931719
  * ASoC: Ensure we generate a driver name
    - LP: #931719
  * udf: Mark LVID buffer as uptodate before marking it dirty
    - LP: #931719
  * drm/i915: HDMI hot remove notification to audio driver
    - LP: #931719
  * drm/i915: DisplayPort hot remove notification to audio driver
    - LP: #931719
  * drm/i915: check ACTHD of all rings
    - LP: #931719
  * drm/i915: Fix TV Out refresh rate.
    - LP: #931719
  * drm/i915: handle 3rd pipe
    - LP: #931719
  * eCryptfs: Infinite loop due to overflow in ecryptfs_write()
    - LP: #931719
  * cifs: Fix oops in session setup code for null user mounts
    - LP: #931719
  * atmel_lcdfb: fix usage of CONTRAST_CTR in suspend/resume
    - LP: #931719
  * lockdep, bug: Exclude TAINT_FIRMWARE_WORKAROUND from disabling lockdep
    - LP: #931719
  * hwmon: (w83627ehf) Fix number of fans for NCT6776F
    - LP: #931719
  * ASoC: wm_hubs: Fix routing of input PGAs to li...

Read more...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers