Ubuntu

Constant warnings from the kernel: Test WP failed, assume Write Enabled

Reported by Julian Alarcon on 2012-02-02
262
This bug affects 58 people
Affects Status Importance Assigned to Milestone
Linux
In Progress
Medium
linux (Fedora)
Unknown
Unknown
linux (Ubuntu)
Low
Unassigned

Bug Description

I have this problem with this Laptop Acer 5735-4624, when I change to a TTY (Ctrl+Alt+F1..) I got this message everytime

Feb 2 17:07:12 telintel26 kernel: [33802.064779] sd 4:0:0:0: [sdb] Test WP failed, assume Write Enabled
Feb 2 17:07:12 telintel26 kernel: [33802.067026] sd 4:0:0:0: [sdb] Asking for cache data failed
Feb 2 17:07:12 telintel26 kernel: [33802.067034] sd 4:0:0:0: [sdb] Assuming drive cache: write through

This are just warnings, because all seems to work OK but are really nasty messages because appear every time even if you are running another program (example: top)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-12-generic 3.2.0-12.21
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: alarconj 1752 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8900000 irq 47'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,10250176,00100101 HDA:11c11040,11c10001,00100200'
   Controls : 16
   Simple ctrls : 9
Date: Thu Feb 2 17:06:19 2012
HibernationDevice: RESUME=UUID=bb53f046-48a6-441f-82c7-0e0fdb12ce2f
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120102)
MachineType: Acer Aspire 5735
ProcEnviron:
 LANGUAGE=es_CO:es
 PATH=(custom, no user)
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-12-generic root=UUID=6da9a4fd-7e97-4217-b00e-4c5c5bd76813 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-12-generic N/A
 linux-backports-modules-3.2.0-12-generic N/A
 linux-firmware 1.68
SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2012-01-26 (7 days ago)
dmi.bios.date: 12/04/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.10
dmi.board.name: CathedralPeak
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.10:bd12/04/2008:svnAcer:pnAspire5735:pvr0100:rvnAcer:rnCathedralPeak:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 5735
dmi.product.version: 0100
dmi.sys.vendor: Acer
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: alarconj 2078 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8900000 irq 47'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,10250176,00100101 HDA:11c11040,11c10001,00100200'
   Controls : 16
   Simple ctrls : 9
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=bb53f046-48a6-441f-82c7-0e0fdb12ce2f
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120102)
MachineType: Acer Aspire 5735
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=es_CO:es
 TERM=xterm
 PATH=(custom, no user)
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=6da9a4fd-7e97-4217-b00e-4c5c5bd76813 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-18-generic N/A
 linux-backports-modules-3.2.0-18-generic N/A
 linux-firmware 1.71
Tags: precise
Uname: Linux 3.2.0-18-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-02-17 (16 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/04/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.10
dmi.board.name: CathedralPeak
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.10:bd12/04/2008:svnAcer:pnAspire5735:pvr0100:rvnAcer:rnCathedralPeak:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 5735
dmi.product.version: 0100
dmi.sys.vendor: Acer
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: alarconj 2078 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8900000 irq 47'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,10250176,00100101 HDA:11c11040,11c10001,00100200'
   Controls : 16
   Simple ctrls : 9
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=bb53f046-48a6-441f-82c7-0e0fdb12ce2f
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120102)
MachineType: Acer Aspire 5735
Package: linux-image-3.2.0-18-generic 3.2.0-18.28
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=es_CO:es
 TERM=xterm
 PATH=(custom, no user)
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=6da9a4fd-7e97-4217-b00e-4c5c5bd76813 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-18-generic N/A
 linux-backports-modules-3.2.0-18-generic N/A
 linux-firmware 1.71
Tags: precise
Uname: Linux 3.2.0-18-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-02-17 (16 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/04/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.10
dmi.board.name: CathedralPeak
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.10:bd12/04/2008:svnAcer:pnAspire5735:pvr0100:rvnAcer:rnCathedralPeak:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 5735
dmi.product.version: 0100
dmi.sys.vendor: Acer

Julian Alarcon (alarconj) wrote :
Julian Alarcon (alarconj) wrote :

Maybe this problem is related to the Multi Card reader , if you need more info just let me know.

Bus 001 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.3-rc2 fixed the issue, the tag would be: 'kernel-fixed-upstream-v3.3-rc2'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

tags: added: needs-upstream-testing
Brad Figg (brad-figg) on 2012-02-02
Changed in linux (Ubuntu):
status: New → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-13.22
Brad Figg (brad-figg) on 2012-02-17
Changed in linux (Ubuntu):
importance: Undecided → Low
Neal McBurnett (nealmcb) wrote :

I get the same 3 messages in /var/log/syslog every 52 seconds on my Dell mini 1012.
I get it both with the recent Ubuntu kernel 3.2.0-15,
and with the latest Ubuntu-built mainline kernel: 3.3.0-030300rc4-generic-pae

description: updated
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
tags: removed: kernel-request-3.2.0-13.22
Neal McBurnett (nealmcb) wrote :

.... and the bug is also there in the latest precise kernel: 3.2.0-17-generic #26-Ubuntu

My dmesg is attached.

Neal McBurnett (nealmcb) wrote :

I do not see the bug when booting in precise using the oneiric kernel 3.0.0-16-generic

I do see the same bug in 3.1: ~kernel-ppa/mainline/v3.1.10-precise - the Ubuntu build of the mainline 3.1.10 kernel: 3.1.10-030110-generic #201201181135

So it looks like a regression in the mainline kernel 3.1

And I hate it when my logs and consoles get filled up with stuff that doesn't otherwise matter :/

The code that prints the KERN_NOTICE messages is in linux/drivers/scsi/sd.c, and says it is only called when sd_revalidate_disk() is called. Why would that be called every 52 seconds? Here are some snippets from around each of the three messages:

* ... read write protect setting, if possible - called only in sd_revalidate_disk()
sd_read_write_protect_flag(struct scsi_disk *sdkp, unsigned char *buffer)
{....
  if (sdp->skip_ms_page_3f) {
  sd_printk(KERN_NOTICE, sdkp, "Assuming Write Enabled\n");
...
 if (!scsi_status_is_good(res)) {
  sd_printk(KERN_WARNING, sdkp,
     "Test WP failed, assume Write Enabled\n");

...
sd_read_cache_type - called only from sd_revalidate_disk()
....
 if (scsi_sense_valid(&sshdr) &&
     sshdr.sense_key == ILLEGAL_REQUEST &&
     sshdr.asc == 0x24 && sshdr.ascq == 0x0)
  /* Invalid field in CDB */
  sd_printk(KERN_NOTICE, sdkp, "Cache data unavailable\n");
 else
  sd_printk(KERN_ERR, sdkp, "Asking for cache data failed\n");

Neal McBurnett (nealmcb) wrote :

2 WORKAROUNDS:
I can at least get it to shut up by doing "sudo rmmod ums_realtek"

If I subsequently do a "sudo modprobe ums_realtek" the messages start showing up again every 52 seconds.

If I actually try use the sdb device (which is the SD card in my dell mini 1012 netbook) by inserting an SD card, the card seems to work fine - it automatically reloads the module and mounts the card.

And, in addition, inserting a card also makes the messages go away, even after the card is removed, and even though ums_realtek remains loaded.

Neal McBurnett (nealmcb) wrote :

Aha - it turns out the second workaround (inserting an SD card) stopped working when I re-inserted the little inert plastic insert that fills in the SD card hole when you're not using it.

So the real workaround is to pull that out and leave it out, or to remove the kernel module.

This also suggests what is going on - for some reason the driver now seems to be constantly trying to figure out what is going on with the inert plastic insert. I'm guessing that some change for the 3.1 kernel is now kicking off that behavior.

Neal McBurnett (nealmcb) wrote :

I did one more rmmod command, and got a kernel oops (but not a crash) which is now documented at bug 936652.

Julian Alarcon (alarconj) wrote :

Good news: The error do't come up over and over again in the tty.
Bad news: The error is still there, using lastest Ubuntu 12.04 (Linux telintel26 3.2.0-17-generic #26-Ubuntu SMP Fri Feb 17 21:35:49 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux)

Feb 22 16:08:25 telintel26 kernel: [ 2940.441575] [drm:drm_mode_getfb] *ERROR* invalid framebuffer id
Feb 22 16:08:25 telintel26 kernel: [ 2940.441583] [drm:drm_mode_getfb] *ERROR* invalid framebuffer id
Feb 22 16:09:01 telintel26 kernel: [ 2977.061171] sd 4:0:0:0: [sdb] Test WP failed, assume Write Enabled
Feb 22 16:09:01 telintel26 kernel: [ 2977.063289] sd 4:0:0:0: [sdb] Asking for cache data failed
Feb 22 16:09:01 telintel26 kernel: [ 2977.063297] sd 4:0:0:0: [sdb] Assuming drive cache: write through
Feb 22 16:09:53 telintel26 kernel: [ 3029.060664] sd 4:0:0:0: [sdb] Test WP failed, assume Write Enabled
Feb 22 16:09:53 telintel26 kernel: [ 3029.062794] sd 4:0:0:0: [sdb] Asking for cache data failed
Feb 22 16:09:53 telintel26 kernel: [ 3029.062802] sd 4:0:0:0: [sdb] Assuming drive cache: write through

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-17.26
Neal McBurnett (nealmcb) wrote :

Two of us already reported that 3.2.0-17.26 fails. I removed the tag also.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: kernel-request-3.2.0-17.26
Brad Figg (brad-figg) wrote :

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-17.26
Neal McBurnett (nealmcb) wrote :

Hmm - maybe I shouldn't have removed that tag.... :/

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Julian Alarcon (alarconj) wrote :

I already test the last kernel, and was trying to add the info to this bug, but apport crash.

Last kernel in Ubuntu 12.04, Linux telintel26 3.2.0-17-generic #26-Ubuntu SMP Fri Feb 17 21:35:49 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux, also has this bug.

I you are curious, this is the apport bug (private for now):
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/939589

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-17.27

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Julian Alarcon (alarconj) wrote :

I jst added the info (twice, sorry) for the kernel linux-image-3.2.0-18-generic
So, the error is still there.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Christian Kujau (christiank) wrote :

Still present with3.2.0-24-generic. Upstream bug: https://bugzilla.kernel.org/show_bug.cgi?id=43191
The workaround from comment #8 works here (Lenovo Ideapad S10), thanks nealmcb :)

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
mgoreiro (mgoreiro) wrote :
Download full text (92.3 KiB)

Same problem with eMachines EL1200 after udate to Ubuntu 12.04 LTS. Made a fresh installation and problem still exists.

Dmesg reports as follow:

[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 3.2.0-24-generic (buildd@yellow) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 (Ubuntu 3.2.0-24.37-generic 3.2.14)
[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=bee2c41d-b1e9-44ca-862d-c0d29bac17c6 ro quiet splash vt.handoff=7
[ 0.000000] KERNEL supported cpus:
[ 0.000000] Intel GenuineIntel
[ 0.000000] AMD AuthenticAMD
[ 0.000000] Centaur CentaurHauls
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
[ 0.000000] BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 0000000037ee0000 (usable)
[ 0.000000] BIOS-e820: 0000000037ee0000 - 0000000037ee3000 (ACPI NVS)
[ 0.000000] BIOS-e820: 0000000037ee3000 - 0000000037ef0000 (ACPI data)
[ 0.000000] BIOS-e820: 0000000037ef0000 - 0000000037f00000 (reserved)
[ 0.000000] BIOS-e820: 0000000038000000 - 0000000040000000 (reserved)
[ 0.000000] BIOS-e820: 00000000f0000000 - 00000000f4000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
[ 0.000000] NX (Execute Disable) protection: active
[ 0.000000] DMI 2.5 present.
[ 0.000000] DMI: eMachines EL1200/WMCP61M, BIOS R01-A0L 09/17/2008
[ 0.000000] e820 update range: 0000000000000000 - 0000000000010000 (usable) ==> (reserved)
[ 0.000000] e820 remove range: 00000000000a0000 - 0000000000100000 (usable)
[ 0.000000] No AGP bridge found
[ 0.000000] last_pfn = 0x37ee0 max_arch_pfn = 0x400000000
[ 0.000000] MTRR default type: uncachable
[ 0.000000] MTRR fixed ranges enabled:
[ 0.000000] 00000-9FFFF write-back
[ 0.000000] A0000-BFFFF uncachable
[ 0.000000] C0000-C7FFF write-protect
[ 0.000000] C8000-FFFFF uncachable
[ 0.000000] MTRR variable ranges enabled:
[ 0.000000] 0 base 0000000000 mask FFC0000000 write-back
[ 0.000000] 1 disabled
[ 0.000000] 2 disabled
[ 0.000000] 3 disabled
[ 0.000000] 4 disabled
[ 0.000000] 5 disabled
[ 0.000000] 6 disabled
[ 0.000000] 7 disabled
[ 0.000000] x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
[ 0.000000] found SMP MP-table at [ffff8800000f3c50] f3c50
[ 0.000000] initial memory mapped : 0 - 20000000
[ 0.000000] Base memory trampoline at [ffff88000009a000] 9a000 size 20480
[ 0.000000] init_memory_mapping: 0000000000000000-0000000037ee0000
[ 0.000000] 0000000000 - 0037e00000 page 2M
[ 0.000000] 0037e00000 - 0037ee0000 page 4k
[ 0.000000] kernel direct mapping tables up to 37ee0000 @ 1fffd000-20000000
[ 0.000000] RAMDISK: 364e6000 - 3726b000
[ 0.000000] ACPI: RSDP 00000000000f8080 00014 (v00 ACRSYS)
[ 0.000000] ACPI: RSDT 0000000037ee3000 00038 (v01 ACRSYS ACRPRDCT 42302E31 NVDA 00...

Well, i have the same problem with my SD-Card reader and I can confirm that this bug is still there with Ubuntu 12.04.

I tested the latestest upstream kernel (3.4.0-030400rc6-generic #201205061835 SMP Sun May 6 22:42:47 UTC 2012 i686 i686 i386 GNU/Linux) and i have no good news for you. :-(

Sorry, I overlooked this report and marked my one #994414 as duplicated.

Changed in linux:
status: Confirmed → In Progress
ilf (ilf) wrote :

Same here, anything you need for it to progress?

Andrei Cazimir (cazimir) wrote :

I am running ubuntu 12.04 LTS 64 bit on a Dell Vostro 3550 and I have experienced this issue as well. However, the problem has been SOLVED by simply removing the factory installed dummy from the SD slot. Apparently, the relevant driver is designed to detect a SD module via the slot plug-in switch activation. As such, any object with the right shape that could activate this switch will be detected as a valid SD module. The ensuing syslog messages are a result of the automout trying (every ~ 45 seconds) to mount what is in fact an invalid device.

Should these messages be generated with an empty SD slot, I would suspect the slot plug-in switch to be faulty ("on" all the time).

Consequently, I do not believe this to be a kernel bug, although it may be possible to find a more reliable way to detect a valid SD module for the device driver.

Regards

Changed in linux (Ubuntu):
assignee: nobody → Feras Abdullah (pianoforte)
Changed in linux (Ubuntu):
assignee: Feras Abdullah (pianoforte) → nobody
Sebastian Meyer (x-archimedes) wrote :

For the record:
There is hardware with faulty slot plug-in switches, namely the EeeBox B202 (one of the earlier Intel-Atom-in-a-small-box-boxes).
Mine has an empty tray, but displays that message on the tty every 51 seconds.

lsusb reveals the "bad" device (snippet):
> Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader

Obviously, doing an rmmod ums_realtek solves the issue of annoying trash on the tty.

I am not fluent in rsyslog configuration, but maybe it is possible to reroute that message to /dev/null?

Sebastien (tuzisan) wrote :

Same problem on my Dell Mini 1010 with a solid state drive.

The workaround from comment #8 works, I've added these lines in the file /etc/rc.local to make this change "temporarily permanent":

# Avoid constant kernel warnings about missing cache on SSD
# see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/925760
rmmod ums_realtek

ilf (ilf) wrote :

Just blacklist the module in /etc/modprobe.d/blacklist.conf

Nick Bunyan (nick-bunyan) wrote :

Running 12.04 LTS on 64-bit AMD setup with a generic USB attached Multi-card reader. With all the slots in the reader empty (CF/SD/USB etc) the following appears in kern.log and syslog, repeating the whole block approximately every 55 seconds.

Oct 26 12:59:38 chi kernel: [238967.019095] sd 8:0:0:0: [sdd] Test WP failed, assume Write Enabled
Oct 26 12:59:38 chi kernel: [238967.021168] sd 8:0:0:0: [sdd] Asking for cache data failed
Oct 26 12:59:38 chi kernel: [238967.021174] sd 8:0:0:0: [sdd] Assuming drive cache: write through

Inserting a card or stick into any of the device slots generates 6 additional lines in the logs then stops the cycle. In other words this is only a problem when the device is 'empty'

FYI - the reader does NOT appear to have any specific card sensing mechanism, either switch or sensor, built in.

Rather than blacklisting the module, which I may want to use one day, I stuck an old SD card in the reader and the logs are quiet...

Kaulbach (mystic-scientist) wrote :

The "ss_en" option of the ums_realtek driver seems to solve this for me as I described in post #3 at http://askubuntu.com/questions/132100/errors-in-dmesg-test-wp-failed-assume-write-enabled
modinfo ums_realtek shows as options:

parm: auto_delink_en:enable auto delink (int)
parm: ss_en:enable selective suspend (int)
parm: ss_delay:seconds to delay before entering selective suspend (int)

Empirical testing shows that ss_delay value is how often the error will appear in the console.
Disabling the suspend with ss_en=0 still allows the reader to work but not suspend/wake every ss_delay amount of seconds.

This fix is still working for me as of Raring Ringtail with 64bit kernel 3.8.0-1-generic #5-Ubuntu

Download full text (9.1 KiB)

A better solution may be to get the Realtek developer to fix their driver.

On Tue, Jan 22, 2013 at 4:22 PM, Kaulbach <email address hidden> wrote:

> The "ss_en" option of the ums_realtek driver seems to solve this for me as
> I described in post #3 at
> http://askubuntu.com/questions/132100/errors-in-dmesg-test-wp-failed-assume-write-enabled
> modinfo ums_realtek shows as options:
>
> parm: auto_delink_en:enable auto delink (int)
> parm: ss_en:enable selective suspend (int)
> parm: ss_delay:seconds to delay before entering selective suspend (int)
>
> Empirical testing shows that ss_delay value is how often the error will
> appear in the console.
> Disabling the suspend with ss_en=0 still allows the reader to work but not
> suspend/wake every ss_delay amount of seconds.
>
> This fix is still working for me as of Raring Ringtail with 64bit kernel
> 3.8.0-1-generic #5-Ubuntu
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/925760
>
> Title:
> Constant warnings from the kernel: Test WP failed, assume Write
> Enabled
>
> Status in The Linux Kernel:
> In Progress
> Status in “linux” package in Ubuntu:
> Triaged
> Status in “linux” package in Fedora:
> Unknown
>
> Bug description:
> I have this problem with this Laptop Acer 5735-4624, when I change to
> a TTY (Ctrl+Alt+F1..) I got this message everytime
>
> Feb 2 17:07:12 telintel26 kernel: [33802.064779] sd 4:0:0:0: [sdb] Test
> WP failed, assume Write Enabled
> Feb 2 17:07:12 telintel26 kernel: [33802.067026] sd 4:0:0:0: [sdb]
> Asking for cache data failed
> Feb 2 17:07:12 telintel26 kernel: [33802.067034] sd 4:0:0:0: [sdb]
> Assuming drive cache: write through
>
> This are just warnings, because all seems to work OK but are really
> nasty messages because appear every time even if you are running
> another program (example: top)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: linux-image-3.2.0-12-generic 3.2.0-12.21
> ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
> Uname: Linux 3.2.0-12-generic x86_64
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
> AplayDevices:
> **** List of PLAYBACK Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> ApportVersion: 1.91-0ubuntu1
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: alarconj 1752 F.... pulseaudio
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xf8900000 irq 47'
> Mixer name : 'Realtek ALC268'
> Components : 'HDA:10ec0268,10250176,00100101
> HDA:11c11040,11c10001,00100200'
> Controls : 16
> Simple ctrls : 9
> Date: Thu Feb 2 17:06:19 2012
> HibernationDevice: RESUME=UUID=bb53f046-48a6-441f-82c7-0e0fdb12ce2f
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64...

Read more...

akamanax (edmon-xxl) on 2013-02-26
Changed in linux (Ubuntu):
assignee: nobody → akamanax (edmon-xxl)
assignee: akamanax (edmon-xxl) → nobody
Krzysztof Kosinski (tweenk) wrote :

For a permanent workaround, create the file /etc/modprobe.d/ums-realtek.conf with the following content:

options ums_realtek ss_en=0

or execute this command:

sudo sh -c 'echo "options ums_realtek ss_en=0" > /etc/modprobe.d/ums-realtek.conf'

I think this bug could be declared fixed once the ss_en option is disabled by default. This can be done either by shipping a modprobe conffile or by changing the default value of the option in the kernel source.

The 'ss_en' switch controls 'selective suspend', e.g. suspending parts of the card reader which are not used. Typically only one card slot is in use at any time, so disabling would slightly decrease power consumption when a card is inserted. When there is no card, the reader would power down through the normal USB suspend mechanism.

Neal McBurnett (nealmcb) wrote :

Thank you, Krzysztof!! Your suggestion in comment #75 worked for me, at least it seems to be working after doing this to restart the module:

$ sudo rmmod ums_realtek
$ sudo modprobe ums_realtek

My current setup is a bit screwy, running 12.10 on a 12.04 kernel (3.2.0-36-generic) because of another nasty kernel bug on my dell mini 1012.

Ganton (ganton) wrote :

It's still happening in Kubuntu 13.04.

Ganton (ganton) wrote :

In my computer, using Kubuntu 13.04, the "ss_en" option of the ums_realtek driver didn't work for me, the messages were still filling the logs.

The solution proposed in comment #70 worked.

Me too #78. After using "ss_en" option, the messages changed to continuous "USB disconnected" and reconnected messages.

So, finally the only solution is to disable the module as #70 recommended and wait to a fixed driver.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.