[MacBook Pro 8,2] Wireless cannot associate after s3 with no external power (BCM4331)

Bug #925577 reported by Seth Forshee on 2012-02-02
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Seth Forshee
Precise
Medium
Seth Forshee
Quantal
Medium
Seth Forshee

Bug Description

== SRU Justification ==

Impact: Macbook Pro models with BCM4331 wireless will be unable to transmit wireless data following S3 if resumed without external power attached.

Fix: Add workaround to BCMA to reinitialize the ext_pa pin muxings after S3.

Test case: Suspend an affected machine, then resume it without A/C power. Observe that without this patch the wireless fails to work afterwards, whereas with the patch the wireless does work.

---

When the machine is suspended without external power attached, after being resumed the wireless is unable to associate. Analysis with wireshark shows that no frames are being transmitted by the laptop when this happens, although it is able to receive frames as it can successfully scan. The problem can be fixed by unloading both the b43 and bcma modules and reloading them; unloading and reloading b43 by itself is not enough to fix the issue.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-12-generic 3.2.0-12.21
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1743 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 1743 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xb0900000 irq 47'
   Mixer name : 'Cirrus Logic CS4206'
   Components : 'HDA:10134206,106b1d00,00100302'
   Controls : 24
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xb0840000 irq 48'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Thu Feb 2 10:49:26 2012
HibernationDevice: RESUME=UUID=13594e7c-281a-4c68-afc8-7ef8aae830c9
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64+mac (20111208)
MachineType: Apple Inc. MacBookPro8,2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-12-generic root=UUID=b914ccd7-a73e-4a8b-97b2-4b23a1d3d39c ro acpi_backlight=vendor quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-12-generic N/A
 linux-backports-modules-3.2.0-12-generic N/A
 linux-firmware 1.68
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/28/11
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP81.88Z.0047.B22.1109281426
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-94245A3940C91C80
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro8,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-94245A3940C91C80
dmi.modalias: dmi:bvnAppleInc.:bvrMBP81.88Z.0047.B22.1109281426:bd09/28/11:svnAppleInc.:pnMacBookPro8,2:pvr1.0:rvnAppleInc.:rnMac-94245A3940C91C80:rvrMacBookPro8,2:cvnAppleInc.:ct10:cvrMac-94245A3940C91C80:
dmi.product.name: MacBookPro8,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Seth Forshee (sforshee) wrote :
Tim Gardner (timg-tpi) wrote :

I can confirm the same behavior on a MB Pro 8,2 w/B43

Antonio Censi (accensi) wrote :

I can confirm the bug. Exactly the same problem, except it a MacBookPro8,1 on kernel 3.2.0-17 64bit.

Brad Figg (brad-figg) on 2012-04-11
tags: added: kernel-wifi
Seth Forshee (sforshee) on 2012-05-09
Changed in linux (Ubuntu):
status: In Progress → Confirmed
Changed in linux (Ubuntu Precise):
status: In Progress → Confirmed
Changed in linux (Ubuntu):
assignee: Seth Forshee (sforshee) → nobody
Changed in linux (Ubuntu Precise):
assignee: Seth Forshee (sforshee) → nobody
Jussi Pakkanen (jpakkane) wrote :

I have this issue with MacBookPro8,1 but the difference is that I only need to reload the b43 module and wireless starts working.

Seth Forshee (sforshee) wrote :

The fix just hit Linus's tree, and quantal will get it in the rebase to 3.5-rc3. Attaching backport for precise.

description: updated

The attachment "0001-bcma-add-ext-PA-workaround-for-BCM4331-and-BCM43431.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Seth Forshee (sforshee) on 2012-06-14
Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
Changed in linux (Ubuntu Precise):
assignee: nobody → Seth Forshee (sforshee)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-1.1

---------------
linux (3.5.0-1.1) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * [Config] highbank -- enable CONFIG_RFKILL=y and CONFIG_CAN=m

  [ Leann Ogasawara ]

  * Rebase to v3.5-rc1
  * [Config] Remove USB_DEVICEFS from the config enforcer
  * [Config] Updateconfigs after rebase to v3.5-rc1
  * [Config] Temporarily disable CONFIG_MACH_NOKIA_RX51 on arm
  * [Config] Temporarily disable CONFIG_TOUCHSCREEN_EETI on arm
  * [Config] Temporarily disable CONFIG_TOUCHSCREEN_EGALAX on arm
  * [Config] Temporarily disable CONFIG_EZX_PCAP on arm
  * [Config] Temporarily disable CONFIG_LIS3L02DQ on arm
  * [Config] Temporarily disable CONFIG_TI_CPSW on arm
  * [Config] Temporarily disable CONFIG_GPIO_EM on arm
  * [Config] Temporarily disable CONFIG_SERIAL_8250_EM on armhf
  * [Config] Temporarily disable CONFIG_STMMAC_ETH on armhf
  * [Config] Temporarily disable CONFIG_HW_RANDOM_ATMEL on armhf
  * Rebase to v3.5-rc2
  * [Config] Updateconfigs after rebase to v3.5-rc2
  * [Config] Temporarily disable CONFIG_MV643XX_ETH on powerpc
  * Rebase to v3.5-rc3
  * [Config] Updateconfigs after rebase to v3.5-rc3

  [ Paul Mundt ]

  * SAUCE: fix bug.h's inclusion of kernel.h

  [ Stefan Bader ]

  * SAUCE: Fix compile failures of dm-raid45
  * [Config] Enable dm-raid45
  * Move dependency on crda to extra package
    - LP: #657901
  * SAUCE: Mask CR4 writes on older Xen hypervisors

  [ Upstream Kernel Changes ]

  * rebase to v3.5-rc3
    - LP: #993162
    - LP: #925577
  * rebase to v3.5-rc2
  * rebase to v3.5-rc1
    - LP: #955892
    - LP: #978038
    - LP: #987371
    - LP: #929545
    - LP: #942316
    - LP: #903853
 -- Leann Ogasawara <email address hidden> Fri, 08 Jun 2012 14:28:46 -0700

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Seth Forshee (sforshee) on 2012-07-09
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-27.43). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Seth Forshee (sforshee) on 2012-07-09
tags: added: verification-done-precise
removed: verification-needed-precise
Launchpad Janitor (janitor) wrote :
Download full text (13.6 KiB)

This bug was fixed in the package linux - 3.2.0-27.43

---------------
linux (3.2.0-27.43) precise-proposed; urgency=low

  [ Andy Whitcroft ]

  * No change upload to fix .ddeb generation in the PPA.

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1020016

linux (3.2.0-27.42) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1020016

  [ Chris J Arges ]

  * PACKAGING: add .gnu_debuglink sections to .ko files
    - LP: #669641

  [ Ike Panhc ]

  * [Config] Updateconfigs
    - LP: #1008345

  [ Luis Henriques ]

  * SAUCE: (upstreamed) [media] ene_ir: Fix driver initialisation
    - LP: #1014800
  * SAUCE: ocfs2: Fix NULL pointer dereferrence in
    __ocfs2_change_file_space
    - LP: #1006012

  [ Rob Herring ]

  * SAUCE: net: calxedaxgmac: enable rx cut-thru mode
    - LP: #1008345
  * SAUCE: EDAC: Add support for the highbank platform memory
    - LP: #1008345
  * SAUCE: EDAC: add support for highbank platform L2 cache ecc
    - LP: #1008345

  [ Seth Forshee ]

  * (pre-stable): bcma: add ext PA workaround for BCM4331 and BCM43431
    - LP: #925577

  [ Takashi Iwai ]

  * SAUCE: ALSA: hda - Fix power-map regression for HP dv6 & co
    - LP: #1013183

  [ Tim Gardner ]

  * [Config] Enable CONFIG_CGROUPS for highbank
    - LP: #1014692

  [ Upstream Kernel Changes ]

  * Revert "net: maintain namespace isolation between vlan and real device"
    - LP: #1013723
  * x86/amd: Re-enable CPU topology extensions in case BIOS has disabled it
    - LP: #1009087
  * hwmon: (k10temp) Add support for AMD Trinity CPUs
    - LP: #1009086
  * hwmon: (fam15h_power) Increase output resolution
    - LP: #1009086
  * Input: wacom - use BTN_TOOL_FINGER to indicate touch device type
    - LP: #1009435
  * Input: wacom - use switch statement for wacom_tpc_irq()
    - LP: #1009435
  * Input: wacom - isolate input registration
    - LP: #1009435
  * Input: wacom - wireless monitor framework
    - LP: #1009435
  * Input: wacom - create inputs when wireless connect
    - LP: #1009435
  * Input: wacom - wireless battery status
    - LP: #1009435
  * Input: wacom - check for allocation failure in probe()
    - LP: #1009435
  * Input: wacom - add basic Intuos5 support
    - LP: #1009435
  * Input: wacom - add Intuos5 Touch Ring/ExpressKey support
    - LP: #1009435
  * Input: wacom - add Intuos5 Touch Ring LED support
    - LP: #1009435
  * Input: wacom - add Intuos5 multitouch sensor support
    - LP: #1009435
  * iommu/amd: Add workaround for event log erratum
    - LP: #1013723
  * MIPS: BCM63XX: Add missing include for bcm63xx_gpio.h
    - LP: #1013723
  * cifs: Include backup intent search flags during searches {try #2)
    - LP: #1013723
  * sunrpc: fix loss of task->tk_status after rpc_delay call in
    xprt_alloc_slot
    - LP: #1013723
  * exofs: Fix CRASH on very early IO errors.
    - LP: #1013723
  * cifs: fix oops while traversing open file list (try #4)
    - LP: #1013723
  * Fix dm-multipath starvation when scsi host is busy
    - LP: #1013723
  * ixp4xx: fix compilation by adding gpiolib support
    - LP: #1013723
  * drm/i915: properly handle interlaced bit for sdvo dtd conversion
    - LP: #1013723
...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.