Ubuntu

[regression] Speakers are not muted while plugin the headphone

Reported by syldeb35 on 2012-01-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
David Henningsson

Bug Description

since linux 3.2.0-11, the speakers are not muted.
It works with the 3.2.0.10.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-12-generic 3.2.0-12.20
ProcVersionSignature: Ubuntu 3.2.0-10.18-generic 3.2.1
Uname: Linux 3.2.0-10-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: syl 2444 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xc0100000 irq 49'
   Mixer name : 'Realtek ALC262'
   Components : 'HDA:10ec0262,11790660,00100302 HDA:11c11040,11790001,00100200'
   Controls : 20
   Simple ctrls : 13
Date: Sun Jan 29 12:53:15 2012
HibernationDevice: RESUME=UUID=3bc1b2a1-ac9c-4c2d-a1af-f76704c89e6e
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110728)
MachineType: TOSHIBA Qosmio G50
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-10-generic root=UUID=f6c31599-430c-47fd-9cdf-00ade91283f1 ro intel_iommu=off quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-10-generic N/A
 linux-backports-modules-3.2.0-10-generic N/A
 linux-firmware 1.68
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/16/2009
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 2.10
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion2.10:bd02/16/2009:svnTOSHIBA:pnQosmioG50:pvrPQG55E-04Y00PFR:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: Qosmio G50
dmi.product.version: PQG55E-04Y00PFR
dmi.sys.vendor: TOSHIBA

syldeb35 (sylvain-debray) wrote :

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-12.20
syldeb35 (sylvain-debray) wrote :

I've already test with the new 3.2.0-12.20
The problem still exist.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
assignee: nobody → David Henningsson (diwic)
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: regression-update
David Henningsson (diwic) wrote :

Hi syldeb35 and thanks for trying out the development version of Ubuntu!

Could you please try the following:
1) with sudo/root permissions, open /etc/modprobe.d/alsa-base.conf
2) add this line to the file:
options snd-hda-intel model=auto
3) Save and reboot
4) Now test and see if automute works, and if other inputs and outputs work.
5) With this new configuration, attach an alsainfo ( https://wiki.ubuntu.com/Audio/AlsaInfo )

Thanks in advance!

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
syldeb35 (sylvain-debray) wrote :

Hi,

It works with the modified alsa-base.conf.
Alsainfo attached.

The user reports that model=auto works better than current handling
on a 3.2 based kernel (with jack detection patches backported).
Since model=auto is what we prefer these days anyway, the quirk
should be removed.

Alsa-info for the relevant machine:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/923316/+attachment/2702812/+files/alsa-info.txt.Pbfno2x7bp

BugLink: https://bugs.launchpad.net/bugs/923316
Signed-off-by: David Henningsson <email address hidden>
---
 sound/pci/hda/patch_realtek.c | 13 -------------
 1 files changed, 0 insertions(+), 13 deletions(-)

diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 42b6a01..a8e82be 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -4747,7 +4747,6 @@ enum {
  ALC262_FIXUP_FSC_H270,
  ALC262_FIXUP_HP_Z200,
  ALC262_FIXUP_TYAN,
- ALC262_FIXUP_TOSHIBA_RX1,
  ALC262_FIXUP_LENOVO_3000,
  ALC262_FIXUP_BENQ,
  ALC262_FIXUP_BENQ_T31,
@@ -4777,16 +4776,6 @@ static const struct alc_fixup alc262_fixups[] = {
    { }
   }
  },
- [ALC262_FIXUP_TOSHIBA_RX1] = {
- .type = ALC_FIXUP_PINS,
- .v.pins = (const struct alc_pincfg[]) {
- { 0x14, 0x90170110 }, /* speaker */
- { 0x15, 0x0421101f }, /* HP */
- { 0x1a, 0x40f000f0 }, /* N/A */
- { 0x1b, 0x40f000f0 }, /* N/A */
- { 0x1e, 0x40f000f0 }, /* N/A */
- }
- },
  [ALC262_FIXUP_LENOVO_3000] = {
   .type = ALC_FIXUP_VERBS,
   .v.verbs = (const struct hda_verb[]) {
@@ -4819,8 +4808,6 @@ static const struct snd_pci_quirk alc262_fixup_tbl[] = {
  SND_PCI_QUIRK(0x10cf, 0x1397, "Fujitsu", ALC262_FIXUP_BENQ),
  SND_PCI_QUIRK(0x10cf, 0x142d, "Fujitsu Lifebook E8410", ALC262_FIXUP_BENQ),
  SND_PCI_QUIRK(0x10f1, 0x2915, "Tyan Thunder n6650W", ALC262_FIXUP_TYAN),
- SND_PCI_QUIRK(0x1179, 0x0001, "Toshiba dynabook SS RX1",
- ALC262_FIXUP_TOSHIBA_RX1),
  SND_PCI_QUIRK(0x1734, 0x1147, "FSC Celsius H270", ALC262_FIXUP_FSC_H270),
  SND_PCI_QUIRK(0x17aa, 0x384e, "Lenovo 3000", ALC262_FIXUP_LENOVO_3000),
  SND_PCI_QUIRK(0x17ff, 0x0560, "Benq ED8", ALC262_FIXUP_BENQ),
--
1.7.8.3

David Henningsson (diwic) wrote :

Thanks, I've sent a patch upstream. I'm attaching a backport patch for Ubuntu 12.04.

Changed in linux (Ubuntu):
status: Incomplete → In Progress
tags: added: patch

Hi David,

I've gone ahead and applied the patch from comment #7 to the Precise master-next branch. This should then be available in the next upload. Marking this Fix Committed for now. Thanks.

tags: added: rls-p-tracking
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-13.22

---------------
linux (3.2.0-13.22) precise; urgency=low

  [ Alex Deucher ]

  * (pre-stable): drm/radeon/kms: move panel mode setup into encoder mode
    set
    - LP: #925538
  * (pre-stable): drm/radeon/kms: rework modeset sequence for DCE41 and
    DCE5
    - LP: #925538

  [ Andy Whitcroft ]

  * [Config] review IPv6 configuration options and enable

  [ David Henningsson ]

  * SAUCE: ALSA: HDA: Remove quirk for Toshiba Qosmio G50
    - LP: #923316
  * SAUCE: ALSA: HDA: Fix jack creation for codecs with front and rear Line
    In
    - LP: #923409

  [ James M. Leddy ]

  * SAUCE: Bluetooth: Add support for BCM20702A0 [0a5c:21e6]
    - LP: #906832

  [ Manoj Iyer ]

  * SAUCE: Bluetooth: Add support for BCM20702A0 [0a5c:21e1]
    - LP: #906832
  * SAUCE: Add vendor specific ID (0a5c 21f3) for BCM20702A0.
    - LP: #925552

  [ Seth Forshee ]

  * (pre-stable): drm/radeon/kms: disable output polling when suspended
    - LP: #925570

  [ Tim Gardner ]

  * [Config] CONFIG_BLK_DEV_PCIESSD_MTIP32XX=m
    - LP: #922221
  * [Config] Add mtip32xx to d-i block modules
    - LP: #922221
  * [Config] Enable USB3.0 in d-i

  [ Upstream Kernel Changes ]

  * block: Add driver for Micron RealSSD pcie flash cards
    - LP: #922221
  * mtip32xx: fix warnings/errors on 32-bit compiles
    - LP: #922221
  * mtip32xx: cleanup compat ioctl handling
    - LP: #922221
  * mtip32xx: ensure that all local functions are static
    - LP: #922221
  * mtip32xx: mark a few more items static
    - LP: #922221
  * mtip32xx: add module.h include to avoid conflict with moduleh tree
    - LP: #922221
  * mtip32xx: update to new ->make_request() API
    - LP: #922221
  * mtip32xx: updates based on feedback
    - LP: #922221
  * mtip32xx: uninitialized variable in mtip_quiesce_io()
    - LP: #922221
  * mtip32xx: do rebuild monitoring asynchronously
    - LP: #922221
  * watchdog: iTCO_wdt: add Intel Lynx Point DeviceIDs
    - LP: #900119
  * drm/i915: mask transcoder select bits before setting them on LVDS
    - LP: #924989
  * (pre-stable) USB: Realtek cr: fix autopm scheduling while atomic
    - LP: #917962
  * nouveau: properly check for _DSM function support
    - LP: #925608
  * nouveau: Support Optimus models for vga_switcheroo
    - LP: #925608
 -- Leann Ogasawara <email address hidden> Thu, 02 Feb 2012 13:26:59 -0800

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.