Ubuntu

nouveau: second monitor remains blank in installed system, but works in liveCD

Reported by pablomme on 2012-01-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

When booting off an Oneiric release / Precise daily liveCD image, my two monitors (connected to the two DVI outputs of my Nvidia 9600GT (nv50 type) graphics card) come up nicely when the plymouth boot splash shows up, and continue to work throughout the liveCD session.

When booting the installed system, the plymouth bootsplash fails to render, showing graphical corruption instead, and the second monitor stays off. Then X loads successfully, and the second display is correctly detected, but any attempt to turn it on fails (no signal reaches the monitor), even though the system believes it's turned it on - everything works as if the monitor was on, except for the monitor actually being on.

I would think this is a problem with the initialization of the hardware, and given the point at which the liveCD/installed boot processes show differences, it may have to do with the grub-kernel handover. My grub menu is displayed by default.

A note about the corrupted plymouth screen: about 2/3 of the screen is corrupted, but the bottom 1/3 becomes Ubuntu-aubergine-coloured. This could indicate that there is a wrong memory offset somewhere.

WORKAROUND Use the nvidia binary driver with TwinView.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-10-generic 3.2.0-10.17
ProcVersionSignature: Ubuntu 3.2.0-10.17-generic 3.2.1
Uname: Linux 3.2.0-10-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: M1010LT [M Audio Delta 1010LT], device 0: ICE1712 multi [ICE1712 multi]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: M1010LT [M Audio Delta 1010LT], device 0: ICE1712 multi [ICE1712 multi]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: pablo 1701 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'M1010LT'/'M Audio Delta 1010LT at 0x1140, irq 20'
   Mixer name : 'ICE1712 - multitrack'
   Components : ''
   Controls : 85
   Simple ctrls : 57
Date: Sun Jan 22 18:30:48 2012
HibernationDevice: RESUME=UUID=e8f4b4c9-0fa5-4a4d-8cd7-cc108fc92653
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120117)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Hewlett-Packard HP Compaq dc5750 Microtower
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-10-generic root=UUID=9e251900-b9d7-4135-9c96-b3a417352468 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-10-generic N/A
 linux-backports-modules-3.2.0-10-generic N/A
 linux-firmware 1.67
RfKill:

SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2012-01-19 (3 days ago)
dmi.bios.date: 08/07/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786E3 v02.35
dmi.board.name: 0A64h
dmi.board.vendor: Hewlett-Packard
dmi.chassis.asset.tag: CZC7011NMX
dmi.chassis.type: 6
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786E3v02.35:bd08/07/2008:svnHewlett-Packard:pnHPCompaqdc5750Microtower:pvr:rvnHewlett-Packard:rn0A64h:rvr:cvnHewlett-Packard:ct6:cvr:
dmi.product.name: HP Compaq dc5750 Microtower
dmi.sys.vendor: Hewlett-Packard

pablomme (pablomme) wrote :
Brad Figg (brad-figg) on 2012-01-22
Changed in linux (Ubuntu):
status: New → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-10.18
pablomme (pablomme) on 2012-01-25
tags: added: bot-stop-nagging
removed: kernel-request-3.2.0-10.18
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
pablomme (pablomme) on 2012-01-25
description: updated
tags: added: oneiric
Brad Figg (brad-figg) on 2012-02-16
Changed in linux (Ubuntu):
importance: Undecided → High
pablomme (pablomme) wrote :

I'm attaching a video depicting what I wrote in the description, using the latest precise daily image and an up-to-date precise installation with both nouveau and nvidia-current. This is just to make clear when things happen during boot in each situation.

I'd be happy to try any tricks, as dirty as they may be, to identify the source of the problem (or even work around the problem temporarily -- I'd like to get the monitors working with nouveau in any case).

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc1-precise/

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
pablomme (pablomme) wrote :

Testing done. The grub-to-plymouth corruption is not present in the upstream kernel, but that's just because the upstream kernel ignores the vt.handoff parameter, if I understand correctly. The second monitor still does not come up with the upstream kernel.

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Brad Figg (brad-figg) wrote :

@pablomme,

Have you tried using the proprietary driver to see if that will work?

pablomme (pablomme) wrote :

The nvidia binary driver with TwinView works, but I'm interested in using a kernel with the realtime patch (with proper full preemption, as packaged by Alessio Bogani in his PPA at https://launchpad.net/~abogani/+archive/realtime ) for audio recording purposes, and the nvidia binary driver won't work with that. So yes, I'm aware of that possibility but unfortunately I need nouveau to work.

I'm happy to try any other workarounds you might think of - anything that makes the boot process of the installed system closer to that of the liveCD would be worth a try.

pablomme, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-2.36
description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
pablomme (pablomme) wrote :

Unfortunately I do not have the affected system any more.

pablomme, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/920120/comments/9 regarding you no longer have the hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers