devmapper kernel modules missing from precise server cd

Bug #919281 reported by Владимир Зубко on 2012-01-20
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Leann Ogasawara
Precise
Critical
Leann Ogasawara

Bug Description

== Precise SRU Justification ==

Several device mapper modules, including dm-mirror and dm-raid are missing from the server install cd, despite being included in the generic kernel image package. This prevents installing on fakeraid, and likely lvm as well.

== Fix ==
Add dm-mirror and dm-raid to the md-modules d-i file

== Testing ==
I've done a test build of the kernel and can confirm the contents of the md-modules udeb now contains dm-mirror and dm-raid:

$ dpkg -c md-modules-3.2.0-22-generic-di_3.2.0-22.36_amd64.udeb | grep "dm-raid.ko"
-rw-r--r-- root/root 27472 2012-04-05 16:30 ./lib/modules/3.2.0-22-generic/kernel/drivers/md/dm-raid.ko

$ dpkg -c md-modules-3.2.0-22-generic-di_3.2.0-22.36_amd64.udeb | grep "dm-mirror.ko"
-rw-r--r-- root/root 34192 2012-04-05 16:30 ./lib/modules/3.2.0-22-generic/kernel/drivers/md/dm-mirror.ko

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/919281/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in ubuntu:
status: New → Incomplete
Jason McMullan (jason-mcmullan) wrote :

This is know to affect the Ubuntu Server Daily Build of Ubuntu 12.04, as of March 12, 2012.

The kernel modules for 'dm-mirror' and 'dm-raid' are missing, which prevent the installer's dmraid setup from starting for NVidia and Silicon Image ATA fakeraid controllers.

Compounding this issue, for upgrades of systems that are running lvm2 on top of dmraid mirrors, the lvm2 'vgchange -a y' *does* occur, which then leads the installer to perform the installation on only half of the drives in the raid set.

Curiously, at least on the Silicon Image firmware, this does not break the raid set and start a rebuild, but allows the raid to come up in a very strange, broken manner that rapidly leads to filesystem corruption, and an unusable installation.

Changed in ubuntu:
status: Incomplete → Confirmed
Phillip Susi (psusi) wrote :

Confirmed, the modules are missing from the server iso, but not desktop, as of April 2.

summary: - Ubuntu installation image Fake RAID
+ devmapper kernel modules missing from precise server cd
description: updated
Changed in ubuntu:
importance: Undecided → Critical
status: Confirmed → Triaged
tags: added: regression-potential
Changed in ubuntu:
milestone: none → ubuntu-12.04
Colin Watson (cjwatson) wrote :

These need to be added to the md-modules udeb by the kernel packaging.

affects: ubuntu → linux (Ubuntu)
tags: added: rls-mgr-p-tracking
tags: added: kernel-key
Steve Langasek (vorlon) wrote :

Andy, this looks like a straightforward packaging bug to fix - can we please have this fixed for the last package drop before kernel freeze?

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)

I've added the dm-mirror and dm-raid modules to the md-modules d-i file. This fix won't likely make it in an upload prior to kernel freeze, but I'll make sure this fix is uploaded and available before final release for 12.04.

Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → Leann Ogasawara (leannogasawara)
status: Triaged → Fix Committed
tags: added: rls-p-tracking
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-23.36

---------------
linux (3.2.0-23.36) precise-proposed; urgency=low

  [ Andy Whitcroft ]

  * tools/hv: add basic Makefile
    - LP: #977246
  * tools/hv: add basic manual pages
    - LP: #977246
  * Hyper-V KVP daemon -- add to the tools package
    - LP: #977246

  [ David Henningsson ]

  * SAUCE: (drop after 3.3) ALSA: HDA: Remove quirk for Gigabyte
    GA-H61M-S2PV
    - LP: #948360

  [ Leann Ogasawara ]

  * d-i: Add dm-mirror and dm-raid to md-modules
    - LP: #919281

  [ Tim Gardner ]

  * [Config] Fix invalid linux-headers link
    - LP: #974403
  * Remove headers asm symlink entirely
    - LP: #974403

  [ Upstream Kernel Changes ]

  * Revert "x86/ioapic: Add register level checks to detect bogus io-apic
    entries"
    - LP: #974982
  * ALSA: HDA: Realtek: Take vmaster dac from multiout dac list
    - LP: #974090
  * kexec: remove KMSG_DUMP_KEXEC
    - LP: #944772
  * kmsg_dump: don't run on non-error paths by default
    - LP: #944772
  * pstore: Introduce get_reason_str() to pstore
    - LP: #944772
 -- Leann Ogasawara <email address hidden> Tue, 10 Apr 2012 08:16:09 -0700

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers