Garbled display on external screen when using 1920x1080 instead of 1920x1200

Bug #915408 reported by Joe Barnett on 2012-01-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
xserver-xorg-driver-ati
Invalid
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

originally reported as bug 813566 :

i have an external monitor (1920x1200 resolution) that, when set to 1920x1080 resolution (native resolution of laptop display), garbles the screen as seen in the screenshot below. The problem doesn't happen using the catalyst driver.

https://bugs.launchpad.net/lightdm-gtk-greeter/+bug/813566/+attachment/2221015/+files/2011-07-20_07-51-28_83.jpg

ProblemType: BugDistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-15.25-generic 3.0.13
Uname: Linux 3.0.0-15-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: None
Date: Thu Jan 12 07:42:25 2012
DistUpgraded: Log time: 2011-07-13 10:07:59.371965
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 ATI Technologies Inc Broadway PRO [Mobility Radeon HD 5800 Series] [1002:68a1] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:1522]InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
MachineType: Hewlett-Packard HP ENVY 15 Notebook PC
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-15-generic root=UUID=639dc488-e095-42a4-8c1f-ffb1a9299e1c ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7SourcePackage: xorg
UpgradeStatus: Upgraded to oneiric on 2011-07-13 (182 days ago)
dmi.bios.date: 04/23/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.26
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1522
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 36.34
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.26:bd04/23/2010:svnHewlett-Packard:pnHPENVY15NotebookPC:pvr048F110000241920001530000:rvnHewlett-Packard:rn1522:rvr36.34:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP ENVY 15 Notebook PC
dmi.product.version: 048F110000241920001530000
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Joe Barnett (thejoe) wrote :
Bryce Harrington (bryce) on 2012-01-13
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → High
status: New → Triaged
description: updated

Forwarding this bug from Ubuntu reporter Joe Barnett:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/915408

[Problem]
i have an external monitor (1920x1200 resolution) that, when set to 1920x1080 resolution (native resolution of laptop display), garbles the screen as seen in the screenshot below. The problem doesn't happen using the catalyst driver.

https://bugs.launchpad.net/lightdm-gtk-greeter/+bug/813566/+attachment/2221015/+files/2011-07-20_07-51-28_83.jpg

ProblemType: BugDistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-15.25-generic 3.0.13
Uname: Linux 3.0.0-15-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: None
Date: Thu Jan 12 07:42:25 2012
DistUpgraded: Log time: 2011-07-13 10:07:59.371965
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
ATI Technologies Inc Broadway PRO [Mobility Radeon HD 5800 Series] [1002:68a1] (prog-if 00 [VGA controller])
Subsystem: Hewlett-Packard Company Device [103c:1522]InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
MachineType: Hewlett-Packard HP ENVY 15 Notebook PC
ProcEnviron:
PATH=(custom, user)
LANG=en_US.UTF-8ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-15-generic root=UUID=639dc488-e095-42a4-8c1f-ffb1a9299e1c ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7SourcePackage: xorg
UpgradeStatus: Upgraded to oneiric on 2011-07-13 (182 days ago)
dmi.bios.date: 04/23/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.26
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1522
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 36.34
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.26:bd04/23/2010:svnHewlett-Packard:pnHPENVY15NotebookPC:pvr048F110000241920001530000:rvnHewlett-Packard:rn1522:rvr36.34:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP ENVY 15 Notebook PC
dmi.product.version: 048F110000241920001530000
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Created attachment 55541
BootDmesg.txt

Created attachment 55542
CurrentDmesg.txt

Created attachment 55543
XorgLog.txt

Bryce Harrington (bryce) wrote :

Joe - I've forwarded your bug report upstream to https://bugs.freedesktop.org//show_bug.cgi?id=44755 - please subscribe yourself to the CC for that bug in case they need further information or wish you to test something.

Changed in xserver-xorg-driver-ati:
importance: Unknown → High
status: Unknown → Confirmed

The problem is the modeline from your monitor for the 1920x1080 mode is greater than 165 Mhz which is the current cut off for single link mode in the driver:
(II) RADEON(0): Modeline "1920x1080"x60.0 172.78 1920 2040 2248 2576 1080 1081 1084 1118 -hsync +vsync (67.1 kHz)

It should work if you specify a modeline with a lower clock E.g.,
Modeline "1920x1080R" 138.50 1920 1968 2000 2080 1080 1083 1088 1111 +hsync -vsync

Created attachment 55557
possible fix

This patch against drm-next or Linus git should fix the issue.

confirmed that the following sequence displays a non-garbled 1920x1080 display on the external monitor:

# xrandr --newmode "1920x1080R" 138.50 1920 1968 2000 2080 1080 1083 1088 1111 +hsync -vsync
# xrandr --addmode HDMI-0 1920x1080R
# xrandr 1920x1080R

A patch referencing this bug report has been merged in Linux v3.3-rc2:

commit 9aa59993e226af94088adaee993eb8cfd33ae295
Author: Alex Deucher <email address hidden>
Date: Fri Jan 20 15:03:30 2012 -0500

    drm/radeon/kms: refine TMDS dual link checks

Bryce Harrington (bryce) wrote :

Guessing this patch should fix it.

tags: added: kernel-da-key kernel-handoff-graphics
Bryce Harrington (bryce) wrote :

Kernel team - mind rolling a test kernel deb for Joe to test?

Bryce Harrington (bryce) wrote :

Based on the upstream bug, it sounds like this is due to a bug in the kernel so no change needed to X itself. However I'll leave the X task open for a bit longer so we can track progress.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → In Progress
Joseph Salisbury (jsalisbury) wrote :

Building a test kernel now. I'll post a link to the kernel shortly.

Brad Figg (brad-figg) on 2012-02-02
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

There is a test kernel available from the following:

http://people.canonical.com/~jsalisbury/lp915408/

Can you test the kernel and report back if the patch resolves the bug?

Joe Barnett (thejoe) wrote :

still seeing the same issue with the kernel package from http://people.canonical.com/~jsalisbury/lp915408/

tags: added: patch
Joseph Salisbury (jsalisbury) wrote :

@Joe,

Can you run uname -a, just so I can confirm you received the correct test kernel?

Bryce Harrington (bryce) on 2012-02-08
tags: added: corruption
Joe Barnett (thejoe) wrote :

went back to the oneiric kernel after it didn't work, but uname at the time was definitely showing 3.2.0-12-generic ; do you need me to reinstall and verify more info from uname -a?

Changed in linux (Ubuntu):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

When you ran the test kernel from http://people.canonical.com/~jsalisbury/lp915408/, did the uname -a report only 3.2.0-12-generic as the kernel version? It should have had the following test appended ~lp915408. If it didn't it may not have been the correct test kernel.

Joe Barnett (thejoe) wrote :

ok, still seeing the problem with:

$ uname -a
Linux taplop 3.2.0-12-generic #21~lp915408 SMP Thu Feb 2 21:24:18 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Joseph Salisbury (jsalisbury) wrote :

If that is the case, it seems the refine_tmds_dual_link_checks.patch patch does not resolve this bug.

Joseph Salisbury (jsalisbury) wrote :

Could you test one additional kernel? This is the latest upstream stable kernel:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc6-precise/

This will tell us if the fix is in the mainline kernel.

Joe Barnett (thejoe) wrote :

confirmed still seeing the problem with:

$ uname -a
Linux taplop 3.3.0-030300rc6-generic #201203032235 SMP Sun Mar 4 03:36:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged

I've tested against a kernel with this patch, as well as mainline kernel (both built by ubuntu kernel team), and am still seeing the same behavior. So seems like this change doesn't fix the issue.

Created attachment 58148
fix

This patch should fix it. Your chip is limited to 165 Mhz single link tmds. The mode you are trying to set is >165 Mhz. With this patch applied the mode should be properly rejected by the driver.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed

A patch referencing this bug report has been merged in Linux v3.3-rc7:

commit 38aa4a568ba4c3ccba83e862a01e3e60e3b811ee
Author: Alex Deucher <email address hidden>
Date: Wed Mar 7 19:05:01 2012 -0500

    drm/radeon/kms: fix hdmi duallink checks

Bryce Harrington (bryce) on 2012-03-28
no longer affects: xserver-xorg-video-ati (Ubuntu)
Joe Barnett (thejoe) wrote :

appears to be fixed upstream, by using latest kernel image form http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/ . only "problem" remaining is that it picks 1280x960 as the default/initial/lightdm resolution for both screens, which is fine, but everything looks quite large.

Andy Whitcroft (apw) wrote :

It appears that we may well need both of these fixes together:

  commit 9aa59993e226af94088adaee993eb8cfd33ae295
  Author: Alex Deucher <email address hidden>
  Date: Fri Jan 20 15:03:30 2012 -0500

    drm/radeon/kms: refine TMDS dual link checks

and:

  commit 38aa4a568ba4c3ccba83e862a01e3e60e3b811ee
  Author: Alex Deucher <email address hidden>
  Date: Wed Mar 7 19:05:01 2012 -0500

    drm/radeon/kms: fix hdmi duallink checks

I have pulled both of these patches back to Precise and produced some test kernels. Could those of you affected please test the kernels at the URL below:

    http://people.canonical.com/~apw/lp915408-precise/

Please report any testing here.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Changed in linux:
status: Confirmed → Fix Released

Original reporter noted fix released in later kernel version 3.3.

Joe Barnett, this bug report is being closed due to your last comment
https://bugs.launchpad.net/xserver-xorg-driver-ati/+bug/915408/comments/28 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in xserver-xorg-driver-ati:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.